Posts by Swissmaster

    Hallo zusammen

    Gehe ich richtig in der Annahme, dass TTS nur mit Sonos Lautsprecher funktioniert?

    Hin und wieder habe ich das Problem, dass wenn vorher per Handy im Netzwerk per Spotify Connect auf Lautsprecher 1 etwas abgespielt wurde, beim Abspielen des ersten Titels mit dem kidscontroller nicht auf den vor definierten Lautsprecher 2 abgespielt wird sonderb auf Lautsprecher 1. Woran könnte das liegen?

    Wie kann die Zoom Funktion von Chromium dekativiert werden, weiss das hier zufällig jemand?

    Und zu guter Letzt habe ich manchmal etwas Probleme wenn etwas ausgewählt wird (zbsp Feuerwehrmann Sam) mit vielen verschiedenen Geschichten, dass das Scrollen herum zickt. Ich weiss nicht ob das etwas damit zu tun hat, dass so viele Covers geladen werden müssen. Ich hab mich gefragt, ob ein Pi 3 allenfalls zu wenig Power hat für diese Anwendung ( die API läuft bei mir auf einem anderen Gerät).

    Hm, das könnte beim PI zum Problem werden.

    Denn er wird dann quasi "Hart" abgeschaltet, da ihm dieser "Latching Switch" abrupt die Spannung wegnimmt.

    An dem Latching Switch habe ich ein Verzögerungsrelais angehängt, welches das Signal von NO des Latching Switch erhält. Sobald der Latching Switch zum Ausschalten gedrückt wird, läuft ein vordefinierter Countdown bis die Stromzufuhr unterbrochen wird. Das reicht normalerweise zum herunterfahren des PI.

    Ziel der ganzen Übung ist eigentlich nur, dass der Raspberry PI und 1-2 andere Komponenten die an der Leitung hängen über den Latching Switch ein- und ausgeschaltet werden können, so dass kaum mehr Strom fliesst.

    Die 12V führe ich via DC/DC Wandler (18v) über einen HifiBerry Amp2 in den Raspberry.

    Switch verwende ich diesen hier:

    22mm 15A Wasserdichte Rast und Momentary Edelstahl Metall Push Button Schalter Icon LED Licht Glanz Auto horn Auto Lock

    https://a.aliexpress.com/_BUgOdt

    Verzögerungsrelais das hier:

    DC 5V 12V 24V LED Licht Digitale Zeit Verzögerung Relais Trigger Zyklus Timer Verzögerung Switch Circuit Board timing Control Modul DIY

    https://a.aliexpress.com/_BOvtsP


    Ich habe nicht so viel Ahnung von Elektronik und Schaltungen, weshalb ich das so versucht habe zu lösen.

    Die schönste Lösung wär natürlich etwas in der Art wie der On/OffShim gewesen.

    Warum möchtest Du mit der Taste eigentlich (unbedingt) 12V schalten?

    Hat der Taster weitere Aufgaben als nur Signalgeber für den PI zu sein. Falls nicht, wäre es wohl am besten, Du verwendest die Raspberry internen PullUp Widerstände. Der Taster zieht das Signal bei Betätigung gegen Masse...

    Einen Vorwiderstand mit ca. 1K vor dem Taster empfehle ich trotzdem, falls der GPIO mal als Ausgang geschaltet werden sollte (es fließt in diesem Fall zu viel Strom)...

    ich schalte darüber verschiedene andere Lasten und möchte so erreichen, dass alle Lasten ausgeschaltet und der Raspberry Pi heruntergefahren wird.

    Ich habe an einer Autobatterie einen Latching Switch (Einschalttaste) angehängt. Die Spannung der Batterie beträgt geladen ca. 12V. Ich möchte nun einen GPIO Input Port damit beschalten und eine Aktion durchführen sobald die Einschalttaste gelöst wird. Es ist mir klar, dass ich nicht direkt mit 12V auf den GPIO-Port gehen kann. Das hier habe ich ebenfalls gelesen: https://www.elektronik-kompendium.de/sites/raspberry-pi/2110091.htm

    Ich dachte mir, dass es wohl das einfachste wäre an den NO (Normal Open) Anschluss des Latching Switches einen DC/DC Wandler zu montieren, welcher die Spannung von 12 auf 3,3V herunter regelt. Sobald der Latching Switch gedrückt wird, öffnet das Relais am NO und es liegt dort keine Spannung mehr an, was beim GPIO Eingang zu einem LOW führen sollte. Dazu würde ich die im Raspberry PI integrierten Pull Down Widerstände verwenden. Würde das funktionieren? Spricht etwas dagegen?

    Herzlichen Dank für eure Antworten. 8)

    Meine cleanshutd sieht genau so aus. Und ShutdownSound.sh habe ich genau so:

    Bash
    #!/bin/bash
    mpc stop
    cvlc "/home/pi/RPi-Jukebox-RFID/shared/shutdownsound.mp3" \
    -q \
    vlc://quit
    
    sleep 1

    Kann dir daher nicht sagen, wo dein Problem liegt, wenn der Sound damit korrekt abgespielt wird:

    Code
    cvlc "/home/pi/RPi-Jukebox-RFID/shared/shutdownsound.mp3"

    Bei cleanshutd nach Zeile 86 diese Zeile hinzufügen:

    Code
    sudo -H -u pi bash -c '/home/pi/ShutdownSound/shutdownSound.sh'

    Die Datei shutdownSound.sh hat dann folgenden Inhalt:

    Bash
    #!/bin/bash
    mpc stop
    cvlc "/home/pi/RPi-Jukebox-RFID/shared/shutdownsound.mp3" \
    -q \
    vlc://quit
    
    sleep 1

    Ich habe kurz nachgeschaut, das 5V LED Panel läuft mit 160mA und hat eine Nennleistung von 1.6W bei einer Betriebsspannung von 4.5 bis 5.5V. Könnte ich die 5V auch mit einem Optokoppler an einem GPIO schalten? Falls ja welches Model wäre dafür das richtige? Ich verstehe all die Begriffe auf den Datenblätter nicht und weiss daher nicht wie ich den richtigen finde.

    Hallo bombom

    Bin leider erst jetzt wieder dazu gekommen dir zu antworten. Danke für deine Hilfe. Ich werde es dann wohl mit einem FET bzw. MOSFET versuchen, sobald ich dazu komme. Die Frage mit der Diode kann ich dir leider nicht beantworten. Ich weiss zwar, was eine Diode ist, erkenne es aber auf der Platine nicht.

    Es liegt definitiv am Relais. Es gibt viel weniger Störungen bei den Sensoren, wenn ich das Relais nicht anschliesse. Ich glaube, ich werde nicht drum herum kommen, eine Alternative für das Relais zu suchen, da das Magentfeld des Relais kaum gegenüber der Umgebung abgeschirmt werden kann. Was meinst du mit RC Glied? Das kenne ich nicht.

    Hallo zusammen

    Besten Dank für eure Antworten. Für mich ist das schon alles sehr schwer verständlich, da ich nicht viel Ahnung von Elektrotechnik habe.

    Ich habe nun versucht, dass die Sensoren nur ausgelöst werden, wenn sie "gehalten" und nicht nur kurz gedrückt werden. Naja, so richtig klappen wollte das nicht. Ich hab nun jedoch bei der Fehlersuche eine massgebliche Fehlerquelle gefunden. Ca. 5cm von den Sensoren befindet sich ein 5V Relais. Die Fehler treten wie ich festgestellt habe dann auf, wenn das Relais einmal geschaltet wurde. Das Relais bringt die Sensoren dann komplett durcheinander. Habe jetzt die Schaltung mit dem Relais mal deaktiviert und versuche mich nun weiter an der Fehlerbehebung.

    Hätte auch selber darauf kommen können, dass die Sensoren in unmittelbarer Nähe des Relais nicht funktionieren kann.

    Hallo zusammen,

    Ich betreibe mehrere kapazitive Touchsensoren an den GPIO‘s eines Raspberry Pi. Die Sensoren werden alle mit 3,3V vom Raspberry betrieben. Normalerweise funktioniert das auch ganz gut. Aber hin und wieder machen sich die Sensoren wie von Geisterhand selbstständig und lösen ohne ersichtlichen Grund aus. Das machen sie dann in diesen Momenten fast ununterbrochen. Ich habe schon was über „false positives“ bei den kapazitiven Sensoren gelsen, nur verstehe ich noch immer nicht, was der Grund dafür ist und wie sich das Problem beseitigen lässt.

    Kann mir da einer auf die Sprünge helfen?

    Bleibt die Box an, wenn Du ein Ladekabel an/Abstöpselst, oder führt das beim Pi zum Neustart?

    Funktioniert das mit den Photosensoren bei Dir problemfrei? Habe es ähnlich gelöst, der Schaltbereich war bei mir (blaue LEDs der Intenso Powerbank) jedoch sehr eng und entsprechend die ideale Einstellung sehr langwierig zu finden (kein Fehlalarm, aber auch nicht das erlöschen der LED verpassen). Mittlerweile läuft es zwar, beim nächsten Projekt werde ich aber wohl das Gehäuse der Powerbank öffnen und die Spannung an den LEDs direkt abgreifen zwecks Auswertung.

    Ja, sie bleib an beim Abstöpseln. Bis jetzt funktioniert das mit dem Fotosensor. Kann aber noch nichts über die Zuverlässigkeit sagen.