Beiträge von BustiXF

    Hast Du die Frage bzgl. setzen der regdomain auf DE beantwortet?

    Hast Du alle config-Dateien geändert? Dann solltest Du den Befehl:

    Code
    1. iw reg set US

    nicht manuell ausführen müssen.

    Ich habe alle befehle gesetzt die du mir im laufe dieses gesprächs vermittelt hast.

    Ich bin mir auch ziemlich sicher - und ich werde das morgen überprüfen - das der befehl nicht dauerhaft gesetzt ist.

    Aber das schau ich morgen, hab eine gute nacht..

    Ich hab die Lösung gefunden.


    omg.


    Aber ich benötige dennoch hilfe von dir, falls du noch lust hast - das ganze dauerhaft werden zu lassen..


    Aber nun erstmal zur Problemlösung.


    1. Wir haben ja festgestellt, das der Hotspot den PI durch nen "IE request" dazu bringt auf DE zu schalten.

    Also dachte ich mir ich versuche das mal zu verhindern.


    2. Ich habe den Spot auf 5GHz gestellt, dann habe ich IW Event beobachtet.

    Dann kam die Teufelsmeldung:

    Code
    1. wlan0 (phy #0): connected to 26:18:1d:ef:1a:5e
    2. phy #0: regulatory domain change: set to DE by a country IE request on phy0


    Jetzt habe ich blitzschnell ein anderes Terminal Fenster geöffnet und diesen Befehl ausgeführt:

    Code
    1. iw reg set US


    Danach kam im IW Event fenster diese meldung:

    Code
    1. regulatory domain change: intersection used due to a request made by a user


    Und jetzt läuft das 5GHz wlan seit über 10 minuten ohne unterbrechung oder sonstigen schwankungen.


    Also hatte es scheinbar doch damit zutun, das sobald er mich auf die DE frequenzen gezwungen hat, die US 4.745GHz nichtmehr gefunden hat -> Carrier lost.

    Nach dem Carrier lost, zählte dieser "IE request" nicht mehr, da der Carrier ja nicht mehr vorhanden war- welcher diesen ausgesprochen hatte, somit nutzte der PI wieder die Standard Einstellungen - welche er aus der wpa_supplicant übernommen hatte.

    Dadurch war der PI wieder auf US, fand das Netz, hat connected, bekam die Anfrage für den switch auf DE, PI switcht auf DE, findet das Netz nichtmehr, carrier lost, die Anfrage auf DE wird verworfen-> weil er "antragssteller" nichtemhr auffindbar ist, switcht wieder auf den standard (US), findet das netz wieder.....usw.


    Genau so erkläre ich mir das.

    Falls du der selben Meinung bist oder denkst ich liege falsch, ich bin für alle Vorschläge offen.


    Nun zur neuen hauptfrage.


    wie unterbinde ich diesen IE request?!

    ich hab ja mal noch nie sowas nerviges erlebt, haha.


    rpi444 vielen dank dennoch für all die Zeit und Nerven die du geopfert hast.

    Dank dir bin ich soweit gekommen und konnte mein wissen soweit ausbauen, dies alles noch herauszufinden.

    Und nur dank deines letzten versuches mit dem wpa_cli - bin ich überhaupt auf die message mit dem IE request gekommen.

    Also vielen vielen dank.

    bist spitze!



    Edit:

    seid rund 30+ min ohne Unterbrechung

    Also,


    hier nochmal der korrigierte 5GHz output:



    Code
    1. root@raspberrypi:/home/pi# wpa_cli -i wlan0 -B -a /home/pi/Desktop/wpa_action.sh -G 45
    2. root@raspberrypi:/home/pi# ps aux | grep -i [w]pa
    3. root 329 0.0 0.4 9992 3992 ? Ss 14:24 0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
    4. root 393 0.0 0.3 10580 3304 ? Ss 14:24 0:00 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
    5. root 4204 0.0 0.0 2636 144 ? Ss 14:36 0:00 wpa_cli -i wlan0 -B -a /home/pi/Desktop/wpa_action.sh -G 45
    6. root@raspberrypi:/home/pi#




    Edit:


    ich habe gerade online von jemand anderen mit so einem problem gelesen, das er vom DHCP ein DHCPNAK paket erhalten hat, kann ich das irgendwie überprüfen ob ich auch so eines erhalte


    ich editiere gleich nochmal die ergebnisse von iw event


    Edit:



    Edit:


    wpa_action.sh (hab sie nur unbenannt)

    sorry bei dem textuploader zerschiest es die formatierung

    Hallo,


    die Information mit den 4.745 habe ich von meinem pi, wenn ich den scan durchführe während ich kurzzeitig verbunden bin.

    Ich habe gerade ein sehr nützliches script gefunden, von welchem ich dir die ergebnisse jetzt einmal mitteilen werde.

    Die sind einmal für 2.4GHz und einmal für 5GHz.


    Hier noch die ausgabe von ps aux | grep -i [w]pa

    Code
    1. root@raspberrypi:/home/pi# ps aux | grep -i [w]pa
    2. root 341 0.0 0.4 9992 3944 ? Ss 11:58 plicant -u -s -O /run/wpa_supplicant
    3. root 402 0.0 0.3 10580 3192 ? Ss 11:58 t -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dn
    4. root@raspberrypi:/home/pi#


    wireless-info script 2.4GHz:


    wireless-info script 5GHz:

    Code
    1. --- update ich gleich [edit: update in meinem nächsten post weiter unten #110]


    moment, ich glaube das zweite is auch das erste

    gib mir eine sekunde das zu überprüfen

    Hallo,


    entschuldige bitte das ich jetzt erst antworte, ich habe nicht mitbekommen das du geantwortet hast.

    Also, ich hab das jetzt ausgeführt.

    Die Ergebnisse editiere ich in einer Sekunde vom PI aus.

    Moment


    Edit:


    Bittesehr.


    Ich bin verwirrt.


    Hier mal ein Ausschnitt von der 2.4GHz verbindung


    Scheinbar wechselt er country auf US, weil ich das so möchte, dann erhält er einen Request es auf DE zu setzen, dann findet er das Netzwerk nichtmehr, weil 4.745 nicht in der DE country liste ist, daraufhin verliert er die verbindung, wechselt auf US, connected wieder und so weiter


    Und bei 2.4 entsteht das problem nicht, weil er in DE und US die frequenz findet.


    Versteh ich das richtig?

    Code
    1. root@raspberrypi:/home/pi# ls -la /lib/modules/4.14.98-v7+/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
    2. -rw-r--r-- 1 root root 396580 Feb 18 10:11 /lib/modules/4.14.98-v7+/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
    3. root@raspberrypi:/home/pi#



    Code
    1. root@raspberrypi:/home/pi# uname -a
    2. Linux raspberrypi 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
    3. root@raspberrypi:/home/pi#


    ich muss es kurz posten, da ich an dem kleinen display es nicht vergleichen kann :D


    Gibts ein tool für den raspi, dass mir das side-by-side vergleicht?


    Und danke! :)



    Edit:


    der einzige unterschied, ist unser loginname... :(

    Hmmm, das ist schade.

    Ich weiß nicht wann ich dieses Setup in der nächsten Zeit so einrichten kann.


    Kann es nicht sein, das ich nen fehlerhaften/alten brcmfmac treiber installiert habe?

    Kann ich das irgendwie rausfinden?

    Hast du einen rpi3b+ - bei dem 5GHz funktioniert und wir vergleichen die installierten Kernel/WLAN treiber?


    Anfangs war der RPi ja headless - aber halt ohne Tastatur ist in meiner derzeitigen Situation schwer möglich.

    Guten Morgen,


    sorry für den Bump, ich wollte eigentlich nur noch in Erfahrung bringen, ob der liebe rpi444 noch gewillt ist mit mir nach einer Lösung zu suchen, oder ob ich es so hinnehmen soll?

    Bitte nicht als ein drängen interpretieren, lass dir alle Zeit der welt - ich möchte nur wissen wie kontinuierlich ich nach einer neuen Nachricht schauen soll - oder ob überhaupt

    Hier, ich hab jetzt 2.4GHZ hotspot + USB0 Tethering aktiv.

    Ergebnis: kein problem.


    https://ibb.co/F5Yyp4t


    das läuft und läuft ohne jegliche probleme.

    und der einzige unterschied ist: ich habe den haken bei 5GHz beim handy hotspot rausgemacht.

    es muss ein 5G raspi-internal wifi problem sein, ich kanns mir nicht ander erklären.


    ich probiere kurz das avahi zu deinstallieren, editiere gleich die ergebnisse.


    avahi deinstalliert:

    soll ich rebooten nach der deinstallation? (ist wieder das 5ghz netzwerk)



    verbindung:

    abbruch:

    Code
    1. Mar 17 16:18:18 raspberrypi dhcpcd[454]: wlan0: carrier lost
    2. Mar 17 16:18:18 raspberrypi dhcpcd[454]: wlan0: deleting address fe80::150b:7823:e6f2:33b4
    3. Mar 17 16:18:19 raspberrypi dhcpcd[454]: wlan1: adding default route via 192.168.5.0
    4. Mar 17 16:18:19 raspberrypi dhcpcd[454]: if_route (ADD): Invalid argument
    5. Mar 17 16:18:19 raspberrypi dhcpcd[454]: wlan0: deleting default route via 192.168.43.1
    6. Mar 17 16:18:19 raspberrypi dhcpcd[454]: wlan0: deleting route to 192.168.43.0/24
    7. Mar 17 16:18:19 raspberrypi dhcpcd[454]: wlan1: adding default route via 192.168.5.0
    8. Mar 17 16:18:19 raspberrypi dhcpcd[454]: if_route (ADD): Invalid argument

    lost:

    Code
    1. Mar 17 16:19:25 raspberrypi dhcpcd[454]: wlan0: carrier lost
    2. Mar 17 16:19:25 raspberrypi dhcpcd[454]: wlan0: deleting address fe80::150b:7823:e6f2:33b4

    lost:

    Code
    1. Mar 17 16:20:32 raspberrypi dhcpcd[454]: wlan0: carrier lost
    2. Mar 17 16:20:32 raspberrypi dhcpcd[454]: wlan0: deleting address fe80::150b:7823:e6f2:33b4


    jede minute und 10-15 sekunden.


    während dieser minute bin ich voll funktionsfähig verbunden


    Edit:


    carrier lost


    Edit:


    nochmal zum sicherstellen:


    habe meine xbox one mit dem 5ghz verbunden.

    kein problem, kein verbindungsabbruch.

    das hat irgendwas mit den raspi zutun...


    Edit:


    https://www.raspberrypi.org/forums/viewtopic.php?p=1365217

    hier hat jemand das exakt das selbe problem mit exakt der selben 5.745 frequenz

    und mehrere andere auch die z.B ne lösung mit dem power management gefunden haben - welches bei mir aber leider keine verbesserung der situationa aufzeigt.



    Edit:


    eine lösung wie ein user schreibt ist:

    Code
    1. However, your point that it may be some kind of sophisticated type of connection made me look at all router settings related to 5Ghz Wifi, although tech support of my ISP kept saying that the problem can not be related to them or to their router I use. So I decided to try all the options and tickingDisable DFS Channels did the trick. It is already half an hour of internet without interruption. Googling DFS chanels gave me the following:

    das problem ist, ich weiß n icht wie ich das an meinem handy deaktiveren kann, falls es überhaupt an ist.


    Edit:


    muss ich eventuell die txpower verändern?



    Edit:


    hier ein iwlist wlan0 scan

    cell 1 = kollege sein handy hotspot

    cell 2 = dongle wlan1 hotspot

    cell 3 = ?

    cell 4 = ?

    cell 5 = mein handy hotspot. und der is auch immer auf 5745GHz aka. channel 149

    Nochmal ein Update.


    Ich habe jetzt USB tethering (usb0) an


    mein routing routed usb0 -> wlan1 (usb dongle) und zurück

    gleichzeitig wird wlan0(intern) -> wlan1 geroutet und zurück.


    nun habe ich gleichzeitig zu usb tethering, wlan0 aktiviert.


    Soweit so gut, usb blieb verbunden und wlan0 hat sich auch verbunden.


    nach kurzer zeit, das übliche problem auf wlan0:

    carrier lost.


    und das tritt ausschlieslich über 5GHz auf, weder beim usb tethering (welches nun schon über ne stunde läuft, noch 2.4GHz)


    Das kann doch nicht, sein, irgendwas muss ich doch falsch machen--.....

    Dieses agetty dreht bei mir übrigends auch völlig durch.


    hioer noch ein bild:https://ibb.co/fH2YWjh



    leider hab ich keine möglichkeit, dein vorgeschlagenes setup aufzubauen. :-(


    Edit:

    ich habe 3x raspi 3b+ und auf allen 3 der selbe fehler.

    die Warscheinlichkeit, dass das ein hardwarefehler bei allen 3 geräten st, ist gleich 0.

    dazu kommt das 2 davon in einem anderen laden gekauft wurden.


    Edit: j

    kann ich mit keinem Befehl, den "Carrier Lost" fehler genauer inspizieren?=

    2. Block ist entfernt.


    am handy kann ich den 2.4 nicht ausstellen, nur einen haken für "5GHz verwenden wenn verfügbar"

    aber sobald ich den haken setze, finde ich auch nur eine verbindung mit 5.745GHz


    hier mal zwei screenshots for crash und nachher von iwconfig und ifconfig

    vor crash.

    https://ibb.co/pxQfDP6


    nach crash:

    https://ibb.co/jg0rBdS


    Ein vorteil hat das ganze ja, ich werd immer schneller mit den ganzen befehlen :P.


    Ahja, ich benutze die "LXqt" Oberfläche.


    sonst wüsst ich nicht, wie ich die ganze interaktion hier mit dir führen würde - da ich jetzt nichtmehr zuhause bin und nur noch das handy und den pi zur verfügung habe.


    Edit:


    der stick is nur drin, weil es vorhin nicht funktioniert hat, wenn du mir ne neue sache zum testen gibst, reverte ich auf deine letzten einstellungen und stecke stick ab.


    Edit:


    2 bilder vom "taskmanager"

    https://ibb.co/6sjZXKD

    https://ibb.co/0XQMSyc



    Edit:


    kleiner crosscheck:


    5GHz hotspot aus

    USB Tethering an - funktioniert

    2.4GHz hotspot an - funktioniert

    5GHz hotspot an - carrier lost nach 1 min und 10-15 sec


    Edit:


    hier mal ein dmesg, ka obs was bringt, aber ich weiß nicht was ich dir noch für sinnvolle informationen geben kann

    Also, habs jetzt mal geändert auf US.


    Dann zu deinen Fragen:

    im router netzwerk, das 5Exxxx ist kein sonderzeichen

    im hotspot wlan 5GHz sind 2 sonderzeichen, zwei !!

    im hotspot wlan 2.4GHz sind 2 sonderzeichen, zwei !!


    2.4ghz funktioniert aber. denkst du es liegt an den sonderzeichen? ich probiers mal ohne.

    Der Home router mit 5g hat auch keine sonderzeichen und da passiert das selbe.


    Code
    1. root@raspberrypi:/home/pi# mv /etc/dhcpcd.conf /etc/dhcpcd.conf.bak
    2. root@raspberrypi:/home/pi# nano /etc/dhcpcd.conf
    3. root@raspberrypi:/home/pi# systemctl daemon-reload
    4. root@raspberrypi:/home/pi# systemctl restart dhcpcd
    5. root@raspberrypi:/home/pi# watch -n 0.5 ifconfig
    6. root@raspberrypi:/home/pi#


    edit:


    verbindung gedropppt

    im terminal auf meinem s9, gebe ich ifconfig ein.

    dann gibt er mir zurück: inet addr: 192.168.43.1

    Also ja, mein handy hotspot fungiert als AP und vergibt über DHCP addressen.



    und wie füge ich so einen arp eintrag hinzu? ist das mein fehler? hab ich irgendwas übersehen?


    edit:


    Code
    1. root@raspberrypi:/home/pi# arp -a
    2. root@raspberrypi:/home/pi# arp
    3. Address HWtype HWaddress Flags Mask Iface
    4. 192.168.43.1 ether 26:18:1d:ef:1a:5e C wlan0
    5. root@raspberrypi:/home/pi#


    verbindung reisst immernoch hab

    Code
    1. root@raspberrypi:/home/pi# arp -av
    2. Entries: 0 Skipped: 0 Found: 0
    3. root@raspberrypi:/home/pi#