Posts by Mike300

    Hallo zusammen,


    final und der Vollständigkeit halber:

    Das Problem lag daran, dass der Service, den ich zum Temperatur messen, auch einen der GPIO's, die der i2S nutzt, angesprochen hat:-(

    Das kann dann nicht funktioneren.

    Geändert und alles funktioniert (auch auf der ursprünglichen SD-Karte)


    Danke für eure Tips!


    VG

    Mike

    Hallo zusammen,


    raspbastler: keine sorge: Backups kann ich gut


    Update: Ich habe jetzt mit dem neu aufgesetztem System weiter-konfiguriert (siehe post #60).

    Ich bin mir ziemlich sicher, dass mein ursprüngliches Audioproblem nicht am User oder an Rechten liegt.

    Jedoch: Sobald ich einen Service zum Messen der Temperatur mit dem DS1820 Sensor aktiviere, verstummt das Audio-Signal.

    d.h. entweder dieser Service oder Audio hören.

    Der Service basiert auf wiringPI und dem 1-wire Bus und nutzt den Sensor DS1820.

    Ich versuche das Problem mal weiter einzugrenzen.


    Aber hat jemand Erfahrung mit dem MiniAmp in der Kombination mit wiringPi oder dem 1-wire Bus??


    VG Mike

    Hallo,

    Soweit erfolgreich: Musik bzw Internet-mp3-streams spielen über den omxplayer (ja, ich höre was:-))

    über den alsamixer bzw amixer kann ich einfach z.B. die Lautstärke steuern.


    d.h. ich werde jetzt versuchen, die Unterschiede zwischen beiden SD-Karten, also zwischen beiden Konfiguratinen, zu verstehen...


    VG
    Mike

    Hallo Thotaa,
    das gehört zwar nicht in den Thread her: ich möchte am Ende ein Internetradio haben: Also bräuchte ich eine Möglichkeit Sender und vor allem Lautstärke extern zu ändern: Kann man MPD/MPC extern (z.B. von einem Background-Service) ansteuern? Hast du dazu Erfahrungen?

    ---
    Ich gehe jetzt erstmal noch zum alsamixer...

    VG
    Mike

    Hallo Manul, Thotaa,


    habe heute nochmals alles der /boot/config.txt gelöscht und nur noch den Eintrag

    dtoverlay=hifiberry-dac

    belassen.


    Aber gleicher Effekt, d.h. kein Ton mit speaker-test -c 2


    Nun auf einer leeren SD-Karte ein Raspbian Stretch lite aufgesetzt (GUI will ich eigentlich nicht und brauche ich nicht).

    Übliche Schritte: update&upgrade; language&keyboard eingestellt; wifi konfiguriert; ssh aktiviert

    Konfiguration noch mit per HDMI angeschlossenen Monitor.


    aplay -l zeigt nun:

    **** List of PLAYBACK Hardware Devices ****

    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

    Subdevices: 7/7

    Subdevice #0: subdevice #0

    Subdevice #1: subdevice #1

    Subdevice #2: subdevice #2

    Subdevice #3: subdevice #3

    Subdevice #4: subdevice #4

    Subdevice #5: subdevice #5

    Subdevice #6: subdevice #6

    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

    Subdevices: 1/1

    Subdevice #0: subdevice #0


    Nun wie im link hier beschrieben

    https://support.hifiberry.com/…rry-MiniAmp-Configuration

    in der /boot/config.txt

    die Zeile

    dtoverlay=hifiberry-dac

    eingefügt und


    reboot


    und aplay -l:


    **** List of PLAYBACK Hardware Devices ****

    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

    Subdevices: 7/7

    Subdevice #0: subdevice #0

    Subdevice #1: subdevice #1

    Subdevice #2: subdevice #2

    Subdevice #3: subdevice #3

    Subdevice #4: subdevice #4

    Subdevice #5: subdevice #5

    Subdevice #6: subdevice #6

    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

    Subdevices: 1/1

    Subdevice #0: subdevice #0

    card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

    Subdevices: 1/1

    Subdevice #0: subdevice #0


    und cat /proc/asound/cards:

    0 [ALSA ]: bcm2835_alsa - bcm2835 ALSA

    bcm2835 ALSA

    1 [sndrpihifiberry]: HifiberryDac - snd_rpi_hifiberry_dac

    snd_rpi_hifiberry_dac


    Nun wieder der

    speaker-test -c 2

    Ich höre am Monitor, der noch über HDMI angeschlossen ist, rauschen ==> ok

    Aber ich ich höre am Lautsprecher am miniamp nichts!


    Also nach folgender Anleitung:

    https://www.hifiberry.com/buil…/configuring-linux-3-18-x

    diese Zeile in der /boot/config.txt noch auskommentiert

    # dtparam=audio=on


    HDMI-Monitor auch abgesteckt, d.h. nur noch der Lautsprecher am miniamp und reboot


    Nun zeigt aplay -l:

    **** List of PLAYBACK Hardware Devices ****

    card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

    Subdevices: 1/1

    Subdevice #0: subdevice #0


    cat /proc/asound/cards

    0 [sndrpihifiberry]: HifiberryDac - snd_rpi_hifiberry_dac

    snd_rpi_hifiberry_dac


    Und endlich:

    speaker-test -c 2

    JA, ich höre (nach kurzer Verzögerung von ca 2 sek) endlich ein Rauschen


    Ich werde nun versuchen, den alsamixer zu konfigurieren (der zeigt jetzt natürlich noch "This sound device does not have any controls." an), damit ich eine Lautstärkenregelung habe und mit dem omxplayer (oder was ist der einfachste player für Internet mp3 streams??) ein mp3 abzuspielen.

    Melde mich dann nochmal.


    Und dann bleibt die Aufgabe, die Unterschiede zwischen beiden SD-Karten, also zwischen beiden Konfiguratinen, zu verstehen...


    Viele Dank schon mal soweit

    VG Mike

    Hallo


    Thotaa:

    ich habe /boot/config.txt geändert:

    dtparam=i2s=on -> auskommentiert

    dtoverlay=i2s=on -> eingefügt

    dtoverlay=w1-gpio,gpiopin=4,pullup=on -> auskommentiert

    Neu gestartet und speaker-test, aber immer noch kein Ton.


    Dann nehme ich jetzt mal das image von PiCorePlayer (auf eine andere SD Karte) und schaue, ob ich damit weiterkomme.


    In welchen Gruppen ist der User bei euch?

    bei mir ist er in:

    adm sudo audio www-data video gpio i2c spi


    VG Mike

    Hallo


    Manul:

    du meinst von hier:

    https://picoreplayer.org/main_downloads.shtml

    Version pCP4.1.0 Standard Version vom 24.11.2018

    Ja, das werde ich testen. (Klar habe ich mehrere SD Karten hier)


    Thotaa:

    bei mir steht in der /boot/config.txt aktuell

    dtparam=i2s=on

    Soll ich das mal in

    dtoverlay=i2s=on

    ändern?


    Ich teste auch das mit den direkten PIN-Verbindungen (Ich hatte das so ganz am Anfang, weil ich andere GPIO's für weitere Zwecke im Radio nutzen will. Aber nachdem ich keinen Ton bekam, habe ich versucht alles rückzubauen und nur noch den hifiberry anzuschließen.)


    VG Mike

    Hallo Thotaa,


    hier meine /boot/config.txt:

    Wäre schön, wenn ich da was 'verstellt' hätte.


    # For more options and information see

    # http://rpf.io/configtxt

    # Some settings may impact device functionality. See link above for details


    # uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1


    # uncomment this if your display has a black border of unused pixels visible

    # and your display can output without overscan

    disable_overscan=1


    # uncomment the following to adjust overscan. Use positive numbers if console

    # goes off screen, and negative if there is too much border

    #overscan_left=16

    #overscan_right=16

    #overscan_top=16

    #overscan_bottom=16


    # uncomment to force a console size. By default it will be display's size minus

    # overscan.

    #framebuffer_width=1280

    #framebuffer_height=720


    # uncomment if hdmi display is not detected and composite is being output

    #hdmi_force_hotplug=1


    # uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1

    #hdmi_mode=1


    # uncomment to force a HDMI mode rather than DVI. This can make audio work in

    # DMT (computer monitor) modes

    #hdmi_drive=2


    # uncomment to increase signal to HDMI, if you have interference, blanking, or

    # no display

    #config_hdmi_boost=4


    # uncomment for composite PAL

    #sdtv_mode=2


    #uncomment to overclock the arm. 700 MHz is the default.

    #arm_freq=800


    # Uncomment some or all of these to enable the optional hardware interfaces

    dtparam=i2c_arm=on

    dtparam=i2s=on

    #dtparam=spi=on

    dtoverlay=hifiberry-dac



    # Uncomment this to enable the lirc-rpi module

    #dtoverlay=lirc-rpi


    # Additional overlays and parameters are documented /boot/overlays/README


    # Enable audio (loads snd_bcm2835)

    # dtparam=audio=on


    # ###################################

    # 16-Feb-2019, for temperature meassurement with DS1820

    # dtoverlay=w1-gpio,gpiopin=4,pullup=on

    dtoverlay=w1-gpio,gpiopin=4,pullup=on


    # ###################################

    # 21-Feb-2019, for HiFiBerry MiniAMP: dtoverlay=hifiberry-dac

    # dtparam=i2s=on ## activated already above

    # dtoverlay=hifiberry-dac ## activated already above

    # dtoverlay=i2s-mmap

    #



    Jürgen Böhm

    Entsprechend diesem Link:

    https://pi-buch.info/hifiberry…er-klang-fuer-audiophile/


    Stellen Sie außerdem sicher, dass die Dateien /etc/modprobe.d/* die folgenden Zeilen nicht enthalten. Gegebenenfalls müssen Sie auch diese Zeilen durch ein Kommentarzeichen deaktivieren. Bei einer aktuellen Raspbian-Version besteht hier kein Handlungsbedarf.


    # diese Zeilen dürfen NICHT in Dateien

    # innerhalb /etc/modprobe.d/* vorkommen

    blacklist i2c-bcm2708

    blacklist snd-soc-pcm512x

    blacklist snd-soc-wm8804


    Das passt bei mir alles.



    Diesen Link hier im Forum habe ich schon gelesen (und ich glaube, das war letztendlich der Grund warum ich den hifiberry Miniamp gekauft habe)

    HIFIberry miniAmp aktivieren

    so wie auf dem Link schaut es bei mir auch aus:

    https://forum-raspberrypi.de/a…98-rpi2-susv-miniamp-jpg/

    Interessanterweise gibt es wohl dort ebenfalls Leute, bei denen es einfach funktioniert und - siehe Thread #7 vom 31.10.2017 - auch Leute mit einem ähnlichen/gleichen Problem wie ich??


    ein aplay -l zeigt mir das device auch (würde ich meinen):

    **** Liste der Hardware-Geräte (PLAYBACK) ****

    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

    Sub-Geräte: 1/1

    Sub-Gerät #0: subdevice #0



    ein cat /proc/asound/cards zeigt:

    0 [sndrpihifiberry]: HifiberryDac - snd_rpi_hifiberry_dac

    snd_rpi_hifiberry_dac


    Irgendwie schaut das für mich alles so aus, wenn ich die Konfiguration so hätte, wie andere auch, aber mit dem Unterschied, dass ich keinen Ton erhalte. Also muss ich irgendwo eine andere Konfiguration oder Einstellung haben!


    Ich habe auch nach Thread #11 von schlizbäda sichergestellt, das ich keine versteckte .asoundrc im HOME Verzeichnis habe.

    Ich würde behaupten bis zum speaker-test habe ich alles genauso gemacht, aber dann höre ich halt das 'rosa Rauschen' nicht.


    hyle:

    Nein, die Phoniebox habe ich nicht benutzt oder getestet.



    Noch eine etwas verrückte Idee:

    Kann es sein, dass meinem User (ich arbeite nicht mit dem Standarduser pi) irgendwo Rechte oder eine Gruppenzugehörigkeit fehlen?


    VG

    Mike

    Hallo Thotaa,


    ok. Danke für den Hinweis für den 4. Ring (dann muss ich da nicht mehr suchen)


    Ich habe eben mit sudo raspi-config den I2C zur Sicherheit nochmals enabled:


    ┌──────────────────────────────────────────────────────────┐

    │ │

    │ The ARM I2C interface is enabled │

    │ │


    Kopfhörer mit speaker-test danach aber leider auch noch ohne Ton.


    Viele Grüße

    Mike

    Hallo Thotaa,


    ich habe eben eine PC-3,5mm-Klinken Kopfhörer angeschlossen. Mit speaker-test höre ich leider ebenfalls nichts.

    Aber brauche ich da nicht einen speziellen Klinkenstecker für den Raspi (ich habe da was im Kopf, dass die Buchse am Raspi 4 Ringe hat)

    Dann müsste ich mir so einen Adapter besorgen.


    Den Miniamp könnte ich höchstens an einem anderem Raspberry Pi testen. Ich habe noch einen Zweier-Raspberry, derzeit aber in einem Projekt eingebaut.

    Umgekehrt kenne ich leider niemanden, der auch den hifiberry-dac hat oder nutzt, so dass ich mal temporär tauschen und testen könnte.


    Viele Grüße

    Mike

    Hallo Manul,


    ich habe extra noch ein zweites Lautsprecher alternativ angeschlossen, die ich vorher auch getestet hatte.

    Ich nutze ebenfall Raspbian strech mit Kernel 4.14.98-v7+.

    Ich habe in der /boot/config.txt diesen Eintrag:

    dtoverlay=hifiberry-dac

    Ich habe eine asound.conf mit diesem Inhalt:

    pcm.!default {

    type hw card 0

    }

    ctl.!default {

    type hw card 0

    }


    Viele Grüße

    Mike

    Hallo zusammen,


    Thotaa: ok - du hörst eben schon was mit 'speaker-test'. Da fängt es bei mir an, da ich da nichts höre. Insofern verstehe ich auch, dass ich dannach mit keiner Software einen Ton hören kann.


    Thotaa: dein Beitrag 26: ich nutze ebenfalls Stretch. Und ich habe mein erstes Projekt vor ca 3 Jahren begonnen und umgesetzt. Seitdem auch 2 Projekt ununterbrochen am Laufen. Nun wollte ich mir letztes Jahr ein Internet-Radio bauen. Also viel Rechere betrieben und gelesen und dann begonnen. LCD Display läuft, alles andere kann ich ebenfalls. Aber ich schaffe es eben nicht einen Ton zu hören und deswegen habe ich nach ca 4 Monaten Suche gedacht, ich schaue mal, ob ich hier Hilfe finde....


    raspbastler:

    Diese Anleitung kenne ich. Habe ich auch schon vor längerer Zeit, als ich mit meinem Projekt begonnen habe, gelesen.

    Er beschreibt zwar ganz viele Sachen - auch absolute Basics wie OS installieren - extrem detailliert, ich finde aber keine Detailkonfiguration für den hifiberry-dac.

    Irgendwann nutzt er eine Software 'configure_radio'. Aber alles andere wie LCD Display hätte ich schon am Laufen.

    Er verweist dann auf troubleshooting ab Seite 108, aber das hilft mir eben auch nicht weiter:-(


    raspbastler:

    Vielleicht liegt mein Problem doch in der Konfiguration von alsa oder ...

    Hast du evtl eine Idee, was ich noch prüfen könnte?


    Viele Grüße

    Mike

    Hallo Thotaa,


    Ich habe die /etc/asound.conf jetzt so (wie im Beitrag #8 verlinkt) geändert:


    pcm.!default {

    type hw card 0

    }

    ctl.!default {

    type hw card 0

    }


    Die /etc/mpd.conf habe ich analog zu dir so geändert (Ausschnitt):

    # An example of an ALSA output:

    #

    audio_output {

    type "alsa"

    name "Output"

    # device "softvol" # optional

    mixer_type "software" # optional

    # mixer_device "default" # optional

    mixer_control "Master" # optional

    # mixer_index "0" # optional

    # dop "no" # optional

    }

    #


    Vorsichtshalber neu gestart


    Ich bekomme mpd/mpc bisher nicht zum Laufen.

    Ich glaube ich habe in der mpd.conf alles richtig konfiguriertund ich kann den service mit

    sudo service mpd restart

    sudo service mpd status

    (re-)starten (nach 'status' auch ohne Fehler)

    Jedoch beim

    mpc add <link>

    oder auch beim

    sudo mpc add <link>

    erhalte ich den Fehler

    ...you don't have permission for "add"


    (Ich habe kein passenden 3,5 mm Klinkenkopfhörer, deswegen kann ich das nicht testen. Ich habe allerdings auch verstanden, dass ich den Raspberry dazu ja umkonfigurieren müsste??)


    Hörst du was mit

    speaker-test -c 2

    als einfachsten Test?


    Wenn ich

    alsamixer

    aufrufe und mit F6 die Soundkarte auswähle, scheint scheinbar immer der erste Eintrag '- (Standard)' ausgewählt zu sein?

    ┌─────── Soundkarte ───────┐

    │- (Standard) │

    │0 snd_rpi_hifiberry_dac │

    │ Gerätenamen eingeben...│

    └──────────────────────────┘


    Der zweite Eintrag mit '0 snd_rpi_hifiberry_dac' ist der gleiche wie in der Ausgabe von

    aplay -l

    Ist das bei dir auch so?


    Und nur mal zum Abgleich: am Raspbian kann es nicht liegen?

    uname -a liefert:

    Linux raspi04 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux



    Viele Grüße

    Peter

    Hallo Thotaa,


    ich poste hier mal meine "/etc/asound.conf":


    # #############################

    #

    #

    pcm.!default {

    type plug

    slave.pcm "softvol"

    }

    pcm.softvol {

    type softvol

    slave {

    pcm "plughw:0"

    }

    control {

    name "Master"

    card 0

    }

    }

    ctl.!default {

    type hw

    card 0

    }


    die Datei "/etc/mpd.conf" sah bisher so aus (Ausschnitt):


    # An example of an ALSA output:

    #

    audio_output {

    type "alsa"

    name "Output"

    device "softvol" # optional

    # mixer_type "hardware" # optional

    # mixer_device "default" # optional

    mixer_control "Master" # optional

    # mixer_index "0" # optional

    dop "no" # optional

    }

    #


    Habe ich jetzt geändert in (gleicher Ausschnitt):


    # An example of an ALSA output:

    #

    audio_output {

    type "alsa"

    name "Output"

    device "softvol" # optional

    mixer_type "software" # optional

    # mixer_device "default" # optional

    mixer_control "Master" # optional

    # mixer_index "0" # optional

    dop "no" # optional

    }

    #



    Ich habe bei meinem bisherigen Versuchen Musik abzuspielen folgende Player genutzt:


    omxplayer -o alsa ~/Music/example.mp3


    d.h. als Quelle auch ein lokales mp3-file.

    Final wäre mein Ziel, dass ich für ein Internet-Radio mp3-streams abspielen kann.

    (Bisher scheitert alles daran, dass überhaupt keinen Ton erzeugen/hören kann)


    Wie kann ich mit mpd ein mp3-file zum Testen abspielen?

    (Oder geht das nur über konfigurierte playlists?)


    Danke für deine Hilfe

    Mike

    Hallo Thotaa,


    ja, so habe ich das auch verstanden: kleine Lautsprecher mit 4 ohm und max 3 Watt sollte ok sein.

    Solche Lautsprecher verwende ich.


    Jetzt wären die Fragen:

    Was mache ich anders/falsch

    Wie könnte ich den I2S testen?


    Viele Grüße

    Mike

    Hallo Schlizbäda,


    wenn ich 'aplay -l' ausführe erhalte ich


    **** Liste der Hardware-Geräte (PLAYBACK) ****

    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

    Sub-Geräte: 1/1

    Sub-Gerät #0: subdevice #0


    das schaut so aus wie bei dir im Post, bis auf die Zeile 'Sub-Geräte: 1/1'

    Aber schon dann beim Kommando 'speaker-test -c 2' höre ich nichts:-(


    Viele Grüße

    Mike

    Hallo Thotaa,


    ja - ich habe die Karte auf den Raspberry Pi aufgesteckt und dann direkt die Lautsprecher angeschlossen.

    Hier ein Bild (zum Testen jetzt mal nur 1 Lautsprecher am grün-roten Kabel angeschlossen)



    Links ein USB-Stick - nur als Speicherplatz.

    Ich greife per Terminal zu und nutze keine GUI am Raspberry PI - aber das sollte kein Problem sein, oder?


    Bitte korrigiere mich: diese Karte ist doch genau ein Verstärker, so dass ich die Lautsprecher direkt anschließen kann??

    (so hätte ich Manul weiter oben auch verstanden, der die Karte sein 3,5 Jahren nutzt)


    Deine Vermutung, dass die I2S-Schnittstelle nicht bedient wird: wie könnte ich das verifzieren?


    Viele Grüße

    Mike

    Nein, ich konnte noch nie irgendetwas hören.

    Egal wie laut im alsamixer eingestellt, egal welcher Player oder speaker-test -> ich höre nie etwas.

    Deswegen meine Vermutung, dass irgendwo noch ein grundstätzliches Setting falsch sein muss?

    (Bei der Hardware kann eigentlich nicht viel falsch sein: Aufgesteckt und Lautsprecher angeschlossen)?