Posts by Bern93

    Das hat super geklappt danke vielmals. Das einzige was ich anders machen musste, war, dass ich anstelle von sudo apt-get update folgendes ausführen musste: sudo apt-get update --allow-releaseinfo-change. Sonst war es Top.

    Anschliessend konnte ich die intl-Erweiterung installieren:sudo apt-get install php7.4-intl.

    Danach konnte ich Grocy auf die neuste Version (Version 3.1.1) updaten und anschliessend auch fehlerfrei starten.

    Nun habe ich das Grocy Update wieder Rückgängig gemacht (Image vor Update geladen), weil ich schauen wollte, was mir das sudo apt-get update zurückgibt. Das gibt zwar nicht genau dasselbe zurück wie nach dem Update aber etwas ähnliches:


    Danach habe ich das hier gemacht (der Beitrag von Hofei)


    dann erschien das als ich apt-get update --allow-releaseinfo-change eingegeben habe :


    Das klingt nicht so wie es klingen sollte, oder?

    Hallo Jürgen Böhm

    Danke für die schnelle Antwort.

    Ich habe mir die Links angeschaut, aber leider hilft mir das nicht weiter, da ich leider so gut wie keine Ahnung davon habe.

    Mit Buster wird die 7.3er intl-Version ausgeliefert.

    Aber die 7.3er Version funktioniert ja nicht für die 7.4er Version oder? Das müsste ja sicher eine eigene Erweiterung sein..?

    Es ist auch möglich, das der Server/Webseite wg. Wartungsarbeiten down ist, versuch es später noch einmal.

    Das wäre möglich aber eher unwahrscheinlich, da ich es am Freitag, Sonntag und gerade eben noch einmal probiert habe und es leider immer noch nicht geht.


    LG Bern

    Hallo zusammen

    Ich wollte Grocy auf meinem RPI aktualisieren.

    Nun habe ich das Problem, dass wenn ich localhost aufrufe, die Meldung erscheint:Unable to run grocy: PHP module 'intl' not installed, but required..

    Nun wollte ich die intl- Erweiterung mit Hilfe von sudo apt-get install php7.4-intl installieren. Da kommen dann diese Meldungen (ich benutze php7.4.13):

    Das scheint ja nicht zu funktionieren. Daher wollte ich einmal ein update machen, weil es vorgeschlagen wurde, aber das scheint auch nicht zu gehen, oder?

    Kann mir jemand helfen die Probleme zu lösen?


    LG Bern

    Ich habe den Wechsel nicht freiwillig gemacht. Ich musste es, weil die neue Version nicht auf 7.4 läuft. Aber dank deiner Hilfe klappt es nun. Zuerst habe ich im Terminal a2enmod php7.4 und danach a2dismod php7.3. So klappt nun alles. Danke vielmals :)

    Ok Danke.

    Was könnte aber dann das Problem sein? Das Ganze läuft noch über SQLite3. Muss ich diesem noch irgendwie mitteilen, dass dieser nun über PHP 7.4 läuft und nicht mehr über 7.3? Oder kann es sein, dass der Webserver eine andere PHP-Version benutzt als die, die es mir in der Kommandozeile anzeigt ?


    Leider habe ich keine Ahnung davon. Ich bin einer Anleitung gefolgt, danach hat das alles funktioniert. Nun nach dem Update funktioniert es nicht mehr.

    Ja läuft:

    edit:

    Ist die Meldung Feb 01 13:17:37 raspberrypi apachectl[2673]: AH00558: apache2: Could not reliably determine the server

    normal?

    Hallo KKoPi


    Danke für die Antwort.

    Ich habe einen Neustart mit sudo service php7.4-fpm restart versucht. Leider erschien der Fehler, dass dies nicht gefunden werden kann:

    Code
    pi@raspberrypi:~ $ sudo service php7.4-fpm restart
    Failed to restart php7.4-fpm.service: Unit php7.4-fpm.service not found.

    Muss ich da erst noch ins passende Verzeichnis wechseln?


    LG Bern

    Hallo caldir65


    Ja das stimmt, die Website scheint nicht mehr zu existieren.

    Hast du denn dasselbe Problem wie ich zu Beginn?

    Am Besten setzt du dich direkt mit 3M in Verbindung und erklärst denen dein Problem. Mir konnten sie so recht einfach helfen.


    LG Bern

    Ausgelagert aus Warenwirtschaftssystem (grocy) auf Raspberry als Webserver



    Hallo Leute


    Ich wollte Grocy auf die neuste Version aktualisieren, da ich mir erhoffte, dass ein Fehler behoben wurde. Nun habe ich diese Schritte ausgeführt (Beschreibung von GitHub):

    Quote

    If you run grocy on Linux, there is also update.sh (remember to make the script executable (chmod +x update.sh) and ensure that you have unzip installed) which does exactly this and additionally creates a backup (.tgz archive) of the current installation in data/backups (backups older than 60 days will be deleted during the update).

    Danach erschien beim Aufruf von localhost die Meldung:

    Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.4.0".

    Anschliessend habe ich die PHP Version 7.4.13 installiert aber es erscheint immer noch dieselbe Fehlermeldung. Muss ich da sonst noch etwas anpassen?


    Die Ausgabe von php -v im Terminal ist:

    Code
    pi@raspberrypi:~ $ php -v
    PHP 7.4.13 (cli) (built: Nov 30 2020 20:40:09) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.13, Copyright (c), by Zend Technologies

    LG

    Bern

    Hallo __blackjack__ Danke für die Antwort.


    Ich werde das Programm entsprechend anpassen, damit ich alle Punkte, die du mir genannt hast ausmerzen kann.


    Nun habe ich noch eine Frage zum erstellen von Listen:

    Ich möchte mehrere leere Listen (33 Stück) erstellen. Die erste heisst alarm1, die zweite alarm2 usw. (ich weiss nummerierte Variablen, Listen etc. sind nicht optimal. Aber hier macht es Sinn.)

    Kann man diese mit wenigen Zeilen Code erstellen? So nach diesem System:


    Code
    for i in range (0, 33):
        alarm(i)=[]

    Gibt es irgendeine einfach Möglichkeit dazu?


    LG Bern