Posts by Fillip13

    Hallo zusammen,
    wollte jetzt nicht einen neuen Thread aufmachen, da ich denke es passt schon hier rein. Python ist zwar nicht komplettes Neuland für mich, jedoch mit der Programierung hab ich nicht sooo viel am Hut.
    Ich würde gerne so ein Num Pad per USB an den Pi schließen, und wenn eine Zahl gedrückt wird, soll ein url per urllib2 geöffnet werden soll.
    Hatte bereits versucht da was zusammen zu basteln, aber leider hat das nicht so geklappt, sah auch noch sauber aus. Bin für Ideen offen uns Dankbar :-)

    Ich hab aktuell auch das Problem unter Jessy, will zwar nicht Chromium starten, sondern ein anderen Browser, habe unter "/etc/xdg/lxsession/LXDE-pi/autostart" folgendes stehen:


    #@lxpanel --profile LXDE
    #@pcmanfm --desktop --profile LXDE
    #@xscreensaver -no-splash
    @xset s off
    @xset -dpms
    @xset s noblank
    @epiphany-browser -a /home/pi/start.htm


    Jedoch startet ganz normal der Desktop und das wars, kein Browser o.ä...


    Was muss denn unter den Einstellungen "raspi-config" als Boot Option gewählt werden?

    Aktuell habe ich (mal wieder) das Problem das ich mich mittels "door" > "pi" nicht in der Weboberfläche anmelden kann, das Problem hatte ich schon einmal.


    Wo kann ich denn noch das Logfile finden?
    ---------------------------------------------------------------------------------------------------
    Nun klappt der Mail Versand auch nicht mehr, nichts geändert, irgendwer will glaube ich nicht das das ganze so läuft wie es soll :wallbash:

    Also ich habe jetzt alles bedenkliche versucht, um den DoorPi an meine 7490 anzumelden. Danke da auch nochmal an "Nea", aber es passiert nichts. Wenn ich vom Telefon den DoorPi (**620) versuche anzurufen erhalte ich immer "Keine Verbindung"


    Die DoorPi.ini sieht bei mir wie folgt aus


    Username habe ich sowohl mit ** als auch ohne versucht.


    In der fritz!box ist der Nutzer als IP/WLAN Telefon wie folgt angemedet bzw angelegt


    Was mache ich falsch?


    Das ganze sollte ja auch ohne vorhandenes DSL laufen sprich nur die Fritz!Box, daran sollte es eigentlich nicht liegen, oder doch?

    Guten Abend nochmals zusammen,


    hat jemand bereits den Mail Versand getestet und erfolgreich im Einsatz? Ich habe es getestet, bzw versucht, erhalte jedoch keine meldung, anbei mal meine .ini.


    Eventuell habe ich (mal wieder) was vergessen...

    Nun, nach einem neuen Aufsetzen und neuer Installatio klappt auch der Login,
    nur jetzt lässt sich der DoorPi nicht sauber beenden, bei dem Versucht mit Strg + C das zu beenden, tut er dies zwar, aber er gibt mir keine möglichkeit am Pi weiter zu Arbeiten, erst bei einem druck auf "Pause", danach lässt sich DoorPi aber erst nach einem reboot wieder starten...


    Code
    2015-12-30 23:22:04,878 [INFO]          [doorpi.doorpi] ======== DoorPi successfully shutdown ========
    ^Z
    [1]+  Stopped                 sudo doorpi_cli --trace
    pi@raspberrypi /tmp/DoorPi $


    Aber bis hier hin - Top Projekt - Super Arbeit :danke_ATDE:


    Super Anderas, ich danke dir" mittels sudo hat es nun geklappt.
    Automatisch zusammengefügt:[hr]

    User: door
    Password: pi


    Stimmen die Login Daten noch? Bei mir schlägt der Login mit den Daten nämlich fehl :(


    Aber als kleinen Tip von mir, löse deine Probleme immer stück für stück. Das hat den Vorteil wenn du irgendwo Änderungen in der doorpi.ini machst und du DoorPi startest und es nicht läuft bzw. automatisch beendet wird das du gleich weist das deine Änderungen nicht funktionieren.
    Du solltest als erstes DoorPi richtig zum laufen bekommen das heist das du keine Fehlermeldungen mehr im log bzw. in der Ausgabe mehr drin stehen hast (sudo doorpi_cli --trace) danach die Einstellungen in der FritzBox vornehmen sprich DoorPi als Telefoniegerät registrieren natürlich auch einen Client sonst kann ja DoorPi niemanden anrufen. Wenn dann alles soweit läuft kannst du dich ans Anpassen machen.


    Gruß Andreas



    Das heißt ja, das DoorPi auch ohne vorhandene Fritz!Box erst einmal starten sollte. Die ist nämlich noch unterwegs zu mir :D Wollte das ganze erst einmal Testen, es wird später auch nur eine Klingen und eventuell der BriefkastenSensor angeschlossen, keine Sprechanlage o.ä.


    Problem ist ja, das ich die Datei garnicht bearbeiten kann, da DoorPi ja gar nicht startet, er beendet sich ja gleich nach dem versuch ihn zu starten, wie in der letzten Zeile ausgegeben :-/



    :danke_ATDE:


    Grüße Fillip


    Ist denn die Installationsanleitung von GitHub noch die aktuelle? Denn so bin ich "Nur" vorgegangen

    Code
    sudo rm -r -f /tmp/DoorPi
    git clone https://github.com/motom001/DoorPi.git /tmp/DoorPi
    cd /tmp/DoorPi
    sudo python setup.py install
    doorpi_cli --trace


    In der doorpi.ini wird das eingestellt. Editieren kannst du es so.


    Code
    sudo nano /usr/local/etc/DoorPi/conf/doorpi.ini



    Gruß Andreas


    Die Datei habe ich gesucht genau! Nur leider ist die bei mir leer / existiert nicht [New file]


    Aber noch ne andere frage, muss der Pi denn an der Fritz!Box als Telefoniegerät registriert werden oder wie läuft das denn ab dann?


    EDIT: Beim Versuch zu starten, haut er mir im übringen jede menge "Meldungen / Hinweise" raus

    Hallo, ich habe auch das Problemm mit dem make befehl, das dieser nicht ausgeführt wird, mir wird zum Schluss des ./configure "configure: error: No libjansson found. Try --disable-json
    " angezeigt, auch ein manueller Download brachte keine besserung... die datei "makefile.in" ist auch vorhanden... :-/


    Ich habe auch noch ein merkwürdiges Phänomen... Das Wetter wird mal angezeigt und mal nicht... Habe mir die Daten von Temp, Himmel, Aufgang und Untergang anzeigen lassen. Gestern ging es ab und zu und heute will es garnicht, auf der NetIO App wird mir nur noch das Label angezeigt, man merkt er will aktualisieren aber es kommt dann nichts... Im Crontab steht es drinne

    Code
    */15 * * * * sudo python /home/pi/netio_server/openweather_client.py Wolfsburg > crontab_ow_client.log 2>&1

    , die datei ist auch in dem Ordner netio_server drinne.


    Achso und P.S mario, auf der ersten seite im Tutorial hast du einen kleinen "fehler" drinne, da steht

    Code
    cd netio-server

    , müsste es aber nicht

    Code
    cd netio_server

    heißen?


    Was nutzt du denn für einen Empfänger? Ich habe einen UP Schalter, an diesem kann ich aber nur einen Buchstaben "A-.." und eine zahl "1-.." einstellen, mehr nicht...


    EDIT: Denn egal wie, mittels


    Code
    pi@raspberrypi ~/raspberry-remote $ sudo ./send a 1 1
    sending systemCode[a] unitCode[1] command[1]
    pi@raspberrypi ~/raspberry-remote $ sudo ./send A 1 1
    sending systemCode[A] unitCode[1] command[1]
    pi@raspberrypi ~/raspberry-remote $


    tut sich nichts... Der Schalter steht auf "A" und "1"

    An den LEDs habe ich noch keine Widerstände dran...


    Aber gibt gute News,
    Habe nun zwischen 3,3V und GPIO den Widerstand gehängt, den Taster zwischen GND und dem GPIO sowie das Skript in False umgeändert, nun läuft alles wie es soll... Hoffentlich bleibt das so