Posts by dy8

    Der Pi ist derzeit noch separat mit einem original Netzteil angebunden, soll später aber ebenfalls mit in den Stromkreis integriert werden

    War nur eine grundsätzliche Frage, die Leitung könnt ich so legen und werd ich nachher mal versuchen. Richtig, der Plan zeigt den funktionierenden, aber nicht zufriedenstellenden, Zustand. Klemme ich eine Leitung vom 12V Trafo an den 12V Eingang vom Motodriver, dreht sich wie gesagt nichts.

    Moin und schon mal vielen Dank für die Antworten.

    Bin fritzing-Neuling; hoffe ihr könnt den Plan trotzdem nachvollziehen. Ich arbeite mit einem 230V auf 12V Trafo, anschließend geht +12V in einen +5V Wandler (dargestellt als Vortage Regulator im Schaltplan) und von dort aus in den Motodriver. GND hole ich mir vom Ausgang des 5V Wandlers per Wago-Klemme; spart mir Löten und Quetschverbinder. GND ist NICHT mit dem 12V Trafo verbunden; wusste nicht wie ich das anders darstellen kann.

    Leider hab ich nicht genau das L298N Modul gefunden, welches ich einsetze. Hat aber zusätzlich noch einen 12V Eingang und einen Jumper, wie von TGD beschrieben. Derzeit muss ich, auch wenn ich 5V verwende, den Jumper gesetzt haben, da das Modul sonst nicht anstartet. Hängt das mit der, von TGD angemerkten, fehlenden Masseverbindung zwischen Pi und Motodriver zusammen? Falls ja, würde ich nachher noch mal den bisherigen Aufbau überarbeiten und überall Masseverbindungen schaffen. Vielleicht nur ein Anfängerfehler. :)

    Edit: Danke Thomas, aber wenn ich - wie in der pdf beschrieben - 5V, GND und 12V angeschlossen habe und dann den Jumper entferne, dreht sich der Motor gar nicht mehr. :/ Außer ich entferne eine der beiden Input Leitungen vom Pi bzw. Motodriver.

    Liebe Grüße

    Moin zusammen,

    ich baue zurzeit nach dieser Anleitung eine automatische Hühnerklappensteuerung (https://drive.google.com/file/d/12W2sYZ…N5kYXK2H6q/view & https://sites.google.com/view/huehner-pi/home). Bisher klappt auch alles super, auch wenn mich die Anleitung einiges an Nerven gekostet hat, da Dinge schlecht oder falsch dokumentiert sind. Nun ja. Auf Seite 10 der PDF-Datei wird das Anschließen des L298N Motodriver Moduls erklärt.

    Schließe ich 5V und GND an das Modul an, lässt sich alles problemlos via GPIO ansteuern und der Motor dreht auch in die gewünschte Richtung. Leider ist das zu wenig Leistung um die eigentliche Klappe (Plexiglasscheibe) anzuheben und deshalb wollte ich nun 12V auf den Motor speisen. Laut der PDF soll das wohl funktionieren, indem man den Jumper vom Motodriver entfernt und zusätzlich eine 12V Versorgung herstellt. - Mache ich das, lässt sich nichts mehr ansteuern. Es sei denn, ich entferne einen GPIO vom Pi.

    Zur Stromversorgung habe ich ein 230V -> 12V Trafo verwendet. Die +12V Leitung splitte ich mit einer Wago-Klemme auf. Dabei geht eine Leitung zu einem 12V -> 5V KFZ-Wandler und anschließend in den +5V Eingang des Motodrivers. Die andere Leitung, mit dann +12V, in den +12V Eingang des Motodrivers.

    Ich verwende einen SBC MotoDriver 2 (Datenblatt: https://produktinfo.conrad.com/datenblaetter/…SEN__L298N_.pdf) sowie einen Raspberry Pi 3 mit Raspbian Butter. Löchert mich gern mit Gegenfragen zu weiterer verwendeter Hardware; ich denk mal bisher sollte das relevanteste genannt worden sein.

    Dazugehörige Software ist https://drive.google.com/open?id=1qQRHl…1gM3mGuaRTEJWJP - die muss ich allerdings noch um bzw. neu schreiben um MQTT Support zu haben.

    Liebe Grüße