Posts by prozanko

    So alt ist die Karte noch nicht, tausche die ein Mal im Jahr aus.

    Hier mal die Ausgabe von mount:


    /dev/mmcblk0p2 on / type ext4 (rw,noatime)

    devtmpfs on /dev type devtmpfs (rw,relatime,size=1867776k,nr_inodes=117760,mode=755)

    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

    proc on /proc type proc (rw,relatime)

    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)

    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)

    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)

    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)

    tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)

    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)

    cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)

    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)

    bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)

    cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)

    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)

    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)

    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)

    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)

    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)

    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)

    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)

    sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)

    debugfs on /sys/kernel/debug type debugfs (rw,relatime)

    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=40,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)

    mqueue on /dev/mqueue type mqueue (rw,relatime)

    configfs on /sys/kernel/config type configfs (rw,relatime)

    /dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

    tmpfs on /run/user/999 type tmpfs (rw,nosuid,nodev,relatime,size=399972k,mode=700,uid=999,gid=995)

    //192.168.1.10/SmartHome/rpi_visu on /home/pi/nas_share type cifs (rw,relatime,vers=2.1,cache=strict,username=pi,uid=1000,forceuid,gid=1000,forcegid,addr=192.168.1.10,file_mode=0755,dir_mode=0755,soft,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1)

    tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=399972k,mode=700,uid=1000,gid=1000)

    gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

    /dev/sda1 on /media/pi/RPI type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

    Hallo,


    ich habe in der /etc/apt/sources.list sowie in der /etc/apt/sources.list.d/raspi.list Paketquellen ausgeklammert und mit sudo apt-get update bestätigt. Das sah auch soweit gut aus.


    Aber:

    Sobald ich den Raspi neu boote, sind die Einträge in den Dateien wieder aktiv und das #-Zeichen davor ist wieder verschwunden.


    So sollen die die Einträge aussehen:

    /etc/apt/sources.list

    deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

    #deb http://apt.symcon.de/ stable rpi



    /etc/apt/sources.list.d/unifi-controller.list

    #deb http://dl-origin.ubnt.com/unifi/debian/ stable ubiquiti


    Wenn ich die die Einträge ganz lösche, dann sind diese nach einem Neustart wieder vorhanden.


    Woran könnte das liegen?


    Zur Info: ich habe leider nicht viel Ahnung von Linux, daher wäre eine Erklärung für Anfänger hilfreich😉


    Grüße

    Hallo,



    ich habe zwei PCs mit Windows 10 pro. Beide möchte ich per net rpc shutdown mit einem Raspberry herunterfahren.

    Folgende Schritte habe ich durchgeführt:


    1. Auf Raspberry Samba installieren:

    sudo apt-get install samba-common


    2. In Windows einen Admin-Benutzer mit Passwort anlegen (test%test)


    3. cmd mit Adminrechten starten und folgendes eintragen:

    C:\Windows\system32>reg ADD HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

    Der Vorgang wurde erfolgreich beendet.


    C:\Windows\system32>sc config RemoteRegistry start= auto

    [SC] ChangeServiceConfig ERFOLGsc start RemoteRegistry


    C:\Windows\system32>sc start RemoteRegistry


    3. Im Raspberry per Konsole mit folgendem Befehl herunterfahren:

    net rpc shutdown -I 192.168.1.13 -U test%test


    Bei einem PC hat es auf Anhieb funktioniert, bei den zweiten kommt folgende Fehlermeldung:

    Could not connect to server 192.168.1.11

    Connection failed: NT_STATUS_IO_TIMEOUT

    Could not connect to server 192.168.1.11

    Connection failed: NT_STATUS_IO_TIMEOUT


    Scheint, als würde der PC da was blocken.

    Ich habe schon nach paar Sachen gesucht und ausprobiert, leider ohne Erfolg. Was könnte ich noch so ausprobieren?


    Grüße

    Bist Du sicher, dass das Netzwerk zu dem Zeitpunkt des Cronjobs schon vollständig "oben" und das NAS gemountet ist?


    Zum Test könntest Du mal folgende Zeile in der Crontab versuchen:

    Code
    @reboot sleep 30 && lsyncd /etc/lsyncd.conf


    Btw. sudo ist nicht nötig, da das die Crontab von root ist. sudo gehört eigentlich grundsätzlich nicht in eine Crontab.

    So wie es aussieht, hat diese Lösung geholfen:)

    pi@raspberrypi:~ $ namei -l /home/pi/nas_share/backup_symcon

    f: /home/pi/nas_share/backup_symcon

    drwxr-xr-x root root /

    drwxr-xr-x root root home

    drwxr-xr-x pi pi pi

    drwxr-xr-x pi pi nas_share

    drwxr-xr-x pi pi backup_symcon


    pi@raspberrypi:~ $ ls -l /home/pi/nas_share/backup_symcon

    insgesamt 0

    drwxr-xr-x 2 pi pi 0 Mai 17 16:02 lib

    drwxr-xr-x 2 pi pi 0 Mai 20 09:24 log

    drwxr-xr-x 2 pi pi 0 Mai 17 16:15 root

    Hallo,



    ich möchte mit lsyncd drei Verzeichnisse mit einem vom NAS gemounteten Laufwerk synchronisieren. Das Laufwerk ist soweit eingebunden:

    //192.168.1.10/SmartHome/rpi_symcon /home/pi/nas_share cifs uid=1000,gid=1000,defaults,nofail,username=XYZ,password=XYZ,_netdev 0 0


    pi@raspberrypi:~ $ ls -l

    drwxr-xr-x 2 pi pi 0 Mai 20 08:12 nas_share


    lsyncd habe ich folgend installiert:

    sudo apt-get install lsyncd


    Anschließend Eintrag in crontab erstellt:

    sudo crontab -e

    @reboot sudo lsyncd /etc/lsyncd.conf



    Die lsyncd.conf


    settings {

    logfile = "/var/log/lsyncd.log",

    statusFile = "/tmp/lsyncd.status",

    nodaemon = false

    }

    sync {

    default.rsync,

    source = "/var/lib/symcon",

    target = "/home/pi/nas_share/backup_symcon/lib"

    }

    sync {

    default.rsync,

    source = "/var/log/symcon",

    target = "/home/pi/nas_share/backup_symcon/log",

    delay = 60

    }

    sync {

    default.rsync,

    source = "/root",

    target = "/home/pi/nas_share/backup_symcon/root"

    }

    Es wird aber nicht synchronisiert, im Log kommt folgende Fehlermeldung:

    rsync: mkdir "/home/pi/nas_share/backup_symcon/lib" failed: No such file or directory (2)

    rsync error: error in file IO (code 11) at main.c(682) [Receiver=3.1.3]


    Da ich von Linux noch nicht viel Ahnung habe, komme ich da überhaupt nicht weiter


    Grüße

    OK. Mein Eintrag in der fstab sieht mometan so aus:


    //192.168.1.10/SmartHome/rpi_symcon /home/pi/nas_share cifs defaults,nofail,username=XYZ,password=XYZ,_netdev 0 0

    Dieser soll nun so ausehen?:

    //192.168.1.10/SmartHome/rpi_symcon /home/pi/nas_share cifs uid=1000,gid=1000 defaults,nofail,username=XYZ,password=XYZ,_netdev 0 0


    Grüße

    Hallo,


    ich tue mir gerade auch schwer mit den Benutzerrechten.


    Ich möchte den Ordner nas_share von root:root auf pi:pi ändern. Pi ist mein Standarduser, mit dem ich mich einlogge. Bin laut der wiki folgend vorgegangen:



    pi@raspberrypi:~ $ ls -l


    drwxr-xr-x 2 root root 0 Mai 14 17:49 nas_share


    sudo chown -c pi /home/pi/nas_share


    Besitzer bleibt root


    sudo chown -R pi:pi /home/pi/nas_share


    Besitzer und Gruppe bleiben root.


    Was mache ich hier falsch?



    System: RPI4 mit Buster



    Grüße

    Hallo,


    danke für die Antworten😊


    Mal zum Verständnis (bin Raspi Anfänger):

    Raspi4 alt: gleiche fstab konfig, NAS-Ordner wird gemountet

    Raspi4 neu: gleiche fstab konfig, NAS-Ordner wird nicht gemountet


    Der Mountbefehl wird zu früh abgearbeitet: Ist der Raspi noch nicht so weit? Das NAS ist immer online, somit müsste das Netzwerk immer da sein.


    Der Befehl ,_netdev hat leider nicht geholfen.

    Habe mir noch den Link zu systemd Mount Unit angeschaut, da verstehe ich nur Bahnhof.

    Das muss doch irgendwie einfacher funktionieren.


    Grüße

    Hallo,


    ich habe bei meinem neuen PRI4 mit Buster in der fstab ein Mountpunkt zu meinem NAS angelegt:


    //192.168.1.10/SmartHome/symcon /media/symcon cifs defaults,nofail,username=XYZ,password=XYZ 0 0


    Leider wird das Laufwerk nach einem Neustart nicht gemountet. Ich muss erst „sudo mount -a“ eingeben, dann sind die Daten auch da.


    Ich habe das Mounten bereits bei meinem alten RPI4 mit Buster eingerichtet, da funktioniert es auch nach einen Neustart. Da beide Einträge in der fstab identisch sind, habe ich langsam keinen Plan, woran es liegen könnte.


    Grüße

    Hallo,


    ja, da sind noch mehrere Dienste installiert. Als System habe ich Raspbian Buster installiert.


    So wie es aussieht, hat die Deinstallation vom VLC Player geholfen. Die Updates sind nun durch.

    Kann ich folgende Meldung ignorieren?

    pi@raspberrypi:~ $ sudo apt-get upgrade

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Paketaktualisierung (Upgrade) wird berechnet... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    alsa-base gstreamer0.10-alsa gstreamer0.10-plugins-base libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libxfce4util-bin libxfce4util-common libxfce4util7

    libxfconf-0-2 pimixer xfconf

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    Die folgenden Pakete sind zurückgehalten worden:

    libgl1-mesa-dri libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37 mesa-va-drivers mesa-vdpau-drivers pcmanfm

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 6 nicht aktualisiert.


    Grüße