Posts by det_lev_da

    hehehe...


    ich glaub das Problem ist:


    ip addr flush $inter


    #beide male auskommentieren

    #ip addr flush $inter


    Wenn PROV_IP eingetragen wird als DNS-Server in Windos läuft es gar nicht über den DNS-Server dnsmasq sondern über iptables direkt zum Router.

    Ich hab ja 192.168.100.1 eingetragen in Windows :) dann dnsmasq.


    *edit* etwas besser geworden.

    :D

    Der Plan ist, dass der $provider immer das gleiche Interface ist, da ist das Internet.

    $inter kann verschieden sein, nur $provider muss nach meiner Strategie gleich sein überall, wenn man schon 2 Scripte haben will, dann den DNS-Server auslagern und und von den Anderen Script starten lassen, zuvor auch beenden und neu starten.


    *edit* bei mir gibt es einen USB-Wlan-stick der beim Anschluss den Hotspot startet, deshalb starte ich den DNS-Server neu :)

    Schöne Windows-Welt! ;)


    Ich hatte hier jetzt mal pivpn installiert und danach bei existierendem tun0-Interface nochmal das Script gestartet - dann geht allerdings garnichts mehr weil irgendwie auch das tun0-Interface mit "verarbeitet" wird und am Ende soll die tun0-IP als DNS gesetzt werden, genau wie oben in Zeile 7 bei der Info von dnsmasq, nur eben mit der tun0-IP..........ich setz nochmal sauber neu auf......Kannst Du das irgendwie integrieren das bei vorhandenem tun0 der Traffic dann nur zwischen tun0 <-->eth0 läuft??

    Gruß!

    Ich überlege ... diese Zeile 7 Fehler kann nur passieren wenn das Script 2mal gestartet wurde. Es müssen also 2 Scripte da sein. eins davon läuft schon. Ein Zweites Script (identisch) mit einem anderen Dateinamen wird gestartet und es kommt der Fehler Ja???


    Dann muss man den DNS-Server in beiden Scripten auskommentieren und in ein Extra Script packen, dann gibt es 3 Scripte, wo bei in den Scripten, wo der DNS-Server auskommentiert wurde, das 3te Script mit dem alleinigen DNS-SERVER beinahaltet ist, gestartet werden.

    Es darf nur ein DNS-Server vorhanden sein.


    Der DNS-Server Teil müsste eigentlich in ein Extra Script.

    Das ist bei mir So in Wirklichkeit, ich hab den DNS-Server dnsmasq zu diesem einzigen Script HIER nur hinzugefügt damit nur eins da ist.

    Ich hab aber kein VPN deshalb kann ich nicht sagen wie der funktioniert, echt nicht :)

    Bei mir gibt es ein Script für eth0->wlan0 Hotspot, eth0->b0 Bluetooth (ja). Diese Scripte Starten den DNS-Server (dnsmasq). (vorher vielleicht noch beenden.


    Das ist so weit alles was ich sagen kann.

    *edit*

    Wobei wlan0->eth0 und tun0->eth0 meineier Ansicht nach nicht geht.

    Ich geh da im Baukasten Prinzip vor, aber da braucht man einen guten Tag :)

    bax5000

    Also ich schätze es kann nur hier dran liegen, weil da eigentlich was passiert, was eine Auswirkung haben könnte, alle andere ist eigentlich iptables zwischen eth0 wlan0. Man sollte oben auch nur das eingeben ... nur mein Tipp.


    Hier Passiert was:


    Also "while read z;do" müsste besser "while read interface;do" heißen, war nur zu faul die übrigen "z" in "interface" umzubennen.

    Unten in (Fußgesteuerten) while Schleife wird das Interface reingeschoben wie eth0 wlan0.

    man muss also interfaces unten außschließen.


    done <<< $(echo "$IFCONFIG"|grep -v ^" "|grep -v '^$'|awk '{print$1}'|awk -F':' '{print$1}'|grep -v tun0)


    Aber "ifconfig -a" ist ja ein Konsolenbefehl, kennt man ja "ifconfig" zeigt nur die aktiven an. Aber mit -a werden auch die ausgeschalteten Angezeigt.

    Eigentlich wird einfach diese Ausgabe von "ifconfig -a" """"zerhackt"""


    *edit* OpenVPN daran hab ich nicht gedacht und kann jetzt nicht sagen wie das funktioniert. Das ist die Stelle wo man es ausschließen könnte :)

    So.. ich hab noch ein kleines nie gebrauchtes nagelneues 60 cm Netzwerkkabel angeschlossen, das Selbe, irgendwann wird ping ohne Fehler ausgeführt. Nach dem Wechsel zum alten Kabel 3 Meter lang mach ping nichts mehr außer Fehler und wird nicht mehr besser. Wenn aber das nagelneue 60cm Netzwerkkabel angeschlossen wird läuft ping ohne Fehler und die Internetverbindung steht :)

    Nach dem Reboot von Windows, das Selbe, ping funktioniert nicht :) :) :)


    *edit* Windows mit dem kleinen Kabel ein Weile gewartet und ping ging auf anhieb wieder.

    Ich glaub mit Windows als Client am Pi, irgend etwas muss Windows überlegen, ob es wirklich den DNS-Server benutzen will.

    Startet man die Pi neu (ich hab die 20 Sekunden sleep nicht drin in /etc/rc.local Wlan ist zu dem Zeitpunkt schon da!) und startet Windows ist es ganz schlimm.

    Im Windows-Terminal "ping google.de" Zeitüberscheitung, dann geht der ping auf einmal und verschlückt 3, dann wieder gar nichts und dann wieder.

    Irgendwann geht es aber dann doch auf einamal.

    Ubuntu keine Probleme hab da nie Windows betreiben. Windows hab ich neulicht wieder installiert weil ich ""ausversehen"" die Platte mit dd gelöscht hab :) :) :)

    Windows akzeptiert es auf einmal.

    Zumindest auch wenn man den die DNS-Server Adresse eingeben hat, dass muß man. An Windows hab ich nie gedacht, es so zu betreiben :)

    Hallo,

    es ist bei mir jetzt 2 Tage gut gelaufen (das Script ist gemeint) stabil + zuverlässig.

    Da es in RaspberryOs zum Glück noch /etc/rc.local gibt, kann man es sehr einfach automatisch starten lassen wenn der Pi neu gebootet wird und es wird dann immer gestartet solange dieser Befehl vor den "exit 0" steht (nicht nach "exit 0" schreiben, sonst wird der Befehl nie erreicht).



    /home/pi/Documents/WLAN-LAN.sh start

    exit 0


    *eventuell eine Zeitverzögerung von 20 Sekunden kann auch ohne glatt hochfahren*


    /usr/bin/sleep 20

    #oder nur:

    #sleep 20

    /home/pi/Documents/WLAN-LAN.sh start

    exit 0



    Die DNS-Adresse ändert sich ja nicht und bleibt fest in Windows eingestellt, auch nach reboot.

    Sollte sich das Wlan (ip-Adresse) ändern muss man eben PROV_IP neu eingeben in Windows.

    Wlan ist auf dem PC bei mir komplett deaktiviert und es gibt nur Ethernet.

    Dann hat es nach reboot von Windows auch wieder funktioniert.


    *edit*

    Zur Sicherheit (nicht getestet, aber schadet nicht) das Script nochmal ausführbar machen

    sudo chmod +x /home/pi/Documents/WLAN-LAN.sh

    (kann sein wenn es nicht ausführbar ist, es nicht startet :) :) )


    Vielleicht gibt es auch bessere Lösungen, da offensichtlich Windows den dnsmasq nicht automatisch akzeptieren will.

    Das ist aber das schnellste, was geht, meiner Ansicht nach ohne zig config files zu ändern.

    Ob es besser geht? Ich denke schon, wenn man den 2.ten dnsmasq im Script ersetzt, ich hab aber nichts gefunden.


    Rechtschreibung ist Glücksache (wenigstens ein Wort richtig geschrieben)

    Windows Firefox ist gleich alles rot :)

    In Windows funtkioniert es jetzt über Netzwerk-kabel auch.

    Leider muss man die DNS-Server selber eingeben für Ethernet-Adapter.

    Leider Leider geht es aus irgend einem Grund nicht automatisch.


    geändert hab ich diese Zeile

    echo "neg-ttl=3600" >> "$dnsmasqconf"


    in

    #echo "neg-ttl=3600" >> "$dnsmasqconf"


    Diese Option gibt es nicht mehr.

    Hab auch geschaut ob "Windows" in der man Page vorkommt, und es kommt vor. --> "man dnsmasq|grep -i windows"

    Hab aber keine ausprobiert, diese müsst dann auch dort hin wo "neg-ttl=3600" steht.


    Windows DNS für Ethernet-adapter einstell: (Windows 10)

    https://www.windowscentral.com…twork-adapters-windows-10


    Netzwerkstatus->Adapteroptionen ändern ->Ethernet ->Eigenschaften -> internetprotokoll Version 4 TCP/IPv4) -> Eigenschaften -> Folgenden DNS Server verwenden -> """"" PROV_IP für DNS """"""


    Hab das Wlan abgschaltet, weil ich es auf die schnelle nicht herausbekommen hab wie man die Netzwerke "priorisiert", wenn es sich so nennt.

    Ah so ich hab auch das log File von dnsmasq aktiviert und es rennt loß wie wild und das ist gut :) :)

    Windows hat erst eine IP bekommen nach dem die Wlan-karte wieder eingebaut war. Aber auch keine DNS...


    Mir ist noch was anderes eingefallen, könnte es vielleicht Pihole erledigen.

    Pihole müsste das doch können ???


    Zu dem Script, es hatte immer zuverlässig funktioniert egal ob Bluetooth Wlan-Hotspot immer zuverlässig funktioniert immer parat gewesen. Wobei ich im Network-manger die Mac-Adresse gesperrt hab. Aber es funktiniert mit Linux, sogar die Live-Cd hat funktioniert.

    Das muss ich in Ruhe anschauen, dass kann dauern. Aber das es so nicht geht hätte ich nicht gedacht.

    hehehe..... ich hab am Pc die Wlan-Karte ausgebaut Linux gestartet mit Netzwerk-kabel eingesteckt und es geht.

    Mir ist dann eingefallen, dass es auf dem PC auch ein Windows gibt (Testphase immer noch) und da geht es nicht.

    Mit Linux geht alles... :) Windows nicht da bekommt er nicht mal eine IP (vielleicht hat es keine Treiber :) )


    Das Script hat Service-funktionen :lol:

    #hier kommt die Hilfe

    ./WLAN-LAN.sh

    Wie sind den die Ausgaben von:

    ./WLAN-LAN.sh pl


    (Und mir wird das Internet abgestellt, dann muss ich auf den Marktplatz laufen mit dem Handy :) :) :)


    Ich melde mich auf alle Fälle wieder. Erst will ich Windows ins Nezt bringen.

    Hallo :)

    Ja ich hab einige Fehler behoben weil die PROV_IP nicht aus der Schleife kommt.

    Hab es jetzt ernsthaft geprüft mit nagelneuem RaspbberryOs 11.

    Also nur diesese Script sonst nicht und ich konnte jetzt keinen Fehler feststellen.

    Wichtig ist nach dem installieren gleich das ausführen:

    systemctl disable dnsmasq.service

    Damit dieser nie automatische gestartet wird, sonst müsst es jetzt hinhauen.

    Viele Grüße :)


    Wie man es richtig einstellt mit "Bordmitteln" kann ich nicht sagen.

    Das neue Script müsste soweit funktionieren.

    Ich glaub aber nicht das es Freude macht :) :)



    hab es getestet und zumindest der Internet start müsse klapen.

    Ich bin über Netzwerk-kabel am Pi und der Pi geht ins Internet.

    Einschalten geht, abschalten auch??

    Viel Spaß

    *edit* es war kein frisches RaspberryOs, es liefen schon Scripte :)

    Aber so im Prinzip *au man*

    Telekom-Fon soll da dicht machen und ich kann dann nicht mehr 24/7 internet :)


    Hier hab ich mal vorerst aus dem Script zusammen "geklaupt"


    nano 0000.sh

    CTRL+X

    y

    ENTER

    chmod +x 0000.sh

    sudo ./000.sh


    Um es zu beenden Prozess killen oder Raspberry Rebooten


    Vielleicht geht das schon. oder man muss noch ein Route setzten?

    Ein Versuch ... :)

    Ja ich setzt Dnsmasq als DHCP Server und auch DNS Server ein, das geht weil man das interface lo ausschließen kann. Man Braucht da nichts umstellen oder konfigurieren. Einfach DNSmasq mit Optionen Starten und die Iptabels rule und schon geht es. Wie gesagt, nicht offiziell, weil Debian ziemlich viel geändert hat wie z.B /etc/network/interfaces, dass soll ja nicht mehr gehen etc.

    Ich kann mal gucken im Script. Ahso das Script muss gestartet werden, ohne den Script-Start geht alles so als ob nichts gewesen wäre :)

    hehehe .. ich kenne nur den unoffizellen "Hack" mit dnsmasq, das ist gut weil man den einfach "rein-mogelt" ohne zu wissen wie man das richtig einstellt. Funktioniert seit 3 Jahren egal was sich RaspberryOs sich einfallen läßt.

    (Bei mir ist vermutlich ab 16.1.2022 Ende mit Internet. Sie streichen TelekomFon :) )

    *edit* ein Iptables rule braucht es auch noch, wenn ich mich richtig erinnere.

    hehe ein Mac .. tja ich geh davon aus das es da "nc" (netcat) gibt wie in Ubuntu? :)


    hab bei mir mal geschaut ob am PC bei mir der Port 22 offen ist für SSH (ssh ist standardmässig auf Port 22, wenn nicht geändernt)


    Befehl:

    nc -z -v 192.168.1.107 22

    Ergebniss:

    Connection to 192.168.1.107 22 port [tcp/ssh] succeeded!


    Man muss statt der Ip den Hostnamen des Pi eintragen:


    Code
    nc -c -v raspberrypi.local 22


    Das hier bedeutet "NEIN auf dem PC läuft kein SSH":

    nc: connect to 192.168.1.107 port 22 (tcp) failed: Connection refused


    Vielleicht hat Mac-OS auch "nc" :) ich kanns nicht sagen