Posts by Lukkilukki

    Habe es nun komplett neu installiert. Hat tatsächlich funktioniert. Mir sind einige komische Dinge aufgefallen. Zum Einen, dass man anscheinend die gpios nicht nachträglich installieren kann.

    Zum anderen: gebe ich bei der Installation die Spotify Zugangsdaten ein, funktioniert es wunderbar und ich kann mich auch authentifizieren. Im Nachhinein wird irgendwie allerdings die Konfiguration angepasst und die Zugangsdaten in der Konfigurationsdatei geändert. Warum ich mir sicher bin dass ich sie richtig eingegeben habe? Ich habe sie in der Config Datei eingegeben in der Installation. Dann habe ich diese Daten kopiert um sie für die Authentifizierung zu verwenden. Öffne ich danach die Konfigurationsdatei, ist mein Passwort geändert. Vielleicht liegt es an dem Sonderzeichen zu Beginn.

    Hi Sascha,

    Habe beide files entsprechend angepasst und danach deinen Instalationsbefehl erneut abgeschickt. Keine Veränderung zu meiner Angabe weiter oben.

    Da ich auch bei der initialen Installation so viele Probleme hatte und letztlich über 20 Stunden investiert habe, um es ans Laufen zu bekommen, scheue ich davor, alles noch einmal zu tun, zumal ich nicht bestimmt sagen kann, welche Änderung am Ende dazu geführt hat, dass es funktioniert.

    In jedem Fall hatte ich nichts an den gpios eingestellt außer an der ini, die man ja aber anpassen muss.

    Gruß und Danke für deinen Support.

    Phil

    GPIO_CONTROL.PY

    led.py

    Code
    pi@laurasbox:~ $ cd RPi-Jukebox-RFID
    pi@laurasbox:~/RPi-Jukebox-RFID $ sudo python3 -m pip install --upgrade --force-reinstall -q -r ./requirements-GPIO.txt
    pi@laurasbox:~/RPi-Jukebox-RFID $ sudo systemctl enable phoniebox-gpio-control.service
    Failed to enable unit: Unit file phoniebox-gpio-control.service does not exist.
    pi@laurasbox:~/RPi-Jukebox-RFID $ 

    Nach nunmehr grundsätzlich erfolgreicher Installation der Box, möchte ich gerne noch Buttons nachrüsten. Allerdings scglägt bei mir die Installation fehl.

    Folgendes habe ich versucht:

    1. GPIOs entsprechend mit den Buttons verkabelt
    2. Service ist nicht installiert und entsprechend in der Weboberfläche der Box deaktiviert
    3. Versucht den service zu installieren mit :sudo /home/pi/RPi-Jukebox-RFID/components/gpio_control/install.sh
    4. Folgende Fehlermeldungen kamen hoch:

    Die requirements.txt ist übrigens vorhanden und liegt im gleichen Verzeichnis wie install.sh.

    Den Hinweis zur Datei im Ordner sampleconfigs verstehe ich nicht. Ich finde nur einen Ordner example_configs.

    sudo /home/pi/RPi-Jukebox-RFID/components/gpio_control/gpio_control.py gibt folgendes aus:

    und meine ini so:

    sudo nano /home/pi/RPi-Jukebox-RFID/settings/gpio_settings.ini


    Ich möchte nur zwei Buttons einbauen für vor und zurück.

    Komme an dieser Stelle leider auch mit der Suche nicht weiter

    Also... aktueller Stand:

    Wenn ich die Lautstärke der Box über die Webapp einstellen möchte, springt diese wieder zurück auf 0% (bzw. im Kreis auf -1%).

    Das andere Problem ist, dass ich lokal nichts abspielen kann:

    Wenn ich eine Spotify Liste abspielen möchte:

    Habe jetzt um die 30 Stunden investiert um die Software ans Laufen zu bekommen und weiß wirklich nicht mehr weiter.

    mpc play gibt aus:

    Code
    volume: n/a repeat: off random: off single: off consume: off

    mpc status das gleiche

    Habe nunmehr den on/off shim installiert und das scheint soweit zu funktionieren, auch wenn der Shutdown sehr schnell zu gehen scheint. Um den Phoniebox shutdown zu triggern muss man wohl selbst noch mal Hand anlegen. Mal schauen.

    Habe nunmehr noch ein Problem.

    Scheint soweit zu laufen bis auf das eigentliche abspielen. Gibt es die Mopidy config an mehreren Stellen?

    Habe nunmehr auch die raspberry pi config angepasst, dass er beim Start auf eine Netzwerkverbindung wartet. Das hat leider auch nichts gebracht. Ich gehe davon aus, dass das Problem also mit den oberen configs zusammenhängt. Demnach muss ich nun rausfinden, wie man die Berechtigungen ändert.

    Aber anscheinend gibt es ein ganz grundsätzliches Problem mit der Software in Verbindung mit der aktuellen Betreibssystem Verison

    Sow ie ich das sehe komme ich mit dieser Version des Betriebssystems nicht weiter....

    Habe nun einfach mal diesen user geändert auf mpd und siehe da...

    ich bekomme mal einen anderen Fehler angezeigt. In diesem Fall habe ich versucht, etwas lokal abzuspeielen (also kein Spotify Stream)

    habe mir nun einmal noch mal die mpd.conf angeschaut. Dort heißt es

    Code
    # General music daemon options ################################################
    #
    # This setting specifies the user that MPD will run as. MPD should never run as
    # root and you may use this setting to make MPD change its user ID after
    # initialization. This setting is disabled by default and MPD is run as the
    # current user.
    #
    user                            "root"

    Offensichtlich soll ich das nicht mit root ausführen. Es sieht aber so aus, als wenn dies so sei.

    Ist das relevant?

    alles durchgeführt.

    Keine Änderungen nach dem Neustart.

    Dec 17 15:04:15 raspberrypi mopidy[2252]: INFO [SpotifyBackend-6] mopidy_spotify.lookup Failed to lookup 'spotify:track:27u7t9d7ZQoyjsCROHuZJ3': Session must be logged in and online to load objects: <ConnectionState.LOGGED_OUT: 0>

    Dec 17 15:04:15 raspberrypi mopidy[2252]: INFO [SpotifyBackend-6] mopidy_spotify.lookup Failed to lookup 'spotify:track:0eu0G2tueICibVWy0sHaRb': Session must be logged in and online to load objects: <ConnectionState.LOGGED_OUT: 0>


    und wieder

    Dec 17 15:05:24 raspberrypi mopidy[2252]: INFO [MpdSession-224] mopidy_mpd.session New MPD connection from [::ffff:127.0.0.1]:43576

    Dec 17 15:05:24 raspberrypi mopidy[2252]: INFO [MpdSession-225] mopidy_mpd.session New MPD connection from [::ffff:127.0.0.1]:43580

    Dec 17 15:05:24 raspberrypi mopidy[2252]: INFO [MpdSession-226] mopidy_mpd.session New MPD connection from [::ffff:127.0.0.1]:43584

    Dec 17 15:05:24 raspberrypi mopidy[2252]: INFO [MpdSession-227] mopidy_mpd.session New MPD connection from [::ffff:127.0.0.1]:43588

    Dec 17 15:05:24 raspberrypi mopidy[2252]: INFO [MpdSession-228] mopidy_mpd.session New MPD connection from [::ffff:127.0.0.1]:43592

    Successfully installed Mopidy-3.1.0 Mopidy-Iris-3.54.2. Ich reboote...

    Leider nein. Immer noch der gleiche Fehler im log.

    Er sagt, ich sei nicht connected.

    Wie gesagt habe ich aber den Pi umgestellt, so dass er erst auf eine Internetverbindung wartet.

    Ich höre den Startton der Phoniebox (aufsteigende Noten).

    Außerdem bekomme ich in Iris angezeigt, dass ich authorisiert sei. Außerdem bekomme ich in der Webapp der Phoniebox angezeigt, dass der Track abgespielt würde (grünes Overlay). Er lädt das Cover korrekt. Es gibt keinen Fortschrittsbalken und keine Soundausgabe.

    Musikbibliothek habe bereits mehrfach gescannt. Macht keinen Unterschied.

    Komme leider nicht so wirklich weiter.

    Habe diese Info hier gefunden:

    Quote

    Just in case one of you has still this problem: I could solve it by running mopidy as the same user that runs pulseaudio (this is the mpd user for me). So it seems to be a permission problem, just like Freso said. The user can be changed in

    Code
    /usr/lib/systemd/system/mopidy.service

    Of course you would need to accordingly change ownership of all files in

    Code
    /etc/mopidy/
    /var/lib/mopidy/

    So wie ich das sehe, sollte ich einmal versuchen, das zu probieren, sprich: Die Berechtigungen anpassen. Allerdings weiß ich leider nicht, wie der Nutzer heißt, noch, wie ich das machen kann. Was meinst du StefanMinke ?

    So, habe nun einmal verschiedene Dinge ausprobiert. Mittlerweile habe ich es hinbekommen, dass der Startsound der Box abgespielt wird. Ich denke, dass ich diesen Punkt abhaken kann. Ich denke, dass es an der asound.conf lag, die ich erst einmal erstellen musste.

    Allerdings bekomme ich immer noch den Fehler mit der mopidy session angezeigt.

    Aber ich bleibe dran.