Posts by Alv

    Mein Problem ist eher, die richtigen Suchbegriffe bei Google einzugeben...


    Aber in dieser Dokumentation sind einige Zeilen unleserlich, z.B.

    Code
    “b†here is either “yâ€, “Y†or “1†for true or “nâ€,    “N†or “0†for false.

    Verstehe ich das richtig: true = y,Y,1 und false = n,N,0 ?

    Mal eine Veständnisfrage.

    Bei

    sudo dd if=/dev/zero of=/test.bin bs=1M count=1024

    sind da bs und count nur Parameter für die Dateigröße, oder wirkt sich das auch auf des Dateisystem (Sektorgröße) aus?

    Würde also "sudo dd if=/dev/zero of=/test.bin bs=1G count=1" dasselbe bewirken?


    Weiterhin, wo finde ich die Parameter für g_mass_storage?

    Ich habe schon Google durch, ohne fündig geworden zu sein.

    Vergeßt die letzte Frage, es scheint an einem defekten USB-Kabel zu liegen.

    Jetzt muß ich erstmal die ganze Hard- und Software überprüfen und sortieren...


    Da ich nie richtig weiß, wann der Zero fertiggebootet hat, gibt es eine einfache Möglichkeit, am Ende des Bootens einen GPIO-Pin zu schalten?

    Nun die nächste Frage:

    Worin unterscheidet sich der Zero mit Version Bernd666 von einem gewöhnlichen USB-Stick mit Fat32?


    Also die Bernd666-Variante wird auf dem PC als Laufwerk erkannt. Ich habe eine .cbddlp-Datei draufkopiert, diese SD-Karte dann in den Zero am Mars gesteckt, aber der Mars erkennt keine Dateien...

    Nochmal die hyle-Variante (ohne USB-Konsole ausprobiert) bis zum Reboot:

    Kein Laufwerk erscheint (auch nichts in der Datenträgerverwaltung).

    Beim Hochfahren des Zeros findet der PC ein unbekanntes USB-Gerät (wieso eigendlich? Da muß der Zero doch irgendwelche falsche Daten senden?), sonst auch nichts weiter.


    Nach Eingabe von

    sudo modprobe g_mass_storage file=/piusb.bin stall=0 removable=1 iSerialNumber=1234567890

    erschien dann ein Laufwerk, in das ich sogar etwas kopieren konnte...



    Wozu ist dann alles das, was in der hyle-Version nach dem Reboot folgt?

    Und einfach nix zuschreiben, wenn Leute dir eine Lösung präsentieren ist auch nicht so fein. Nur auf Nachfrage kommt dann ein "Geht nicht"

    Tut mir leid, ich bin hier noch neu und kenne mich mit den hiesigen Gepflogenheiten nicht so aus.

    Wenn ich nicht sofort anworte, liegt es daran, daß ich nicht immer Zeit und Gelegenheit habe, gleich zu recherchieren und auszuprobieren.


    Ich habe jetzt die beiden Massenspeichervarianten von hyle und Bernd666 ausprobiert, allerdings mit USB-Konsole.

    hyle: sollte nach dem Reboot des Zero auf dem PC ein Laufwerk erscheinen?

    Bei beiden Varianten passiert das nicht.


    vielleicht schreibst du mal, was du mit diesem Teil erreichen möchtest.

    Ich möchte das zum Laufen bekommen:

    "https://forum-raspberrypi.de/forum/thread/53283-mariner-3d-zum-funktionieren-bringen/"

    Dort gab es keine Antwort. Nachdem ich das Problem etwas eingrenzen konnte, habe ich hier nochmal nachgefragt.

    Wo und wie wird denn "dwc2" richtig eingetragen, damit ich mit das gleich richtig angewöhne?

    Alv Hast du denn nun was hin bekommen?

    Ich probiere weiterhin diverse Anleitungen aus.

    Bislang habe ich eine gefunden, bei der Win7 schonmal ein Laufwerk erkennt, aber leider keine Dateien darin...

    https://icul238025840.wordpres…rry-pi-zero-as-usb-stick/


    Der einzige richtig funktionierende WLan-Massenspeicher hat ein eigenes OS-Image. Falls das Jemand auseinandernehmen möchte:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    WOL funktioniert generell nicht mit WLan.

    Wieso nicht?

    Außerdem, wer sagt, dass CPU und WLan an Spannung hängen, wenn der Pi heruntergefahren ist ??

    Das ist beim Raspberry Pi zero nicht anders möglich.

    Der hat nach dem (unvollständigen) Schaltplan als Spannungsversorgung nur einen Step-Down-Wandler, der aus den 5V 3,3V und 1,8V macht. Dieser Wandler läuft ständig, solange die 5V anliegen.

    Da der Raspberry Pi kein Power-Management hat, ist das ohne Modifikation nicht möglich.

    Beim RasPi0 liegen CPU und WLan-Chip ständig an Spannung. das wären ja die idealen Voraussetzungen für WoL.

    Schade, daß der WLan-Chip das nicht unterstützt.

    Hi


    Ein RasPi0 soll über WLan/Webinterface ein Gerät per GPIO-Pin ein- und ausschalten.

    Wenn das Gerät ausgeschaltet ist, kann dann der Zero runterfahren und dann per WOL wieder geweckt werden, um das Gerät einzuschalten?

    Oder muß der Zero die ganze Zeit voll an bleiben?

    Hi

    Eine Frage an die Zero-Hardwerker:

    Woher bekommt der WLan-Chip des Zero seine Versorgungsspannung?

    Ich vermute, diese geht über eine der beiden Ferritbrücken (eine über dem Chip, eine rechts daneben)(Zero-Orientierung: SD-Karte = oben)?

    Jetzt wird es zu kompliziert für mich.


    Ich gehe davon aus, daß die Anlieitungen irgendwann mal funktioniert haben, also muß sich irgendwas geändert haben.
    Nur was und wo?

    Hat sich an den Raspberry Pi zero W mal was geändert?

    Oder am RaspoOS? Aber ich habe auch mal ein altes Jesse-Image probiert, ohne Erfolg...