Posts by Alv

    Da wir nicht wissen welche Anleitung Du schon versucht hast, funktioniert vielleicht diese hier: https://magpi.raspberrypi.org/…o-w-smart-usb-flash-drive

    Ok, nehmen wir die als Beispiel.


    Der Raspi0 steckt als USB-Stick in meinem PC.

    Bedient wird er per WLan mittlels Putty/ssh.


    Verwendet habe ich RaspiOs lite vom März/21


    Angefangen habe ich bei Step 04


    Step 05:

    Win7 vermeldet "unbekanntes USB-Gerät"


    Step 06:

    Statt in den Fenseher habe ich den Pi einmal aus dem PC rausgezogen und wieder reingesteckt


    Step 09:

    Unterstrich bei "usbshare" fehlt und die Downloaddatei ist nicht mehr vorhanden.


    Step 10:

    Nichts tut sich, außer daß im der Datenträgerverwaltung ein "Datentröger 0", unbekannt, nicht initialisiert, 2GB nicht zugeordnet, auftaucht.


    Bei "sudo modprobe -r g_mass_storage" verschwindet er wieder.


    Step 11- brauche ich für diesen Test nicht.


    Ein erneutes aus-/einstecken des Pi erzeugte wieder die Meldung "unbekanntes USB-Gerät", ohne Datenträger in der Datenträgerverwaltung.

    Vermutlich muß die Zeile "sudo modprobe g_mass_storage file=/piusb.bin stall=0 ro=1" noch in irgendeine Systemdatei.


    Genau so lief bisher jeder Versuch ab.

    Hi


    Vorweg, ich bin Linux-DAU.

    Ich kann nach Anleitung Befehle eingeben und Dateien ändern, aber verstehe nicht wirklich, was ich da tue.

    Zum Problem:

    Im Internet gibt es eine Menge Anleitungen, wie ich einen Raspberry Pi zero zu einem USB-Speicherstick mache.

    Ich habe davon etliche mit aktuellem RaspiOs lite (und auch full) ausprobiert.
    Alle haben eines gemeinsam: Sie funktionieren nicht!
    Auf der Raspi-Seite scheint alles zu funktionieren, der Speicher ist da, ich kann Dateien reinspeichern und auslesen.
    Aber am PC (Win7 und Win10) wird der USB-Stick nicht erkannt. Der PC findet zuerst ein unbekanntes USB-Gerät und läd auch noch den Linix-USB-Gadget-Treiber. Dann nichts weiter.
    In der Datenträgerverwaltung wird der Pi dann als unzugeordneter, nicht initialisierter und schreibgeschützter Speicher angezeigt.

    Woran liegt das? Was mache ich falsch?
    Gibt es Links zu Anleitungen, die funktionieren?



    Was hast du denn für einen Wlan-Router, der nur 5Ghz zur Verfügung stellt?

    Es ist nicht mein WLan, ich kann es nur benutzen.

    die 3270 konnte nur 2,4 oder 5 GHz, nicht beides zusammen.

    Schade, aber mit einem WLan-USB-Dongle am Pi4 würde es funktionieren?

    Könntest den 4er als AP nutzen, aber irgendwie ist des Verschwendung

    Der Pi4 liegt eh ungenutzt rum. Falls ich den mal anderweitig brauche, kann ich ja einfach die SD-Karte tauschen...

    Es wäre auch nett vom TO, sich einmal selber zu Wort zu melden, da er ja die ganze Zeit online ist.

    Bei mir ist "angemeldet bleiben" aktiviert. Wenn ich als "online" angezeigt werde, heißt das also nicht, daß ich vor dem Forum sitze...

    Außerdem gilt es in anderen Foren als unfreundlich, wenn man zu schnell nachfragt...

    Hi


    Ich möchte Raspberry Pi Zeros einrichten, habe aber nur ein 5GHz-WLan zur Verfügung.


    Ich habe noch einen Rasberry Pi4 rumliegen, der kann ja 2,4GHz und 5GHz.


    Kann man daraus etwas basteln, das für den Raspberry Pi Zero einen Access-Point darstellt und die Zugriffe ins 5GHz WLan weiterleitet?

    Hi


    Ich habe versucht, für meinen Elegoo Mars (Resindrucker) das Mariner 3D (etwas ähnliches wie Octoprint) zu basteln.

    https://mariner.readthedocs.io/en/latest/index.html

    https://l9o.dev/posts/controll…elegoo-mars-pro-remotely/


    Hat das schon jemand erfolgreich verwirklicht?


    Vorweg: Ich bin Linux-DAU.


    Ich habe das aktuelle Raspian-OS lite verwendet, per WLan und Putty/ssh alles wie auf den Seiten angegeben auf den RasPi0 übertragen.

    Es scheint auch alles soweit zu funktionieren, nur erkennt der Drucker den RasPi0 nicht als USB-Stick (the printer returned an unexpected response: '//Disk init fail!\r\n').


    Woran kann es liegen, daß die USB-Gadget-Sache nicht funktioniert?

    Hi

    Ich bin (noch) absoluter Anfänger auf dem Pi4.


    Wie muß ich das NOOBS-Archiv auf eine 8GB-SD-Karte bringen?

    Ich habe die Karte per Win7 auf FAT32 formatiert und das NOOBS-zip darauf entpackt.

    Im Pi4 tut sich aber nichts Sinnvolles. Kein Bild, rote Led leuchtet dauernd, grüne blinkt 4*.

    Was ist falsch?