Posts by boris_clinton

    Was natürlich nicht klappen kann ist, dass Du den Raspberry nach dem Herunterfahren mit dem Netzgerät ein- und ausstecken wieder aktivierst, da er das ja gar nicht mitbekommt, solange der HUB zurück versorgt.

    Jetzt fragst Du mich ja was... Bin mir gar nicht mehr so sicher.


    Ich benutze das Case ArgonOne, welches über einen gesonderten Netzschalter ausgestattet ist. Dieser erlaubt mir auch einen Reboot (wenn ich einen "Doppelklick" am Netzschalter ) aber auch einen "Soft-Shutdown" (Herunterfahren) und eine Hard-Off-Funktion. In jedem Fall wird hierbei der Netzstecker nie gezogen. Das erledigt wohl die Elektronik des Cases.
    Nun werde ich den Hub noch einmal anschließen und folgendes ausprobieren:

    1.) Reboot durch Befehl an der Konsole
    2.) Reboot durch Funktion am Netzschalter des Cases und
    3.) Ausschalten und neu Einschalten durch das Case.

    Ich berichte dann, wenn ich den Test durch habe (ich werde das wohl morgen erst schaffen.
    Ich überlege mir nur, wenn es denn wirklich das Problem ist, dass der Strom durch den Hub nie getrennt werden kann, dann liegt es letztenendes nicht am Hub, sondern an der Konstellation, die ich gewählt habe.

    Da ich nun wirklich nicht zu den Technikern auf dieser Erde gehöre, muss ich mir das mit dem "Dauerstrom" erst einmal in die Hirnwindungen prügeln...


    --------------------------------------------------------------------

    [EDIT]

    Ich habe es dann aus Neugierde gleich erledigt:

    Reboot an der Konsole und durch das Case waren möglich, da hier die Stromversorgung nie Abgeschaltet wird.


    Beim Abschalten durch das Case liefert der Hub weiterhin Strom, so dass der Raspi nie "stromlos" ist. Dies verhindert (wie auch immer) den Boot-Vorgang. Sobald ich den Hub trenne oder vom Strom nehme läuft der Bootvorgang wieder weiter.


    Ergo: Reboot durch Befehl läuft. Wenn der Raspi vom Strom getrennt werden muss, so muss auch ein aktiver Hub entweder vom Strom weg, oder vom Raspi getrennt werden.


    Was ich an der gesamten Geschichte halt leider nicht verstehe, ist die Tatsache, dass die Verbindung zwischen Hub und Rechner (sei es nun ein Raspi, PC, o.ä.) mit Strom versorgt wird. Daten würden da meines Erachtens vollständig reichen. Der aktive Hub sollte ja schließlich nur die Endgeräte mit Strom versorgen.
    Nun ist mir ja auch klar, dass die USB-Ports Strom an Endgeräte liefern, aber hier Endet dann schon mein Verständnis an Elektronik (Strom ist demnach keine Einbahnstraße).


    Ich denke, ich habe zwar keine Lösung für das Problem, aber das Problem ist durch das Verständnis der Umstände doch schon sehr viel kleiner geworden.

    Wenn meinen Auslassungen keiner groß widerspricht (was mir nun wirklich nichts ausmachen würde - würde es doch einer Lösung näher kommen), werde ich dieses Thema dann bald als erledigt markieren.


    Ich danke allen Beteiligten, habe wieder was dazu gelernt.

    Ich habe auch einen USB-Hub, 8-fach, USB 3.0 mit zusätzlichen Ladebuchsen und ext. Netzteil, Kaltgerätestecker, angeblich 60 W, der kann mir nicht mal einen einfachen BananaPi mit 7" Touchdisplay versorgen. :wallbash:

    BTW. Der Pi4 will mehr Spannung sehen, ich bin bei 5,37 Volt, damit der Blitz weg ist:

    RE: Immernoch Undervoltage trotz 5,27 Volt und Elko

    Hallo fred0815,


    ich denke, Du hast mich da missverstanden. Der Pi hat seine eigene Stromversorgung und hängt nicht an dem Hub. Der Hub scheint aber mit seinem Strom an den USB-Ports (A-Stecker) den Bootvorgnag zu behindern.

    Hallo an alle,

    ich habe mir kürzlich einen aktiven USB 3-Hub (link (Affiliate-Link)) besorgt und an einen Raspberry 4 angeschlossen, damit ich 2 externe HDD's an diesen anschließen kann.
    Nach dem Booten angeschlossen, hat das auch alles super funktioniert, aber ein Neustart war mit diesem angeschlossenen Hub nicht möglich. Hier wird der Bootvorgang solange unterbrochen, bis ich entweder den Hub vom Strom genommen habe, oder den Hub vom Raspi getrennt habe. Es gibt demnach Probleme mit dem Strom, welcher hier mitgeliefert wird (obwohl ich eigentlich erwartet hätte, dass genau hier nur Daten fließen sollten (Strom benötigen doch eigentlich nur de Geräte, welche am Hub angeschlossen sind).

    Ich habe hier im Forum bereits 1-2 Threads gefunden, die mit einem sehr ähnlichen Problem aufwarten können, allerdings nicht mit einer Lösung, mit der ich etwas anfangen kann.

    Nun meine Frage: Habt Ihr ggf. das selbe Problem unabhängig vom eingesetzten (aktiven) Hub, und wenn nicht: Welchen Hub könnt ihr demnach empfehlen?

    Viele liebe Grüße und
    Gesund bleiben!

    Boris

    [edit] Ich habe den Hub im Übrigen auch an eine ältere Synology NAS (DS 413) angeschlossen. Hier verweigerte die NAS vollständig die Entgegennahme der Daten von der angeschlossenen HDD. Ohne Hub dann kein Problem.

    Ich habe nach dieser Anleitung (die ich im Übrigen gut geschrieben finde) mal versucht Nextcloud 18.0.0 zu installieren.

    Bei der Erstellung der Nextcloud-Datenbank bekomme ich leider die Fehlermeldung:

    Error while trying to create admin user: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [1698] Access denied for user 'oc_admin'@'localhost'


    ggf. hat jemand eine Idee, was ich hier machen könnte?
    Gruß Boris

    Ich habe die selben "Probleme" mit der Datenübertragungsgeschwindigkeit.

    Habe einen Raspi 4 mit OMV und einer HDD angeschlossen und einer Übertragungsgeschwindigkeit von allem was eine Gigabit-Leitung hergibt (rd. 110 MB/s).

    Bei dem 2. Raspi 4 mit NextcloudPi habe ich eine Übertragungsgeschwindigkeit von gerade mal rd. 30 - 35 MB/s.

    Über Ursachen kann ich als Neuling gar nichts sagen. Ich kann nur dir Aussage von ErreUno verifizieren.

    Mir ist aber darüber hinaus aufgefallen, dass die Festplatte an dem Raspi immer wieder anfängt zu drehen, obwohl keine Datenzugriffe erfolgen (können - Zugriffsberechtigte Maschinen sind abgeschaltet).


    Gruß Boris

    Das war eine denkbar schlechte Entscheidung, mit der Du Deinem Schwager definitiv mehr schadest als nutzt. Hätte das ein IT-Fachmann bei mir getan, bekäme der ab sofort als Rechner nur noch einen Abakus zur Einrichtung.

    OpenVPN kann selbstverständlich auch mit IPv6 umgehen.

    Mit den anscheinend vollständig fehlenden Kenntnissen für eine sichere Netzwerkadministration solltest Du in Deinem eigenen Interesse zweifellos davon absehen.

    Youtube-Videos enthalten im Regelfall nicht mal die elementarsten Grundlagen dessen, was für Netzwerkadministration notwendig ist. Die sind auf Click-Zahlen fokussiert, Netzwerkgrundlagen (die als Basics eher kompliziert sind und jedes Video sprengen) sind dafür hinderlich.


    Hallo ThomasL,


    auch ich wünsche Dir einen schönen guten Morgen (in Deinem Falle war es wohl eher Abends...).


    Gerne möchte ich mal klarstellen, dass ich kein Netzwerkadministrator bin und auch keiner werden möchte. Ich bastel gerne an Heimnetzwerken rum und probiere auch mal vieles aus.

    Ich würde mein Vorhaben nicht in einem Forum posten, wenn ich nicht davon ausgehen würde, dass jemand, der mehr Ahnung hat als ich (und das sind definitiv die meisten hier) mir den einen oder anderen Tip gibt, was ich besser lassen sollte, oder besser gesagt was ich anders machen sollte um an das Ziel zu gelangen.


    Von Dir habe ich nun folgendes vernommen:

    Lese ein gutes Buch oder gehe Informatik studieren, aber lass die Finger von Netzwerken.


    Nun aber genug der Schelte. Du hast es sicherlich nicht böse gemeint.

    -> Dass OpenVPN auch IPv6 Netzwerke kann, habe ich nicht bestritten. Ich sprach von dem Programm PiVPN, welches sich zunächst einmal nur auf IPv4 bezieht, und dem erst noch gesagt werden muss, dass es auch anders geht.

    -> Wenn ich an den Private Extensions nicht rumspielen sollte (abschalten damit der Router auch immer weiß, welches Netzwerkgerät angesprochen wird), da die die Freigaben an den VPN-Server durch jeden Router auch so funktionieren, dann hättest Du es mir auch so sagen können...
    -> Das Youtube keine Grundlagen lehren kann, sollte jedem klar sein. Aber wenn dort eine Anleitung präsentiert wird, die man nachbauen oder nachstellen kann, und das Projekt funktioniert danach, dann denke ich mir dass das manchmal hilfreich sein kann. Die Grundlagen oder die offenen Fragen, die ein solches Video nicht vermitteln kann versuche ich mir dann anderweitig anzueignen.


    An einem IPv4 Anschluss einen VPN-Server zu betreiben ist wohl ein Kinderspiel. An einem IPv6-Anschluss (DS lite) scheint die Welt wohl etwas anders auszusehen. Da Du hier offensichtlich gut in der Materie bist, wäre es sehr nett, wenn Du den einen oder anderen Hinweis geben könntest, was zu beachten ist, damit ein VPN-Server und somit das dazugehörige Heimnetzwerk von "außen" erreichbar ist.


    Viel Dank schon einmal im Voraus


    Boris

    Servus,
    nachdem ich den PiVPN bei mir zu Hause über einen IPv4-Anschluss laufen habe, soll ich das selbe nun auch bei meinem Schwager ermöglichen. Dieser hat leider auch einen IPv6 DS lite Anschluss...

    Ich denke, das mit dem DynDNS werde ich hinbekommen (nachdem ich die Privacy Extensions abgeschaltet habe) und die Vor- und Nacharbeiten an PiVPN (welches wohl eigentlich auch nur IPv4 kann, wenn ich das so richtig verstanden habe) erledigt habe.

    Problem werden halt die Handy-Netze oder öffentliche WLAN-Hotspots sein, die meist noch auf IPv4 laufen. Also würde mir der ganze kram erst einmal nicht bringen. Hier kommt dann (so soll es zumindest ein meiner Welt sein ;)) ein virtueller Server mit statischer IPv4 Adresse ins Spiel. Kann man bei Ionos für 1,- € / Monat mieten. Hier soll dann über die Statische IPv4-Adresse durch das IPv6 Protokoll getunnelt werden. Dann sollte es von überall her klappen - Habe es noch nicht ausprobieren können, aber so wie ich einige Anleitungen und Videos verstanden habe, sollte das so klappen.

    Wie gesagt, in meiner Welt stelle ich mir das machbar vor - wie seht Ihr das?

    Gruß Boris

    Servus,

    ich habe mit Raspberian und PiVPN sehr gute Erfahrungen. Die maxiamale Upload-Rate (bei mir sind es rd. 33 MBit) werden vollumfänglich erreicht. Habe den Raspi direkt an der FritzBox hängen.