Posts by tenten

    Hier der Inhalt meines Pi-hole RPi zur Verdeutlichung:

    Code
    pi@pi:~ $ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1

    wobei es egal ist ob da localhost oder die IP 127.0.0.1 steht. Das kommt auf das gleiche raus. ;)

    Ist bei mir nicht anders in der Resolv


    Nee, das solltest Du besser nicht machen... die Fritte muss bei den DNS-Einträgen auf den Pihole zeigen und definitiv nicht auf einen DNS-Server irgendwo im Web. Das hattest Du alles bereits korrekt eingerichtet. Würdest Du das so ändern, wäre Pihole neutralisiert. BTW, cloudflare ist auch nicht besser als google... da würde ich auch 'nen Bogen drum machen.


    Das einzige offene war eben nur noch die lokalen DNS-Abfragen des PIs... da braucht es nur localhost als Ziel.

    Macht kein Sinn was du da sagt man kann natürlich gleich den DNS von pihole in die fritzbox einbauen aber spätesten beim pihole muss man rebound setzten und dann eben nicht fritzbox ip sondern ein DNS zu auflösen ! Dementsprechend egal ob opendns , cloudflare , digitalcourage oder , oder


    DNS ist Glaubens frage muss jeder selbst wissen !


    Optimal wäre unbound das ist aber andere Geschichte


    damit pihole funktioniert gibt es zwei Wege entweder DNS zum auflösen auf dem Router oder rebound auf dem pihole in beiden Fällen wird die DNS Auflösung mit dem gesetzten Server gemacht.

    Irgendwo habe ich dir das schon geschildert auf der fritzbox wird schon lokal auf pihole verwiesen

    Du musst nur auf der fritzbox Zugangsdaten / DNS die DNS Adresse von z.b cloudflare eintragen 1.1.1.1/1.0.0.1 und dann bei pihole unter settings / DNS nur die fritzbox ip bei custom #1 das sollte alles sein somit läuft alles Lokal über pihole ab.

    zudem erneuerst du lease deiner Geräte im Netzwerk oder trägst gleich bei DNS die ip von raspberry.

    Das einzige was ich nich nicht funktionier das nordvpn sich automatisch mit dem US Server verbindet.

    Der Rest geht.


    Hätte aber lieber das ganze Menü von nordvpn das währe krass !

    kannst du doch !


    nordvpn set autoconnect on country_code+server_number. Example: nordvpn set autoconnect on us2435.

    So weit so gut.

    Ich habe kein Menü im Raspi selbst für den Nord-Vpn.

    Kann man das ändern?

    Ich kann zwar alles über die Kommando Zeilen wie in der Anleitung alles starten

    aber wie wechsele ich jetzt den Server direkt am Raspi 4 ohne das Hauptmenü von Nord VPN ?

    Steht doch alles auf der Page was console angeht da warst du bestimmt drauf ?


    support.nordvpn


    Geiler Ansatz :thumbup:müsste ich mal testen ob alles einwandfrei läuft.


    Die erklären das selbst auf der Page das wiregurad keine dynamische IP kann daher kamen die auf die nordlynx Lösung um die NAT anderes zu Regel kommt bestimmt weil die einfach Zuviel Server habe und für die zu aufwendig/teurer wäre k.a

    Habe nicht im Kopf aber tun0 gibt es nicht logisch aber auch. Ich sage mal so nur mit config nordlynx zu nutzen geht nicht es geht nur mit clienten bei Linux.

    Und das ist dann mit dem WireGuard den man installieren kann, nicht kompatibel?

    Wenn das so ist, dann finde ich das schon merkwürdig, dass NordVPN das als "Wireguard" bezeichnen bzw. damit werben darf/kann.

    Ja leider ist das so :( ist zwar wireguard aber NordVPN hat sein nordlynx eigens geschrieben daher ich kenne keinen der die iptables hin bekommen hat auch die Schnittstelle ist anders bei nordlynx man könnte auch den Clienten nutzen und schauen wie er die iptables abändert aber das habe ich nicht gemacht irgendwann vielleicht

    NordVPN nutzt eigenes abgewandeltes Protokoll basierend auf Wireguard. Bei NordVPN heißt es nordlynx und dafür gibt es keine iptables es sei den er benutzt den NordVPN Client headless auf dem Pi, ich nutze selbst auf meine Pi NordVPN (Openvpn) als Gateway.


    Hier how to hast du pihole an laufen um so besser iptables sind gleich für pihole mit.


    NordVPN Gateway raspberry iptables etc

    Weil er immer wieder Login Fehler hat auf das webIF von pihole, es ist immer besser einfach mal von vorne sauber anzufangen meinst du nicht ?


    Oder der thread wird kein wirkliches Ende haben

    Man kommt so nicht weiter mach alles von vorne bessere so !


    ziehe die neues Raspbian Buster full version und schreibe auf die SD Karte.

    SD in den Pi >>> Boot

    sudo apt update

    sudo apt full-upgrade

    reboot


    dann :


    curl -sSL https://install.pi-hole.net | bash


    und wenn alles installiert ist

    reboot

    Dann kommst du wieder anders dreht sich der thread ewig ....

    Ich persönlich nutze macOS und Debian dennoch

    Bist du für den Anfang mit Linux Mint oder Ubuntu sehr gut beraten gerade weil du Windows Hardware hast wird da kaum etwas mit Treibern Probleme bereiten eigentlich hatte ich früher nie irgendwelche Probleme auf dem Windows Hardware wo halt Windows mit lief.


    Ganz klar ist Fedora schickes Distro djbase

    Zeig mal was bei dir drin steht

    sudo nano /etc/apt/sources.list


    alles raus kopieren und hier als Quote reinsetzen


    Wenn wir dabei sind Auszug von hier


    Quote
    Code
    ls /etc/apt/sources.list.d

    dann sehen wir weiter der Vorredner hat recht das repo gehört nicht auf dem Pi ! Also da wo es ist muss / sollte es weg

    ja das habe ich gemacht siehe Bild

    Dann ist alles ok so du kannst bei Zugangsdaten / DNS den 1.1.1.1/1.0.0.1 setzen


    Dennoch bei pihole settings / DNS unter custom 1 die ip von Router setzten!


    Läuft alles über pihole also nur Zugangsdaten / DNS gesetzt dann unter custom #1 den DNS Server von cloudfare z.b setzten


    Du musst wissen soll alles über pihole laufen oder soll intern DNS gesetzt werden

    Andi17

    Hier das Bild von meiner Fritzbox ip 66 ist die Rasbi mit dem PiHole

    So läuft alles über Pihole im Netzwerk


    Das musst du einstellen unter.


    Heimnetz--> Netzwerk --> netzwerkeinstellungen -->ipv4 Konfiguration


    Da gibt es dann den lokalen DNS Server.

    das ist richtig damit kannst du definieren was über pihole laufen soll über DNS Vorgabe am Gerät selbst