Posts by Sandmanyz

    Hallo,


    ich habe im Flur als auch im Hauswirtschaftsraum eine Unterputzdose in welche ich jeweils einen kleinen Lautsprecher legen möchte. Die Lautsprecher sollen beide gleichzeitig Sprache ausgeben wenn ich z.B. meinen RFID-Chip vor den RFID-Leser halte.

    Nun dachte ich mir, dass ich einfach über den Klinkenstecker die beiden kleinen Lautsprecher anschließe. Da es nicht fürchertlich Laut sein muss und auch keine Musik ausgeben soll, dachte ich mir das so einfach kleine wie diese hier: 3W 4 Ohm (Affiliate-Link).


    Geht das?


    Viele Grüße

    Kann mir Jemand sagen wo ich am Supramatic P Antrieb zwischen 9 - 30 Volt finde um einen Fibaro Smart Implant anzuschließen um wiederum das Garagentor zu öffnen/schließen?

    Habe an diversen Kabeln gemessen, welche ich im Gehäuse finden konnte, aber entweder liegen nur 5 Volt an oder nichts. Nur im Moment des öffnens/schließens liegen mal ca. 14 Volt an.

    Danke für eure Hinweise/Tipps. Mal schauen ob ich am Wochenende den einen oder anderen Test mache.


    Quote

    bei langen Kabeln wirst du Probleme bekommen die Zustände (open/closed) zuverlässig zu erkennen. Ich weiß jetzt nicht wie lang deine Kabel sind, aber wahrscheinlich reicht nicht mal die 3.3V des RPIs.

    Du solltest also auf jeden Fall mal das "Problem" mit den langen Kabeln recherchieren.

    Mit der Kabellänge muss ich dann tatsächlich mal schauen. Ich konnte noch keinen Erfahrungswerte finden ab wieviel Meter es problematisch wird. Mein längstes Kabel ist 16 - 17m lang (Telefonleitung/Fernmeldekabel 4 x 2 x 0,6 mm²).


    Quote

    Die 16 Reed-Kontakte können auch mit einem MCP 23017, ein I2C Port Expander abgefangen werden.

    Dann bleiben die GPIOs des RasPi für andere Aufgaben frei. Das Problem der Kabellänge besteht aber weiterhin.

    Der Raspberry ist nur für die Alarmanlage da. Eigentlich brauche ich keine freien GPIOs. Ich weiß natürlich nicht wie sich das Projekt entwickelt....und ganz plötzlich muss dann doch ein Port Expander her ^^.


    Quote


    Dieser Beitrag ist zwar schon etwas älter, aber vielleicht noch ein weiterer Lösungsansatz, um HW Resourcen des RPi optimal zu nutzen.

    Schaue ich mir an :)

    Bei mir war es am Ende ein ganz einfache Ursache. Der RAM war manchmal zu 100% ausgelastet. Leider hat der Raspberry sich auch nach langer Wartezeit nicht erholt. Habe nun einen Raspberry 4 mit 4 GB und keine Probleme mehr.


    Danke an alle Beteiligten für die gute Unterstützung bei der Fehlersuche.

    Hallo Zusammen!


    Ich möchte mit meinem zweiten Raspberry eine Alarmanalage realisieren. Bevor ich jetzt durchstarte und eventuell den Raspberry zerstöre, möchte ich das Projekt einmal kurz vorstellen. Ich hoffe ihr könnt mir sagen ob das so realisierbar ist und/oder hat ggf. Verbesserungsvorschläge.


    Einige Details:

    • An den Fenstern und Türen habe ich kabelgebundene Reed-Kontakte (16 Stück). Alle 16 Kabel kommen im HWR an.
    • Die Reed-Kontakte haben bei geschlossenen Türen/Fenster durchgang und unterbrechen wenn das Fenster öffnet.
    • Zusätzlich habe ich zwei Bewegungsmelder, dessen Kabel ebefalls im HWR ankommen.
    • Die Bewegungsmelder werden über ein zusätzliches Netzteil mit 12 Volt versorgt.
    • Die Bewegungsmelder haben zwei weitere Pins, welche dauerhaft durchgang haben und bei Bewegung, über ein internes Relais, trennen.
    • Desweiteren möchte ich zwei UART RFID-Reader einsetzen. Das habe ich schon getestet und es funktioniert.
    • Auf dem Raspberry installiere ich Raspbian Buster sowie Node Red und konfiguriere die GPIO Ports entsprechend (Pullup/Pulldown). Über MQTT sende ich die Zustände dann an den ioBroker.

    Anschluss der Reed-Kontakte

    Ich würde das jetzt wie folgt verkabeln? So schließe ich alle 16 Reed-Kontakte. Masse -> Reed-Kontakt -> GPIO

    D.h., ich kann am Ende den Status (offen/geschlossen) jedes Fensters bzw. jeder Tür sehen.


    [Blocked Image: http://sandmanyz.de/reed.jpg]


    Die Pfeile, welche in dem Bild (siehe unten) in Richtung des PIN's zeigen, sind für die Reed-Kontakte und Bewegungsmelder. Die ausgehenden Pfeile habe ich entsprechend beschriftet.
    [Blocked Image: http://sandmanyz.de/GPIO.png]

    Quote

    BTW: Für die Fehlersuche ist nicht entscheidend ob eine funktionierende/brauchbare ssh- oder telnet-Verbindung zu deinem PI hergestellt werden kann, sondern ob der PI auf einfache Portscans (Ports 22 und 23) _aus dem (W)LAN_ antwortet oder nicht antwortet. Z. B.:

    OK, danke für den Hinweis. Werde ich das nächste Mal berücksichtigen :)

    Quote

    Du hast doch "dtparam=act_led_trigger=heartbeat" auf deinem Pi konfiguriert, oder?

    Wenn ja, weißt Du dann wie die grüne Led am PI zu blinken hat? Das darf kein durchgängig gleichmäßiges Blinken sein. Kannst Du einen Unterschied im Blinken der grünen Led an deinem PI feststellen, sofort nach dem booten, wenn dein PI per ssh oder telnet noch erreichbar ist und zu einem Zeitpunkt wenn dein PI per ssh oder telnet nicht mehr erreichbar ist?

    Wenn der Raspberry auf der Seite liegt, blinkt die grüne LED recht schnell und durchgängig gleichmäßig. Das habe ich gestern abend geprüft. In den Tiefen des Internets habe ich jedoch keinen Hinweis zur Bedeutung gefunden.


    Wenn er normal läuft, also im Moment, blinkt er 2 mal schnell.


    Quote

    Stromkabel ziehen ist nicht gut. Schreibe ein Script das auf dem PI (per cronjob oder timer-unit) prüft ob dieser von außen nicht mehr erreichbar ist, und wenn das der Fall ist dann soll sich der PI selber rebooten (so dass Du nicht immer das Stromkabel ziehen muss).

    Muss ich mir nachher mal anschauen, wie das funktioniert.


    Quote
    prlimit --pid=<PID> | grep -i cpu
    prlimit --pid=$(pidof -s sshd) | grep -i cpuErgebnis: CPU | CPU | time unlimited unlimited seconds

    prlimit --pid=$(pidof -s inetd) | grep -i cpuErgebnis: CPU | CPU | time unlimited unlimited seconds

    prlimit --pid=$(pidof -s telnetd) | grep -i cpuDen Telnet Daemon habe ich wieder entfernt, weil ich ihn eigentlich nicht mehr benötige.

    Um ca. 19:06 Uhr ist er wieder eingeschlafen. Was ich so festgestellt habe...

    - Der Raspberry antwortet auf einen PING. Hat das mit den Anpassungen aus Beitrag #6 zu tun?

    - SSH Verbindung (Port 22) funktioniert nicht. Bei Putty kommt aber kein Timeout oder Connection Error. Ist der Raspberry ausgeschaltet, kommt von Putty nach kürzester Zeit ja Connection Error.

    - Telnet (Port 8888) zu einem eigens installierten Service (im ioBroker) funktioniert.

    - Telnet zum Raspberry (Port 23) funktioniert nicht.

    - Die rote LED am Raspberry leuchtet dauerhaft.

    - Die grüne LED am Raspberry blinkt recht schnell und durchgängig gleichmäßig.

    - Habe einen Bildschirm angeschlossen, welcher jedoch kein Eingangssignal bekommt.

    - Auf Tastastatureingaben reagiert der Raspberry nicht, Bildschirm hat kein Eingangssignal.

    - Auf eine Mausbewegungen ragiert der Raspberry ebenfalls nicht, Bildschirm hat kein Eingangssignal.

    - LAN-Kabel gezogen und wieder gesteckt. Schafft jedoch keine Abhilfe. Raspberry antwortet nach dem Einstecken auch wieder auf einen PING.


    Habe dann um etwa 19:35 Uhr das Stromkabel gezogen und anschließend in die Logs geschaut. Richtig weg ist er nicht, er macht noch Dinge und merkt auch, dass ich eine Tastatur angeschlossen habe.



    In dem syslog sind Zeitsprünge drin. Das ist irgendwie merkwürdig.

    Link zum Syslog (zu viele Zeichen für den Post)

    Genau wegen dem Problem des Hängenbleibens. Meist ist er genau dann abgestürzt wenn ich nicht zu Hause war und dann kam ich nicht mehr ran.

    Habe Raspbian Desktop inkl Watchdog am vergangenen Mittwoch installiert/eingerichten. Davor hatte ich Raspbian Lite laufen...ist aber auch abgestürzt.


    Ich werde dann heute Abend mal deine Hinweise aus dem Beitrag #6 umsetzen. Watchdog muss ich dann vermutlich deaktivieren?

    Danke für deine Unterstützung :)


    Code
    ls -la /dev/watchdog*
    
    crw------- 1 root root  10, 130 Jan 30 20:17 /dev/watchdog
    crw------- 1 root root 251,   0 Jan 30 20:17 /dev/watchdog0
    Code
    cat /boot/config.txt | grep -i watchdog
    
    Gibt nichts aus
    Code
    apt-cache policy watchdog
    
    watchdog:
      Installiert:           5.15-2
      Installationskandidat: 5.15-2
      Versionstabelle:
     *** 5.15-2 500
            500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
            100 /var/lib/dpkg/status

    Ich habe seinerzeit dieses Set gekauft: Raspberry Pi 3B+Hutschienenset. Gemäß Artikelbeschreibung hat das Hutschienennetzteil bei 5.1V 2.4 Ah

    Angeschlossen (per USB) ist an den Raspberry ein Aeon Labs Z-Stick, sonst nichts weiter.


    Um 19:00 Uhr lauft eine Sicherung des ioBroker.

    Hallo Zusammen!


    Ich bin neu hier und habe auch direkt ein Problem mit meinem Raspberry 3 B+. Er stürzt mind. 1x am Tag ab?(. Das äußert sich so, dass er per LAN nicht mehr erreichbar ist. In die Logs habe ich schon einige Male geschaut aber ich habe einfach zu wenig Ahnung um Fehler zu sehen. Deshalb nun dieser Beitrag.


    Das ist installiert:

    - Raspbian Buster with desktop

    --> Raspbian GNU/Linux 10 (buster)

    --> Linux Automation 4.19.93-v7+ #1290 SMP Fri Jan 10 16:39:50 GMT 2020 armv7l GNU/Linux

    - ioBroker


    Um etwa 20:45 Uhr ist der Raspberry gestern abgestürzt. Ich habe mal aus einigen Logs was rauskopiert und hoffe, dass Jemand etwas erkennen kann?