Posts by xxx_turbo_xxx

    Tip top... dann such ich mal danach, ob das bei mir so ähnlich aussieht.


    Danke!

    Rückwärtsspeisung sollte nicht der Grund sein. Problem besteht auch wenn ich den HUB abstecke

    Der Raspi ist ein Jahr alt

    USB > SATA Controller kann ebenfalls ausgeschlossen werden. Da hab ich auch schon 3 unterschiedliche ausprobiert. Hab dann ein USB SATA Gehäuse mit externer Stromversorgung genommen um auszuschließen, dass es an der Stromaufnahme liegt. Raspi Netzteil ist das originale

    Ich fürchte es liegt nicht am Booten, sondern am Herunterfahren. Wenn ich den Stecker ziehe, bootet er ja immer ganz normal. Monitor hab ich keinen dran, kann aber testhalber einen anstecken. Dann müsste man ja sehen, wie weit er kommt, oder?


    Danke schonmal für euren Support!

    Mit dmesg bekommt man nur die aktuellen Meldungen des Kernels angezeigt, das kann für eine Reboot Fehleranalyse zu spät bzw. zu früh sein. Besser wäre ein Blick bzw. grep -i in die Datei /var/log/syslog bzw. /var/log/messages ( je nach OS ) oder man schaut mal mit

    journalctl ins Journal des Systems nach Auffälligkeiten. Von Interesse wäre noch, wie der Reboot angestoßen wird, es gibt ja unterschiedliche Wege wie z.B. reboot, shutdown -r 0, init 6 ...

    Den reboot habe ich sudo reboot, bzw. sudo reboot now und sudo shutdown -r, bzw. shutdown -r now versucht

    K.A. für was Du die beiden USB Optokoppler brauchst, aber hast Du es mal ohne diese versucht? Die Logfiles könnte man nach Schlagworten wie fail, err, warn usw. durchsuchen.

    Die Optoköpfe benutze ich um die Zählerdaten meiner Stromzähler auszulesen und mit zu loggen. Ich hab schon versucht alles ab zu ziehen, allerdings bringt es nichts.


    Blöde Frage... Welche logs sind wichtig und wo speichert Raspberry os diese? in /var/log sind viele aber schlau werd ich daraus nicht...

    Hallo zusammen,


    ich hab das Problem, dass sich mein Raspi 4 beim reboot immer aufhängt. Beim Runterfahren gehen die LEDs am LAN-Port nie aus. Wenn ich dann die Stromversorgung unterbreche bootet er wieder normal.


    Boote von SSD (mit externer Stromversorgung), hatte das Problem aber auch schon mit der SD Karte.


    Am Raspi hänt ein LAN-Kabel, und 2 USB Optokoppler und natürlich die SSD


    Woran könnte das liegen?


    Danke für eure Unterstützung!

    Hallo zusammen,


    ich versuche Grafana upzudaten, scheitere aber aus unerdenklichen Gründen. Vielleicht kann mir jemand sagen, was ich falsch mache.


    Meine Vorgehensweise:


    sudo apt-get install -y adduser libfontconfig1

    wget https://dl.grafana.com/oss/release/grafana_7.3.4_armhf.deb

    sudo dpkg -i grafana_7.3.4_armhf.deb



    Raspi meldet folgendes:


    (Lese Datenbank ... 107258 Dateien und Verzeichnisse sind derzeit installiert.)

    Vorbereitung zum Entpacken von grafana_7.3.4_armhf.deb ...

    Entpacken von grafana (7.3.4) über (6.7.2) ...

    Ersetzt durch Dateien in installiertem Paket grafana-rpi (7.0.3) ...

    grafana (7.3.4) wird eingerichtet ...

    Restarting grafana-server service... OK

    Trigger für systemd (241-7~deb10u4+rpi1) werden verarbeitet ...


    Wenn ich dann aber Grafana öffne, steht da immer noch 7.0.3 drinnen... :/

    Hallo zusammen,


    ich habe im Garten eine Insel Solaranlage und möchte nun einen Speicher installieren, den ich per Raspberry überwachen und absichern kann. Ich habe vor 4 24V Batteriemodule parallel zu installieren. Jedes dieser Module besitzt die Möglichkeit die einzelnen Zellspannungen und 2 Temperaturen zu überwachen. Jetzt bräuchte ich eine zuverlässige Möglichkeit die Spannungen abzugreifen. Meine Idee wäre 2 ADS115 pro Modul zu nutzen um 6 Zellspannungen und 2 Temperaturen zu messen. Diese würde ich gerne an einem Wemos anschließen und im ersten Schritt alle Daten zu erfassen, per MQTT an den Raspi zu senden, mit ioBroker zu loggen und per Grafana darstellen. Im 2. Schritt möchte ich die ganze Anlage abzusichern.


    Meine Frage is nun, ob die ADS1115 hierfür ausreichend genau sind? Bei denen, die ich bisher genutzt habe sind schon mal Analoge Eingänge kaputt gegangen, bzw. die Schwankung der gemessenen Spannungen sind oftmals recht groß.


    Welche Alternativen gäbe es für dieses Projekt?


    Danke für euren Support!

    Dann ist diese Karte mit den ganzen Fehlern defekt, würde ich mal behaupten. Hast du auf der "defekten" Karte irgendwas wichtiges drauf ?

    Wenn nicht dann würde ich diese nochmal komplett neu am PC flashen. Normalerweise wird die SD Karte nach dem flashen verifiziert und eventuelle Beschädigungen werden angezeigt.

    Ich glaube nicht dass sie defekt ist. Ich fürchte es sind "nur" Dateien, welche vom System benötigt werden nicht mehr da, wo sie sein sollen. Wie gesagt... in dem Bootverzeichnis waren nur noch 4!!!

    Habs mal durchlaufen lassen...


    erst auf die schnelle Variante


    Code
    rootfs: ***** FILE SYSTEM WAS MODIFIED *****
    rootfs: 209626/1839328 files (0.6% non-contiguous), 2331091/7478400 blocks
    Memory used: 6608k/0k (1041k/5568k), time: 125.78/ 3.73/ 2.09
    I/O read: 484MB, write: 200MB, rate: 5.43MB/s



    Dann auf die langsamere...




    Die Mühle bootet trotzdem nicht mehr :( Hab testhalber ein altes backup wiederhergestellt und damit läuft alles wie gehabt. Hab übrigens gerade mal nen Monitor angehängt während des Bootens.


    Ne Idee wie ich das fixen kann?


    Das ist einmal eine Aussage für das IT Kuriositätenkabinett.


    Servus !

    Ich bin (offensichtlich) kein Linux-Experte. Wenn ein Windowsrechner nicht mehr bootet, kann ich theoretisch ein neues, separates System installieren, die Platte mit dem zerstörten Windows extern an das neue System anschließen und die Daten auf das neu installierte System kopieren. Das sollte doch so oder so ähnlich auch beim Raspi funktionieren!?

    Dann probier aus ob Du noch etwas lesen kannst, das Filsystem eventl. reparieren kannst Du damit aber nicht.


    MfG


    Jürgen

    Wie gesagt... Das Filesystem ist mir eigentlich Wurscht, wenn ich meine Daten von ioBroker, Grafana und influx DB auf eine neue Installation umziehen kann. Hab gestern noch ein System (aus einem Backup) aufgesetzt und auf neuesten Stand gebracht. Jetzt müsste ich nur meine Daten von der einen SD Karte auf die andere bekommen, falls das so einfach ist, wie ich mir das vorstelle :)

    Komischerweise passiert das in letzter Zeit öfter bei den Leuten, die via Putty auf ihren Pi zugreifen. Mag vielleicht Zufall sein aber ich würde auch da mal überprüfen. Es kommen ständig neue Versionen mit Bug fixes raus. Und größere System Updates/Upgrades würde ich immer direkt am Pi machen, sprich Monitor, Maus und Tastatur dran aber wer bin ich denn...

    Danke für den Tip.

    Anscheinend gibt es in jedem Forum die gleichen Sorten von Usern... Die, die einem helfen wollen/können und die, die die Weisheit mit Löfflen gfressen haben und nur dumme Sprüche auf Lager haben oder einen auf Google verweisen! Hätte ich dort was nützliches gefunden, hätte ich auch hier auch niemanden um Hilfe gebeten!


    Ich mache regelmäßig Backups, aber zwischen dem letzten Backup und dem Crash hab ich leider wichtige Daten, die ich eben nicht gespeichert habe.





    Danke Jürgen für deinen Link. Das werde ich versuchen!


    Habe gestern mein Backup wieder her gestellt. Man kann doch bestimmt auch "einfach" wichtige Ordner (ioBroker, Grafana, influxDB) von der SD Karte defekten Installation auf die neue per Windows Rechner kopieren!? Hat da jemand Erfahrung?