Posts by kajoty

    Hi ich habe div. Sachen getestet um ein script nach dem booten meines Pi automatisch zu starten.


    sudo crontab -e
    oder

    systemctl


    Mein Script wird allerdings nicht gestartet.


    Inhalt meines scripts:

    Bash
    #!/bin/bash
    # Script to start our application
    echo "Doing autorun script..."
    rtl_433 -G -F json -M utc | mosquitto_pub -h localhost -t home/rtl_433 -l &


    Startet man das Script manuell klappt es ohne Probleme. Nach einem reboot passiert leider nicht.


    Über

    Code
    sudo systemctl status rtl433.service

    kommt folgender output:

    Code
    ● rtl433.service - RTL433 Deamon
       Loaded: loaded (/etc/systemd/system/rtl433.service; enabled; vendor preset: e
       Active: inactive (dead) since Tue 2020-02-25 14:42:49 GMT; 13min ago
      Process: 676 ExecStart=/home/pi/script/rtl433start.sh (code=exited, status=0/S
     Main PID: 676 (code=exited, status=0/SUCCESS)
    
    Feb 25 14:42:49 raspberrypi systemd[1]: Started RTL433 Deamon.
    Feb 25 14:42:49 raspberrypi rtl433start.sh[676]: Doing autorun script...
    Feb 25 14:42:49 raspberrypi systemd[1]: rtl433.service: Succeeded.


    Kann mir hier einer sagen wo das Problem liegt?

    Es ist doch ein Schalter und kein Taster. Oder verstehe ich das falsch?


    Beim Klick auf einen Schalter bleibt der Zustand so lange aktiv bis erneut geklickt wird. Wenn du das nicht willst, baue doch ein delay ein welches den Zustand nach einer gewissen Zeit "resettet" oder wieder auf "null" setzt

    Warum hast du bei "Y-Axis" 10.000.000.000.000 und nicht 100. Bzw. 50 (Grad) würde ja auch reichen..


    Bei "Min" würde ich -25 und max. 50 eintragen.


    Sollen nur die letzten 10 Einträge deiner Datenbank angezeigt werden? Oder was soll Limit 10?

    Du willst doch sicherlich einen Verlauf sehen mit der "chart" Node und die aktuelle Temp. bei der Gauge?