Posts by Julian248

    Hallo zusammen,


    aktuell habe ich Ambilight mit APA102 bzw. SK9822 mit 60LEDs/Meter an einem 65" Display, das sind etwa 4,5 Meter LED-Streifen und es funktioniert perfekt.

    Insgesamt bin ich mit dem APA102 super zufrieden und würde daher nur ungern auf einen anderen wechseln, jedoch habe ich noch nie einen 6 Meter langen APA102 für einen 85" betrieben und bin mir unsicher, ob das stabil läuft. Ist der APA102 dafür noch geeignet oder sollte ich aufgrund der Länge auf einen anderen Streifen wechseln? z.B. WS2801 oder WS2812B?


    Einerseits habe ich bedenken, dass 5V auf die Länge problematisch werden könnte, obwohl ich 3 Einspeisepunkte vorgesehen habe. Sind 12V in dem Fall besser?

    Andererseits weiß ich nicht, wie sich der Clock auf die Länge auswirkt, sodass am Ende des Streifens vielleicht kein zuverlässiges Signal mehr ankommt.


    Ich freu mich sehr auf eure Ratschläge!

    Vielen Dank im Voraus!

    Wahrscheinlich kommt meine Antwort etwas spät.


    Wenn du einen Denon eine Nummer größer genommen hättest, hättest du dir den HDMI Splitter sparen können, denn der hätte 2 HDMI Outputs auf Zone 1.

    Den von dir gezeigten Grabber (zumindest anhand vom Gehäuse) habe ich auch versucht. An sich liefert der bei mir ein sehr schönes klares Bild, jedoch hat dieser eine so große Latenz, dass das Ambilight damit keinen Spaß mehr macht. Nur weil er das gleiche Gehäuse hat, heißt das aber nicht, dass das Innenleben identisch ist.

    Mein Grabber sieht optisch wie folgender aus: https://www.ebay.de/itm/353829856557 habe dafür etwas unter 10€ bezahlt. Das Bild ist wirklich unscharf und zum Grabben unbrauchbar, aber für das Ambilight spielt das keine Rolle. Hauptsache die Farben am Rand sind einigermaßen richtig und die Latenz ist bei optischer Wahrnehmung nahezu 0. Das einzige Problem was ich bei diesem habe ist, dass er durch den aufgezeichneten Pixelbrei bei eigentlich schwarz, mehr grün aufzeichnet und daher die LEDs bei schwarzen Bildern etwas grün flackern.

    Ich habe mir noch nicht so viele Grabber bestellt, um den Preis- Leistungssieger nennen zu können :D


    APA102 würde ich auch wieder kaufen. Unbedingt mit 300 LEDs auf 5 Meter.


    Hyperion würde ich das aktuelle Image nutzen, bei welchem Hyperion bereits vorinstalliert ist.

    Ich versteh nicht ganz, woran es bei mir scheitert... Das Projekt ist inzwischen sehr ernüchternd...
    Liegt es an der Spannungsversorgung oder kann der ESP32 nicht so viele LEDs ansteuern?

    Die Spannungsversorgung würde ich eher ausschließen, da es mit Hyperion keine Probleme gibt.

    Bezüglich der Anzahl an ansteuerbaren LEDs habe ich folgende Information gefunden:


    jar, du meinst, das Problem löst sich, indem ich den Strip alle 36 LEDs einspeise?

    Jetzt muss ich leider doch noch einmal um Hilfe bitten...


    Ich habe zwei verschiedene ESP32 an zwei verschiedenen ca. 50cm Abschnitten ausprobiert und es funktioniert absolut perfekt.

    Wenn ich jedoch an die ca. 4,5m anschließe, bleiben alle LEDs dunkel... Das Problem bezieht sich auf beide ESP32 und auf drei verschiedene 4,5m Streifen..

    Am Netzteil kann es nicht liegen. Liefert bei 5V 30A. Eingespeist werden die Streifen jeweils von beiden Seiten, jedoch nicht mittig.

    Mit Hyperion gibt es bei den 4,5m keine Probleme. Was mache ich mit dem ESP32 falsch, dass er die längeren Streifen nicht packt? Den brightness limiter hatte ich auch schon deaktiviert. Leider ohne Erfolg.


    das solltest du mal besser erklären, warum sollte man den nicht auch gleich richtig vollständig beschalten?

    Anschluß png ist eh falsch, denn an LV geht Vin und da Vin 5V sind und LV low voltage meint das wären ja 3,3V ist mir unklar wie man auf solche Verkabelung kommt?


    also GND nach GND LV nach 3,3V und HV nach 5V oder Vin solange Vin nicht >5V ist, Vin ist was über USB reinkommt also 5V und kann benutzt werden.

    Vielen vielen Dank!! Das hat das Flackern behoben.
    Ich dachte erst ich hätte einen Fehler bei CLK und Data, da ich hierüber auch überhaupt keine Informationen finden konnte, wie diese angeschlossen werden müssen.

    Auf gut Glück habe ich ein paar Pins gefunden, mit denen die Ansteuerung funktioniert...

    Leuchten die LEDs denn schon?

    Jetzt nach 2 weiteren Stunden habe ich die LEDs zum leuchten gebracht, also ja.

    Nur ists aktuell noch nicht wirklich brauchbar.

    Data habe ich am ESP32 an GPIO23, also MOSI angeschlossen.

    CLK habe ich an GPIO1, GPIO3 und CPIO18 ausprobiert.

    Bei GPIO3 passiert gar nichts, bei GPIO1 und GPIO18 flackern die LEDs und lassen sich annähern einer Farbe annehmen. Jedoch noch nicht zufriedenstellend. (siehe Video)

    External Content vimeo.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Hatte jetzt wieder etwas Zeit, mich um das Projekt zu kümmern.


    Habe ein paar ESP32 und auch schon WLED geflasht. In den Einstellungen habe ich den APA102 ausgewählt.

    Leider weiß ich nicht, welche Pins ich verwenden muss. Ein paar habe ich durchprobiert, aber vermutlich muss man die richtigen erwischen.

    Für einen Vorabaufbau auf dem Schreibtisch mit wenigen LEDs habe ich es wie im Anhang gezeigt aufgebaut.

    Wo schließe ich CLK und Data an?


    Vielen Dank im Voraus! raspbastler

    Willst du auch Lauflichteffekte von links nach rechts oder nur farbiges Licht?

    Bei nur farbigen Licht, beide LED Stripes vom Raspberry parallel ansteuren mit Level Shifter nicht hinten verbinden.

    Bei Lauflichteffekten auf beiden Seiten Strom einspeisen.

    Eigentlich will ich schon Lauflichteffekte, sonst hätte ich einen einfachen 5050 RGB SMD Strip auch nutzen können...

    Falls die Ansteuerung gar nicht möglich wäre, müsste ich als Notlösung aber darauf zurückgreifen. Schon mal gut zu wissen, dass es diese Möglichkeit gibt.

    Masse zwischen Stripe 1 und 2 verbinden.

    Du meinst, bei der 15m Verbindung, lediglich jeweils eine Ader für Clock und Data verwenden und dafür aber auch GND verbinden?

    Denn auf Steuerungsseite mit Raspberry werden die beiden Stripes mit gebrücktem GND versorgt. Bzw. kommt ja alles aus einem Netzteil.




    Habe heute etwas mit der Baudrate rumgespielt.

    Grün und blau funktioniert, nur bei rot fängt der rechte Streifen an, zu flackern.

    External Content vimeo.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Hallo liebe Community,


    ich habe zwar kein Ambilight gebaut, sondern mit den gleichen Komponenten eine Effektbeleuchtung in einer Lichtvoute gebastelt.

    Eine Skizze meines Aufbaus ist im Anhang zu finden. Ich denke, darin sind die meisten und wichtigsten Infos enthalten.


    Auf dem Raspberry Pi 2 ist HyperBian Image vom 19.11.2020 geflasht. Das entspricht der Version 2.0.0-alpha.9.


    Der linke LED-Strip funktioniert perfekt. Der rechte LED-Strip allerdings blinkt in willkürlichen Farben. Ich vermute, dass die Leitung für Data + Clock zum 2. Strip zu lange ist.


    - Kann es helfen die Baudrate zu senken und wenn ja, welcher Wert wäre sinnvoll?

    - Ich habe noch 3 Levelshifter auf Lager. Würde es Sinn machen, einen oder mehrere in die lange Datenleitung einzulöten? Wenn ja, an welcher Position und wie wäre dieser anzuschließen?

    - Gibt es vielleicht weitere Möglichkeiten, um das Problem zu bekämpfen?


    Ich freue mich sehr auf eure Antworten!

    Vielen Dank im Voraus!

    Julian

    Sorry, ich bekomme keine E-Mail Benachrichtigung und schaue nur sehr sporadisch ins Forum.


    Deinem Verständnis kann ich zustimmen.


    Für den Levelshifter sind die Jumperkabel ausreichend.


    Wie hoch der Spannungsabfall sein darf, kann ich dir auswendig nicht sagen und Recherche im Datenblatt der LEDs ist mir zu mühsam. Außerdem wären Messwerte zuverlässiger.

    Ein Netzteil liefert auch nicht exakt 5,0V. Meist sind die auch etwas drüber, aufgrund des Abfalls unter Last. Gerne wird bei 5V auch eine Z-Diode verwendet, welche auf 5,1V stabilisiert.

    Den Querschnitt würde ich ehrlich gesagt eher schätzen anstatt ausrechnen. Kurz gesagt geht es darum, den LED-Strip nicht mit Jumperkabeln zu versorgen.

    Eigentlich sollte 0,75mm² ausreichen. Kannst gerne 1mm² oder sogar 1,5mm² verwenden. Vom Hersteller sind an den Strips meist sogar kleinere Querschnitte angelötet (0,5mm²).

    Anfang und Ende des LED-Strip ist bei Ambilight sowieso direkt beieinander bzw. wenige cm voneinander entfernt. Ich habe mein Netzteil direkt an diese Start/Ende-Ecke positioniert. Das Netzteil selbst hat auch ca. 30cm Leitungslänge. Von dem her musste ich diese nur miteinander verbinden und nichts verlängern oder andere Leitungen zusätzlich verlegen.


    Ich würde keinen Grund sehen, bei den Eckverbindungen den Querschnitt zu verringern.

    Falls du einen dicken Geldbeutel hast, kannst du dir für die Ecken auch solche Winkel kaufen:


    https://www.zanasta.de/media/import/1033061741_1.jpg

    Bei diesen kann man den Plastikclip entfernen und die Winkel direkt anlöten.


    Oder solche:

    https://www.led-universum.de/m…_r-rgb-led-streifen_2.jpg

    Die Steckverbinder entlöten und den Winkel direkt an den Strip löten.


    Egal für welche dieser 3 Varianten du dich entscheidest, wichtig ist: löten

    Vielleicht liege ich falsch, aber soweit ich weiß, ist Pin 2 und Pin 4 am Raspberry 5V Output. Über diese Pins kann der Raspberry nicht versorgt werden. Allgemein kann der Pi nicht über GPIO versorgt werden.

    Was ich nur selbst noch nicht verstanden habe ist, ob man überhaupt so viel Leistung braucht. Lese sehr häufig Beiträge in denen von ca. 20W pro Meter gesprochen wird. Also bei 5 Meter wären das 20A. Selbstverständlich ist das inkl. etwas Reserve gerechnet.

    In einem anderen Forum habe ich 20W für 5 Meter gelesen und gestern habe ich selbst spaßhalber das Multimeter reingehängt. Ich habe 1,2A bei 5 Meter gemessen. (Farbe weiß, wobei wenn ich es richtig in Erinnerung habe auf 75% Helligkeit gedrosselt habe) Das entspricht 6A + 2A für den Pi

    Dann wäre ein 10A Netzteil locker ausreichend und hätte auch noch Reserven.

    Hoffe ich habe mich nicht verrechnet oder was übersehen :D

    RS ist wohl die Standardvariante

    So wie ich das bisher rausgelesen bedeutet ist LRS wohl 1U low profile und damit denen ihre ultra compact Variante

    Und RSP hat einen PFC verbaut.


    Ich würde in erster Linie auf den Preis und Maße achten. Demnach entweder RS oder LRS kaufen.

    Ich hab so einen für 12€ von Aliexpress

    https://de.aliexpress.com/item…b201602_,searchweb201603_
    Der funktioniert mit dem Pi super und für Ambilight perfekt, aber am PC mit OBS zeigt der nur Pixel an


    so einen hab ich schon ausprobiert
    https://www.amazon.de/dp/B089M9LB3F?tag=psblog-21 (Affiliate-Link)
    hatte den auf aliexpress bestellt

    funktioniert am PC mit OBS bei weitem besser als der andere, aber am Pi geht damit gar nichts

    MeanWell hat schon eine gigantische Auswahl an Netzteilen, da findet sich sicher ein flaches.


    Bezglich deinen 3 unterschiedlichen Netzteilen. Hättest du da nen Link dazu?


    Wenn du einen AV-Receiver hast, ist das natürlich Jackpot. Mein DENON z.B gibt 2 mal genau das gleiche Bild über HDMI aus. Somit spar ich mir auch alles bis auf den HDMI-Grabber. Außerdem ist an Bildquellen sowieso alles über den Receiver abgefangen von Sat, PCs, Konsolen, egal ob Cinch, HDMI, Component, etc. Damit hat man ausnahmslos bei jeder Quelle Ambilight.


    Würde sowieso nur ein Netzteil verwenden, statt mehrere. Die LEDs und der Pi werden beide mit 5V versorgt, von dem her sehe ich keine Notwendigkeit und im schlimmsten Fall gäbe es immernoch Step-Up-Down-Wandler.


    60€ für beides bedeutet 30€ für das Netzteil. Dann würde auch nichts gegen ein für dich ohnehin passenderes flaches Netzteil von MeanWell sprechen. Sollten sogar günstiger wie 30€ sein.


    Funktionieren wird das mit Sicherheit, aber ob alles in das Gehäuse passt bin ich ehrlich gesagt zu faul zum überprüfen :D


    Ein PC-Netzteil ist natürlich deutlich übertrieben. Aber wenn es wie erwähnt von einem ausrangierten PC stammt (und man sich durch die Anschaffungsersparnis damit ca. 7 Döner holen kann), kann man Ambilight schon sehr lange nutzen, bis sich die Kosten für ein neues MeanWell anhand des Stromverbrauches amortisiert haben.

    jar, du kannst gerne die Vor- und Nachteile von WS2812B in Bezug auf Ambilight darlegen und dies neutral formulieren.

    Nur wird das dem TE nicht großartig weiterhelfen.


    Wie bereits erwähnt, würde ich mir von dir inhaltlich zielstrebigere Beiträge freuen. Diese müssen nicht weit ausschweifen, Meinung anderer auflisten und Tippfehler aufzeigen, damit werden sie nur unnötig in die Länge gezogen. Der Informationsgehalt dieser Beiträge ist äußerst gering.

    Da du damit anscheinen Schwierigkeiten hast, kann ich es dir in einem Positivbeispiel darstellen.


    - Der TE hat WS2812B

    --> Du könntest ihn ermutigen und berichten, dass Ambilight auch mit diesen LEDs möglich ist. Anschließend erklären, was bei den LEDs im Aufbau und bei der Ansteuerung zu beachten wäre.

    Ist das so schwierig?

    Probiers aus ;)


    da alles von einem Netzteil versorgt wird vermutlich nichts, aber sollte der Potentialunterschied zu groß sein, könnten die LEDs z.B. gar nicht leuchten oder flackern, etc.

    jar, ich weiß, dass du äußerst kompetent bist und bin auch sehr froh, dass du mir bei meinem Ambilight geholfen hast.

    Nur inzwischen fällt es mir schwer, meine Meinung zu enthalten.

    Ich bitte dich deine Beiträge sachlicher zu formulieren. Du verschwendest deine Zeit und opferst deine Nerven für solche Sticheleien.


    Ich z.B. habe die Frage von raspbastler nicht als Vorwurf aufgefasst.

    Dass WS2812B nicht falsch sind, kann man auch zielstrebiger ausdrücken.

    Und vertippen kann sich jeder mal, außerdem wurde es wie du auch angemerkt hast, korrigiert. Wer sich dafür interessiert, liest sich vermutlich mehr durch. Falls ein Widerspruch vorhanden ist oder etwas nicht ganz verständlich aufzufassen war, kann dies gerne detailliert erfragt werden.


    Auch ich kann die APA102 empfehlen, obwohl ich mit den WS2812B bisher noch keine Erfahrung gemacht habe.

    Die APA102 sind mit 25-30€ für 5 Meter 60LED/Meter nicht zu teuer, liefern hinter meinem TV fabelhafte Farben und liesen sich problemlos via Hyperion ansteuern.


    Außerdem jar, falls dir mal wieder die Langeweile zu Kopf steigt und dich solche Threads anscheinend zu sehr die Eier quetschen, wäre vielleicht eine vernünftig ausgearbeitete, vollständige und unmissverständliche Anleitung für alle Ambilight-Bastler eine riesen Hilfe. Garantiert mehr, als deine Beiträge mit Andeutungen, statt Sachinhalten.

    Ich habe den Pegelwandler wie im Anhang gezeigt angeschlossen.

    Der Levelshifter benötigt soweit ich weiß auf der sekundärseite die 5V vom Netzteil als Referenz, dementsprechend auch GND.

    Wie genau die Transistoren auf der Platine verschalten sind habe ich mir nicht angeschaut. Die Steuersignale sollten jeweils die Basis sein, die 5V vom Netzteil der Collector und GND der Emitter.


    Ich habe bei mir auch die 3,3V und GND am Raspberry angeschlossen. So sollten mögliche Potentialunterschiede minimiert werden, wobei bei meiner PC-Netzteillösung das Problem nicht bestehen sollte.

    Sollte der Raspberry von einem anderen Netzteil aus versorgt werden, sollten die Massen zusammen auf das gleiche Potential geführt werden.


    Kurz: schließ einfach alle 4 drähte statt nur 2 an. Die Kosten dafür liegen im 1 stelligen Cent-Bereich und der Mehraufwand ist nahezu 0.


    Ich habe aktuell auf dem Schreibtisch noch einen Prototypen, davon kann ich dir heute Abend ein Foto zusenden.