Posts by Matsch1

    ...


    Mein BMP280 ist so verkabelt das es dem I2C entspricht. Ich lese den BMP280 mit dem D1 und D2 Anschluss aus. In den Testbeispiel klappt es auf I2C auch super.

    ...

    dann ändere doch mal

    Code
    ...
    
    //Adafruit_BMP280 bmp; // I2C
    
    Adafruit_BMP280 bmp(BMP_CS, BMP_MOSI, BMP_MISO, BMP_SCK);
    
    ...

    in

    Code
    ...
    
    Adafruit_BMP280 bmp; // I2C
    
    //Adafruit_BMP280 bmp(BMP_CS, BMP_MOSI, BMP_MISO, BMP_SCK);
    
    ...


    ...

    Kannst du mir auf die Sprünge helfen? Wo müsste denn printValue hin und warum? das verstehe ich noch nicht.

    Pack mal die Zeile 29 aus deinem Programm hinter die Zeile 35, dort wird erst die serielle Ausgabe initialisiert.

    Wow Dein Programm ist genauso ein zusammenkopiertes Chaos wie meine Eigenen. :lol:


    In dem von Dir zitierten Beispiel ist die I2C-Zeile aktiviert:

    Code
    ...
    
    Adafruit_BMP280 bmp; // I2C
    //Adafruit_BMP280 bmp(BMP_CS); // hardware SPI
    //Adafruit_BMP280 bmp(BMP_CS, BMP_MOSI, BMP_MISO,  BMP_SCK);
    ...

    diesen Aufruf hattest Du auch in #5, in Deinem Programm nutzt Du jetzt aber:

    Code
    ...
    
    //Adafruit_BMP280 bmp; // I2C
    
    Adafruit_BMP280 bmp(BMP_CS, BMP_MOSI, BMP_MISO, BMP_SCK);
    
    ...

    Wie ist es denn verdrahtet???


    Außerdem nutzt Du einmal die Funktion printValue bevor die serielle Schnittstelle initialisiert wird, da wird nichts rauskommen.

    Du hast da wahrscheinlich auch einen Kopierfehler drinnen:

    Das sollte wohl beides in den Setup-Bereich rein, durch den Fipptehler wird das bmp.setSampling jetzt gar nicht aufgerufen, damit wird der BMP dann die Einstelungen nicht kennen. Das könnte die Fehler auslösen.

    Von der Verpackung her scheint es mir eher das hier zu sein, da ist allerdings kein Foto vom Inhalt zu sehen. Auf der englischen Seite ist von "raw materials" die Rede, würde auf dein Foto zutreffen. Dann wäre aber die Verbrennung die falsche Entsorgungsmethode.

    Bei der von Dir erwähnten Größe der Kammer, wieviel m³/h hat denn die Anlage, nur mal Interesse halber.


    Vielleicht steht in der Doku der Anlage mit welchen Differenzdrücken am Filter zu rechnen ist.


    Bei Anbietern wie z.B. Reichelt gibt es passende Differenzdrucksensoren, wenn man den Arbeitsbereich kennt. Ich hatte jetzt welche so um die 30 € gefunden.

    Hallo Burnz,


    bist Du sicher, dass der BME280 der richtige Sensor dafür ist. Ich hatte irgendwo was von einer Genauigkeit von +-1hPa gelesen (Arbeitsbereich 300-1100 hPa). Die Differenzdrücke bei Filtern für Lüftungsanlagen beginnen normalerweise in sauberen Zustand bei 50 Pa und bei 200 Pa sind die normalerweise zu.

    Wenn die Genauigkeit dann bei 100 Pa liegt, ist das glaube ich nicht so geeignet.

    Ich habe das Problem leider schon und ich habe quasi schon einen "Farbmanagement-Experten" zu mir gebeten, weil vom Epson support kann ich nichts erwarten. Da ist es bei Epson egal ob ein Drucker um 100.- oder 1.200.- Euro. Wir drucken zu dritt privat (kommen alle aus der Druckbranche) von 3 verschiedenen Rechnern am Epson (aktuell der neue SC-P900) und ich/wir erwarte mir nicht "schön bunt" nach Automatik, sondern quasi farbverbindliche Ausdrucke. Ohne Profilierung und Kalibrierung käme "nur Mist heraus". Ich rede natürlich nicht von unmöglichen 100%, - wir wissen ja alle- unterschiedliche Farbräume etc. leuchtend und beleuchtet .... aber ein blau-Grün muss blau-grün sein und ich bin heikel.

    Sonst könnte ich jeden 100 Euro Drucker nehmen.

    Das verstehe ich schon, wie gesagt, ich habe je Rechner-Drucker-Papier-Kombination (für die Standard-Papier, ich nutze zwei verschiedene von Hahnemühle, eins von Canson und eins von MOAB) ein eigenes Profil angelegt und ja da muss man schon aufpassen, dass man auch das richtige Profil erwischt (Abends schon mal nicht so einfach).


    Passt es denn auf einem der Rechner? Wenn nicht, werdet Ihr um den Einsatz eines Kalibriergeräts nicht herumkommen. Beim Einsatz eines zentralen Druckerservers muss die Kalibrierung dann natürlich auf diesen zugeschnitten sein.

    Anforderungen an den Rechner werden von Dinax nicht genannt, finde ich im Internet auch nichts zu, da würde ich sicherheitshalber noch mal den Support kontaktieren (ohne Angaben traue ich mich nicht das nicht zu beurteilen, wobei ein Druckerserver sollte auf dem Mini-PC locker laufen).

    Naja das Problem ist, dass ich wenn ich von einem Mac etwas am Epson drucke oder ich etwas am PC etwas am selbigen Drucker drucke, die Farbabstimmung - trotz kalibrierten Monitore und profilierten Pappieren (alles profiliert/kalibriert), nicht auf jedem Computer das exakt gleiche Druckergebnis bzg. Farben erhalte. ...

    Das Problem habe ich bei mir nicht, gut bei einigen meiner Materialien fällt das auch nicht auf, die lassen sich nicht kalibrieren, da gibt es innerhalb eines Blattes schon Unterschiede. Bei meinen Standard-Papieren habe ich über Testausdrucke mit einem Kalibriergerät für jeden Rechner ein eigenes Rechner-Drucker-Papier-Profil angelegt.

    Könnte es mit Windows 11 (ARM) im Herbst klappen, dass ARM besser unterstützt wird, oder ist das nur wunschdenken?


    Könnte es mit Windows 11 (ARM) im Herbst klappen, dass ARM besser unterstützt wird, oder ist das nur wunschdenken?


    Mich wundert dann aber, dass Windows ARM überhaupt am Raspberry läuft und auch fast alle Prgramme.

    Es hapert quasi NUR mit ARM Treibern? Software läuft.

    Sollte mich wundern, bei Epson wird bei allen nicht Windows-Systemen auf Standard-Treiber verwiesen, ich glaube nicht, dass die Treiber für ein solches spezielles System einen eigenen Treiber anbieten werden.

    Hallo,


    ich muss gestehen, dass ich mich nie mit dem Gedanken beschäftigt habe den Drucker an einen Linux Rechner anzuschließen. Ich bastele viel mit den Einstellungen des Windows-Treibers, da ich verschiedene Medien bedrucke, das ist immer schon Experiement genug und ich scheue das Experiment, dass auf dem Raspberry zu versuchen. Daher habe ich keine Erfahrungen, ob das mit dem Druckertreiber überhaupt funktioniert.


    Aber reicht Dir die WLan-Verbindung oder der Netzwerk-Anschluss nicht. Ich greife auch von verschiedenen Rechnern (ich glaube es sind drei) auf den Drucker über einen Netzwerkanschluss zu.

    Ich würde auch über eine Datenbank gehen. Erstens gibt es da für beide bzw. für alle drei Teile gut erprobte Beispiele gibt. Zweitens bleibt es flexibel, man kann später weitere Sensoren dazupacken bzw. zeitliche Verläufe zeigen (kommt bei mir früher oder später immer dazu).

    Ob mit MariaDB oder InfluxDB ist Geschmackssache.

    ... Aber was ist ein "PH 2.0 Holder"...

    Eine Typangabe für eine Steckverbindung, in diesem Fall als Anschluss Stromversorgung z.B. LiPo-Akku.

    ... Wie Lange das ganze wohl funktioniert mit einem 18650er Akku?

    Ich bin kurz davor mir einen zu bestellen um das mal auszuprobieren. Ich hätte für das Teil auch ein paar Ideen.


    bitteschön ;)

    Danke.

    Der BME280 ist einfach überall nicht mehr lieferbar. Selbst die Angebote aus CN sind fast alle gelöscht, bzw als nicht lieferbar gekennzeichnet.

    Reichelt bietet noch diese an für ca. 6 Euro, 1,71-3,6V digitale I2C und SPI Schnittstelle 6-Pin(voraussichtliche Verfügbarkeit ab 01.07.)

    Ich befürchte mal das wird nichts mit 1.7., ich denke die werden die Verfügbarkeit noch anpassen.


    Da ich noch einige für ein Projekt brauche hatte ich beim fleissigen Chinesen ein 10er-Pack für 6,80€ das Stück bestellt, wenn das kommt, hätte ich 2-3 abzugeben. Aber auch da bin ich noch skeptisch, ob die Lieferung wirklich kommt. :gk1:


    In der Bucht habe ich ein Angebot für über 500€/Stück gefunden, vielleicht sollte man einige als Geldanlage horten :lol: .


    D.h.dann das ist auch für mich nichts 😫

    Bei meinen feinmotorischen Fähigkeiten für mich auch nicht :no_sad: .

    Entschuldige bitte, habe ich überlesen.


    Kann es sein, dass die Luftfeuchtigkeit aus dem Gehäuse nicht "schnell genug" herauskommt und bei den Temperaturunterschieden dann im Innern größere Mengen Kondensat anfallen?

    Ich habe meinen ESP wie Du in einer Abzweigdose untergebracht und nur den Sensor in einem Kupa-Rest, der an die Abzweidose geklebt ist untergebracht. Das ganze hängt dann etwas herunter, so dass Flüssigkeit nach unten ablaufen kann. Ich hatte den Sensor extra nicht an die Kabel angelötet, sondern mit Steckverbindern ausgestattet, damit man den ggf. mal schnell wechseln könnte. Musste ich bisher aber nicht, er läuft jetzt schon eine ganze Zeit. Gewinnt mit Sicherheit keinen Designpreis, muss es aber auch nicht, da kommt kaum jemand hin.

    Wenn noch Winter wäre, würde ich tatsächlich noch mal einen Vergleichssensor danebenhängen, um mal auszuprobieren, ob das wirklich einen so großen Unterschied macht. Nur jetzt im Sommer ist das glaube ich nicht so kritisch, da wird es tagsüber schnell wärmer und die Luft kann das Kondensat wieder aufnehmen.