Posts by ragman1976
-
-
Hi,
ob ich postfix richtig installiert habe, kann ich nicht sagen auf jeden Fall kann ich mit:
echo "Test mail from postfix" | sendmail "Test Postfix" testmail@gmail.com
eine email versenden.
echo "Test mail from postfix" | mail "Test Postfix" testmail@gmail.com
funktioniert allerdings nicht!
-
Hallo,
ich habe auf dem Raspi postfix installiert und kan über :
echo "Test mail from postfix" | sendmail "Test Postfix" testmail@gmail.com
emails versenden.
In raspiBackup unter Mailkonfiguration ist mail eingestellt. Wenn ich ein Testbackup starte wird diese abgebrocjem mit der Fehlermeldung:
"RBK0039E: Mail Program mail ist nicht installiert um eMail zu senden." RC 124?
log Datei sagt folgendes:
Code
Display More20220615-064552 DBG 6120: *** ls -1 /dev/mmcblk* 20220615-064552 DBG 6120: /dev/mmcblk0 20220615-064552 DBG 6120: /dev/mmcblk0p1 20220615-064552 DBG 6120: /dev/mmcblk0p2 20220615-064552 DBG 6121: *** ls -1 /dev/sd* 20220615-064552 DBG 6121: /dev/sda 20220615-064552 DBG 6121: /dev/sda1 20220615-064552 DBG 6121: /dev/sdb 20220615-064552 DBG 6122: --- mountpoint /boot: 179:1 mountpoint /: 179:2 20220615-064552 DBG 6137: --- Legacy boot discovery 20220615-064553 DBG 6140: --- part: /dev/mmcblk0p1 20220615-064553 DBG 6143: --- bootDeviceNumber: 179:1 20220615-064553 DBG 6144: --- rootDeviceNumber: 179:2 20220615-064553 DBG 6209: --- BOOT_DEVICE: mmcblk0 20220615-064553 DBG 6213: --- BOOT_DEVICENAME: /dev/mmcblk0 20220615-064553 DBG 2848: --> getPartitionPrefix mmcblk0 20220615-064553 DBG 2857: <-- getPartitionPrefix mmcblk0p 20220615-064553 DBG 6217: --- BOOT_PARTITION_PREFIX: mmcblk0p 20220615-064553 DBG 6220: <-- inspect4Backup 20220615-064553 DBG 6045: --> commonChecks 20220615-064553 DBG 3817: --> colorAnnotation 1 20220615-064553 DBG 3841: <-- colorAnnotation ??? RBK0039E: Mail Program mail ist nicht installiert um eMail zu senden. 20220615-064553 DBG 2355: --> exitError 124 20220615-064553 DBG 2362: <-- exitError 124 20220615-064553 DBG 4315: --> cleanup 20220615-064553 DBG 3817: --> colorAnnotation 1 20220615-064553 DBG 3841: <-- colorAnnotation --- RBK0033I: Bitte warten bis aufgeräumt wurde. 20220615-064553 DBG 4547: --> cleanupBackup 20220615-064553 DBG 4549: --- Got trap EXIT 20220615-064553 DBG 4550: --- rc: 124 -
et voila..
Erst
Ordner /var/log/nginx erstellen und die beiden Dateien access.log und error.log anlegen. Danach systemctl restart nginx und flupp..
die web-GUI ist wieder da.
Das wars, was ein Akt.
Danke nochmal!
-
Hi,
danke für deine Mühen.
Ich werde noch einen Versuch machen und nach dem Restore die Ordner manuell anlegen. Einfach um die Sache abzuschliessen, vielleicht hilft es ja irgendwann mal jemandem.
Gruss
-
Wenn Du sie Dir ansiehst wirst Du an verschiedenen Stellen @@@ finden. raspiBackup maskiert automatische die meisten sensiblen Informationen im Log. Allerdings besteht keine Garantie dass alles maskiert wurde (Siehe die Uebershrift im Log). D.h. Du kannst jetzt entweder mal manuell druebersehen und eventuelles noch maskieren oder Du zippst die Datei verschluesselt und schickst mit den Schluessel per PN.
Hi,
im Anhang die Datei. PW via PM.
Gruß
-
Hm ... dann ist das die Ursache fuer das Nichtstarten. Nur ist jetzt die Frage warum wird der Ordner nicht gesichert? Kannst Du mal das Debuglog eines Backuplaufes zeigen?
Kann ich die raspiBackup.log hier einfach als Datei anhängen oder steht da was drin was nicht jeder wissen sollte?
-
Die Zeilen 12 und 13 weisen auf Probleme hin. Kannst Du mal checken ob die Dateien im Backup drin sind? Sollten sie gemaess Code - ausser Du hast noch Excludestatements definiert. Wenn ich mich auf der SYno durch die Backupdatei klicke ist der komplett Ordner /var/log leer:
-
Die Zeilen 12 und 13 weisen auf Probleme hin. Kannst Du mal checken ob die Dateien im Backup drin sind? Sollten sie gemaess Code - ausser Du hast noch Excludestatements definiert.
Du meinst die:
/var/log/nginx/access.log
und die
/var/log/nginx/error.log
?
-
Hi,
ich habe jetzt alles nochmal in Ruhe durchgepielt. Die WebGui startet nach dem Restore definitiv nicht.
Im log sthet folgendes:
Code
Display MoreSep 19 06:55:02 Raspi4-OMV systemd[1]: Started User Manager for UID 1000. Sep 19 06:55:02 Raspi4-OMV systemd[1]: Started Session 18 of user pi. Sep 19 06:55:26 Raspi4-OMV monit[1259]: 'nginx' failed to start (exit status 1) -- '/bin/systemctl start nginx': Job for nginx.service failed because the control process exited with error code.#012See "systemctl$ Sep 19 06:55:56 Raspi4-OMV monit[1259]: Cannot create socket to [127.0.0.1]:25 -- Connection refused Sep 19 06:55:56 Raspi4-OMV monit[1259]: Cannot open a connection to the mailserver 127.0.0.1:25 -- Operation now in progress Sep 19 06:55:56 Raspi4-OMV monit[1259]: Mail: Delivery failed -- no mail server is available Sep 19 06:55:56 Raspi4-OMV monit[1259]: Alert handler failed, retry scheduled for next cycle Sep 19 06:55:56 Raspi4-OMV monit[1259]: 'nginx' process is not running Sep 19 06:55:56 Raspi4-OMV monit[1259]: 'nginx' trying to restart Sep 19 06:55:56 Raspi4-OMV monit[1259]: 'nginx' start: '/bin/systemctl start nginx' Sep 19 06:55:56 Raspi4-OMV systemd[1]: Starting A high performance web server and a reverse proxy server... Sep 19 06:55:56 Raspi4-OMV nginx[2408]: nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (2: No such file or directory) Sep 19 06:55:56 Raspi4-OMV nginx[2408]: 2021/09/19 06:55:56 [emerg] 2408#2408: open() "/var/log/nginx/access.log" failed (2: No such file or directory) Sep 19 06:55:56 Raspi4-OMV nginx[2408]: nginx: configuration file /etc/nginx/nginx.conf test failed Sep 19 06:55:56 Raspi4-OMV systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE Sep 19 06:55:56 Raspi4-OMV systemd[1]: nginx.service: Failed with result 'exit-code'. Sep 19 06:55:56 Raspi4-OMV systemd[1]: Failed to start A high performance web server and a reverse proxy server. Sep 19 06:56:27 Raspi4-OMV monit[1259]: 'nginx' failed to start (exit status 1) -- '/bin/systemctl start nginx': Job for nginx.service failed because the control process exited with error code.#012See "systemctl$ Sep 19 06:56:57 Raspi4-OMV monit[1259]: Cannot create socket to [127.0.0.1]:25 -- Connection refused Sep 19 06:56:57 Raspi4-OMV monit[1259]: Cannot open a connection to the mailserver 127.0.0.1:25 -- Operation now in progress Sep 19 06:56:57 Raspi4-OMV monit[1259]: Mail: Delivery failed -- no mail server is available Sep 19 06:56:57 Raspi4-OMV monit[1259]: Alert handler failed, retry scheduled for next cycle Sep 19 06:56:57 Raspi4-OMV monit[1259]: 'nginx' process is not running Sep 19 06:56:57 Raspi4-OMV monit[1259]: 'nginx' trying to restart Sep 19 06:56:57 Raspi4-OMV monit[1259]: 'nginx' start: '/bin/systemctl start nginx' Sep 19 06:56:57 Raspi4-OMV systemd[1]: Starting A high performance web server and a reverse proxy server... Sep 19 06:56:57 Raspi4-OMV nginx[2434]: nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (2: No such file or directory) Sep 19 06:56:57 Raspi4-OMV nginx[2434]: 2021/09/19 06:56:57 [emerg] 2434#2434: open() "/var/log/nginx/access.log" failed (2: No such file or directory) Sep 19 06:56:57 Raspi4-OMV nginx[2434]: nginx: configuration file /etc/nginx/nginx.conf test failed Sep 19 06:56:57 Raspi4-OMV systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE Sep 19 06:56:57 Raspi4-OMV systemd[1]: nginx.service: Failed with result 'exit-code'. Sep 19 06:56:57 Raspi4-OMV systemd[1]: Failed to start A high performance web server and a reverse proxy server. Sep 19 06:57:27 Raspi4-OMV monit[1259]: 'nginx' failed to start (exit status 1) -- '/bin/systemctl start nginx': Job for nginx.service failed because the control process exited with error code.#012See "systemctl$Wenn ich das richtig sehe wird nginx nicht gestartet, das würde ja zum Verhalten passen.
An was kann das liegen?
Gruß
UPDATE:
nginx lies sich mit:
sudo systemctl restart nginx
nicht wieder starten, da gab es eine Fehlermeldung.
Ich habe nginx mit:
nochmal "drübergebüglt"....jetzt funtioniert die web-GUI wieder!
k.A. warum nginx nach dem restore nicht funktioniert... framp -> your turn

Der nginex Service wird vor dem Backup gesoppt.
-
Hi,
ich habe das jetzt mal durchgesielt, d.h. die entsprechenden Einträge gelöscht -> Backup von einer funktionierenden Installation -> Restore (dem HomeOffice sei Dank
)Der Inhalt von /var/cache werden gesicher und wieder zurückgespielt, die WEB-GUI ist allerdings immer noch nicht erreichbar. Ich weiß nicht ob was mit den Benutzerrechten nicht stimmt oder was da faul ist. Ich habe auch keine Ahnung wie/wonach ich suchen soll...
Schade, dass sich OMV da nicht an die gängigen Regularien haltet.
-
Hallo framp,
danke für die schnelle Antwort und den "Lösungsvorschlag".
Auf der Suche nach der Ursache, dass OMV GUI nach einem Restore nicht mehr funktoiniert bin ich über folgende Foreneinträge gestoßen. Da gab es wohl nach einem Update Berechtigungsprobleme mit dem Ordner /var/cache/openmediavault, bzw. die Paketlisten, die sich im Ordner /var/cache/openmediavault/archieves befinden wurden gelöscht. Danach habe ich bei mir geschaut und festgestellt, dass der Ordner /var/cache/ nach dem Restore leer ist.
OMV\Exception: Failed to open file (filename=/var/cache/openmediavault/cache.omv\controlpanel\login_js.json, mode=w+) - openmediavaultHallo,zur Vorgeschichte:Hatte bisher Erasmus 3.99 unter debian 8 am laufen. Leider gab es auf OS-Ebene durch apt autoremove einen Crash, der so ziemlich alles…forum.openmediavault.orgapt-upgrade fail on rockpro64 - openmediavaulthello, I'm getting the following error when trying to upgrade via ssh(Quelltext, 3 Zeilen) also, I can't access to the web interface, with "cannot connect to…forum.openmediavault.orgDeleted /var/cache or How do I reinstall the web-gui? - openmediavaultHey,as I was running out of diskspace on the systemdisk, I deleted everything in /var/cache - I now know that this was not a good idea...I manually created…forum.openmediavault.orgIch hoffe es hilft dir weiter, eine dauerhafte Lösung wäre super, da es je nachdem doch viel Zeit in Anspruch nimmt OMV neu zu installieren und zu konfigurieren.
Falls du noch was brauchst, melde dich.
Ich werde deinen Lösungsansatz ausprobieren und mich nochmal melden.
Gruß
-
Hallo,
ich habe ein Raspberry4 mit OMV installiert. den ich mit raspibackup sicherere.
Ich habe versucht ein Backup wiederherzustellen, jedoch ist die Web-GUI von OMV nach dem Restore nicht mehr erreichbar. Nachdem ich mich im OMV Forum etwas umgesehen habe, ist mir aufgefallen, dass der Ordner /var/cache/openmediavault und entsprechende Unterordner nach dem Restore nicht vorhanden ist. Darin sollten sich auch div. Datien für die Web-GUI befinden.
So wie es aussieht werden die Ordner nicht mitgesicher, bzw. nicht entsprechend wiederhergestellt?
Ist das bekannt, bzw. gibts da eine Lösung?
Gruß
-
Dann weiß ich auch nicht, warum apt-get/apt diese Meldung:
bringt. buster ist up to date.
Evtl. kann man diese Warnung:
auch ignorieren.
OK, trotzdem Danke für deine Bemühungen!
-
root@Raspi1-PiHole:~# dpkg --print-architecture
armhf
root@Raspi1-PiHole:~# dpkg --print-foreign-architectures
root@Raspi1-PiHole:~# ls -la /lib/modules
insgesamt 24
drwxr-xr-x 6 root root 4096 Jul 31 07:00 .
drwxr-xr-x 17 root root 4096 Jun 26 06:40 ..
drwxr-xr-x 3 root root 4096 Aug 6 10:43 5.10.52+
drwxr-xr-x 3 root root 4096 Aug 6 10:43 5.10.52-v7+
drwxr-xr-x 3 root root 4096 Aug 6 10:43 5.10.52-v7l+
drwxr-xr-x 3 root root 4096 Aug 6 10:43 5.10.52-v8+ -
Versuch mal als root:
Und poste auch die Ausgabe von:
Evtl. hast Du docker-ce doch aus einer Fremdquelle installiert und die zuständige *.list-Datei, ist warum auch immer, jetzt nicht mehr vorhanden.
root@Raspi1-PiHole:~# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
W: APT had planned for dpkg to do more than it reported back (0 vs 3).
Affected packages: docker-ce:armhf
root@Raspi1-PiHole:~# apt autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
W: APT had planned for dpkg to do more than it reported back (0 vs 3).
Affected packages: docker-ce:armhf
root@Raspi1-PiHole:~# ls -la /etc/apt/trusted.gpg.d
insgesamt 8
drwxr-xr-x 2 root root 4096 Feb 5 2021 .
drwxr-xr-x 7 root root 4096 Aug 29 18:06 ..
-rw-r--r-- 1 root root 0 Mär 11 07:00 microsoft.gpg
root@Raspi1-PiHole:~# -
Ändert auch nichts:
root@Raspi1-PiHole:~# apt update
Holen:1 http://archive.raspberrypi.org/debian buster InRelease [32,6 kB]
OK:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Holen:3 http://archive.raspberrypi.org/debian buster/main armhf Packages [378 kB]
Es wurden 410 kB in 1 s geholt (306 kB/s).
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
root@Raspi1-PiHole:~# apt-get -s dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Conf docker-ce (5:20.10.8~3-0~raspbian-buster [armhf])
-
Siehe EDIT im Beitrag #15 (oben) und versuche danach erneut.
root@Raspi1-PiHole:~# nano /etc/apt/sources.list.d/raspi.list
root@Raspi1-PiHole:~# apt-get -s dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Conf docker-ce (5:20.10.8~3-0~raspbian-buster [armhf])
root@Raspi1-PiHole:~# -
a voila:
root@Raspi1-PiHole:/etc/apt# apt-get -s dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Conf docker-ce (5:20.10.8~3-0~raspbian-buster [armhf])
root@Raspi1-PiHole:/etc/apt# -
ja, das habe ich doch schon geschrieben. Warum ist die sources.list zweimal vorhanden? ... und andere *.list-Dateien fehlen. Hast Du das manuell geändert? Mach mal ein:
und versuche erneut mit:
Das ich was manuell geändert habe daran kann ich mich nicht erinnern (was nichts heißen mag) Jetzt kommt die Ausgabe:
root@Raspi1-PiHole:/etc/apt# sudo apt-get update -y && sudo apt-get upgrade -y
OK:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Paketlisten werden gelesen... Fertig
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
W: APT had planned for dpkg to do more than it reported back (0 vs 3).
Affected packages: docker-ce:armhf
root@Raspi1-PiHole:/etc/apt#