Posts by Heiglberger

    Erstmal Danke für die nette Aufnahme im Forum!


    Bernd666: Neu würde ich jetzt nicht sagen, aber mir fehlt die Praxis.


    Zu meinem ersten Problem, ja ich hatte tatsächlich noch einen internen Pull_down_Widerstand programmiert. Ein Überbleibsel aus dem ersten Programmierversuch. Ich hab den entfernt und die Schaltung wie in meinem ersten Bild verkabelt. Funktioniert nun. Soweit schon mal vielen Dank ;)


    Problem Nr. 2:

    Hätte ich es jemanden gezeigt, würde man sagen Vorführeffekt. Das Problem ist einfach nicht mehr vorhanden. Müsste aber wohl irgend ein Störeinfluss von dem Terminal -->Optokoppler gewesen sein. Den die Kabel von der Heizung sind relativ lange ( ca. 100m) und die vom Optokoppler zum PI nur 10cm.


    Gnom: Falls es dich interessiert: Spannung an den Terminal klemmen sind genau 3V (mit Multimeter gemessen). Die Toggle Impulste sind schwanken immer zwischen 1-5s. Ich habe auch deshalb die Software "robuster" gemacht. Die Benachrichtigung wird nur rausgeschickt, wenn der GPIO Pegel min. 10s lang auf high ist.



    Aber da nun alles funzt, will ich euch nicht länger mit meinen nicht vorhandenen Problem nerven.^^

    Euch allen vielen Dank für die schnelle und gute Hilfe.


    Gruß,

    Christian

    Hallo Zusammen,


    ich möchte für eine Heizung eine Überwachung realisieren.

    Ausgangssituation ist folgende: die Heizung schaltet eine LED über eine Gleichstromleitung ein falls ein Fehler vorhanden ist.

    Nun ist die Idee folgende: Überwachung der Gleichstromleitung per GPIO (Python -->Meldung über Telegrambot).


    Nachdem ich nun noch etwas neu in dem Thema bin, hab ich im Internet recherchiert und bin zum Schluss gekommen, eine Lösung mit Optokoppler ist am sinnvollsten :).


    Ich habe mich an folgenden Beispiel orientiert, da dass meinem Fall am nächsten kommt:



    Verwendeter Optokoppler ist der 4N45.


    Nun treten aber 2 Fehler auf:

    1. Sobald ich die Schaltung auf RasPI Seite wie im Bild beschrieben verbinde ist der GPIO auf HIGH Pegel.

    Tausche ich die PINS GPIO 3,3V <-->GPIO Input, ist das richtige Verhalten vorhanden. Das ist in meinen Augen auch sinnvoller oder?


    2. Schaltung wie beschrieben aufgebaut, zum Testen als "Terminal Spannung" 3,3V vom RasPI genommen -->Funktioniert wie erwartet. Spannung vorhanden, Optokoppler lässt durch.

    Sobald ich nur eine Ader(egal ob + oder -) vom Terminal verbinde, toggelt der Pegel am GPIO hin und her (kein genaues Muster erkennbar)

    An externen PINS von der Heizung liegt aber definitiv keine mit dem Multimeter messbare Spannung an. Ich bin hier gerade etwas ratlos, warum schaltet der Optokoppler immer wieder obwohl keine Spannung anliegt bzw. nur eine Ader verbunden ist?


    Ich sag schon mal danke im Voraus für Antworten.:)


    Gruß,

    Christian


    PS.: Original Thread zur Schaltung: https://www.raspberrypi.org/forums/viewtopic.php?t=202764