Posts by darksonic2112

    Mit "manuell mein Internet anmachen", meinst Du das herstellen der WLAN-Verbindung und/oder das Zuweisen einer IP-Adresse an das wlan-Interface bzw. das Konfigurieren einer default route oder einer brauchbaren Namensauflösung (DNS)?

    Wie sind vor dem "manuellen anmachen" die Ausgaben von:

    Code
    iwconfig
    ip a
    route -n
    arp -av

    ? Beschreibe mal, wie Du das "Internet manuell anmachst"?

    Entschuldige für die späte Antwort. Hatte viel nachzuholen, weil ich versucht habe das erste Problem zu lösen :S.
    Mit "manuell anmachen" meine ich mit der Maus auf dem Desktop nach oben Rechts auf das WLAN Symbol zu gehen, linksklick draufzudrücken und anschließend auf "Turn On WLAN" zu drücken.


    Das ist ja nicht unnormal. ich erstelle bei einer Neuinstallation eine Datei names wpa_supplicant.conf im Boot-Verzeichnis, die dann rüberverschoben wird.


    Welches OS verwendest Du? Die anderen Fragen erspare ich mir, denn Wie frage ich nach Hilfe? hatte ich bereits verlinkt. ;)

    Auch hier entschuldige für die späte Antwort. Ich werde mich nochmal am Sonntag melden, weil ich im Moment sehr viel um die Ohren habe :S.
    Ich erwarte selbstverständlich nicht am Sonntag direkt eine Antwort, aber ich möchte mir soviel Zeit für die Antwort auf deine Frage geben, damit keine Rückfragen entstehen müssen ^^.

    Das ist IMHO das größere Problem, weil das nicht so leicht auffindbar sein könnte. Welches OS, ... usw. > Wie frage ich nach Hilfe? ? Hast Du bestimmt schon gelesen, aber arbeite das bitte nochmals durch und zeige uns alle erdenklichen Infos!

    Wäre es vielleicht einfacher herauszufinden, wie man sowas hinbekommt? xD

    Ich hab tatsächlich eine Idee was es sein könnte.
    Ich habe meinen Pi mit eine wpa2-Enterprise Netzwerk verbunden. Ich musste dafür direkt in <sudo nano /etc/wpa_supplicant/wpa_supplicant.conf> Datei gehen und mein Netwerk mit identifikation, Passwort, ect. eingeben.

    Das habe ich übrigens aus folgender Quelle: https://medium.com/@iced_burn/…2-enterprise-ddd5a40c0b07
    In der Quelle wird noch eine Kleinigkeit ergänzt.
    Es wird noch ein Problem beschrieben, was manche User haben: Das Wlan connected und disconnected die ganze Zeit und es dauert so 5min, bis es sich beruhigt hat. Als fix wurde folgendes in <sudo nano /etc/dhcpcd.conf> eingegeben:

    Code
    interface  wlan0 
    env  ifwireless = 1 
    env  wpa_supplicant_driver = wext , nl80211

    Ich weiß leider nicht was es aussagt und ob es damit zusammenhängt, ich kann es mir aber vorstellen.

    Du hast aber hoffentlich das rpi-update nicht gemacht oder? Siehe dazu hier: https://www.elektronik-kompend…/raspberry-pi/2006061.htm

    Tatsächlich hab ich das upgrade nicht gemacht, also danke nochmal für den Hinweis.

    Ja, aber die Syntax wäre falsch und das eth0-Interface wird dann nur in der dhcpcd.conf nicht berücksichtigt, was nicht heißt, dass dieses Interface in einer anderen config (z. B. bei systemd-networkd) nicht berücksichtigt/konfiguriert werden kann.


    Aber wenn Du eine bridge brauchst, ist das was ich weiter oben geschrieben habe, nicht mehr aktuell.

    Danke nochmal an euch beide. Jetzt hab ich nur noch eine Kleinigkeit die mich stört. Jedes Mal wenn ich mein System reboote, muss ich manuell mein Internet anmachen. Könnt ihr euch erklären, woran das liegen könnte? Ich hab versucht danach zu Googlen, aber noch kein Erfolg gehabt. Auch in der wpa_supplicant Datei kann ich kein "disabled" oder whatever sehen.

    Ja, aber die Syntax wäre falsch und das eth0-Interface wird dann nur in der dhcpcd.conf nicht berücksichtigt, was nicht heißt, dass dieses Interface in einer anderen config (z. B. bei systemd-networkd) nicht berücksichtigt/konfiguriert werden kann.


    Aber wenn Du eine bridge brauchst, ist das was ich weiter oben geschrieben habe, nicht mehr aktuell.

    Ja sorry :S. Das liegt einfach daran, dass ich mich in der Sprache nicht so gut auskenne und ich habe versucht das zu umschreiben xD.
    Ich habe jetzt eine bridge erstellt, aber das gleiche Problem wie vorher.

    Folgende Sachen habe ich gemacht:
    https://www.raspberrypi.org/forums/viewtopic.php?t=132674

    Mir ist aufgefallen, dass er das über das "network interface" gelößt hat (auf nem Pi 3).
    Ich hab ja jetzt ein Pi 4 und ich habe gehört, dass man das immer über "dhcpcd" alles was static ip's angeht machen musst.

    Es könnte auch sein dass ich die Benennung der statischen ip (beim eth0) verkackt habe, aber warum hab ich dann schon wieder kein Wifi?

    Was ist das, ein "Wlan Signal über den Ethernet Port ausgeben" ausgeben und wie machst Du das?


    In der dhcpcd.conf kannst Du für das eth0-Interface deny konfigurieren.

    Die Zuweisung der statischen IPv4-Adresse für das eth0-Interface kannst Du mit systemd-network bzw. mit einer *.network-Datei machen.

    Ich habe eine WLAN Verbindung auf mein Pi. Die Sicherheit des WLAN Netzwerkes ist WPA2-Enterprise. Weil meine Nintendo Switch keine Verbindung zu diesem Netzwerk aufbauen kann, muss ich das über den Pi machen. Der fängt das WLAN Signal auf, und gibt das anschließend über den Ethernet anschluss (und LAN-Kabel) weiter an meine Konsole.

    wenn ich eth0-Interface deny einfüge, dann ist das doch so wie wenn ich kein Interface für eth0 habe, oder?

    Hi!

    Ich habe 1 kleines und ein großes Problem:

    Das kleine Problem ist, nachdem ich meinen PI reboote, schaltet er die WiFi funktion aus. Ich muss sie jeden Mal manuell anschalten (warum auch immer).


    So, das große Problem:
    Ich versuche 2 statische IP's zu vergeben. Das hab ich über <sudo nano /etc/dhcpcd.conf> gemacht. Dort habe ich ein Interface:
    <interface wlan0
    metric 200
    static ip_address...
    static router...
    static domain_name_server...
    >

    Die jeweiligen Daten habe ich aus dem Befehl <ifconfig> und <route> entnommen.
    Wenn ich reboote, dann funktioniert alles (Ich muss halt Wifi manuell einschalten, aber darüber hinaus funktioniert alles wunderbar).

    Das Problem entsteht erst, sobald ich ein zweites Interface für Ethernet erstelle:
    <interface eth0
    metric 300
    static ip_address...
    static router...
    static domain_name_server...
    >

    Auch hier habe ich die passenden Informationen aus <ifconfig> und <route> entommen. Wenn ich jetzt reboote und das Wifi starte, dann wird mir angezeigt, dass es keine drahtlosen Verbindungen gibt. Sobald ich das ethernet Interface (eth0) zum Comment umwandel, funktioniert es wieder. Es gibt also irgendein Problem bei Erstellung des Interfaces.
    Auch die Prioritätsetzung mit "metric" hab ich beachtet, aber nichts...

    Zur Info, ich möchte mit meinem Pi ein Wlan Signal über den Ethernet Port ausgeben, und dafür muss ich anscheinend statische Addressen für wlan und ethernet haben.

    Falls ihr noch weitere Informationen benötigt, gerne melden!

    Mfg, darksonic2112

    Edit:
    Hab das Problem gelößt.
    Bei der Webseite: https://www.raspberrypi.org/forums/viewtopic.php?t=132674 war ein kleines Problem.
    1. musste das was in <sudo nano /etc/network/interfaces> reingeschrieben werden musste eigentlich in <sudo nano /etc/dhcpcd.conf> rein (Weil ich ein Pi 4 habe, und er das mit einem Pi 3 gemacht hat).
    2. wurden die Kommentare nicht richtig erkannt und haben den Befehl somit ungültig gemacht. Einfach die Kommentare rauslöschen und es hat bei mir geklappt.

    Des Weiteren Muss man auf der Spielekonsole (in meinem Fall Switch) eine manuelle IP angeben. Welche IP man nehmen kann ist abhängig davon, was man in <sudo nano /etc/dnsmasq.conf> bei "dhcp-range" angegeben hat.
    Beispiel: Hat man folgendes in <sudo nano /etc/dnsmasq.conf> eingegeben: <dhcp-range=196.187.39.70,196.187.39.150, 12h>, dann muss man der Konsole eine IP zuweisen, die zwischen diesen IP-Addressen liegt, also bspw. 196.187.39.74.

    Hallo Leute!

    Ich habe meinen Pi mit dem Internet verbunden und wollte diesen direkt als Client umfunktionieren (Also mein Pi fängt ein WLAN-Signal ein, und gibt es per Ethernet Kabel weiter).
    Ich habe dazu eine Anleitung im Internet gefunden: (https://www.instructables.com/…t-Port-on-a-Raspberry-Pi/).
    Ich bin nun bei Schritt 6 und habe bereits dnsmasq installiert.
    Danach gibt er eine Reihe von Aktionen vor, die ich nicht befolgt habe (weil keine Befehle dazu angegeben wurden. Muss ich das vielleicht nachholen?)



    Anschließend soll man eine Reihe von Commands ausführen, was ich auch gemacht habe:

    Diese haben mir alle keine Antwort gegeben (aber das scheint bei manchen Commands ja normal zu sein).

    Dann hab ich die dnsmasq setting gemacht und auch den hint befolgt:



    Danach wurde es sehr kompliziert für mich und ich habe nichts mehr verstanden:


    Die ersten 3 Zeilen von dem Bild habe ich stumpf versucht zu ergänzen, was nicht funktioniert hatte.
    Das was ich in <etc/dnsmasq.conf>
    editieren sollte, habe ich editiert.

    Beim ausführen des letzten Befehls <sudo systemctl start dnsmasq> kamen Fehler:


    Bei <systemctl status dnsmasq.service> krieg ich folgendes:


    Ich hoffe ich konnte genug Informationen bereitstellen. Falls noch was benötigt wird, gerne schreiben!

    Was genau meinst Du mit " falsch konfigurierte"?

    Ich habe mit dem Befehl:
    <sudo nano /etc/dhcpdcp.conf> und <sudo nano /etc/interfaces.conf> Ein paar Sachen verändert -> versucht eine statische IP-Addresse zu erstellen. Diese war aber falsch konfiguriert, da ich eine völlig willkürliche IP-Addresse verwendet habe, die ich aus irgendeinem online IP-Addressen-Rechner entnommen habe.

    OMG LEUTE. ICH HABE ES GESCHAFFT!!!!!!!!!!

    Das Problem war einfach, dass ich eine falsch konfigurierte, statische IP-Addresse hatte. Die hat meine Namensauflösung ge*****.
    Als ich alles rückgängig gemacht habe und zu einer dynamischen gewechselt bin, hat es funktioniert.

    An der Stelle ein dickes dickes Dankeschön an rpi444, der mich den ganzen Tag begleitet hat und versucht hat mein Problem zu lösen. An die anderen natürlich auch ein danke.

    OK, arping geht nicht.

    Teste jetzt mit tcpdump ob ein rekeying statt findet (siehe Beitrag oben). Wenn ja, kann man weiter suchen/schauen und wenn nein, dann bin ich mit meinem Latein am Ende.

    Ich hab nochmal das Internet durchforstet und alle meine selfamde Einstellungen so zurückgemacht, dass ich mich im WLAN anmelden kann (aber immer noch kein internet habe).
    Eine Ursache könnte folgende sein:
    "Der Grund für das Fehlen des Standard-Gateways ist eine unvollständige manuelle IP-Konfiguration oder der DHCP-Server hat eine unvollständige IP-Konfiguration übermittelt. Oder es fand keine IP-Konfiguration statt."

    Wenn ich ip r mache bekomme ich <... dev wlan0 proto kernel scope link src 192.168.55.187>. Problem hieran ist, ist das ich die IP-Addresse selber vergeben habe "192.168.55.187". Wie kann ich das Rückgängig machen?

    Sobald ich eine richtige IP-Addresse habe, kann ich das Standardgateway überprüfen und von dort aus weitermachen.
    Ich kann uach ggf. den Systemadmin fragen, ob er mir ne IP geben kann, wenn ich das manuell ändern muss.

    EDIT:
    Die IP-Addresse habe ich von einer statischen zurück in eine dynamische umgewandelt und ich habe jetzt eine "richtige" Ip-Addresse".

    Den Standard Gateway konnte ich auch anpingen.
    Im Internet steht, dass es vermutlich ein Namensauflösungsproblem gibt:
    "Wenn trotzdem keine Internet-Verbindung möglich ist, dann liegt es eventuell an einer nicht funktionierenden Namensauflösung."

    Es war nicht installiert, ich habe das grade nachgeholt.


    Abgesehen von den falschgeschriebenen Befehlen scheint der das immer noch nicht zu haben...

    WPA2-Enterprise, also mit Zertifikat und Co, oder?

    Denn nur mit dem passenden Zertifikat bekommst du auch die passenden Netzdaten.

    Die Fritz!Box kann kein Enterprise

    Ich hatte nie von einer Fritzbox geredet.
    Ich habe mir angeguckt, wie man den Pi mit wpa2-Enterprise verbindet.

    <sudo nano /etc/wpa_supplicant/wpa_supplicant.conf>
    Dort die Netzwerkdaten hinzugefügt (u.A. PW und nuternamen, SSID, ect.), und dann hatte ich eine Verbindung zu dem Netzwerk, aber keine Internetverbindung

    Code
    sudo apt-get install iputils-arping arp-scan dnsutils tcpdum

    danach:

    Code
    sudo dpkg --configure -a

    Wenn Du diese tools installiert hast, wieder per WLAN mit dem Router verbinden und danach die Ausgaben von:

    Code
    iwconfig wlan0
    
    sudo arp-scan -I wlan0 -l
    
    sudo arping -c 3 -I wlan0 192.168.55.1

    Also das hier?
    Ich verbinde mich dann nochmal mit hotspot um das zu installieren.


    Wenn das nicht helfen sollte, sollte ich den Pi vielleicht zurücksetzten? Vielleicht blockieren andere Lösungsansätze von mir deine Lösungsansätze.