Posts by baseship


    Hallo
    Wie das schalten der Intertechno Empfänger funktioniert habe ich auf meiner GitHub Seite Beschrieben, läuft bei mir mit Pi2.
    https://github.com/baseship/rpiswitch
    Das schalten über einer Harmony Remote sollte mittels IR-Empfänger am Pi auch möglich sein, da bin ich aber nicht im Thema,
    ich schalte meine Funkaktoren über Smartphone...
    Kodi kann nebenbei installiert werden.



    In der Config hast Du den Schalter "WZ_Lampe_TV" definiert, dieser Name wird in der NetIO-App wie folgt unter sends eingetragen,


    Taste fürs Einschalten:
    Licht WZ_Lampe_TV An


    Taste Fürs Ausschalten:
    Licht_WZ_Lampe_TV Aus

    Die Idee mit Widerständen und Dioden hatte ich auch... kann man ja Ausrechnen.
    Werde mir Nächste Woche erst mal ein neues Messgerät kaufen! Hat sonst Glaube ich wenig sinn.


    Trotzdem Danke

    Hallo Leute,
    ich habe hier noch zwei Lichtschranken rumfliegen... diese würde ich gerne zur Überwachung von Garage und Gartentor einsetzen.
    Die Schranken können mit 10-30V Betrieben werden, habe hier noch 12V Netzteile die ich Benutzen würde.


    Leider ist mein Multimeter defekt und ich kann leider nicht die Spannung an den Datenpins Auslesen.
    Hat von Euch einer eine Idee wie ich die Dinger am Pi testen kann, ohne das dieser 12V ab bekommt?


    Es handelt sich um Lichtschranken von Leutze: PRK 25B66-S8

    Images

    • Anschluss.jpeg

    Mein erstes Tutorial :D ...


    Beschreibung:
    Aufsetzen eines Webcamservers mit MJPG-Streamer und der Playstation 3 EYE Kamera.
    Die USB-Cam kann direkt am Raspberry (ich habe den B+) angeschlossen werden, sie braucht keinen aktiven USB-HUB.
    Ich gehe davon aus das eine aktuelle Version von Wheezy Installiert ist und Ihr Zugriff per Terminal habt.


    Als erstes machen wir ein Update - kann ja nicht Schaden
    [code=php]sudo apt-get update[/php]


    Jetzt die Benötigten Paketquellen
    [code=php]sudo apt-get install subversion-tools libjpeg8-dev imagemagick[/php]
    [code=php]svn checkout http://svn.code.sf.net/p/mjpg-streamer/code/ mjpg-streamer[/php]


    Dann wechseln wir in den Ordner von mjpg-streamer
    [code=php]cd mjpg-streamer/mjpg-streamer[/php]


    Für die Installation geben wir nacheinander ein
    [code=php]make[/php]
    [code=php]sudo make install[/php]


    Damit ist die Installation auch schon Abgeschlossen, der Server kann nun gestartet werden (ihr müsst noch in dem Ordner /mjpeg-streamer/mjpeg-streamer sein)
    [code=php]./mjpg_streamer -i "./input_uvc.so -n -y -f 30 -r 640x480" -o "./output_http.so -n -w ./www -p 8060"[/php]


    ### -f 30 ### Framerate der PS3-Cam (max. 60)
    ### -r 640x480 ### Auflösung max.
    ### -p 8060 ### HTTP-Port kann geändert werden


    Zugreifen könnt ihr jetzt mit Eurem Webbrowser unter der IP und den von Euch vergebenen Port
    [code=php]http://ip-des-raspberry:8060[/php]

    ich nutze für meine Rollos den Elro HE889..sende ich nochmal den gleichen Befehl stop das Rollo..


    ich suche noch Zeit um eine implementierung für Rollos in den SHC einzubauen (musste mich erst um Sonnenauf/untergang kümmern war mir wichtiger). Dann könnte man die Knöpfe auch anders benennen als nur an/aus.. auf/zu oder rauf/zu währe besser.


    Habe SHC gerade neu installiert, jetzt gehts bei mir auch, komisch? Allerdings muss ich jetzt auch alles neu Konfigurieren...

    Das Problem ist, dass das Rollo entweder komplett Hoch- oder Runterfährt.
    Ein Abstoppen ist mit den in SHC integrierten Schaltern nicht möglich - da der Schiebeschalter entweder Auf oder Zu sendet.


    Die Steuerung an sich Funktioniert ja...


    Gibt es eine Möglichkeit die Buttons zu tauschen?


    Wie hast du die funkgesteuerten Rollläden realisiert und welche Hardware verwendest du dafür?


    Meine Aktoren sind alle von Intertechno,
    Rohrmotor an Schalter.


    Mit der NetiO App funktioniert alles Wunderbar, allerdings habe ich da nicht so einen großen Funktionsumfang und suche daher nach Alternativen...
    Habe auch schon Domoticz und Domotiga Probiert, leider ist die Unterstützung zu den Low Budget 433Mhz Sendern/Empfändern nicht ohne grossen Aufwand gegeben.
    Sind alles klasse Open Source Projekte, für eine Reibungslose Kommunikation soll aber ein ca. 110.-€ teures Modul Angeschafft werden... das sehe ich immo nicht ein...


    Nachdem meine Temperatursensoren auch Probleme gemacht haben, habe ich ein downgrade der Firmware gemacht, jetzt läuft wieder alles Normal... :bravo2:


    EDIT:
    zum downgrade, für Diejenigen die das selbe Problem wie ich haben


    Code
    sudo rpi-update f74b92120e0d469fc5c2dc85b2b5718d877e1cbb

    Ich finde das Projekt sehr Interressant!
    Allerdings gibt es nur Ein bzw. Aus Schalter, was bei funkgesteuerten Rolladen und Markiesen nicht gerade von Vorteil ist... entweder offen oder zu, ein Abstoppen ist nicht Möglich.


    Da ich nicht so Firm beim Programmieren bin, eher die Hardware mein Ding ist, Hoffe ich darauf das die "Schiebeschalter" durch "An" und "Aus" Schalter Ersetzt werden...

    Gibt es Mittlerweile eine Lösung für das Problem, dass wenn mehrere Clienten auf den NetiO-Server zugreifen, nur der 1. der sich angemeldet hat - Schalten kann?


    z.B.
    iPad App geöffnet - Schaltet Licht ein > geht
    Zeitgleich
    iPhone App geöffnet - Schaltet Rollo > geht nicht
    beim iPad Schaltet das Rollo aber...


    Starte ich den RPi neu und öffne die iPhone App, kann das iPad keine Befehle mehr Senden, umgekehrt das selbe...


    Bei Deinem ./send fehlt am Ende der Befehl für Ein- bzw Ausschalten.


    a 1 1 1 -> bei Dir a 1 1

    Das würde mich jetzt auch Interressieren.
    Habe Quasi selbiges Problem, Leitungslänge ca. 110m


    6 Sensoren werden über 3,3V vom Raspi Versorgt mit 2k4Ohm. Ohne Probleme.


    Habe heute einen weiteren Sensor mit 2,3m Kabellänge Angeschlossen und Zack - zeigen alle 0.0 Grad an... Bevor ich jetzt den Widerstand weiter Verringere, wäre die Frage, wieviel mA das 5V Netzteil Benötigt und ob Masse an diesen kommt oder am Raspi?

    Funksender sind heute angekommen :D


    Meine geänderte send.cpp Funktioniert auch, aber leider nur im Terminal über

    Code
    sudo ./send a 1 1 1


    Über die NetIO App tut sich garnichts...
    müssen da noch irgendwelche Berechtigungen geändert werden?


    edit:
    Hat sich Erledigt. Habe in der netio.config ausversehen Grossbuchstaben eingesetzt.