Posts by DeltaBlue

    Und im RPi als Zeitserver eintragen. (Ich hab die IP der Fritte genommen, nicht fritz.box)

    Hab zwar auf nem 3er son RTC-Modul aber damit komme ich nicht klar.

    Jetzt mal ehrlich und Butter bei de Fische:

    Ich Unterhalte mich mit Freunden, alle Handys liegen auf dem Tisch, und nur das wir uns Unterhalten im beisein der Handys

    bekommen wir dann "gezielt" Werbung ?? :conf:

    Ja ich habe die "Freundin" mit den großen "A" im Namen hier 3x im Haushalt stehen, aber deswegen bekomme ich doch keine Werbung.

    Wenn ich sowas bekommen würde auf mein Handy, dann würde ich aber zuerst mal mein Handy einer Gründlichen Prüfung unterziehen.


    Mfg.


    Edit. Mag mich mal jemand Aufklären wie das gehen sollte?? :danke_ATDE:

    Edit1: Und ja ich habe hier Pihole laufen (wollte ich nur noch erwähnen)

    So nach langem Suchen bei Tante Google hab ich das Problem endlich gefunden.


    In der /etc/resolv.conf stand als DNS Server noch die IP vom "alten" PiHole drin.


    (Auch beim Flashen einer neuen SD-Karte wird die IP eingetragen. Aber das ist eine andere Baustelle, daß finde ich auch noch raus wieso?

    Jemand ein Tip für mich? )


    Hab das mal geändert auf die IP der Fritte und jetzt gehen auch die Updates.


    Dank an alle für die Hilfe.


    Hie noch ein Nachtrag (daher kommt wohl dann auch beim ersten Start die falsche DNS-IP)

    Zitat: Beachten Sie, dass die Datei /etc/resolv.conf automatisch behandelt (und überschrieben) werden kann, wenn das Netzwerk vom NetworkManager verwaltet oder über DHCP konfiguriert wird. Zitat Ende

    Meine source.list

    Code
    deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi

    Und hier meine raspi.list

    Code
    deb http://archive.raspberrypi.org/debian/ bullseye main
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://archive.raspberrypi.org/debian/ bullseye main

    Ich raff es einfach nicht...

    Wie der Titel schon sagt, frage ich mich ob es nur mir so geht.

    Ich versuche seit Tagen mal ein update der Pi's hier zu machen, aber geht einfach nicht.

    Weder per apt-get noch per apt. (sudo natürlich davor)

    Ich bekomme jedesmal :

    Code
    Err:1 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
      Temporary failure resolving 'raspbian.raspberrypi.org'
    Err:2 http://raspbian.raspberrypi.org/raspbian/dists bullseye InRelease
      Temporary failure resolving 'raspbian.raspberrypi.org'
    Reading package lists... Done
    W: Failed to fetch http://raspbian.raspberrypi.org/raspbian/dists/bullseye/InRelease  Temporary failure resolving 'raspbian.raspberrypi.org'
    W: Failed to fetch http://raspbian.raspberrypi.org/raspbian/dists/dists/bullseye/InRelease  Temporary failure resolving 'raspbian.raspberrypi.org'
    W: Some index files failed to download. They have been ignored, or old ones used instead.

    Nun dachte ich, ok ist Temporär versuchst es später noch mal, aber seit voriger Woche geht das nicht..... :@

    Liegt das jetzt an meiner Technik oder ist das bei raspberrypi.org :conf:

    [auth.anonymous]

    # enable anonymous access

    ;enabled = true


    die ; müssen aber wech, sonst wird das ja nicht aktiviert


    [auth.anonymous]

    # enable anonymous access

    enabled = true


    so sollte das dann drin stehn. So ist es in meiner Config...(siehe mein Beitrag oben)

    Ich nutze auch Grafana 8.3.4 und lasse mir die Graphen in MagicMirror anzeigen.

    Das wollte am Anfang auch ewig nicht Funktionieren, bis ich in der .ini datei den Anonymus Zugang aktiviert hatte.

    Bei mir liegt die im Verzeichniss /etc/grafana und dort hab ich die grafana.ini per sudo nano grafana.ini bearbeitet.


    Code
    #################################### Anonymous Auth ######################
    [auth.anonymous]
    # enable anonymous access
    enabled = true
    # specify organization name that should be used for unauthenticated users
    ;org_name = Main Org.
    # specify role for unauthenticated users
    org_role = Viewer
    # mask the Grafana version number for unauthenticated users
    ;hide_version = false

    Ist ziemlich weit unten zu finden, nicht Verwechseln mit dem Security und User....

    Die Einrückungen Zeile 41-48 stimmen nicht , müssen weiter nach rechts, unter den anderen, das ist wichtig.

    Also mM nach dürfte das keine Rolle spielen mit den Einrückungen.

    Wenn der MM nen Fehler zeigt nach dem Hinzufügen eines Moduls liegt das meistens daran das entweder ein "," zuviel oder zu wenig ist.

    Oder eine "{" "}" bzw ";"....(MM ist da pingelig was das angeht)

    Das war am Anfang meines MM immer das größte Problem bei mir.


    Edit: Und kommt auch darauf an ob das Modul unter dem aktuellen MM läuft. Viele der Module laufen nicht mehr.

    Ich hatte mal Testweise Nextcloud auf einem Raspberry Pi 3 Modell B+ und das ganze lief , für mich jedenfalls, ziemlich zäh.

    Hatte es dann auf einem Raspberry Pi 4 Computer Modell B, 4GB RAM und da lief das ganze dann schon besser.

    Hab dann aber doch lieber eine Synology gekauft und Nextcloud ad Acta gelegt.

    framp

    Hätte ich auch nicht gedacht.

    Habe das nur mit bekommen weil ich mal einen Neustart des Pi gemacht habe . (lief 3 Monate durch ohne Probleme)

    Hatte dann ich der Console den Status abgefragt und dann wieder Daten geschrieben/ankommen.

    Das ging ein paar Stunden gut und dann wieder diese Fehlermeldung.

    Deshalb dann die Idee mit dem Neustart des Service.


    Danke für den Link und werde ich mir mal ansehen..

    So an der Stelle mal mein Dank an @IIutz für seine Hilfe in Bezug auf Cron und ein Dank an hyle für die Erklärung.

    Bis jetzt läuft es mit dem Stündlichen Neustart des Services.

    Ist zwar nicht das Gelbe vom Ei mit dieser Lösung des Stündliche Neustarts aber muss erstmal reichen.

    hyle

    Da stellt sich mir jetzt aber die Frage wo der Unterschied ist zu dem Wie und Wo ich das Eingetragen habe. :conf:

    Wärst Du so nett und würdest mir das Erklären. Man Lernt ja nie aus... ;)

    framp

    ja da liegst du richtig, ist nen Workaround für mein Problem.

    Hatte schon in /var/log/telegraf/ und /var/log/influxdb nachgesehen, aber beide Verzeichnisse sind leer.

    Hatten mich so nicht weiter gebracht deshalb der Cron. Vielleicht hilft es ja das Problem zu minimieren bis es eine andere Lösung gibt.


    @IIutz

    Hab mal 0 * * * * root /usr/bin/systemctl restart telegraf.service in /etc/crontab eingetragen.

    Ich berichte dann obs Funktioniert hat.

    Danke für die Rückmeldung. Ich habe das jetzt mal so in der Crontab eingetragen:

    60 * * * * root systemctl restart /lib/systemd/system/telegraf.service (mit Root)

    60 * * * * systemctl restart /lib/systemd/system/telegraf.service (ohne Root)


    Wenn ich dann aber (als root) service restart cron und danach service cron status ausführe bekomme ich folgende Fehlermeldung:

    Wo liegt jetzt der (Denk)Fehler meinerseits...