Posts by bucadoX

    Es geht :)
    Ich habe die Befehle wie angegeben ausgeführt (allerdings 3 vor 2, da es ja noch keine Verbindung zum router gab und damit auch arp ins Leere läuft). Danach ging aber weiter nichts. Darauf habe ich nochmal das Netz aus dem GUI gelöscht, neu ausgewählt, neu das Passwort eingegeben und tschagga, Verdbindung steht :conf:


    Besten Dank für die Geduld!

    Ok, die MAC hab ich. Wie sähe denn der Codeblock für dhcpd.conf aus?

    BTW: Wann stellst Du das power_save auf off? Denn das ist ja nicht persistent.

    Jetzt verstehe ich die Bemerkung von davor mit nicht persistent ;)



    Gut wäre eine service-unit, die vom wlan0-device abhängig ist und die service-unit für den wpa_suplicant, sollte dann von der service-unit für das power_save off, abhängig sein

    Da musst du mich einige Stockwerke tiefer abholen ;) Was mich allerdings wundert: Über das RPi hatte ich vorher überhaupt keine Probleme eine WLAN Verbindung herzustellen. D.h. mit einer Raspian Version von November 2020. Power_save war damals kein Thema.

    Poste mal von deinem PI3, die Ausgaben von:
    Code modinfo brcmfmac | grep -i parm ps aux | grep -i [w]pa



    Code
    pi@pi:~ $ modinfo brcmfmac | grep -i parm
    parm:           txglomsz:Maximum tx packet chain size [SDIO] (int)
    parm:           debug:Level of debug output (int)
    parm:           p2pon:Enable legacy p2p management functionality (int)
    parm:           feature_disable:Disable features (int)
    parm:           alternative_fw_path:Alternative firmware path (string)
    parm:           fcmode:Mode of firmware signalled flow control (int)
    parm:           roamoff:Do not use internal roaming engine (int)
    parm:           iapp:Enable partial support for the obsoleted Inter-Access Point Protocol (int)
    parm:           ignore_probe_fail:always succeed probe for debugging (int)
    Code
    pi@pi:~ $ ps aux | grep -i [w]pa
    root       427  0.0  0.3  10744  3756 ?        Ss   14:31   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
    root       608  0.1  0.4  11132  4268 ?        Ss   14:31   0:07 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext


    • Zu Testzwecken im Moment nur 2,4
    • 1 SSID
    • Nein, zu Testzwecken auf manuel mit der geringsten Auslastung
    • -49dBm
    • Nein, alle neuen Geräte werden zugelassen
    • -

    Jetzt ging es gerade viel schneller, 2 oder 3 versuche. Allerdings bleibt rästelhaft mit was die Verbindung hergestellt wird, da die IP und gateway nichts mit meinem Netz zu tun haben. Die einzige Übereinstimmung ist die SSID. Daher taucht das RPi auch nicht im der Übersicht der fritzbox auf. Über manuelle Vergabe habe ich auch versucht, das interessiert das RPi aber nicht; nach EIngabe IP4 und Router wird bei ifconfig weiterhin die alte IP 169.254.114.215 angegeben.

    und deshalb kann das was in der Ausgabe von iwconfig bzgl. "Bite rate" steht, ignoriert werden.

    Genau, das wollte ich damit ausdrücken.


    dhcp zurückzusetzen ändert leider nichts.






    Code
    pi@pi:~ $ arp -av
    ? (192.168.178.35) at <incomplete> on wlan0
    Entries: 1    Skipped: 0    Found: 1



    Neu ist allerdings der EIntrag (der richtigen IP ) beim arp request.


    Was hat es mit der 169.254.114.215 auf sich? Ist das eine art local host wie 127.0.0.1 ?
    Er werden um die 20 Anmeldeversuche benötigt, um eine Verbindung herszustellen, dann jedoch aber mit der obigen IP anstallt 192.168.178.35 (die das RPi erhält sobald ich mich per Kabel verbinde)

    Erstmal danke für die ganzen Analysevorschläge, man lernt dazu :)


    Die grafische Oberfläche gibt an, dass eine Verbindung zum WLAN besteht, und auch zum dem mit der richtigen SSID. Aber wenn man genauer hinschaut, scheint das nicht der Fall zu sein, wie auch immer das technische möglich ist...


    Erstmal soweit sogut, das richtige Netz ist ausgewählt:


    Code
    pi@pi:~ $ iw wlan0 info
    Interface wlan0
        ifindex 3
        wdev 0x1
        addr b8:27:eb:08:4c:02
        ssid Wurmloch
        type managed
        wiphy 0
        channel 8 (2447 MHz), width: 20 MHz, center1: 2447 MHz
        txpower 31.00 dBm

    Allerdings hat die gewählte IP nichts mit meinem Netz zu tun (Router ist auf 192.168.178.1 konfiguiert)



    Code
     pi@pi:~ $ ifconfig
    
    wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 169.254.114.215  netmask 255.255.0.0  broadcast 169.254.255.255
            inet6 fe80::ba27:ebff:fe08:4c02  prefixlen 64  scopeid 0x20<link>
            ether b8:27:eb:08:4c:02  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 557  bytes 119108 (116.3 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



    Deswegen vermutlich auch die 1MB/s




    Folglich gehen die hier auch alle ins leere:

    Code iwconfig ip a route -n arp -a ps aux | grep -i [d]hc




    Code
    pi@pi:~ $ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         0.0.0.0         0.0.0.0         U     303    0        0 wlan0
    169.254.0.0     0.0.0.0         255.255.0.0     U     303    0        0 wlan0


    Code
    pi@pi:~ $ arp -a



    Code
    pi@pi:~ $ ps aux | grep -i [d]hc
    root       494  0.0  0.2   2904  1904 ?        Ss   10:43   0:00 /sbin/dhcpcd -q -b




    Poste mal von deinem PI3 die Ausgabe von:
    Code sudo iwconfig wlan0 rate auto



    Code
    pi@pi:~ $ sudo iwconfig wlan0 rate auto
    Error for wireless request "Set Bit Rate" (8B20) :
        SET failed on device wlan0 ; Operation not supported.




    Woher kommt diese IP? Die SSID stimmt, alles andere nicht :conf:

    Danke!

    Fällt dir was auf?

    Hoppla :)

    nach erneuter korrekter Eingabe wurde power save on ausgegeben. Ich habe es dann nochmal über

    sudo iw wlan0 set power_save off

    deaktiviert, jetzt ist der Output


    Code
    Power save: off

    Jetzt scheint auch dauerhaft eine Verbindung zu bestehen, aber ohne Datenaustausch. Das RPi scheint weiterhin keine IP vom ROuter zu bekommen, denn die in der Verbindungsoberfläche angezeigte IP hat nichts mit dem WLAN zu tun.


    Was genau meinst Du mit "kurzzeitiger Verbindung"? 1 Sekunde oder 20 Sekunden oder ... ?

    Erst 1s, jetzt mit power_safe off dauerhaft.

    Hast Du evtl. den MAC-Adressen-Filter in deiner FritzBox aktiviert?

    Nein

    Versuch mal in der FritzBox mit nur WPA2, statt dem WPA+WPA2.

    So hatte ich es vorher. Habe es wieder umgestellt auf nur WPA2



    Wenn Du 2,4GHz und 5GHz aktiviert hast, dann deaktiviere temporär für die Zeitdauer des Tests, das 5GHz-WLAN in deiner FritzBox.

    Done. Bis jetzt ohne erkennbare Auswirkungen.



    este auch mit einem festen Kanal (1 oder 6 oder 13), statt Autokanal, in deiner FritzBox.

    Done, wie oben.

    Wie hoch ist die Sendestärke beim WLAN, in deiner FritzBox eingestellt?

    Kein Plan...aber RPi gibt eine link quality von 56/70 udn ein signal lebel von -54dBm an.


    Quote from rpi444

    Starte:

    Code

    Code
    sudo tcpdump -c 100 -vvveni wlan0 ether proto 0x888e 

    auf deinem PI, um das neu aufbauen der WLAN-Verbindung (wifi 4-way-handshake) zu sehen.

    tcpdump wird warum auch immer nicht erkannt....

    Hi, mit



    Code
    sudo iw wlan0 set power_save off

    wird power safe deaktiviert:


    Code
    [    3.000207] Init: Port Power? op_state=1
    [    3.000219] Init: Power Port (0)
    [    3.034001] bcm2835-power bcm2835-power: Broadcom BCM2835 power domains driver
    [   13.326833] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
    [  170.263354] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save disabled


    Bei


    Code
    iw wlan0 get power_save

    scheint etwas im Befehl zu fehlen, da mir nur die Hilfe für iw angezeigt wird:




    Das Ergebnis ist bisher unverändert, die Verbindung wird konstant auf- und abgebaut.

    Ausgabe von iwconfig:


    Code
    wlan0     IEEE 802.11  ESSID:"Wurmloch"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: 98:9B:CB:0C:DA:D0   
              Bit Rate=1 Mb/s   Tx-Power=31 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality=49/70  Signal level=-61 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0




    AUsgabe von dmesg | grep -i power:

    Code
    [    2.997999] Init: Port Power? op_state=1
    [    2.998012] Init: Power Port (0)
    [    3.031957] bcm2835-power bcm2835-power: Broadcom BCM2835 power domains driver
    [   11.929272] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled

    Der Router ist (noch) ne fritzbox. WLAN funktioniert mit anderen Geräten,

    Nach EInrichtung von Raspbian und Konfiguration aller gewünschten Einstellungen sollte der Wechsel von Kabel auf WLAN erfolgen. Die Netze werden auch vom Adapter erkannt und ich kann SSID auswählen und das Kennwort eingeben (entprechende Einträge sind dann auch im wpa_supplicant.conf vorhanden, inkl. Ländercode DE). Allerdings kann keine stablile Datenverbindung aufgebaut werden, die einen Datenaustausch ermöglicht. Nach kurzzeitiger Verbindung wird diese wieder getrennt und neu aufgebaut.

    An der Entferung zum AP liegt es nicht. WPA Modus des Routers ist auf WPA + WPA2 gestellt.

    Gibt es noch Ideen zur Ursache?
    Dankeschön!

    Das war ein guter Hinweis, hat alleine leider nicht ausgereicht, aber mit etwas weiterer Nachforschung habe ich folgende EInstellung vorgenommen:


    In der boot\config.txt folgenden Wert auskommentiert:


    Code
    hdmi_drive=2

    Und jetzt gehts!

    Jetzt mach ich ein Backup und habe hoffentlich dauerhaft Ruhe :)


    Besten Dank nochmal!!

    die neue asound.conf eingespielt und alles paletti.

    woher ich den input von meiner asound hatte kann ich dir leider nicht mehr sagen, da liegt schon wieder zuviel Zeit dazwischen...irgendwo in Foren gelesen.


    Auf jeden Fall besten Dank! (mal wieder....)

    Leider bin ich grad auch nicht mehr in der Lage mich daran zu erinnern, wo ich ANpassungen vornehmen muss um nun audio über HDMI zu aktivieren. Nur im volume control den Haken bei HDMI zu setzen reicht nicht. Muss ich in der PhonieboxInstall.conf AUDIOiFace auf "HDMI" setzen?

    Hi,


    asound.conf von mir so eingestellt:


    Der relevante part der mpd.conf:



    Code
    audio_output {
    type		"alsa"
    name		"My ALSA Device"
    #	device		"hw:0,0"	# optional
    #	mixer_type      "hardware"      # optional
    #	mixer_device	"default"	# optional
    mixer_control	"Headphone"		# optional
    #	mixer_index	"0"		# optional
    }

    Danke, nach aktivierung und EIngabe von

    Code
    sudo systemctl status mpd

    wird folgendes zurückgegeben:

    Anscheinend wird der player erfolgreich gestartet, aber die Meldungen lassen mich zweifeln, dass alles korrekt konfiguriert ist. Bei EIngabe von



    Code
    sudo systemctl start mpd.service

    ist volume auf n/a:


    Code
    volume: n/a   repeat: off   random: off   single: off   consume: off


    So kanns nicht gehen?

    Hi, das ergibt folgendes:

    Code
    mpd.service - Music Player Daemon
    Loaded: loaded (/lib/systemd/system/mpd.service; disabled; vendor preset: ena
    Active: inactive (dead)
    Docs: man:mpd(1)
    man:mpd.conf(5)
    file:///usr/share/doc/mpd/user-manual.html

    Leider ist mir meine Micro SD Karte abgeraucht und ich musste alles nochmal neu aufsetzen (backup mach ich dieses mal garantiert...) Jetzt komme ich aber nicht über die Installation der Phoniebox + Spotify Software hinaus. Ein Abspielen über das Web Interface ist nicht möglich. Auch Spotify über Iris läuft nicht. Was mir aufgefallen ist: Egal was ich versuche, das mpd state file im Folder /var/lib/mpd gibt immer den Status "stop" aus:


    Ich vermute, so kann es nicht funktionieren? Sound läuft ohne externe Karte. Innerhalb Raspbian klappt die Wiedergabe per VLC ohne Probleme.




    Danke euch!