Posts by michi_pi

    Hallo, die letzte Nachricht ist irgendwie untergeganen.

    Ich verwende den iobroker für die Hausautomation, dort habe ich eine Visualisierung erstellt, wo ich die Weckzeit einstelle. (Ziel wäre einmal, das direkt mit Google einzustellen, da ich mit dem auch schon im Bett darüber rede :D)

    Wenn ich den Wecker eingestellt und aktiviert habe, läuft ein Skript ab, der dann zu der genannten Zeit in Spotify dieses Gerät und eine voreingestellte Playlist auswählt. Beginnend mit der Lautstärke 0 erhöht sich alle paar Sekunden die Lautstärke um weitere 2, bis zu einer gewissen Lautstärke. (Damit ich nicht dirket vom Bett falle :) )


    Ich weiß nicht ob hier welche IoBroker verwenden, falls interesse besteht kann man mich jederzeit hier oder im IoBroker Forum anschreiben. :)

    Hallo kle vielen Dank für deine Hilfe. Du hast mir sehr geholfen. :danke_ATDE::bravo2:

    Es läuft bei mir jetzt schon seit ein paar Tage alles gut.

    VOLUME_ARGS="--initial-volume=30" hab den Wert bereits gesetzt gehabt.


    Ich verwende das System jetzt für einen Wecker. Ich lass mich zu einer bestimmten Zeit mit einer bestimmten Playlist wecken.

    Funktioniert sehr gut.

    Quote

    das Overlay pi3-disable-bt entstand mit dem RPi 3B, dem 1. Raspi mit onboard-Bluetooth-Chip. Mit weiteren Raspis (RPi Zero W, RPi 3B+, RPi 3A+, RPi 4B, ...) mit onboard-Bluetooth ist das Overlay umbenannt worden in disable-bt, weil es nicht nur für RPi 3* verwendet werden kann. Aus Kompatibilitätsgünden ist das Overlay pi3-disable-bt weiterhin vorhanden.

    das heißt wenn ich das onboard Bluetooth deaktivieren möchte, schreibe ich nur disable-bt, mein USB-Bluetooth-Stick funktioniert dann weiterhin?



    Ich hab den alsamixer verwendet. hab den auf einen Wert (30) eingestellt. Nach einem neustart war in alsamixer der Wert wieder auf 100 gesetzt.



    Schönen gruß, Michi

    kle hab es gestern doch noch zum laufen bekommen. Hatte in der /boot/config.txt bluetooth deaktiviert, da ich noch ein aufsteckmodul betreibe.


    dachte mit dem Eintrag dtoverlay=pi3-disable-bt setzte ich nur das onboard Bluetooth außerkraft.


    Hab jetzt allerdings noch eine andere Frage.

    Kann ich die Lautstärke am alsamixer voreinstellen? Denn bei dem neu verbinden springt dieser wieder auf 100 zurück

    kle So bin jetzt dazu gekommen und hab alles neu installiert.

    Bin deine Anleitung durchgegangen.

    Hab den Lautsprecher noch pairen und trusten können, nach dem reboot geht es aber nicht.


    wenn ich den Vorgang nochmal wiederhole kommt das

    Code
    $ bluetoothctl
    [bluetooth]#  power on
    No default controller available


    bluealsa und bluetooth sind aktiv


    hab gerade gesehen, dass hciuart Probleme macht

    kle Hab gelesen, dass Raspotify wohl Probleme macht, hab das nun deinstalliert.


    Nun habe ich durch den Nutzer @SparklingBird60393 in einem seiner Beiträge gelesen, dass er spotifyd verwendet.

    Hab mir das angeschaut und nun auch installiert. Allerdings bekomm ich es nicht zum laufen.


    Code
    systemctl --user status spotifyd.service
    ● spotifyd.service - A spotify playing daemon
       Loaded: loaded (/etc/systemd/user/spotifyd.service; enabled; vendor preset: enabled)
       Active: activating (auto-restart) (Result: exit-code) since Tue 2021-01-26 15:03:56 CET; 5s ago
         Docs: https://github.com/Spotifyd/spotifyd
      Process: 10587 ExecStart=/home/pi/spotify/spotifyd --no-daemon (code=exited, status=101)
     Main PID: 10587 (code=exited, status=101)


    Weiß nicht woran es scheitert.


    hier mal die Config, diese liegt unter ~/.config/spotifyd/spotifyd.conf

    username und password hab ich unkenntlich gemacht ;)


     /etc/systemd/user/spotifyd.service

    kle jetzt bin ich es doch nochmal.

    Also mit dem Lautsprecher bin ich jetzt verbunden


    Ich habe auf dem pi den Rasspotify installiert. Wenn ich nun Musik über Spotify auf dem Pi abspielen möchte, kommt kein Ton.

    Abgespielt wird allerdings was.


    Muss ich noch was einstellen/umstellen?

    Du weißt, daß die Foundationmit dem Raspberry Pi OS vom 02.12.2020 auf pulseaudio umgestellt hat (Link), damit entfällt bluealsa.

    Nein das wusste ich nicht.



    hier die Ausgabe von


    Code
    $ cut -d, -f4 /boot/issue.txt
    Raspberry Pi reference 2020-08-20
     stage2


    und die zweite wird verweigert, auch mit sudo

    Code
    $ pactl list sinks short
    Verbindungsfehler: Verbindung verweigert
    pa_context_new() fehlgeschlagen: Verbindung verweigert

    Hallo zusammen,

    ich versuche schon seit einiger Zeit meinen Raspi 3b+ (Buster lite) mit meinen Bluetooth Lautsprecher zu verbinden. Leider ohne Erfolg.

    Bin da auch noch ein NOOB in der Linux welt. :D


    Soweit ich das erkenne, ist bei mir das Profil a2dp-source nicht aktiviert. (soweit ich das gelesen habe, brauche ich das um von pi die musik zum Lautsprecher zu übertragen)

    Bisher konnte ich den Lautsprecher nur pairen und auf trust setzen. Connecten schlägt leider immer fehl.


    Hier mal die Infos zum Gerät aus bluetoothctl


    Allgemeine Infos:

    Wenn ich richtig liege ist hier nur a2dp-sink gestartet?!


    In der config habe ich allerdings a2dp-source eingetragen. Das wird aber wohl schön brav ignoriert.


    geblockt ist auch nichts


    Code
    1: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no


    dmesg sagt folgendes

    Code
    $ dmesg | grep luetooth
    [    5.965278] Bluetooth: Core ver 2.22
    [    5.965348] Bluetooth: HCI device and connection manager initialized
    [    5.965369] Bluetooth: HCI socket layer initialized
    [    5.965380] Bluetooth: L2CAP socket layer initialized
    [    5.965399] Bluetooth: SCO socket layer initialized
    [    6.058533] Bluetooth: hci0: unexpected event for opcode 0x0000
    [    7.532754] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [    7.532767] Bluetooth: BNEP filters: protocol multicast
    [    7.532791] Bluetooth: BNEP socket layer initialized


    Kann mir hier bitte jemand weiterhelfen?