Posts by thaero

    Oh man...

    ich habe vorhin den gewünschten DNS in der PiVPN und Wireguard config eingetragen mit:

    Quote

    sudo nano /etc/pivpn/wireguard/setupVars.conf

    sudo nano /etc/wireguard/wg0.conf

    zusätzlich habe ich davor in der Wireguard App auch den DNS-Server eingetragen


    hat leider nicht funktioniert


    jetzt hab ich aus Verzweiflung einfach mal ein neues Profil angelegt (die Einstellungen in der Config von PiVPN und Wireguard habe ich gelassen)


    Quote

    pivpn -a

    pivpn -qr


    JETZT FUNKTIONIERT ES EINFACH!

    ich fass es nicht! ^^


    sogar Apps die verseucht sind mit Werbung haben keine mehr !

    Wird mir auch alles im PiHole Webinterface angezeigt jetzt.


    Vielen Dank für eure Hilfe !


    und

    Gute Nacht :sleeping:

    Kann es sein dass ich in den PiVPN Configs auch die IP 192.168.0.X eintragen muss?

    Das hier ist der Debugging log: (pivpn -d)


    Also anfangs habe ich nach der Installation ein Wireguard Profil erstellt:


    Quote

    pivpn -a

    und mit


    Quote

    pivpn -qr

    einen Barcode anzeigen lassen den ich dann mit der Wireguard App scanne


    Damit „sollte“ laut Internet alles eingestellt sein...


    Habe die Profil Einstellungen bearbeitet in der Wireguard App und den DNS geändert wie es WaldiBVB erklärt hat


    Dachte dass das Handy sich dann richtig einwählt


    Irgendwie komm ich nicht wirklich weiter

    Hab mir auch alles selbst erklärt über die ganzen Tutorials

    Also mir fehlt auch einiges an Wissen 😅


    Habt ihr noch eine Idee ?

    so...


    rpi444

    ipforward scheint aktiviert zu sein:


    Quote

    sysctl net.ipv4.ip_forward

    net.ipv4.ip_forward = 1


    WaldiBVB

    habe jetzt in der Wireguard-App den Eintrag unter DNS-Server auf die IP von dem Raspberry 192.168.0.x eingestellt


    Leider funktioniert es immernoch nicht :(


    Ich habe PiHole (mit Unbound) mit Hilfe diesem Tutorial installiert https://www.youtube.com/watch?v=FnFtWsZ8IP0&t

    Liegt es vllt daran, dass ich auf dem PiHole Webinterface den Upstream DNS Server IPv4 auf 127.0.0.1#5335 eingestellt habe ?

    ist bei Minute 11:45 zu sehen


    Also mein Gedanke war dass die Einstellung mit Wireguard eventuell in die Quere kommt.

    Ich bin grad auf der Arbeit aber heute Abend werd ich nochmal alles neu aufspielen und es ausprobieren.



    WaldiBVB

    Soll ich dann die Heimnetzwerk-IP also 192.168.0.X vom Raspberry als DNS eintragen (wie ich es am pc unter den ipv4 einstellungen gemacht habe)?

    Oder die öffentliche ipv4 die man mit dem Befehl ifconfig am raspberry herausfindet?


    Momentan ist 10.6.0.1 eingetragen


    rpi444

    Das werde ich heute Abend nachschauen

    Hallo


    ich habe mir auf meinen Raspberry Pi 3 PiHole + PiVPN (Wireguard) installiert.

    Ich besitze eine feste IP Adresse und habe das auch so in der Installation eingestellt.


    Mein PC kann jetzt über PiHole ohne Werbung surfen.

    Mit meinem iPhone kann ich auch schon auf mein Heimnetzwerk und meinen NAS zugreifen. (was meine Grundintention war)


    Was mich jedoch stört ist dass ich mit dem iPhone bei eingeschaltetem VPN (Wireguard) nicht im Internet surfen kann und PiHole nutzen kann.

    Weswegen ich diesen jedesmal ausschalten muss und den Luxus von PiHole auch nicht unterwegs verwenden kann.


    Leider hab ich mit meiner Konstellation kein passendes Tutorial gefunden.


    Was muss ich am Raspberry tun damit die Verbindung vom Handy durch den VPN auch wieder raus ins Internet kann?


    Ich habe irgendetwas mit IP-Forwarding und Privaten/Öffentlichen Schlüsseln gelesen


    Habe auch schon einiges versucht aber es klappt leider Nichts.


    Ich hoffe ihr könnt mir weiterhelfen ! :conf::helpnew:


    LG