Posts by MarvinTLA

    Moin,


    ich wusste nicht genau wie ich die Überschrift nennen soll.

    Ich habe ein kleines Problem. Ich soll aktuell ein kleines Spiel mit Python TK entwickeln.


    Das Prinzip:

    Man Würfelt 3 Würfel. Das ganze habe ich mit

    rnd1 = random.randint(1, 6)

    rnd2 = random.randint(1, 6)

    rnd3 = random.randint(1, 6)


    gemacht.


    Nun ist es so das man ein Kapital hat. Beim Würfeln wird von dem Kapital 1 Coin abgezogen.
    Vorher kann man sich eine Zahl zwischen 1 und 6 ausdenken.


    Zum Beispiel wähle ich eine "2". Dann Würfel ich 1x und es werden 3 Verschiedene Zahlen angezeigt.
    Für Jede 2 die die Würfel anzeigen, bekomme ich 1 Coin hinzugefügt.

    Also zb. rnd1 zeigt eine 3, rnd2 eine 2 und rnd3 eine 5


    Dann bekomme ich 1 Münze wieder.

    Nun ist es leider so, das ich das mit einem "Button" zum Auszahlen gemacht habe.
    Mein Problem ist nun, das wenn ich die 2 gewählt habe und die 3 Würfel zusammen nur eine 2 anzeigen und ich dann auf den Auszahlen Button Drücke, trotzdem 2 Coins wiederbekomme. Obwohl in den 3 Würfeln nur 1x die "2" gewürfelt wurde.

    Hoffe das ist verständlich.


    Hier einmal der Button für das Würfeln

    Und hier einmal die Funktion zum Auszahlen:


    Hat jemand eine Idee wieso mir trotzdem mehr Coins gegeben werden als es eig sein sollten?



    LG Marvin

    Moin, vielen Dank für die Zahlreichen Antworten.

    Das ganze war ein kleiner Fehler von mir.


    Ich habe in folgender Zeile:

    <a href="upload.php?file=" . <?php $ausgabeDatei ?> type="submit" class="btn btn-info btn-fill pull-right btn-sm">Download</a>&nbsp;

    dies genutzt:

    href="upload.php?file=" . <?php $ausgabeDatei ?> einfach ein echo vor dem $ausgabeDatei und alles funktioniert.





    ~ Marvin

    Ich bin ganz normal mit einem Internet Browser (Windows Betriebssystem) auf den Webserver drauf gegangen. Aber er lädt halt nicht die Datei herunter. Vermutlich weil der Webserver nicht soweit zurück geht (Bis zum /home/ Folder).

    Sorry das der Beitrag nicht mehr vorhanden ist.

    Bei mir hat er das eben nicht abgeschickt, daher habe ich das Thema erneut erstellt.

    Aber wie meinst du das mit Client? Ob ich jetzt mit einem Linux Client auf den Webserver zugreife? Wenn du das meinst, dann nein. Greife ganz normal mit einem Windows Rechner auf den Webserver zu.

    Moin,


    ich habe mir auf meinem Raspberry PI einen Webserver erstellt. Es soll eine Oberfläche sein zum Hochladen und Downloaden von Dateien.

    Es ist so das die Dateien bei mir im /home/ Verzeichnis gespeichert werden. Ich möchte nun gerne das er auch von dort die Dateien wieder herunterlädt.

    Leider lädt er nicht die Datei herunter, sondern was anderes. Mit diesem Festplatten Icon:


    So sieht mein Code aus:


    download.php


    Und so der Download Link:


    hat da jemand eine Idee wie ich die Datei herunterladen kann?

    Es geht hier explizit nur darum, das ich es aus einem Linux Internen Bereich herunterladen möchte.



    Bin über jede Hilfe dankbar!



    Lieben Gruß

    ~ Marvin


    Lieben Gruß

    Danke für den Tipp.


    hab das ganze mal mit dem Befehl net session \\<IP vom Server> /delete /y versucht. Dort kommt dann nur die Meldung "Es gibt keine Sitzung mit diesem Computernamen"


    Hab es mit dem Computernamen auch nochmal versucht. Aber gleicher Fehler. Dann habe ich es mit net session /delete /y gemacht. Hat er auch ausgeführt. Aber viel mehr ist nicht passiert. Kann weiterhin ohne Passwort und Benutzername in den Ordner.


    Dann ist auch noch die Frage, wie mache ich das ganze so das es automatisch geht? Also sobald ich den Ordner wieder schließe.

    Guten Morgen,


    also ich habe eure Beiträge mal durchgelesen. Alles sehr gute Vorschläge. Ich werde mal schauen in wie weit ich das ganze umsetzen kann.

    Jedoch habe ich aktuell noch ein Problem das hyle angesprochen hat.


    Ich habe mehrere Ordner wo nur ein Bestimmter Benutzer oder eine bestimmte Gruppe Zugriff hat. (Eingestellt in der smb.conf).


    Sobald ich den Windows Ordner wieder schließe, kann ich immer wieder erneut rein, ohne den Benutzernamen oder das Passwort eingebe. Gibt es dort eine Möglichkeit das sobald ich den Windows Ordner Schließe und diesen erneut öffne, den Benutzernamen und das Passwort wieder eingeben muss? Aktuell geht das nur wenn ich den Rechner neustarte.

    Ist das dann über Windows?

    Weil es gibt an den PCs / Laptops nur ein Konto. Womit sich alle anmelden können. Daher wollte ich gerne die Mitarbeiter Ordner mit einem Passwort schützen.

    Genau das wollte ich so nicht umsetzen.
    Das ganze ist ein Projekt wo ich halt die jeweiligen Anforderungen habe.


    Und die sind eben so das ich den Ordner "Mitarbeiter" habe und dort drin für jeden Mitarbeiter dann ein Ordner ist.


    Man soll sich halt mit Benutzername und Passwort anmelden können. Gibt ja diese Maske bei Windows wo man ein Benutzername und ein Passwort eingeben kann.




    Gruß

    Guten Tag,


    ich hab mal eine Frage. Ich wollte gerne einen Samba Server bei mir installieren. War soweit auch geklappt hat. Ich habe soweit alles eingerichtet und auch schon die ersten Ordner erstellt. Leider finde ich für mein weiteres Vorhaben keine ideale Lösung.


    Ich wollte gerne Mehrere Ordner mit Unterordner erstellen.



    Das heißt wenn ich bei Windows auf meinen Raspberry PI gehe dort die 3 Ordner "Aufgaben", "Abgaben" und "Mitarbeiter" habe.


    Aufgaben und Abgaben habe ich soweit schon geschafft.



    Nun möchte ich gerne im Ordner "Mitarbeiter" Unterordner erstellen. Für jeden Mitarbeiter einen eigenen. Diese sollen dann Passwort geschützt sein. Für jeden Mitarbeiter dann ein eigenes Passwort, was man dementsprechend vorher festlegen kann.



    Hat da jemand eine Lösung oder eine Anleitung wie ich das umsetzten kann?




    Mit freundlichen Grüßen

    Marvin

    Guten Tag,


    ich wollte mal Fragen ob mir jemand helfen kann.
    Ich wollte gerne mit Python überprüfen ob eine LED über gpiozero ON oder OFF ist.


    Ich bin wohl zu blöd eine Lösung zu finden, da ich Online auch nicht wirklich etwas dazu gefunden habe.



    Hat jemand eine Idee?




    Lieben Gruß

    Danke für die Antwort.

    Habe genau das versucht. Leider ist es so, das der Ordner von dem Sensor erst nach einer gewissen Zeit gelöscht wird. Und wenn der gelöscht ist, zeigt er auch den Fehler an, aber die Temperatur vom anderen Sensor wird trotzdem nicht angezeigt.

    Ja und was genau kann ich damit machen?

    Also wenn der Sensor dran ist, dann zeigt der mir in der Datei natürlich alles an, aber sobald der Sensor getrennt ist, ist diese Datei leer.

    Oder der Order vom Sensor ist erst gar nicht Vorhanden.



    LG

    Wie genau funktioniert das mit dem CRC?
    Weil wie gesagt, meine Idee war es, dass sobald ein Sensor fehlt, der andere normal weiter die Temperatur anzeigt und bei dem wo der Sensor Fehlt dann sowas anzeigt wie "Fehler".

    Hey,

    Erst einmal Vielen Dank.

    Also er zeigt aktuell den Fehler:

    [Mon Jun 21 07:17:13.579672 2021] [php7:notice] [pid 576] [client ***.***.*.***:51591] PHP Notice: Undefined offset: 1 in /var/www/html/laden.php on line 22, referer: http://***.***.*.***/

    Das Zeigt er aber durchgehend an. Sonst weiter zeigt der nichts an.

    Hier 1x meine laden.php (Dient zur automatischen Aktualisierung der Temperatur)


    Kann sonst woanders noch ein Fehler auftreten?

    Habe jetzt geschaut in /var/log/apache2/error.log

    Moin,


    ich habe mal eine Frage. Und zwar bin ich aktuell dabei mittels deine DS1820 Sensor, eine Temperaturüberwachung für einen Pool zu erstellen.

    Die ganzen Werte lasse ich mittels PHP auf einer Webseite ausgeben.

    Das klappt soweit auch alles gut. Nur habe ich ein Probleme / Frage.


    Ich möchte gerne das sobald der Sensor nicht mehr vorhanden sind, das dann eine Fehlermeldung angezeigt wird auf PHP, das dieser Sensor fehlt.

    Dazu sollte man wissen das ich 2 Sensoren habe, das heißt, wenn beispielsweise Sensor1, nicht mehr vorhanden / defekt ist, dass dann nur bei Sensor1 ein Fehler angezeigt wird und aber Sensor2 weiterhin die Temperatur anzeigt.


    Aktuell ist es bei mir so das ich sobald ich einen Sensor wegnehme, der überhaupt nichts mehr anzeigt. Also sensor2 somit auch keine Temperatur mehr anzeigt.

    So sieht mein aktueller Code aus um die Sensoren in PHP einzubinden:

    Code
    $sensor1 = exec('cat /sys/bus/w1/devices/**-************/w1_slave |grep t=');
    $sensor1 = explode('t=',$sensor1);
    $sensor1 = $sensor1[1] / 1000;
    $sensor1 = round($sensor1,1);
    
    $sensor2 = exec('cat /sys/bus/w1/devices/**-************/w1_slave |grep t=');
    $sensor2 = explode('t=',$sensor2);
    $sensor2 = $sensor2[1] / 1000;
    $sensor2 = round($sensor2,1);


    Hat jemand eine Idee wie ich das am besten umsetzen kann?




    Lieben Gruß