Posts by Buzhibi

    Danke für eure vielen Antworten! :)

    Ich werde nochmal einen Neustart wagen. Das mit dem USB-Speicher werde ich mir mal überlegen.

    Klar ist jedoch, dass ich mich als erstes mal um ein Backup kümmern werde. Zum Glück habe ich ja alle meine Dateien.

    Isegrimm_666

    Der Pi war nur aus dem lokalen Netzwerk erreichbar. Mit dem öffnen der Firewall des Routers bin ich sehr vorsichtig.

    Meinst du, ob ich es beim Kauf auf der SD-Karte installiert habe? Ich habe das RaspberryPi Desktop Kit gekauft. Auf der enthaltenen SD-Karte war NOOBS bereits vorinstalliert.

    Hallo liebe Forenteilnehmer,

    Ich habe ein Problem mit meinem Raspberry Pi 4. Ich hoffe, dieses Thema passt in dieses Unterforum, sonst bitte ich um Entschuldigung und es kann natürlich gerne verschoben werden.

    Mein Raspberry Pi lief über ein Jahr lang einwandfrei und wurde hauptsächlich für PiHole und Apache2 verwendet. Als ich neulich den Befehl apt-get update && apt-get upgrade laufen ließ, brach die SSH-Verbindung während dem Vorgang auf einmal ab. Wenige Minuten später habe ich wieder eine Verbindung aufgebaut. Der Pi hat dann sehr lange gebraucht, um auf meine Eingaben zu reagieren. Um zu prüfen, ob es ein Problem gibt, habe ich dann eine auf dem Pi gehostete Webseite aufgerufen. Dort wurde mir eine seltsame, auf mySQL bezogene, PHP-Fehlermeldung angezeigt, die ich noch nie zuvor gesehen hatte. Einen Screenshot habe ich leider nicht, aber sie lautete ungefähr Connection Failed: No such file or directory . Weil mir das sehr seltsam vorkam, entschied ich mich, den Pi mittels sudo reboot neu zu starten und zu schauen was passiert. Leider war es eher nicht das, was ich mir erhofft hatte: Auch nach einiger Zeit reagierte der Pi auf sämtliche Anfragen nicht, weshalb ich Maus, Tastur und Monitor anschloss. Angezeigt wurde das bunte Startbild im wechsel mit For recovery mode, hold shift. Nachdem ich dieser Anweisung gefolgt war, wurde mir das von der Erstinstallation bekannte Menü zum Auswählen der Distribution angezeigt. Ich wählte Raspian aus und mir wurde eine Warnung angezeigt, dass die SD-Karte nun formatiert werde. Das wollte ich natürlich nicht und so brach ich den Vorgang ab. Ich bin einer Anleitung aus dem Netz gefolgt und habe Ext2explore auf meinem Windows8-PC installiert, um die SD Karte auszulesen. Wenn ich damit die Datei 1.img öffne, werden mir nur leere Ordner angezeigt. Wenn ich 3.img öffne, finde ich dort alle meine Dateien vom Pi wieder. Sie scheinen wohlbehalten zu sein. ^^ Ich habe gelesen, dass der boot-Ordner wichtig für den Systemstart sei. Dieser scheint allerdings leider leer zu sein.

    Könnt ihr mir weiterhelfen?

    Ich bin leider noch Anfänger was Linux betrifft, sorry. Falls ich noch weitere Informationen liefern soll, gebt bitte bescheid.

    Danke schonmal!