Posts by picollo

    Beim Pi-System weiß ich jetzt nicht genau, wie man die Partitionen aufteilt (ich kenne das Pi-System zu wenig). Man muss Einträge ändern, damit der Raspi von der am USB Port angeschlossenen SSD/HDD bootet. Eine weitere Daten-Partition ist kein Problem und Linux installiere ich immer mit mehreren Partitionen.
    1. Mach dich mal schlau, wie man ohne Micro SD-Karte von der angeschlossenen und mit dem Pi-System installierten SSD/HDD bootet.
    2. Dann musst du die Systempartition auf der SSD/HDD verkleinern, um Platz für eine neue Daten-Partition zu erzeugen. 32GB müssten dafür reichen. Es ist also noch genügend Platz für viele Daten.

    3. Die neue frei gemachte und leere Partition (nicht die System Partition !) danach mit Geparted einrichten und in ext4 formatieren.

    4. Du bindest dann die neue Partition in /mnt ein.
    3. Die alten /home Daten musst du 1:1 auf die neue Datenpartition nach /mnt kopieren.
    4. Dann ist die /etc/fstab so zu ändern, das die neue Partition mit den Daten unter /home im Systemverzeichnis beim booten gemountet wird.

    5. Danach neu booten ...


    Das ist nur eine grobe Vorgehensweise. Ich würde auf jeden Fall die Micro SD-Karte und die ext. Festplatte vorher sichern bzw. 1:1 kopieren!
    Ein Backup des Systems auf die Datenpartition ist keine gute Lösung. Sichere dein ganzes System inkl. Daten auf eine zweite ext. Festplatte.

    Hallo,

    vielen Dank für die Rückmeldung. Aber es war das 64-Bit System installiert - was nun wieder funktioniert, das Problem habe ich gelöst.

    Der Eintrag Gpu_mem=256 war fehlerhaft und noch weiter unten doppelt drin (im Text oben nicht zu sehen).
    Nach dem ich den Eintrag gpu_mem=256 nach der Sektion [All] verlagert und korrigiert hatte (G -> g) hatte, funktionierte es wieder. Full-HD Videos 1080/60fps mit 51Mbit/sek laufen super geschmeidig über den Dell Monitor mit 1080p/60 Einstellung hdmi_mode=16.


    By the way: gibt es eine Einstellung, um 4K/30fps flüssig auf einen Full-HD Monitor abspielen zu können?

    Hallo,

    leider habe ich meine Konfiguration durch zu schnelles Ausschalten vergurkt, eine Sicherung war auch auf einem alten Stand und die alte /boot/config.txt war auch leider nicht gesichert. Vorher funktionierte die flüssige Wiedergabe auf dem HDMI Monitor mit 1080/60fps.

    Mit Full-HD 30fps ruckelt es nicht. Ich weiß aber genau, das ich vorher 4K Videos mit 30fps flüssig wiedergeben konnte.


    Frage: was muss ich einstellen und ggf. welche Tools benötige ich, damit eine Videowiedergabe in Full-HD 60fps auf dem Rapberry Pi 4B wieder funktioniert?


    Die config.txt:

    Da bist Du mit Deiner Meinung aber ziemlich alleine.


    Servus !

    Ist mir egal. Bei mir funktioniert das unter den kritischsten Situationen (macOS SparseBundles im Netzwerk).
    Meine ext. Festplatten, HDD oder SSD oder USB-Stick benötigen max. 900mA. Wenn die mehr bräuchten, hätte das nicht funktioniert. Dann ist natürlich ein aktives Hub erforderlich und da bin ich außerhalb von mir alleine mit Euch.

    Hallo picollo,


    mir ist natürlich aufgefallen, dass Du Deine Lösung hier in letzter Zeit öfter im Forum zeigst. Ich weiß ehrlich gesagt nicht so recht, wie ich es ausdrüken soll, aber das ist bestenfalls ein Würgaround. Damit bekämpft man ggf. die Wirkung, aber nicht die Ursache. Wenn nicht genug Saft am USB anliegt, dann hilft nur eins und das ist mehr Saft. Die Lösung ist und bleibt ein aktiver USB-Hub. ;)


    Sorry, ich will Dir hier wirklich nicht ans Bein pinkeln! Um es mal salopp auszudrücken.

    Ich habe das schon verstanden. Bin aber der Meinung, das bei zwei ext. Festplatten man kein aktives Hub benötigt. Und für zwei ext. Festplatten ist das kein Würgaround, sondern es funktioniert.

    Falls du ein Problem mit der Stromversorgung hast und die Verbindung zu den Festplatten beim mounten oder auch sonst instabil ist, der Eintrag "program_usb_timeout=1" in der /boot/config.txt sorgt dafür, dass das System statt 2 Sekunden nun 5 Sekunden wartet, bis die USB-Geräte sich vollständig initiiert haben.
    Anscheinend ist beim Start der ext. USB-Festplatten der Strombedarf zu hoch, so das nach der kurzen Initiierung es zu instabilen Zuständen kommt. Der Eintrag oben verhindert das.

    Mit dieser Einstellung kann ich immer zwei ext. USB-Festplatten parallel an die USB 3.0 Ports anschließen, ohne das die von dir beschriebenen Fehler auftreten. Vorher funktionierte das bei mir auch nicht.

    Ich hatte die Festplatten einfach nur mit dem nachfolgenden Befehl gemountet, ohne Angabe von irgendwelchen Parametern:


    Code
    # mount /dev/sda1 /mnt/backup


    Mittlerweile habe ich Open Media Vault installiert und konnte damit zumindest folgende neue Erkenntnisse erreichen:

    • Mit den "alten" Western Digital Elements oder My Passport Festplatten (alle USB3, 2,5 Zoll) mit 1 bis 3 TB Speicherkapazität erreiche ich eine durchschnittliche Übertragungsgeschwindigkeit von ~80-90 MB/s.

    ...

    Ja, diese Übertragungsgeschwindigkeit sollte eigentlich erreicht werden.
    Mein fstab Eintrag ist wie folgt mit UUID Eintrag, da ich am gleichen USB-Port häufig die Festplatten wechsle. Für jede Festplatte habe ich einen definierten fstab Eintrag mit UUID und nofail. Der user_xattr,acl-Eintrag ist nur wegen des Zugriffs vom Mac aus notwendig und hier nicht relevant:

    # WD-2TB

    UUID=aea4a9de-..... /srv/wd2tb auto defaults,nofail,user_xattr,acl 0 2

    Sollte das auch noch nicht reichen, dann versuch es mal zusätzlich mit "max_usb_current=1" in der /boot/config.txt. Das ist eigentlich ein Eintrag für ältere Pi (ich weiß nicht, ob der für die Pi 4B überhaupt noch gilt ... ich habe den bei mir drin gelassen) und erhöht die Begrenzung des verfügbaren Stroms für die USB-Ports von 600mA auf 900mA.

    Falls du ein Problem mit der Stromversorgung hast und die Verbindung zu den Festplatten beim mounten oder auch sonst instabil ist, der Eintrag "program_usb_timeout=1" in der /boot/config.txt sorgt dafür, dass das System etwa 5 Sekunden wartet, bis die USB-Geräte sich vollständig initiiert haben.


    Ich habe mittlerweile zwei USB-Speicher dran (WD Elements und SD-Stick), den Samba Dienst laufen und auf den mit ext4 formatierten Shares einige in HFS+ Journaled formatierte SparseBundle-Images des Mac gespeichert. Das Übertragen bei einem Backup mit Carbon Copy Cloner vom Mac aus auf die Pi erfolgt mit 20-57 MB/sek, im Mittel etwa 30-40 MB/Sek. Hierbei wird das Image permanent auf dem Share vergrößert (kostet auf beiden Rechnern Mac und Pi CPU Last) und die Load Average beträgt etwa 1,35 für die 4 Kerne. Das Ganze läuft bei mir über Stunden stabil. Egal was ich für Festplatten anschließe, normale USB-Festplatten ohne eigene Stromversorgung oder in ICY Box verbaute 2.5" oder 3.5" Festplatten mit Stromversorgung ... alles läuft stabil. Ohne dem Eintrag oben hatte ich nur Probleme und konnte nur max. eine Festplatte anschließen.

    Überprüfe deine Konfiguration. Mit dem Eintrag oben habe ich alle meine "undervoltage" Probleme gelöst, das System nimmt max. 900mA pro USB 3.0 Port.

    Falls du ein Problem mit der Stromversorgung hast und die Verbindung zu den Festplatten beim mounten instabil ist, der Eintrag "program_usb_timeout=1" in der /boot/config.txt sorgt dafür, dass das System etwa 5 Sekunden wartet, bis die USB-Geräte sich vollständig initiiert haben.
    Ansonsten: siehe RTFM, mounten nur via UUID-Eintrag in der /etc/fstab oder eben per Skript. Ein "sudo blkid" zeigt dir die UUIDs der angeschlossenen Festplatten.

    Kleine Ergänzung meiner Recherche zum Anschluss zweier ext. USB-Festplatten an den USB 3.0 Ports:


    Wichtig ist eine Erhöhung der Wartezeit in der /boot/config.txt auf 5 Sekunden, bis die ext. USB-Festplatten hochgedreht sind. Hierzu ist der Parameter

    program_usb_timeout=1

    entscheidend, die Wartezeit wird damit auf von 2 auf 5 Sekunden erhöht. Damit können die ext. Festplatten vom System sicher initiiert und gemountet werden.


    Der Parameter

    max_usb_current=1 ist wohl nicht entscheidend das es funktioniert. Die USB MaxPower liegt bei unveränderten 900mA pro USB-Port.

    Die 8 GB RAM sind als Cache gut zu gebrauchen. Die Übertragung bricht aber auf ca. 40 MB/Sek ein, wenn der Cache voll ist und die Daten dann direkt auf die Festplatten geschrieben werden. Macht sich eigentlich nur beim Befüllen der Festplatten bemerkbar.


    Zumindest reichen die 40 MB/Sek für Videoübertragung z. B. auf SmartTV voll aus. Ich nutze eine PI 4B als NAS für Sicherung, Ablage und Videoabspielung über LAN.

    Nein. max_usb_current funktioniert nur beim Pi A, B und A+, weil da der Strom Standardmäßig auf max. 500 mA begrenzt ist. Ab dem Pi 2B werden ab Werk schon 1200 mA freigegeben.


    FAQs - Raspberry Pi Documentation

    Und da frage ich mich, warum das ohne Parametereintrag nicht funktioniert und nur mit Parametereintrag an meiner Pi 4B funktioniert. Denn diese Parametereinstellungen für die Pi habe ich aus einer anderen Internetseite, wo genau das auch für neue Modell empfohlen wird. Für die PI bis PI2 haben diese Parametereinträge auch eine andere Syntax/Werte.

    Nur so am Rand. Ich (kein Profi) betreibe einen bescheidenen NAS testweise mit Pi4B + Icy Box IB-RD2253-U31 (RAID1) und 2 250 GB SSDs. Im Buster-System ist sowohl Samba als auch NFS konfiguriert. Zuriff auf den NAS erfolgt von Windows 10 und LInux Mint PCs aus. Die Energieversorgung von Pi und Icy Box erfolgt jeweils separat.


    maksimilian

    Das ist die gleiche ICY-Box die ich hab. Bei mir sind nur zwei alte 2.5" 320GB Festplatten von 2008 drin, die in der RAID-0 Kombination am Mac im Schnitt 120MB/sek und an der Pi 4B im Schnitt 89 MB/sek Übertragungsrate schaffen. Das Problem mit der Pi 4B war eine weitere ext. Festplatte anzuschließen und dabei brach das System immer zusammen. Mit den von mir weiter oben (-> #9) genannten Einstellungen für die /boot/config.txt tritt dieser Fehler nicht auf, weil die Spannungsversorgung bei Spitzenlast, durch die ext. Festplatten verursacht, nicht mehr einbricht sondern aufrecht erhalten bleibt.


    maksimilian, welcher Dienst lässt denn schnellere Übertragungsraten zu, NFS oder Samba?

    Jackinho, tolle Info. Das es so was gibt. Klar, der Odroid HC4 sieht für NAS besser geeignet aus.


    An der Pi habe ich jetzt zwei ext. HDD-Boxen parallel zum laufen bekommen. Eine Box mit einer 3.5" HDD und die andere mit 2x 2.5" HDD in RAID-0.


    Ich werde noch mal prüfen, wieviel Strom dabei benötigt wird. Ich denke, es ist nicht ratsam, die Pi dauerhaft mit zwei leistungshungrigen ext. Festplatten parallel angeschlossen als NAS zu betreiben. Aber um mal eine zweite Festplatte anzuschließen und Dateien von A nach B zu kopieren reicht es auf jeden Fall.


    Edit:
    in der Konstellation wie oben beschrieben benötigt die Pi nie mehr als 7,5 Watt (max. 0,7 A), in der Regel unter 6 Watt auch im aktiven Zugriff.