Posts by mindthegap

    Hallo,


    mir wurde hier schon wunderbar geholfen, erst einmal danke dafür!


    ich habe aktuell ein kleines Python Programm das via PIR Sensor eine Bewegung detektiert, dann einen Effekt Sound abspielt und ein LED sequenz dazu abspielt, wird keine Bewegung erkannt gibts eine Athmo und einen andere LED Sequenz.


    Die LED Steuerung habe ich mal rausgenommen, im Prinzip simulieren die LEDS ein Feuergewaber.


    Jetzt bekomme ich nach ca einer Stunden Laufzeit, manchmal auch früher die Fehlermeldung:

    [xcb] Unknown request in queue while dequeuing

    [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called

    [xcb] Aborting, sorry about that.

    python3: ../../src/xcb_io.c:165: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.


    die letzte Ausgabe in der console ist:play fire aktion sound


    den Code habe ich angehängt. es wäre super hilfreich wenn mir jemand sagen könnte in welche Richtung ich hier suchen soll.


    Grüße

    sorry, ich war leider eine Woche in einem Projekt.


    ich habe das autostart öffnen jetzt auf ein lauchner script umgestellt. das führe ich ich mit crontab aus. im prinzip dass ich einfach an ein logfile komme.


    @reboot /bin/sleep 10; sh /home/pi/Brennofen/launcher.sh >/home/pi/logs/cronlog$


    das wesentlich in dem script ist:

    Code
    sudo python3 playAudio_v5.py


    wie bereits gesagt, das geht auch vom Terminal aus. wenn das Script im vron ausgeführt wird, wirft es diese fehlermeldung. ALSA lib cannot find carf. Ich habe eine externe USB Karte an dem Pi, stellt sich die Frage wieso diese bei normalem ausführen des Scripts da ist, via cron aber nicht?




    wenn ich die sound devices abfrage bekomme ich die untenstehenden infos, die sagen mir jetzt nicht so viel. die Frage ist was kann ich dran drehen, wo liegt der Fehler?


    aplay -l

    **** Liste der Hardware-Geräte (PLAYBACK) ****

    Karte 1: Device [USB Audio Device], Gerät 0: USB Audio [USB Audio]

    Sub-Geräte: 1/1

    Sub-Gerät #0: subdevice #0



    und die PWM mit

    aplay -L

    default

    Playback/recording through the PulseAudio sound server

    null

    Discard all samples (playback) or generate zero samples (capture)

    jack

    JACK Audio Connection Kit

    pulse

    PulseAudio Sound Server

    sysdefault:CARD=Device

    USB Audio Device, USB Audio

    Default Audio Device

    front:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    Front speakers

    surround21:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    2.1 Surround output to Front and Subwoofer speakers

    surround40:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    4.0 Surround output to Front and Rear speakers

    surround41:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    4.1 Surround output to Front, Rear and Subwoofer speakers

    surround50:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    5.0 Surround output to Front, Center and Rear speakers

    surround51:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    5.1 Surround output to Front, Center, Rear and Subwoofer speakers

    surround71:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

    iec958:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    IEC958 (S/PDIF) Digital Audio Output

    dmix:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    Direct sample mixing device

    dsnoop:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    Direct sample snooping device

    hw:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    Direct hardware device without any conversions

    plughw:CARD=Device,DEV=0

    USB Audio Device, USB Audio

    Hardware device with all software conversions

    usbstream:CARD=Device

    USB Audio Device

    USB Stream Output

    hallo,


    erstmal ein hallo in die runde, freu mich hier zu sein, auch wenn ich gleich ein Ü50 abbekommen habe. ;)


    Ich habe ein Problem beim Öffnen eines Python-Skripts als Sudo auf Raspberry Pi 4b


    Wenn ich eine .desktop-Datei auf dem Desktop erstelle, kann ich die Datei ausführen:


    Code
    [Desktop-Eintrag]
    Name=Hörspiel
    Typ=Anwendung
    Comment=Einige Kommentare zu Ihrem Programm
    Exec=sudo /usr/bin/python3 /home/pi/myPhythonfile.py



    Jetzt habe ich die gleiche Datei in /home/pi/.config/autostart/chmod +x erstellt, aber die Datei wurde nicht ausgeführt, wenn ich die rpi_ws281x LED-Bibliothek verwende.

    Sobald ich irgendein anderes Script ohne die Library verlinke funzt das wunderbar.


    Ich denke, die Lib verwendet den temporären Ordner, ansonsten wird pygame als GUI interface benutzt.


    Das Script ist jetzt nichts aufregendes, beim Beispielscript der Library passiert tritt das gleiche Problem aus.


    Was kann ich probieren?