Posts by THPI

    Habe jetzt getestet, und es funktioniert. Vielen Dank für den Tip!

    Kann man das auch Serverseitig festlegen? Man kann ja so als Client die *.ovpn Datei anpassen wie man will, und die Vorgabe wieder entfernen.

    Ja, es müsste auch möglich sein, die Routen entsprechend direkt vom Server zu übergeben.

    Allerdings kann der Client das dann trotzdem ändern. So lange du auf dem Client System die Rechte hast das Routing zu ändern, kannst du das auch jederzeit tun. Das kannst du serverseitig nicht unterbinden, da der Server deine Routing Config ja gar nicht kennt und nicht merkt, ob du da was änderst.


    Serverseitig kannst du nur über entsprechende Firewall Regeln filtern, dass der nicht zu viel im VPN darf.
    Was der Client außerhalb des VPN tut kann der Server nicht kontrollieren.

    Ja das geht. Es gibt einen Parameter, der festlegt, ob die Default-Route in den Tunnel gehen soll oder nicht.

    Wenn du den deaktivierst kannst du mit einem weiteren Parameter in der Config die Routen definieren, die in den Tunnel sollen.

    Ich habe die Parameter gerade nicht im Kopf und keine Config zur Hand. Am besten mal in die Doku schauen und sonst kann ich morgen mal in einer Config nachsehen.

    So, es funktioniert einwandfrei! :)


    Folgende Daten habe ich gemessen:


    IBE= 2,4mA

    VCE=0,54V


    Der Transistor lässt ab ca. 1,2V bereits ~54,5mA durch. Bis 3,3V steigt das nur noch sehr langsam auf ~56,5mA an.

    (die Werte sind etwas geringer als "erwartet", weil ich den Spannungswandler bereits auf 10,9V gedrosselt habe, weil mir die LEDs bei 12V zu warm wurden und bei 10,9V die Helligkeit nicht wahrnehmbar geringer ist, die Temperatur aber schon.)


    Vielen Dank an alle, die mir hier geholfen haben, insbesondere an Gnom!


    Ich habe einiges gelernt und werde beim nächsten mal auch die Anforderung noch etwas genauer formulieren.


    Die bestellten Relais werden für die Beleuchtung dann wohl nicht benötigt aber ich habe bereits eine weiteren Idee dafür. Es ist sicher auch nicht verkehrt den Drucker auch vom Pi komplett abschalten zu können. Ich melde mich dann also noch mal, wenn die Relais da sind. Bestellt sind übrigens die, die Fred ganz am Anfang empfohlen hatte.

    Der BC485 tuts auch. Hier solltest du einen 1000 Ohm Basiswiderstand nehmen, weil der Verstärkungsfaktor mit 60 etwas schwach ist.

    Der BC548 kann nur 100 mA - das genügt dir nicht.

    Ok, perfekt, dann hab ich bei dem scheiß Wetter ja was sinnvolles zu tun. ;)


    Es hat sich noch eine kleine Änderung ergeben. Ich würde vor dem 24V/12V Spannungswandler schalten. Also dann ~60mA/24V statt 120mA/12V. Das sollte mit dem BC485 und 1K Widerstand, dann ja auch funktionieren, oder?


    Und noch eine Frage zum Testen. Mein Labornetzteil kann nur max. 12V. Das heißt ich muss das Netzteil des Druckers für die Spannungsversorgung der LEDs nehmen und würde dann die 3,3V mit dem Labornetzteil für den ersten Test erzeugen, bevor ich den Pi anbinde.
    Wie mache ich das mit den 2 Netzteilen? Kann ich V-/GND der beiden Netzteile für den Test einfach verbinden?

    Ein BC337 ist so ein Standardteil, das hier genügt. Verstärkungsfaktor über 100. Mit einem Basiswiderstand von 1000 - 2700 Ohm sollte das gehen.

    Ich habe gerade noch 2 Transistoren im Keller gefunden mit gleicher Bauart. Wäre eventuell einer davon auch tauglich dafür?


    BC485

    BC548A (Ic scheint hier zu knapp zu sein, wenn ich das richtig deute?)

    Du willst 12 V / 120 mA schalten? Warum nimmst du dafür nicht einfach einen Transistor?

    Weil mir wohl irgendwie nicht klar war, dass das auch eine Option wäre. ;)

    Ich habe mir jetzt mal ein paar Artikel/Videos zu Transistoren angeschaut. Wie das grundsätzlich funktioniert habe ich also wohl nun verstanden. Und ich brauche wohl einen NPN Transistor + einen Widerstand am Base Pin zum Pi, den ich entsprechend des ausgewählten Transistors berechnen kann.

    Aber wie wähle ich denn nun den passenden Transistor aus? Verstärkungsfaktor sollte wohl so um ~100 liegen? Aber es gibt ja zig verschiedene Transistoren. Was nehme ich denn da? Könnt ihr mir ein konkretes Bauteil empfehlen?

    Vielen Dank für die vielen Antworten!

    Es gibt zahlreiche unterschiedliche Verschaltungen für Relaismodule. Ich vermute, dass es sich hier um die Form handelt, bei der du zwischen active low (es liegen 24 Volt an, die über den Input gegen GND geschaltet werden) und active high (der Input liegt gegen GND und du kannst 3,3 V vom Pi drauf schalten) umgeswitcht werden kann. Wenn du das Modul richtig anschließt, sollte es gehen. Wenn du es falsch machst, dürfen wir dir zu einem neuen Pi gratulieren.

    Soweit ich das auf den Bildern erkennen kann, fehlt der Jumper bei dem 1-Kanal-Modul und ist erst ab 2-Kanal Modul verbaut. Ich brauche allerdings ein kompaktes 1er Modul.


    Mal was ganz grundsätzliches zum Relais-Betrieb durch den Raspberry:

    Mit dem GPIO-Pins kannst du keine Relaispule direkt ansteuern, auch nicht wenn die Spule an der einen Seite an ihrer Versorgungsspannung (5, 12, 24V) hängt und du ja "nur" die andere Seite der Spule nach Masse schalten willst

    Das hast du falsch verstanden. Ich bin davon ausgegangen, dass das Relais-Modul die 3.3V gegen den GND des Relais-Moduls schaltet. (daher auch meine Frage bezüglich der 24V, als ich verstanden habe, dass es anders rum ist. (s.o.)

    schau mal hier - mit dem Teil kommst du weiter, das Ding läuft sofort am Pi.

    Die Anforderung mit der Versorgung über 24V kann das Modul schon mal nicht abbilden. Was unterscheidet dieses Modul von dem 5V China Modul?

    Jetzt noch ein Hinweis: Die Schaltkontakte der China-Relais sind nicht die Besten. Die neigen auch bei geringen geschalteten Strömen zu Kleben. Je nach geschalteter Last must du geeignete Maßnahmen zur sogenannten Funkenlöschung ergreifen.

    Es geht um ca. 120mA bei 12Volt. Das sollte bei den angegebenen 10A bei 230V ja eher nicht das Problem sein.


    Allerdings hätte ich zu dem "Kleben" noch mal eine Frage, auch wenn diese etwas off-topic ist. Ich war zunächst davon ausgegangen, dass ich über die GPIO Pins direkt ein Relais schalten kann und ~20mA Schaltspannung kein Problem wären. (ja, ich hätte mal vorher recherchieren sollen und wurde eines besseren belehrt. Zum Glück scheinbar ohne Schäden am Pi.) Ich hatte mir dafür ein Zettler Electronics AZ9571-1C-3DSE Printrelais gekauft. Nachdem ich verwundert war, warum es am Pi nicht funktionierte habe ich es an einem Labor-Netzteil getestet. Zunächst hat es wie erwartet geschaltet. Nachdem ich es dann aber für 10-20-Minuten eingeschaltet gelassen habe, schaltet es nicht mehr aus. Laut Datenblatt hat es einen Schaltstrom von 1A und wir reden über 120mA bei nur 12V. Gibt es dafür eine logische Erklärung?


    Noch ein Nachtrag:

    Wenn du die 24V Versorgungsspannung deines zu schaltenden Verbrauchers heranziehen willst, um dein Relais zu versorgen, dann kannst du das Gerät nicht einfach über die Relaiskontakte ausschalten, denn dann fehlen die die 24V um das Relais fürs spätere Einschalten zu versorgen.

    Unterbrichst du aber die 24V deines Gerätes zwischen Netzteil und Geräteelektronik, dann kann das Netzteil eventuell Schaden nehmen, wenn es zu lange ohne Last betrieben wird. Einfache Netzteile in Geräten sin häufig nicht auf eine lange Leerlaufzeit eingerichtet.

    Wenn ich die Stromversorgung ausschalte, habe ich keinen Strom mehr. Ja, das ist mir schon klar! ^^

    Das war aber auch nicht der Plan. Aber das kannst du ja nicht wissen und es kann ja nicht schaden das Ziel mal zu beschreiben. ;)

    Es geht um einen 3D-Drucker mit einem (Octo-)Pi für die Steuerung. Das Drucker Netzteil bietet nur 24V an und ich würde da Relais gerne ich das Gehäuse des Netzteils einbauen. Das Relais ist dafür gedacht eine Beleuchtung des Druckers einzuschalten. Ich schalte mir also nicht das eigenes Netzteil aus und dieses ist auch nicht unbelastet, wenn das Relais aus ist. Der Pi wird ebenfalls über das Netzteil versorgt. (über ein LM2596S im Pi)

    Da du 24 Volt bereits im Gerät verfügbar hast, ist es nachvollzeihbar, dass du dieses Modul in der 24-Volt-Ausführung benutzen willst. Ich nehme nach allem, was ich erkennen kann an, dass das Modul dafür auch geeignet ist. Du solltest dir die Beschaltung aber genau ansehen und nachvollziehen, ob das auch wirklich klappt. Wie gesagt, es gibt viele verschiedene Beschaltungen. Nicht, dass es da dann eine Überraschung gibt.


    Möglicherweise ist es aber einfacher, du nimmst ein 5V-Relaimodul und versorgst es vom Pi aus.

    Ich hab mal ein 5V und ein 24V Modul bestellt. Ich schaue sie mir mal genauer an, wenn sie denn dann in 2-3 Wochen ankommen und werde euch dann eventuell noch mal mit Fragen zu dem 24V Modul löchern und kann dann aber wohl auch mehr Infos dazu liefern.

    Ansonsten verbaue ich das 5V Modul und muss halt ein paar mehr Kabel verlegen als geplant. ;)

    Okay, dann habe ich das wohl schon mal falsch verstanden. Das Relais ist dann bei 3,3V am GPIO also aus und zieht bei 0V am GPIO an?

    Die 24V wären für den GPIO bei deinem verlinkten Modul dann kein Problem?


    Angenommen ich würde statt der 24V doch das Modul vom Pi mit Spannung versorgen, wäre dann ein 3,3V Module oder ein 5V Modul sinnvoller?
    Die 3,3V Module werden extra für den Pi angepriesen aber der Pi kann doch bei 3,3V nur sehr wenige mA liefern. Somit sind diese Module doch eigentlich Quatsch und 5V wäre sinnvoller, da der Pi hier viel mehr liefern kann bzw. ich das Modul dann direkt vom Netzteil versorgen kann?

    Vielen Dank für deine schnelle Antwort!


    Irgendwie habe ich wohl noch nicht ganz verstanden wie diese Module aufgebaut sind.

    Ich hatte jetzt erwartet, dass sich VDC+ sich auf die Spule bezieht und INPUT die Trigger Spannung (vom Pi) einfach gegen Masse schaltet, um die Spule auszulösen?


    Hättest du sonst eine konkrete Empfehlung für ein geeignetes Modul?

    Danke für eure Antworten.


    Also muss ich nur darauf achten, dass das Relais per Optokoppler geschaltet wird und dann reichen die 3,3V?


    Ich habe noch kein Modul ausgewählt aber die, die ich mir angeschaut hatte waren im Prinzip alle ähnlich aufgebaut wie von fred0815 verlinkt.

    Bei dem Modul aus dem Link steht aber was von "Current: greater than 100mA". Das wäre für den Pi doch viel zu viel oder auf was bezieht sich das?

    Die die ich gesehen hatte, hatten einen Schaltstrom ~5mA


    Ich dachte an so was hier (24V): https://www.aliexpress.com/item/1005003157661296.html

    Hi,


    ich möchte gerne ein externes Gerät mit dem Pi ein-/ausschalten. Dieses Gerät hat ein 24V Netzteil und ich würde gerne das Relais in dieses Gerät einbauen, dort mit Spannung vom Gerät versorgen und vom Pi nur die GPIO Verbindung an den Input-PIN hängen, um es zu schalten.

    Nun habe ich gesehen, dass es ein 3,3V 5V 12V und 24V Module gibt. Mir ist aber nicht klar, auf was sich die Spannung bezieht. Nur auch die Betriebsspannung zur Versorgung des Moduls oder ist das auch relevant für den INPUT/GPIO PIN?

    Also könnte ich einfach ein 24V Modul nehmen? Reichen dann die 3,3V vom Pi für den Input Pin? Oder brauche ich zum schalten dann auch ~24V?


    Ist für euch wahrscheinlich eine einfache Frage aber irgendwie kann ich sie mir trotz ewiger Recherche im Netz nicht beantworten...


    Vielen Dank schon mal für eure Hilfe! :)