Posts by DistroEx

    Das sind ja (... was den Inhalt betrifft) zwei _verschiedene_ cmdline.txt-Dateien. Wie ist das mit bookworm? ... werden beide benutzt oder sollte die /boot/cmdline.txt nur ein symlink auf die /boot/firmware/cmdline.txt sein?

    Das sollte ein symlink sein, hatte mich beim Nachlesen auch gewundert. Zum Vergleich:

    Code
    moi@bookberry:~ $ ls -la /boot/firmware/cmdline.txt
    -rwxr-xr-x 1 root root 176 Nov  5 23:11 /boot/firmware/cmdline.txt
    moi@bookberry:~ $ ls -la /boot/cmdline.txt
    lrwxrwxrwx 1 root root 20 Oct 10 05:39 /boot/cmdline.txt -> firmware/cmdline.txt
    moi@bookberry:~ $ cat /boot/cmdline.txt 
    console=serial0,115200 console=tty1 root=PARTUUID=5b576c95-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles cfg80211.ieee80211_regdom=DE

    Der ...regdom=DE-Eintrag ist per Installation da, zumindestens habe auch ich den nicht bewusst eingetragen.

    Hat das evtl. damit was zu tun, dass debian das 32bit, angeblich einstellen will? ... und das dann nicht nur für i386, sondern auch für arm?

    Keine Ahnung. Ich habe gerade statt mit 32bit die 64bit-Version gestartet, da habe ich auch das Update. Die /etc/apt/sources.list ist auch länger, unter 32 bit nur eine Quelle, unter 64bit 3, mit debian-security dabei.

    Diese Version:

    Code
    bookworm (security)    1:9.2p1-2+deb12u2    fixed

    ist in bookworm gefixt.

    Poste mal aus bookworm, nach einem "sudo apt update", die Ausgabe von:

    Code
    apt policy ssh openssh-server

    PRETTY_NAME="Debian GNU/Linux 12 (bookworm)"

    Da xrandr bei Dir nicht mehr geht wird vermutlich Wayland benutzt. Kannst Du feststellen mit echo $XDG_SESSION_TYPE. Wenn die Ausgabe wayland ist sieh Dir mal wlr-randr an. Siehe zum Beispiel hier. Ich kann das momentan nicht ausprobieren weil ich ohne Monitor per VNC verbunden bin.

    Edit: für den Fall dass Du den Monitor nicht wieder eingeschaltet bekommst sicherstellen das es eine Zugriffsmöglichkeit auf den Raspi gibt, z.B. per ssh.

    Wenn im rpi-imager ein WLAN vorkonfiguriert wird, darf anscheinend der RPI beim ersten Boot nicht mit dem LAN verbunden sein.

    Denn sonst wird die initiale WLAN-Konfiguration nicht persistent gespeichert... :wallbash:

    Scheint für die 1.8.3 des Imagers immer noch zuzutreffen. Hatte hier bei einer Testinstallation von bookworm 32bit gar nicht darauf geachtet, gerade nachgesehen und kein WLAN vorhanden, es werden gar keine WLAN-Verbindungen angezeigt, und ip a zeigt kein WLAN. Aaaber: oben nach Klick auf das Netzwerksysmbol unter Advanced Options Edit Connections aufgerufen

    Es liegt schon eine Wireless-Verbindung namens preconfigured da, die habe ich noch bearbeitet (angewählt und unten auf das Zahnrad) und die Priorität hochgesetzt auf 5 (unter General). Das wäre natürlich auch mit nmcli gegangen, zu faul nachzusehen. Danach Reboot und ich bin mit meinem WLAN verbunden.

    Kannst Du Dich noch erinnern, ob Du damals nach Dateien unter /etc/NetworkManager/system-connections/ geschaut hattest?

    oje - das wird schwierig. aber der Hinweis, das WIN (oder die Fritz.Box...?) das ssh blockiert könnte tatsächlich sein:

    - mein WIFI-Drucker "spinnt" seit ein paar Tagen

    In Deinem ersten Post ist ein Bild der Ausgabe von raspiNetInfo.sh, nach der sind in wpa_supplicant.conf zwei WLANs konfiguriert, warum?

    In welchem davon ist der RPi 2 B?

    Und könntest Du den Raspi nicht auch einmal per LAN anschließen?

    Wenn ich deinen 2. Screenshot anschaue, hast du den Pi mit der SD/SSD gebootet? Das sieht mir so aus, als hättest du direkt nach dem flashen nachgeschaut.

    Die Einstellungen werden erst beim 1. Booten gesetzt/angepasst.

    Nach dem Brennen am besten mal unter /boot nachsehen. Dort sollte eine firstrun.sh angelegt worden sein, die enthält die benutzerdefinierten Anpassungen, die dann beim ersten Start ins System übernommen werden.

    Welche HW Platform und welches Image hast Du genutzt?

    RPi 4 B mit 4GB, Bookworm 32bit mit Desktop.

    Code
    moi@bookworm32:~ $ cat /boot/issue.txt 
    Raspberry Pi reference 2023-12-05
    Generated using pi-gen, https://github.com/RPi-Distro/pi-gen, 02b371de1a87bbe70cfcbd498527067a7d2ee6ca, stage4

    Ist aber auch schon ein sehr spezielles Szenario was Du getestest hast. Aber Du bestaetigst ja beim Loeschen dass Du ein Backup hast

    Backup ist in dem Fall das Image bei der Foundation. ;)

    raspiHandleKernels.sh funktioniert hier.

    Aber wenn ich auf einem frischen Bookworm 32bit die überflüssigen Kernel entfernen lasse

    Code
    moi@bookworm32:~ $ ./raspiHandleKernels.sh -u -e
    --- Following kernel will be kept
    linux-image-6.1.0-rpi7-rpi-v8
    --- Following unused kernels will be deleted
    linux-image-6.1.0-rpi7-rpi-v6
    linux-image-6.1.0-rpi7-rpi-v7
    linux-image-6.1.0-rpi7-rpi-v7l
    [...]

    und anschließend arm_64bit=0 in die config.txt schreibe bekomme ich nach reboot :

    Code
    moi@bookworm32:~ $ uname -a
    Linux bookworm32 6.1.0-rpi7-rpi-v7l #1 SMP Raspbian 1:6.1.63-1+rpt1 (2023-11-24) armv7l GNU/Linux
    moi@bookworm32:~ $ ls -al /boot
    [...]
    -rw-r--r--  1 root root 16094955 Dec  5 02:33 initrd.img-6.1.0-rpi7-rpi-v8
    [...]
    -rw-r--r--  1 root root       83 Nov 24 17:11 System.map-6.1.0-rpi7-rpi-v8
    -rw-r--r--  1 root root  8760390 Nov 24 17:11 vmlinuz-6.1.0-rpi7-rpi-v8

    In /boot/firmware liegen noch Kernel:

    Code
    -rwxr-xr-x 1 root root  7023344 Dec  5 02:33  kernel7.img
    -rwxr-xr-x 1 root root  7464952 Dec  5 02:33  kernel7l.img
    -rwxr-xr-x 1 root root  8760390 Dec  5 02:33  kernel8.img
    -rwxr-xr-x 1 root root  6694832 Dec  5 02:33  kernel.img

    Sonst hätte ich auch nicht rebooten können, oder?

    Jetzt wird vom Skript angeboten den letzten Kernel zu entfernen: ;)

    Code
    moi@bookworm32:~ $ ./raspiHandleKernels.sh -u
    --- Following kernel will be kept
    
    --- Following unused kernels will be deleted
    linux-image-6.1.0-rpi7-rpi-v8
    moi@bookworm32:~ $ 

    Moment mal. Ich glaube da war die Tage mal was mit irgendwelchen Workarounds in den Browsereinstellungen hier im Forum. :conf: Kann auch sein, dass der Grund ein anderer war.

    Der Beitrag von mir und vor allem die darauf folgenden von Outlaw und Dietmar_43.

    Das Problem mit der verzerrten Anzeige betrifft übrigens nicht nur die beiden Browser, sondern auch alle vorinstallierten Spiele.