Posts by Polle1987

    "Warum Du 36 einzelne Dateien verarbeiten können musst, wo es auch mit einer einzigen viel schneller gehen sollte, ist für mich nicht nachvollziehbar."

    Es ist für meine Zwecke so einfach am besten.

    "Ich habe 2018/19 mal ein Reinraum-Monitoring-Programm geschrieben...."

    Eine solche Lösung ist für mich einfach außerhalb meiner Möglichkeiten und Kenntnisse.

    Mir persönlich es primär um die Erhebung und Aufzeichnung der Messdaten, da ich diese in Bauphysikalische Situationen einfließen lassen kann und werde.

    Die Node-Red Geschichte ist eine reine "gemeinnützige Nebensache" für die Gemeinde, weshalb auch keine Ressourcen für gelernte Programierer zur Verfügung stehen, die sich hier "mal schnell" was schreiben können und das Thema wahrscheinlich in einer Woche erledigt hätten.

    "würde ich die problematische Software komplett deinstallieren und die Daten auf sinnvolle Weise begegnen."

    ich hab noch keine bessere Möglichkeit gefunden. Ich bin für jeden Vorschlag offen

    Wie hast Du das festgestellt?

    Siehe: RE: VNC-Verbindung plötzlich schlecht bis unmölich

    Die gleichen Symptome hat der Pi schon einmal bei CPU-Temperaturen ab 65-70°C gezeigt (Ich hab die CPU- und Gehäuse-Temperatur mit Node-Red geloggt).
    Nach dem Einbau von Lüftern hat sich das Problem gelegt. Aber jetzt bei den hohen Außentemperaturen taucht das Problem wieder auf und bleibt auch dauerhaft bestehen. Auch das Abschalten für mehrere Stunden (zum abkühlen) hilft nicht mehr.

    Er verhält sich jetzt immer, wie bei >70°C CPU-Temperatur, obwohl die tatsächliche Temperatur 50°C oder weniger beträgt.

    Hallo,

    ich verwende momentan in einer Messstation die Sensoren von Tinkerforge mit Brick Viewer/Logger parallel Node-Red zur Visualisierung auf einem Dashboard.
    Und gleich vorne weg - ich bin kein Programmierer und nicht sehr talentiert, was das Thema an geht. "Try and Error" ist aktuell noch mein Erfolgsrezept.

    Momentan gehe ich den Umweg, die Daten via Brick-Viewer und Logger die Messdaten in eine csv-Datei zu speichern und in Node-Red lese ich die csv-Datail mit einem "Tail-Node" ein, um die Messwerte in das Dashboard zu bekommen. (Ich benötige die Messdaten zur Weiterverarbeitung auch primär in einer csv-Datei)

    Der Nachteil an der ganzen Geschichte ist, das es sich insgesamt um 36 unterschiedliche csv-Dateien handelt, die Note-Red permanent einlesen muss.

    Node-Red und der Pi kommen aber mit dem hohen Datenstrom nicht mehr zurecht. Insbesondere nicht, wenn es um Diagramme mit den Werten der letzten Tage, Wochen und Monate geht.

    Mir sind sehr wohl die "Tinkerforge-Nodes" bekannt, mit welchen es wahrscheinlich besser funktionieren würde.

    Jedoch komme ich mit den Anleitungen von Tinkerforge auf deren Homepage (unter "Doku") einfach nicht weiter. Teilweise sind die Anleitungen veraltet und Installations-Pakete nicht mehr erhältlich.

    Andere Anleitungen sind nicht zu finden. Auch nach Umsetzung sämtlicher Anleitungen von Tinkerforge erhalte ich keine Verbindung zu den Notes. Statt dessen, stürtzt Node-Red komplett ab und lässt sich auch nie wieder hochfahren. Am Schluss hilft nur noch eine komplette Neu-Installation des Pi.

    Kann jemand eine komplette Schritt-für-Schritt Anleitung von A bis Z zur Verfügung stellen, wie die Thinkerforge Sensoren unter Node-Red verwendet werden können? Ausgegangen von einem "frischen" Raspberry Pi auf dem, auf dem nur das Betriebssystem und Node-Red installiert ist.

    Ich versuche es nun schon seit November 2021 und bekomme es alleine einfach nicht hin!

    Hallo,

    gibt es eine Möglichkeit die CPU-Temperatur in MotionEye anzeigen zu lassen, zu überwachen oder auszulesen (via Node-Red auf einen externen Gerät)?
    Ein Rasberry Pi in meiner Messstation ist diese Woche wohl den "Hitzetod" gestorben. An der Messstation befindet sich auch eine Wetterkamera mit einem zweiten Pi auf dem MotionEye läuft und ich würde gerne vermeiden, dass ihm das gleiche Schicksal ereilt...

    Hallo,

    ich nutze nun schon seit mehreren Monaten einen Raspberry Pi 4 in einen Messstation. Der Pi ist an einer LTE FritzBox angeschlossen, die wiederum via VPN mit meinem Heimnetzwerk verbunden ist.

    Bis vor kurzen funktionierte der Zugriff auf den Pi via VNC Viewer tadellos. Seit nun 4 Tagen jedoch aus heiteren Himmel nicht mehr.
    Von 10 Versuchen scheitert (gefühlt) 9mal der Verbindungsaufbau oder der Bildschirm bleibt schwarz. Wenn der Verbindungsaufbau geklappt hat, ist der Pi extrem langsam und es dauert teilweise 5 Minuten, um z.B. den Explorer zu öffnen. Zwischen durch läuft mal für ein oder zwei Minuten alles Flüssig und dann wird wieder alles extrem langsam oder die Verbindung bricht gar ganz ab.

    Auf dem Pi läuft auch Node-Red. Hier klappt der Zugriff via Browser ganz normal und störungsfrei. Auch das Dashboard läuft flüssig.

    Auf einem zweiter Pi in der Messstation läuft MotionEye und dieser ist auch einwandfrei zu erreichen, weshalb ich nicht denke, dass es etwas mit der FritzBox oder der VPN-Verbindung zu tun hat.

    Meine erste Vermutung war, das es sich um ein Temperatur-Problem handelt. Doch auch nach dem Einbau von nun mehr drei Lüftern (zwei auf den Pi und einer für das Gehäuse) tritt das Problem weiter auf. Auch in der Nacht, wenn es kühl ist, bleibt das Problem bestehen.
    Mit Note-Red lese ich auch die CPU-Temperatur aus. Der Maximal-Wert liegt bei ca. 60°C.

    Das Problem besteht übrigens auch, wenn ich zur Messstation fahre und mich dort direkt mit dem Netzwerk verbinde.