Posts by MaKin

    Hat jetzt geklappt. Es lag an der Verkabelung bzw. der Stromversorgung. Vielen lieben Dank für eure Hilfe! Jedoch nutze ich an diesem IO-Terminal keinen Widerstand (ist einer verbaut) und es funktioniert.


    Könnt ihr mir verraten, wofür der Pull-Up Widerstand benötigt wird (in meinem Szenario)? Geht am Arduino ja auch ohne. :-)


    Würde mich nämlich auch gerne mal am Raspberry Pi Zero versuchen (ohne Display-Terminal) und dafür das Original Case verwenden - ohne Breadboard.


    Und könnt ihr mir erklären wofür diese IO-Boards überhaupt eingesetzt werden? Kam auch nicht wirklich dahinter was es mit I2C auf sich hat. Siehe dieses Terminal Breakout Board für I2C. Ich bin leider überwältigt von der Informationsflut. :(

    Quote

    Vielleicht reicht es ja auch, den Eingang per pull up auf 3,3V zu legen und über den Schalter auf Masse.

    Kannst Du mir sagen, wie ich hierzu vorgehen sollte? Würde ich dies programmatisch im System ändern?


    Ich würde gleich Mal unseren Elektriker befragen bzgl. des potentialfreien Kontaktes. Der COM Port sollte also mit 3,3V versorgt werden, damit er reagieren kann (weil der Pi mit 3,3V arbeitet?), was ist wenn es mehr wären?


    Nochmals vielen Dank lieber STF!

    Bitte entschuldige, dass ich mich so blöd anstelle, nur sind meine Kenntnisse was Elektrotechnik angeht (noch) extrem beschränkt. Ich würde gerne das Board an einen potentialfreien Kontakt einer Maschine (bzw. eines Impulsgebers der Maschine) anschließen, damit ich die Impulse tracken kann. Ohne das Aufsteckboard ließ sich das relativ simpel simulieren durch das Verbinden von GPIO-Pin und GND. Das war im Grunde hinterher auch genau das, wie es an den potentialfreien Kontakt angeschlossen wurde. Nun mit dem Aufsteckboard, weiß ich nicht wie ich dies zu bewerkstelligen habe. Wenn ich hier einen der INPUT Ports (z.B. 4 -> GPIO4?) mit GND verbinde, wird kein Signal empfangen (also kein Impuls generiert/simuliert).


    Grüße und vielen herzlichen Dank,

    MaKin

    Alles klar, das dachte ich mir schon. :-)


    Wir haben hier eine Art Terminal Touchscreen mit integriertem Raspberry (Clone) geholt. Siehe hier.

    Kannst Du mir sagen, ob es eine Möglichkeit gibt einen der unteren Anschlüsse (RS232C - COM1/2 oder I2C1) für meine Anwendung zu nutzen? Hier könnte ich nämlich Drähte an den Schraubklemmen befestigen statt Aufsteck-Pins zu verwenden.


    Oder gibt es eine kostengünstige und elegante Art eine sichere Kabelbefestigung am 40-PIN Terminal auf der Rückseite vorzunehmen?


    Vielen Dank dafür, dass du dir die Zeit nimmst.

    Hallo zusammen,


    ich habe folgendes (Verständnis-) Problem:


    Gerne würde ich den Raspberry Pi einsetzen um bei uns in der Produktion die produzierten Teile einer Maschine zu tracken. Bisher habe ich das mit einem NodeMCU gemacht, der an einen potentialfreien Kontakt angeschlossen wurde. Also ganz simpel GPIO + GND an den Kontakt des Impulsgebers und jedes Mal wenn der Stromkreis geschlossen wurde, wird ein Teil produziert. Mit etwas Debouncing lies sich auch das Rauschen gut entfernen.


    Simulieren kann man das logischerweise mit einem Kabel, dass den GPIO Pin sowie GND verbindet - bei jeder Berührung wird der Kreis geschlossen und ein Teil "produziert".


    Nun wollte ich auf den Raspberry umsteigen, da ich hier einfacher mit der Datenverarbeitung sowie -speicherung umgehen kann.


    Jedoch ist es nun so, dass sobald mein Draht (oder Büroklammer, ummantelt oder nicht) den GPIO Pin berührt, bereits das Signal aufgenommen wird. Dadurch kann ich mit der Konstruktion leider nichts anfangen. Getestet habe ich es mit den pigpio sowie onoff node packages (da ich Javascript bevorzuge).


    Habt ihr irgendeine Idee woran das liegen könnte? :(

    Hallo zusammen,


    ich bin gerade dabei einen Baby Monitor zu basteln und habe mir deshalb für meinen dafür vorgesehenen Pi 3 ein V2 NoIR Kamera Modul gekauft. Nun suche ich noch die passenden IR LEDs.


    Ausgeleuchtet soll das Babybett aus einer Entfernung von 2 - 2.5m werden. Könnt ihr mir etwa empfehlen? Gerne würde ich eine zusätzliche Stromversorgung meiden. Dachte an 2 LEDs, die ich neben der Kamera im Originalcase unterbringe.


    Ich weiß, dass es ein paar Threads unter diesem bereits eine ähnliche Anfrage gibt. Ich wollte jedoch nicht einen alten Thread von 2015 ausgraben und kapern. Man sehe es mir bitte nach. :)


    Besten Dank

    Hat jemand das Problem mit dem Flackern bei 100 LEDs lösen können? Mir ist folgendes aufgefallen:



    Wenn das Bild von grün auf rot wechselt, dann dauert es etwa 8 Sekunden bis die untere LED Reihe rot wird und dann auch bleibt, dann einige Sekunden später werden auch die seitlichen LEDs rot und die oberen beruhigen sich auch nach 30 Sekunden noch immer nicht.


    Es kann doch nicht sein, dass die Funktionalität bei 50 gewährleistet ist und bei 100 nicht. Aber wie ihr beschreibt, funktioniert die Boblight-Config, vom Pi losgelöst, wunderbar?


    Ist wirklich schade, da bei ambi-tv einige geflackert haben und ich bei schwarzem Bild die LEDs nicht ausgekommen habe. Aber hier ist auch irgendwo der Wurm drin.


    EDIT: Mit der Config für 50LEDs flackert es bei mir trotzdem. Also angeschlossen sind 100 LEDs aber die Config auf 50 eingestellt. Dann flackern die 50LEDs und die anderen 50 (rechte Seite) sind alle aus.

    Achtung. Bitte den Strang am raspberry so verbinden wie im Tutorial angegeben. Ich wollte nur verdeutlichen mit dem Bild wie es aussieht wenn beide Enden des Stranges "genutzt" werden um Pi und Netzteil zu verbinden.

    Im Tutorial ist es so beschrieben, dass an einem Ende des Strangs sowohl der raspberryPi als AUCH das Netzteil angeschlossen wird, richtig? Das führte bei mir dazu, dass eben nur die erste LED in blau leuchtete. Wenn ich nun jedoch das Netzteil am anderen Ende angeschlossen hatte, so funktionierte es einwandfrei.


    Siehe folgendes Bild (Danke an Harald Langer an dieser Stelle):


    [Blocked Image: http://harald-langer.com/wp-content/uploads/2013/01/anschlussarduino.png]


    Nun denke dir eben den Arduino weg und stelle dir stattdessen den RaspberryPi vor. So hat es bei mir funktioniert mit dem einen LED-Strang, der andere funktionierte wiederum nur so wie es in hier im Tutorial beschrieben wird (beides an einem Ende).




    LG MaKin

    Ich klinke mich auch noch kurz ein. Bei mir hat es nicht funktioniert, wenn alles auf einer Seite des Strangs angeschlossen war. Bzw. bei einem LED Strang hat es funktioniert, bei einem anderen (andere Bestellung bei einem anderen Händler) hat es nicht funktioniert und es leuchtete nur die erste LED, obwohl es eigentlich gehen müsste. Also am besten testen bevor man fälschlicherweise (wie ich zuerst) den Strang für kaputt hält. :lol:

    Habe adalight auf arduino mit MacBook und ambitv mit rPi verglichen. Das ambitv arbeitet viel schneller. Leuchten die LEDs bei euch auch bei schwarzem Bild? Bei mir alle bläulich leicht, sonst jedoch korrekt!


    Bei Adalight müsste man die minBrightness runtersetzen, dann würde auch das flackern weniger werden/aufhören. Gibt es beim ambitv ebenfalls eine solche Möglichkeit?


    Hatte jemand hier adalight mit Processing am laufen und kann was zur Performance berichten?

    Kann mir jemand dabei helfen zu verstehen wie der WS2801 LED Strang mit dem rPi verbunden und alles richtig gelötet wird? Ich habe ein Netzteil und einen Stecker für das Netzteil, so dass ich es nicht zerschneiden muss. Der rPi müsste bald eintreffen und ich möchte vorbereitet sein. :-)


    Der Stecker: http://www.watterott.com/de/Fe…k-to-screw-terminal-block


    Da ich leider noch keine Erfahrung mit dem Lötkolben und den rPi noch nicht vor mir liegen habe, erscheint es mir unheimlich schwierig zu verstehen wie ich nach dem Tut vorzugehen habe.



    Sieht gut aus. Wieviele LEDs? Ich empfinde es als ein wenig "unpräzise". Absicht? :)

    Quote


    [font="verdana, arial, helvetica, sans-serif"]The maximum spacing between LEDs on the WS2801 strands is about 10 cm. I seem to recall that some users could get a single strand to [/font][font="verdana, arial, helvetica, sans-serif"]just barely[/font][font="verdana, arial, helvetica, sans-serif"] fit a 32" TV, but you should probably do your own measurements to be sure. Also, for a larger screen like that, more LEDs will give a brighter and smoother result.[/font]


    [font="verdana, arial, helvetica, sans-serif"]The WS2801 and LPD8806 strips follow similar principles but are different enough that a different Arduino sketch is required for each (LEDstream.pde for the former, LEDstream_LPD8806.pde for the latter, both are included in the Git repository). The WS2801 has one more bit of color resolution (8 bits each R,G,B vs. 7 bits for the LPD strips), but the difference is probably subtle enough where it's not very noticeable.[/font]


    Aus dem adafruit-Forum.


    Farbraum (RGB): 3 x 8bit (Driver) = 24bit Farbraum, somit true-color (WS2801)


    Habe mich missverständlich ausgedrückt, Verzeihung.



    Ich habe meine LEDs teuer bei eBay gekauft aus Deutschland. Der Verkäufer hat sie jedoch auch in China bestellt. Die meisten stammen ohnehin aus China würde ich behaupten. ;)

    Hallo und willkommen,


    die WS2801 leuchten diffuser, haben einen 8- statt 7bit Farbraum und du kannst den Abstand nach deinen Wünschen gestalten. Ich nutze 50 LEDs am 55" TV und finde es mehr als ausreichend. Es soll ja Umgebungslicht sein. ;)