Posts by Nueffe


    Bau Dir doch einfach noch ein Poti in deine Schaltung zwischen Plus und GND. Mit dem Schleiferanschluß des Potis, stellst Du dann die optimale Kontrastspannung für das LCD ein.


    So lange das LCD noch nicht initialisiert wurde, sieht man halt die Erste Zeile, bei mehrzeiligen LCD's ggf. auch noch weitere Zeilen.


    Den Poti habe ich beim Testaufbau weggelassen, weil das 16x2 Display auch keinen Benötigt... aber dass es vll. daran liegen könnte ist mal wieder so eine Einfache Lösung des Problems, das man nicht dran denkt. Hatte hier noch einen rumliegen und ihn jetzt mit verbaut - lag wirklich nur daran ^^

    Hi, nachdem ich mehrmals am Arduino 16x2 lcds verwendet hatte habe ich mir jetzt auch mal eins für den Pi zugelegt - als 20x4, da ich etwas mehr Platz brauche.


    Basierend ist das ganze auf dem HD44780 - sowohl meine 16x2 als jetzt auch das neue 20x4. Ich verwende immer die Adafruit Char LCD lib für in python um das ganze zu steuern.


    Mein Aufbau klappt wunderbar mit dem 16x2 lcd, das 20x4 hat allerdings (vermutlich) Kontrastprobleme, da beim Anzeigen des Textes immer alle 5x7 Matrix Felder aufleuchten. (siehe Bilder im Anhang.)


    Fritzing Aufbau ebenfalls anbei.
    Beim Boot sind die erste und die 3te Zeile weiß, was aber normal sein sollte.


    Jemand ne Idee warum das so ist?

    ah ok, dort wird auch auf die elinux Sammlung verwiesen.


    ich habe mir jetzt mal den D-Link Adapter bestellt und werde ihn am Freitag Testen. Zwar benötigt der eine seperate Stromversorgung, habe aber noch einen aktiven Switch zu Hause.


    Der Belkin hört sich am besten an, ist aber leider in deutschland nicht zu finden :(

    Quote

    Und bedenke immer: Da sind mitlerweile überall Airbags in der Nähe


    ohhhh ja...
    ich wollte mir mal in meinem (damals) Renault Megane das kleine Standard display für Uhrzeit, Radio etc. tauschen gegen nen Pi mit diversem Spielzeug und 9" Display... ich hab dann mal das Display ausgebaut um zu sehen wie viel Platz ich habe und wie sich das Auto verhält wenn das Display fehlt. Mir wurde dann an den Amaturen angezeigt, dass der Beifahrer Airbag ohne das Display deaktiviert ist... beim wieder anstecken hatte ich dann mit meinen laienhaften Kenntnissen bange, dass mir der gleich um die Ohren fliegt :D - ging aber gut - das Projekt hab ich dann trotzdem eingestellt.


    Aber gut, das ist jetzt etwas OT.


    Was die Lenkradsteuerung angeht, sehe ich da ein klein wenig schwarz. Ich denke mal die kannst du mit dem Pi nur sehr schwer bis garnicht verwenden.
    Was ich mir damals gedacht hatte war eine selbstgebaute Mittelkonsol-Steuerung. Ich hatte in bequemer Nähe einen Getränkehalter in den ich einfach ein stück Plexiglas mit Tastern rein machen wollte ( 1 Mitte, 1 links rechts oben unten und 2 zusätzliche für Sonderfunktionen).


    Wenn du deine Anlage im Auto anschließen möchtest, dürfte es wesentlich einfacher sein eine vorhandene Eingangsschnittstelle am Radio zu nutzen - die meisten bieten ja z.B. AUX.

    OK, ich werde mich da mal etwas durchwühlen.


    Ich habe auf jeden Fall mal diese liste gefunden und werde vermutlich mal einen der angegebenen testen.
    Mein bisher verwendeter ist irgend ein totaler noname adapter von ebay - deshalb kann ich den leider in der Liste nicht zuordnen.


    Mir ist allerdings auch aufgefallen, dass es wohl auch Probleme mit Keyboards gibt - möglicherweise haben also a+, 2 und zero generell Probleme mit USB?


    Ich müsste auch noch irgendwo nen USB Wlan adapter rumliegen haben, wenn ich den finde werde ich den auch mal testen - leider geht das aber erst am WE :(

    Quote

    ...und MAC-Adressen nur im lokalen Netz vorhanden sind.


    Phu... wenn ich mich richtig erinnere, ist das in diesem Fall sogar nochmal etwas anderes. (aber korrigiert mich wenn ich falsch liege)


    MAC-Adressen sind nicht innerhalb des lokalen Netzes vorhanden - sondern innerhalb einer Kollisionsdomäne. Hast du einen Switch dazwischen, wird zwar die Kollisionsdomäne geteilt, da der switch (in der Regel) nur auf layer 2 arbeitet, antwortet trotzdem der Zielrechner (arp selbst bewegt sich nämlich auf layer 3).
    Hast du nun einen Router (oder eine andere multi layer Komponente) dazwischen, wir dir in der Regel dieser Router antworten - somit bekommst du den Stand des routers bei einem Arp-Request. Auch wenn innerhalb eines Wlans nicht geroutet wird, läuft jede kommunikation über den Router.


    Wie gesagt, das stammt irgendwo aus meinen grauen Gehirnzellen, es ist schon ne Weile her, dass ich mich damit beschäftigt habe.


    edit:
    Was das FritzBox Thema angeht, sind sie für den 08/15 user sehr sehr gut - wer professionelle Router will, muss halt dann 800 statt 150 € ausgeben - schlecht sind sie deshalb noch lange nicht, sie sind halt für die Masse gemacht.


    Achja @TE, du pingst da mehrmals auf xxx.20 - dein Pi ist doch aber 27 - was ist denn dann die 20? Die taucht noch nicht auf.

    Soweit ich weis sind in der StVO nur speziell zugelassene Diagnose-Geräte während der Fahrt erlaubt, da es zu Störungen des Fahrzeugs kommen kann.


    Edit:
    Und schwups: erster Eintrag bei google-Suche nach "obd während der fahrt" >>hier<<
    bestätigt meine grauen Hirnzellen sogar ^^


    PS: es wäre eher ein Lastenheft, das Pflichtenheft enthält konkrete Vorstellungen der Lösung ;-P

    Auch wenns bisher keine Antworten gab - der Vollständigkeit halber ein update zum Problem:


    Ich habe mir jetzt einen anderen - neuen Pi A+ besorgt, das Problem bleibt das selbe. Die einzige in meinen Augen noch mögliche Fehlerquelle kann also nun nurnoch mein verwendeter USB-Ethernet Adapter sein. Er ist momentan die einzige angeschlossene Hardware. Der Fehler tritt außerdem auf wenn ich z. B. ein Git repo clonen möchte, via wget etwas herunterlade oder über SSH "größere" (mehr als ca. 15 Zeilen) Texte in vi kopieren möchte und eben wie oben schon geschildert apt-get update und Ähnlichem.


    Ich werde mir also einen neuen USB-Ethernet Adapter zulegen müssen umd weiter zu testen. Bevor ich mir allerdings wahllos einen anderen zulege:


    Gibt es unter den Pi A+ nutzern Empfehlungen?

    Quote

    Ich persönlich bin vor einiger Zeit komplett auf SMD umgestiegen, da bedrahtete Bauteile wohl nicht mehr zeitgemäß sind.


    Toll danke... jetzt fühle ich mich altmodisch :baeh2: ;)


    Das Bild sieht witzig aus... dachte nach einen ersten blick auf das Thumbnail an Bierkästen... weis auch nicht warum ^^

    oh man, das ist ja am Arsch der Welt... nachdem ich morgen Abend nach München fahre, hatte ich mir gedacht für nen Kuchen würde ich ja auch früher fahren... aber das liegt so garnicht in der Nähe xD

    Ich habe mir vor kurzem einen Pi A+ zugelegt und nachdem ich jetzt auch mal Zeit dafür hatte erstmal Raspbian jessie auf ne SD (32 GB) und los geht's.


    Nach dem ersten Boot und ändern des Tastaturlayouts erstmal apt-get update machen... denkste


    Der Pi friert ein und nichts geht mehr. Beim zweiten Versuch habe ich dann auch mal Fehlermeldungen bekommen (siehe Anhang).



    Danach jessie (kernel 4.1) runter un wheezy (kernel 3.18) auf die SD - aber selbes Problem.


    Ich stehe gerade absolut ratlos da und habe nicht einmal einen Ansatz zur Lösung gefunden.

    Quote

    Bislang wurden mir nur (jeweils mehrere) die Modelle B, A+, B+ und zwei Arduinos (Uno und Mega) geschenkt...


    :denker: Ich glaube ich muss mal ein ernstes Wort mit meiner Frau reden... ich muss mir mein Spielzeug immer selber kaufen :( =(

    Webserver (z. B. Apache(am einfachsten) oder Nginx) einrichten, Domain mieten, DDNS via router oder pi einrichten, Ports am Router freigeben und bei allem was du tust auch an Netzwerk Sicherheit denken.


    So viel dazu... dafür habe ich nun stolze 5 Minuten gebraucht.
    Du selbst hättest es mit Google und/oder der Forensuche ebenfalls in max. 15 Minuten geschafft.


    Ein eigener Webserver ist so ziemlich das erste Projekt, welches wohl 80% der Raspberry Pi user umgesetzt haben - dementsprechend gibt es auch viele Anleitungen.
    Bemühe bei einfachen Dingen erstmal dich selbst - nicht weil ich oder andere Leute hier zu Faul oder sich zu schade sind dir zu Helfen - nein, sondern weil der Lerneffekt größer ist, wenn du dich selber bei einfacheren Dingen durchs Internet wühlst. ;)


    Edit: Achja... was Sicherheit angeht - keine unnötigen Ports öffnen und Dienste (ggf. wird das bei dir der Apache sein) absichern.
    Für Apache z. B. https://www.cais.de/apache/2-2-absichern

    Bezüglich was genau?


    Hardware: Ich brauche nicht sehr oft Taster, wenn es aber ordentlich sein soll, nehme ich diese Multimec - die sind zwar nicht ganz Günstig im Verhältnis zu anderen aber dafür sehr gut - einziger kleiner Negativpunkt ist das relativ laute klicken bei Betätigung. Aber es sind dafür auch ordentliche Kappen verfügbar.


    für Testzwecke oder Projekte bei denen die Optik egal ist, tun es aber auch die billigen schwarzen für 10 - 20 Cent. Zum Beispiel diese


    Was die Simulation von Tastendruck angeht, solltest du mal nach xte (xautomation) Ausschau halten, damit hatte ich schon mal die Simulation von Pfeiltasten umgesetzt.
    Leider habe ich dazu gerade keinen Link.

    Vergesst nicht unseren guten (alten) Jörg


    Zwar ist die Auswahl geringer als bei anderen Shops, dafür kann man sicher sein, dass die Teile auch laufen.


    Und man findet ihn hier im Forum - was meiner Meinung nach auch wertvoll sein kann.


    <<Werbung Ende>> ;)


    Wenn du was ausgefalleneres brauchst, ist aber Ebay auf jeden Fall dein Freund. Die Chinateile sind (meist) nicht schlechter als andere aber wesentlich günstiger - Lieferzeit dafür natürlich meist deutlich höher.


    Edit: und watterott.com ist auch noch erwähnenswert - hohe Auswahl, meist aber relativ teuer (nicht immer) und vieles nicht vorrätig.

    Wenn du eine Oberfläche komplett über GPIO steuern willst, kommst du vermutlich nicht daran vorbei Tastendrucke (bsp. Pfeiltasten und Eingabetaste) zu simulieren. Unter Raspbian geht das, ich habe sowas aber mal unter (damals) raspbmc versucht, jedoch erfolglos - ich schließe mich da also mal Jörg an und würde an deiner Stelle ebenfalls Raspbian mit Kodi autostart wählen.


    Ich bin mir jetzt nicht ganz sicher aber ich glaube du musst zum Autostart nur in /etc/defaults/kodi den Autostart enablen.

    FTP muss hinter einem NAT-Router im passive mode betrieben werden - dafür ist eine Portrange configuriert, die du auch noch freigeben musst > siehe config des FTP-Servers (vermutlich proftpd).


    Schau dich da nochmal im Forum um, es gab einige Themen die dieses Problem behandelt haben.

    Quote

    Die Frage steht oben


    irgendwie nicht so richtig... "make install" ist ein befehl der die "install" sektion in einem Makefile ausführt.


    no-ip.com ist ein DDNS Dienst.


    Der Zusammenhang ist mir gerade noch unklar.


    Meinst du mit Protokoll welche Netzwerkprotokolle für DDNS benutzt werden?


    Edit: Ooooder meinst du ein Logfile für das was make install alles gemacht hat? - ist mir gerade noch eingefallen.