Posts by MagicBird

    der forum beitrag.


    Hallo Forum,


    Backup erstellen ist das eine aber auch wieder zurück spielen das andere.

    Nun habe ich mal versucht ein Backup auf einer anderen Karte zu installieren, als wäre mir die Karte zerschoßen.


    Zog mir also das Image von der NAS und startete win32disk und das ging loß. Dann ging die karte in meinen PI und startete diesen.

    Oh nun wunderte ich mich über den hostname und änderte diesen via raspi-config.


    OK...Openhab bekam auch schon signale vom PI, schien für mich alles viel zu dufte zu laufen. ich startete meinen MPC und ließ die Musik laufen und wollte der Browser(Chromium) starten bekam erstmal eine Fehlermeldungen, Irgendwas mit Prozess und andere User bla..., welches ich dan auf neu starten klickte. ok der lief auch wieder.

    Jetzt startete ich meinen mpc browser anwendung, wo ich quasi die Stream, Artist und Tracktitle auslese und in meine DB schreibe, daslief nun nicht mehr.


    localhost/phpmyadmin konnte ich mich nicht mehr anmelden und bekam eine fehlermeldung.


    #2002 - No such file or directory — Der Server antwortet nicht (evtl. ist der Socket des lokalen MySQL-Servers nicht korrekt konfiguriert).

    mysqli_real_connect(): (HY000/2002): No such file or directory

    Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen.

    mysqli_real_connect(): (HY000/2002): No such file or directory


    So was ist passiert???

    muß ich nach dem Image reinstallieren alle dienste neu installieren?


    pi@webpi:~ $ systemctl start mariadb

    Job for mariadb.service failed because the control process exited with error code.

    See "systemctl status mariadb.service" and "journalctl -xe" for details.




    OK, nun laß ich erstmal die Finger vom System und schau mal auf eure Ideen.


    danke Lars

    Hallo Forum,


    nun habe ich mir eine bash datei gebaut. damit ich das backup automatisch erstellen kann. Nur leider kommt diese Fehlermeldung

    bzip2: Input file backup_openhab_2021-08-03_12-43-30.img is not a normal file.


    #! /bin/sh

    # nfs pakete installieren

    echo "*** installieren von nfs und bzip2 ***"

    sudo apt install nfs-common time bzip2

    # mount Verzeichnis erstellen

    echo "*** Verzeichnix erstellen für BackUp ***"

    sudo mkdir /media/nas/$(hostname)

    # exportierte NAS Feigaben prüfen

    # mit IP

    echo "*** Anfrage an NAS ***"

    sudo showmount -e 192.168.5.15

    # Sieht gut aus, also mounten wir das NFS

    echo "*** Synco Ordner erstellen zwischen PI und NAS ***"

    sudo mount 192.168.5.15:/nfs/backuppi/$(hostname) /media/nas/$(hostname) -t nfs -o rw,soft,nolock

    # von mount kommt kein Okay oder sowas. Wenn kein Fehler kommt hat's funktioniert

    echo "*** Verzeichnis wechsel ***"

    cd /media/nas/$(hostname)

    echo "*** ShakeHand ***"

    touch hello-nas

    # jetzt sollte auf dem NAS die Datei hello-nas sichtbar sein

    # und starten das eigentliche Backup

    echo "*** BackUp erstellen auf NAS ***"

    sudo time dd if=/dev/mmcblk0 of=/media/nas/$(hostname)/backup_$(hostname)_$(date +%Y-%m-%d_%H-%M-%S).img bs=1MB

    # das dauert jetzt ne Weile und time zeigt und wie lange genau

    # Das erstellte Image ist so groß wie die Speicherkarte, daher komprimieren wir es mit bzip

    echo "*** BackUp kompremieren ***"

    bzip2 -7 *img


    In der bz2 Datei ist das img vorhanden und nach dem entpacken ist das eigentliche 32GB Image nur gerade mal 112MB groß.


    Danke Lars

    pi@linux-tree:/media/nas $ sudo time dd if=/dev/mmcblk0 of=/media/nas/backup_$(hostname)_$(date +%Y-%m-%d_%H-%M-%S).img bs=1MB

    31914+1 Datensätze ein

    31914+1 Datensätze aus

    31914983424 bytes (32 GB, 30 GiB) copied, 3574,02 s, 8,9 MB/s

    0.41user 207.05system 59:34.03elapsed 5%CPU (0avgtext+0avgdata 2868maxresident)k

    62332600inputs+62336584outputs (6major+456minor)pagefaults 0swaps

    pi@linux-tree:/media/nas $


    hat geklappt eine Stunde?????? wow also wohl nachts machen.


    Danke LArs

    bei größeren Datenmengen scheinen die WD Clouds das nicht verkraften zu können.


    pi@linux-tree:/media/nas $ sudo time dd if=/dev/mmcblk0 of=/media/nas/backup_$(hostname)_$(date +%Y-%m-%d_%H-%M-%S).img bs=1MB

    dd: Fehler beim Schreiben von '/media/nas/backup_linux-tree_2021-08-01_14-21-55.img': Eingabe-/Ausgabefehler

    dd: Schließen der Ausgabedatei '/media/nas/backup_linux-tree_2021-08-01_14-21-55.img': Eingabe-/Ausgabefehler

    Command exited with non-zero status 1

    0.05user 20.80system 11:08.61elapsed 3%CPU (0avgtext+0avgdata 3000maxresident)k

    5856224inputs+5855928outputs (8major+452minor)pagefaults 0swaps

    pi@linux-tree:/media/nas $


    Doch n kleinen USB Stick kaufen...

    Hallo, nun mal wieder Zeit,


    pi@linux-tree:~ $ sudo mount -t nfs -o rw,soft,nolock //192.168.5.5:/backuppi /media/nas

    mount.nfs: Failed to resolve server //192.168.5.5: Name or service not known

    pi@linux-tree:~ $ sudo mount //192.168.5.5:/backuppi /media/nas -t nfs -o rw,soft,nolock

    mount.nfs: Failed to resolve server //192.168.5.5: Name or service not known

    pi@linux-tree:~ $ sudo mount 192.168.5.5:/backuppi /media/nas -t nfs -o rw,soft,nolock

    mount.nfs: mount to NFS server '192.168.5.5:/backuppi' failed: RPC Error: Unable to receive

    pi@linux-tree:~ $

    pi@linux-tree:~ $ sudo mount 192.168.5.15:/backuppi /media/nas -t nfs -o rw,soft,nolock

    mount.nfs: access denied by server while mounting 192.168.5.15:/backuppi

    pi@linux-tree:~ $ sudo mount 192.168.5.15:/nfs/backuppi /media/nas -t nfs -o rw,soft,nolock

    pi@linux-tree:~ $


    Interessant, die WD legt noch ein zwischen Verzeichnis an "nfs"


    Bereitstellungspunkt: nfs://192.168.5.15/nfs/backuppi


    Nun kam ein SyncoOrdner auf dem Desktop.


    jetzt habe ich die Anleitung weiter verarbeitet und

    Code
    sudo time dd if=/dev/mmcblk0 of=/media/nas/backup_$(hostname)_$(date +%Y-%m-%d_%H-%M-%S).img bs=1MB

    Nun kommt das Abbild vom PI. mega...


    Frage könnte man nun die sudo time ..... Zeile als crontab laufen lassen 1x die woche?


    danke Lars

    Ich fand ja nun im Netz diese Anleitung https://www.hagenfragen.de/son…as-sichern-pi-backup.html


    und bin gerade dabei diese mal abzuarbeiten. Nun bleibe ich bei dem Problem stehen.

    pi@linux-tree:~ $ sudo mount -t nfs -o rw,soft,nolock 192.168.5.15:/backuppi/media/nas

    mount: 192.168.5.15:/backuppi/media/nas: can't find in /etc/fstab.


    Nun dachte ich, ich benötige das backuppi als grundordner und habe es via mycloud web interface erstellt und alle freigaben ohne Passwort gesetzt.

    Leider immer noch der Fehler.


    Was habe ich den nun wieder vergessen.


    danke Lars

    Hallo Forum,


    da ich nun alte MySQL Files gefunden habe und ich diese wieder zurück spielen und so mein System halbwegs retten konnte, stellt sich mir nun die Frage welche wäre wohl die bessere Art das gesamte MySQL zu sichern.


    beim mysqldump müsste ich ja jede DB einzeln sichern

    oder

    wie in diesem beitrag Clean und Autoclean, was passiert?

    wurde mir ja schon einmal danken geholfen per kommadozeile

    Code
    sudo tar -czf /tmp/mysql_backup.tgz /var/lib/mysql


    wobei ich gerade noch einen beitrag fand

    https://www.hagenfragen.de/son…as-sichern-pi-backup.html


    danke Lars

    Naja macht es einen unterschied ob ich das File Expansion bei einer 32 oder 64 oder 128GB karte mache?

    mir würde es auch reichen wenn man die daten via den PI und einem USB Kartenlesegerät zu beschaffen.

    Ist halt das ganze MySQL bla und die kleinen Scripte.

    Guten Morgen,


    gestern kam ich leider auch in dieser Situation. Der PI3 fährt von SD nicht mehr hoch. Im PC fand ich dann den leeren Overlay Ordner und die txt dateien.


    Nun habe ich ein neues Images auf eine frische Karte gespielt, diese dann in das System gelegt und gebootet.

    Danach im Raspi-Config Menu z.b. File Expansion und co aus geführt...


    Dann kopierte ich die fehlenden Dateien wieder von der einen auf die andere SD Karte, dieser fährt auch hoch...top


    aber wenn ich einen befehl ausführen möchte kommt.

    pi@webpi:~ $ sudo apt-get update -y

    >>> /etc/sudoers: Syntax-Fehler near line 23 <<<

    sudo: Syntax-Fehler in /etc/sudoers bei der Zeile 23

    sudo: Keine gültige sudoers-Quelle gefunden, Programmende

    Speicherzugriffsfehler

    pi@webpi:~ $


    was habe ich falsch oder noch nicht gemacht. danke

    Hallo Forum,


    ich habe das Problem, ich kann meinen PI3 nicht mehr booten.

    Wir hatten in den Nachmittagstunden den Elektriker im Haus, der hat kurzer Hand alle Sicherungen gezogen.

    Aus zeitlichen gründen mussten wir dann auch loß.


    Nun versuchte ich den PI wieder zu starten aber nichts passiert, im PC gesteckt sieht man das Verzeichnis Overlay (ist leer) cmdline.txt config.txt und issue.txt mehr ist nicht zusehen.

    Kann ich das Boot Verzeichnis eines anderen PI kopieren und damit die Karte wieder zum laufen zu bringen.

    Auf das Laufwerk SD komme iich ja auch nicht rauf.


    danke Lars