Posts by Bracew

    Hallo,


    ich habe einen RasPi mit MiniDLNA laufen.
    Außerdem einen Samsung 40ES7090 Fernseher.


    Auf dem Samsung kann ich meine MiniDLNA Video Inhalte nach verschiedenen Folders anzeigen lassen.
    Meine Dateistruktur für meine Videos sieht wie folgt aus:
    - 2013-Winter
    - 2013-Sommer
    - 2013-Fruehjahr
    - 2012-Sommer
    etc.


    und so wird Sie auf auf dem Sams angezeigt.


    Mit lieben Grüßen

    Danke,
    nein ich möchte nicht der erste auf der Lok sein, aber halt auch nicht noch im Bahnhof stehen, wenn der letze Wagen durchrollt.
    Ich dachte halt schon ich hätte den Zug verpasst.
    Aber, er schein ja noch gar nicht losgerollt zu sein.
    In sofern alles OK.

    Hallo,


    danke für den Hinweis, dass Raspian ungleich Debian, obwohl es auch dort einen ARM-Zweig gibt.


    Sehe ich es also richtig, dass noch niemand Raspian 7.3 auf seinem RasPi laufen hat?
    Bin ich mit meinem 7.2 also up-to-date?


    Gruß Bracew

    Hallo an alle,


    auf meinem RasPi läuft Debian Linux 7.2


    auf "http://www.debian.org/index.de.html" steht:


    Neuigkeiten
    [14. Dez 2013] Debian 7 aktualisiert: 7.3 veröffentlicht


    Wenn ich meine RasPi aktualisieren möchte mit apt-get upgrade oder dist-upgrade bleibt die Version jedoch auf 7.2. (0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.)


    Mache ich etwas falsch ?


    Gruß Bracew

    Hallo Imperator,


    danke für den Tipp. Werde ich in demnächst ausprobieren.


    Aber, warum lässt Du mich erst zappeln und sagst nicht gleich in Deinem ersten Beitrag "...guckst Du hier:..."?
    Na egal, Schwamm drüber. Sei mir nicht böse. Ich denke halt anders über Foren, Google usw. und deren Funktion.


    Also, ich werde dass demnächst ausprobieren und anschließend hier berichten.

    Hallo Outlaw,


    Danke für Deinen Hinweis.


    Zitat aus meinem ersten Posting zu diesem Thema:

    Quote


    Ich habe dazu schon gegoogelt aber nichts gefunden, was ich habe umsetzen können. Entweder zu kompliziert beschrieben oder ich bin zu blöd in der Umsetzung.


    Deshalb bin ich ja froh meinen Weg, wie zu vor beschrieben, gefunden zu haben.


    Ich bin jedoch für konkrete und konstruktive Verbesserungen offen.


    Ich möchte niemanden hier in diesem Forum persönlich zu nahe treten, aber pauschale Hinweise in der Art "... googlen...VHost..." finde ich nicht so gut, denn natürlich kann man mit Google jederzeit Millionen von Suchtreffern zu VHost finden. Das hatte ich ja, wie oben beschrieben auch schon getan. Es ist jedoch schwierig und zeitaufwendig die "Perlen" aus dem Millionenhaufen herauszufinden und habe deshalb in diesem Forum für konkrete Hinweise gefragt. Es bräuchte dieses Forum ja ansonsten gar nicht, da sich alles immer in Google finden lässt!


    Und deshalb nochmal: Ich bin offen für konkrete und konstruktive Verbesserungen in diesem Forum.

    Hallo Forum,


    Heureka ich habs! (Hoffentlich:s).


    Also , ich habe die Datei /etc/apache2/sites-available/default gefunden.


    Dort habe ich nach dem Teil:


    <Directory /data/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>


    eine Ergänzung wie folgt vorgenommen:


    <Directory /data/www/phpsysinfo>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order deny,allow
    Deny from all
    allow from 192.168.0.0/24
    </Directory>


    und danach das selbe noch einmal in der Datei /etc/apache2/sites-available/default-ssl


    Nach einem Restart des Apache mit:
    sudo apachectl restart
    kann ich auf phpsysinfo von intern zugreifen. Der Externe Zugriff wird mit "Forbidden" dem Browser abgelehnt.


    Weiter Verzeichnisse kann ich jeweils mit wiederholen des Blocks mit anderem Verzeichnissnamen dazufügen und nach dem Restart sind auch diese Verboten (Forbidden).

    Hallo modelb,


    das mit .htaccess sowie .htpasswd hatte ich auch schon gelesen. Das Verfahren ist halt insofern nachteilig, da bei internen Zugriffen auch jedes mal eine Anmeldung durchgeführt werden müsste, was im vertrauenswürdigen Bereich natürlich nur noch eine ungeliebte zusätzliche Hürde ist.


    Den Webmin Zugriff von aussen möchte ich ja gerade nicht, deshalb habe ich diesen Port nicht von aussen nach innen weitergeleitet.
    Ich hatte dieses Beispiel angeführt um so ggf. auch phpsysinfo von aussen unsichtbar (und unzugreifbar) zu machen, habe jedoch keine Ahnung wie ich dieses Beispiel von Webmin auch über phpsysinfo übergestülpt bekomme.
    Wie könnte ich denn auch phpsysinfo nur über einen Port (z.B. 10001) zugreifbar machen? Wen ich den Port dann von aussen nicht weiterleite habe ich den exklusiven internen Zugriff möglich, aber externe Zugriffe verunmöglicht. Das wäre mein Ziel.

    Hallo Forum,


    an meinem RasPi ist eine USB-Festplatte angeschlossen und unter /media/USBHDD1 gemountet. Der RasPi läuft im Hausinternen-Netz unter der IP 192.168.0.20. Es gibt noch weitere (Windows-)PCs im hausinternen Netz. Der RasPi soll mehrere Webseiten in Unterverzeichnissen für internen und/oder externen Zugriff hosten. Für externen Zugriff habe ich eine DynDNS Adresse wie zum Beispiel http://www.meines.dyndns.net
    Der RasPi dient allen hausinternen PC noch als Samba Server für Backups.



    Der Apache2-Webserver (2.2.22) läuft unter Debian Linux 7.2 auf dem RasPi.
    Sein www Verzeichnis liegt unter /media/USBHDD1/www zum Beispiel /media/USBHDD1/www/phpsysinfo oder /media/USBHDD1/www/roundcubemail
    Unter /data habe ich noch einen Link gespeichert auf das www Verzeichnis (/data/www). Der Apache2 greift so über /data/www/phpsysinfo bzw. /data/www/roundcubemail auf die Verzeichnisse zu.


    Auf dem Modem-Router habe ich den Port 80 (und auch 443 für https) weitergeleitet zum RasPi, so dass aus dem Internet über DynDNS auf beide Verzeichnisse zugegriffen werden kann, also zum Beispiel über http://www.meines.dyndns.net/roundcubemail auf das Verzeichnis roundcubemail. Auch aus dem Internen Netz kann auf beide Verzeichnis vom Browser zugegriffen werden, also zum Beispiel über http://192.168.0.20/roundcubemail/ ebenfalls auf roundcubemail.
    Dies ist für roundcubemail auch gut so.
    Jedoch auf phpsysinfo möchte ich nur aus dem internen Netz, also von 192.168.0.XXX, aus zugreifen können.
    Im Moment geht das leider auch noch von "draussen" aus dem Internet. Dies würde ich gerne abschalten. Ich möchte nicht das die internen Daten aus dem Internet herraus von jedem erreichbar sind. Es soll also Seiten geben, welche von intern und extern erreichbar sind und Seiten welche nur von intern erreichbar sind.


    Ich habe dazu schon gegoogelt aber nichts gefunden, was ich habe umsetzen können. Entweder zu kompliziert beschrieben oder ich bin zu blöd in der Umsetzung.


    Ich habe auch Webmin installiert. Komischer Weise (=ich verstehe es nicht, aber es funktioniert gut) ist dieser aus dem Browser nur über https://192.168.0.20:10000/ also intern erreichbar und nicht aus dem Internet. Ich glaube das liegt daran, dass der Port 10000 nicht weitergeleitet wird vom Modem-Router auf den RasPi und der Webmin einen eigenen Webserver hat, also nicht den Apache2.


    Ich würde mich auf eine Anleitung für Dummys freuen, falls es eine Lösung gibt.

    Hallo dbv,


    danke für Deine Hilfe.
    Ich habe foobar2000 zusammen mit dem foo_upnp plugin gerade Portable installiert und angetestet.
    So weit ich es bis jetzt beurteilen kann funktioniert es als DLNA/UPnP-Client.:thumbs1:
    Allerdings ist die Bedienung etwas umständlich. Aber besser als gar nichts.:)


    Das mit dem halbwegs aktuellen Betriebssystem ist so eine Sache.
    Da müsste ich zunächst einmal einen halbwegs aktuellen PC kaufen und anschließend ein halbwegs aktuelles (Windows-)Betriebssystem dazu kaufen.
    Und für all das müsste ich dann noch halbwegs genug Kohle verdienen.


    Ausserdem "...never change a running team"

    Hallo Forum,


    ich habe einen Raspberry-Pi Typ B unter Rasbian. Er hat eine USB-Festplatte. Auf dem RasPi läuft MiniDLNA als Multimedia DLNA/UPnP Server, welcher meine Multimedia-Files (Musik, Hörspiele, Videos und Bilder) von der USB-Festplatte den anderen Geräten im Heim-Netz anbietet.


    Ich kann also auf meinem Samsung-Fernseher über WLAN die Bilder und Videos ansehen sowie die Musik hören. Auch mein Aldi Internet-WLAN-Radio kann die Musik und die Hörspiele vom RasPi wiedergeben. Beide Geräte verbinden sich wunderbar über DLNA/UPnP mit dem RasPi.


    Für meinen Windows-XP-SP3-PC suche ich noch eine DLNA/UPnP-Client-Freeware um auch die Dateien per DLNA/UPnP abspielen zu können.


    Ich habe schon VLC ausprobiert, was aber nicht wirklich gut funktioniert hat, da VLC sehr langsam läuft, den MiniDLNA nicht findet oder schlichtweg abstürzt. Auch über Google habe ich schon mehrmals gesucht, aber nichts brauchbares gefunden.


    Kennt jemand eine DLNA/UPnP-Client-Software für Win-XP?
    Möglichst Free-/Shareware oder sehr günstig.


    Danke für Antworten
    Bracew

    Hallo miny1997,


    egal wie Du es betrachtest, bei dem einen Netzteil kommen mögliche 2,5A raus, bei dem anderen 3,5A.
    USB-2.0 Definition ist 0,5A pro Port, USB-3.0 Definition ist 0,9A pro Port. Mehr ist für den Pi besser.


    Der Pi ist in Sachen Strom sehr empfindlich.
    Ich hatte schon Probleme mit den Micro-USB Kabeln. Einige Kabel funktionierten und andere lassen zu wenig Strom durch für den Pi (meine ist ein wenig übertaktet und benötigt deshalb mehr als 0,5A). Ich bin also froh einen Hub gefunden zu haben, welcher funktioniert. Du musst meiner Empfehlung ja nicht folgen und Deine eigenen Tests machen.


    Jeder ist fast überall auf der Welt Ausländer. Trotzdem liebe Grüsse in die Schweiz.

    Hallo,
    wenn Du Dir das Bild des Netzteil vom von jar vorgeschlagenen Hub anschaust, wirst Du sehen Output 5V 2,5A.
    Die 2,5 A aufgeteilt auf 7 Ports, kommen pro Port weniger als die 0,5A raus, welche gem Definition rauskommen müssten. Das Netzteil ist also etwas schwach auf der Brust.


    Ich habe mir für meinen RasPi letztens diesen HUB besorgt:
    LogiLink UA0091 USB 3.0 Hub 4 Port mit Netzteil USB Verteiler Adapter Speed High
    findest Du in ebay für ca. 22,- EURO.


    Funktioniert tadellos für mich, mit dem Pi selbst, welcher seine Daten wieder in den HUB gibt und einer stromhungrigen USB-Platte.
    Der Hub kommt mit einem 3,5A Netzteil. Pro Port also ca. 0,9A. Dies entspricht der USB3.0 Definition.


    Liebe Grüße von einem Auslandsschweizer

    Hallo framp,


    die Antwort auf Deine Frage "Welche?" hatte ich geschrieben:
    "In unregelmäßigen Zeitabständen kann ich keine Verbindung mit dem Laptop an das WLAN herstellen". Mit anderen Worten, der Laptop findet zwar im WLAN den Router, kann aber keine Verbindung herstellen. Wenn ich danach dem Router für einige Minuten den Strom abdrehe und währendessen den Laptop neu starte, ist wieder alles OK, der Laptop kommt über den Router ins Internet.


    Die Antwort auf Deine Frage "Warum schaltest du den Router für 5 Minuten aus?" ist:
    Damit der Laptop wieder ins WLAN findet (Siehe zuvor). Eingeführt habe ich die nächtliche Trennung jedoch schon vor Jahren, da nach einigen Wochen Dauerbetrieb entweder mein Router sich aufgehängt hatte oder der Telekom-Gegenrouter nicht mehr wollte. Wer der Schuldige war ließ sich auch mithilfe der Telekom damals nicht herrausfinden. Die Lösung war jedoch des Nachts meinen Router über eine Zeitschaltuhr den Strom für einige Minuten abzuschalten.


    Zu: "Sorry, den Satz verstehe ich absolut nicht.":
    Wie Du bereits halifax geschrieben hast: "...kann es nicht sein dass durch eine neue Version das gesamte Home Net steht". Dem schließe ich mich an. Auch ich möchte nicht eine Version zurück, sondern würde gerne wissen, wie ich das Problem mit der jetzigen Version beheben kann.


    Falls Du oder jemand sonst hier im Forum dazu beitragen kann, dass das Problem gelöst wird, wäre ich sehr froh.


    Mit lieben Grüßen
    Bracew

    Hallo zusammen,

    auch ich habe massive Schwierigkeiten im Heim-Netzwerk seit ich meinen neuen Raspberry Pi seit ca. einer Woche an meinem Router angeschlossen habe.


    Ich habe ihn über einen vorgeschalteten Switch am Routers angeschlossen (Netgear DG834GTB).

    In unregelmäßigen Zeitabständen kann ich keine Verbindung mit dem Laptop an das WLAN herstellen, obwohl ich jede Nacht per Zeitschaltuhr den Router für 5 Minuten vom Netz ausschalte.


    Ich habe auch das Image vom 2013-09-10 auf dem RasPi und finde es keine Lösung alle meine Einstellungen mit einem neuem, altem Image wieder herzustellen, wenn ich diese denn wenigstens alle wüsste und nachvollziehen könnte.


    Grüße
    Bracew