Posts by Bracew

    Hallo Framp,


    wir hatten dieses Thema bereits einmal im Forum unter RE: Bosch BME280 und BMP280 Sensoren, Unterschiede und Erfahrungen diskutiert.


    Mittlerweile habe ich nun meinen 3. Sensor in drei Jahren an der Nordaussenwand unserer Hühnerhütte im Garten installiert. Diesmal in einem etwas grösseren Gehäuse.


    Damit Luft für die Messung der Luftfeuchtigkeit an den Sensor kommen kann habe ich zwei Kabelverschraubungen M25 eingesetzt. In die offenen Enden der Kabelverschraubungen habe ich Vliesstoff aus einer ausgedienten FFP2-Corona-Maske eingelegt.





    Mal sehen, ob der BME280 nun länger funktioniert als seine beiden Vorgänger.

    Hallo Thomas H,


    danke für Deine konstruktive Hilfe.

    nach einen andern Gebäude schauen

    geht leider nicht. Der RasPi ist an das Gebäude gebunden, da er dort noch andere Funktionen wahrnimmt. Der RasPi ist im inneren, der Sensor aussen.

    Das mit den Filtern bzw. "Pneumatik Schalldämpfer" ist eine gute Idee. Solche könnte ich in ein neues, ansonsten gleiches Gehäuse schrauben. Ich hatte halt grosse Löcher rein gestanzt, da ich dachte es muss ein schneller Luftaustausch (wg. Temperatur) möglich sein, Wind sollte durchziehen können. Es war mir nicht bewusst, dass der Sensor so empfindlich auf Staub oder Insekten ist.

    Ich mach nachher mal ein Paar Fotos von meinem BME280 Sensor, also vom Standort.

    Danke. Ich bin gespannt.

    nur wie kommt der Dreck da rein?

    Natürlich durch die 4x 1 Cent grossen Öffnungen, welche ich rein gestanzt habe, damit der Sensor überhaupt Luft bekommt.


    Wenn, wie Thomas H angibt, er den

    Ich habe ebenfalls einen BME280 im Freien hängen, unter einem Vordach, also Wind und Regen geschützt.

    BME im Freien hängen hat, kommen dort auch Insekten ran, die sich da mal umsehen und wieder wegfliegen. Scheint bei ihm also unkritisch zu sein.

    filtern!

    wäre noch eine Idee. Muss ich mal drüber nachdenken.

    Nur DU kannst es ergründen, wir hier aus der Ferne nicht warum deine Sensoren nicht lange halten!

    Ist mir klar. Dennoch hatte ich mir ähnliche Erfahrungen und ggf. praktische Lösungsansätze dazu erhofft

    mir fällt nur ein anderen Aufhängungsort wählen wo kein Dreck und keine Insekten reinkommen, überdacht vielleicht und mit Filter.

    Für die Kabeleinführungen evtl. sowas verwenden

    https://www.elektroshopwagner.…Aufputz-System-IP-44.html passend eben


    Den Aufhängungsort kann ich nicht viel ändern. Dies ist die einzige Wand, welche Richtung Norden geht. Alle anderen Wände bekommen mehr Sonneneinstrahlung und verfälschen dadurch den Temperaturwert. Insekten sind (Gott sei dank) immer draussen unterwegs, egal wo. Eine M20-Kabeleinführung vom Kabel in das Gehäuse habe ich schon wie im Link angegeben verwendet.

    Die Kiste ist innen so verdreckt, kein Wunder das sich der Sensor nicht lange wohlfühlt, da scheint also Dreck reinzukommen der auch dne Sensor offensichtlich befällt.

    Irgendwie sieht die Anbringung vom Gehäuse oder die Belüftung nicht optimal aus, ich gehe davon aus als das erstmalig installiert wurde war es innen sauber!

    Auf den Bildern sind die Belüftungslöcher zu sehen. In der unteren Hälfte links und rechts je 2 Stück. Ja, dort kommt ggf. auch mal was rein. Der Sensor hängt aber in der oberen Hälfte frei belüftet und somit eigentlich frei von Dreck. War jedenfalls nichts zu sehen.


    Aber, nichts desto trotz, welche Gehäuse wären denn zu empfehlen bzw. welche Lösung könnte funktionieren?

    Hallo Thomas H,


    danke für Deine Hinweise.

    Ich bin mal eben raus und habe 3 Fotos vom Sensor mit Gehäuse gemacht:



    Kondensfeuchtigkeit im Gehäuse habe ich keine entdeckt, war mit Finger gefühlt trocken.

    Ich habe auf das Miniaturloch im Sensor mal meine Entlötpumpe gehalten und mehrmals absaugen lassen und im Anschluß ein paar mal gepustet.

    Das Messresultat ist gleich geblieben: "2021-03-29_13:04:47 T: 14.4 H: 100.0 P: 1003.4 P-NN: 1030.5"

    H: 100.0 = 100% humidity, obwohl die Sonne scheint und es trocken ist. Internet-Wetter sagt Luftfeuchte 44%.

    Hallo,


    ich habe seit Juli 2018 einen BME280 Sensor im Aussenbereich an einem RasPi im Einsatz.


    Der BME280 ist in einer PVC-Abzweigdose untergebracht, welche an einer Aussenwand im Freien angebracht ist. Die PVC-Abzweigdose ist unten mit mehreren ca. 1 Cent großen Löchern offen.


    Die ersten Monate funktioniert immer alles sehr zufriedenstellend. Alle Werte sind im erwarteten Bereich.

    Nach mehreren Monaten Betrieb ist die Messung der Feuchtigkeit abnormal. Alle anderen Werte sind weiter im normalen. Die Feuchtigkeit ist jedoch meist bei 100% obwohl drausen es erkennbar trocken ist und Internet Wetterstationen für unseren Ort wesentlich andere Werte angeben, zur Zeit zum Beispiel 61% wo der BME280 Sensor zur Zeit 100% angibt.

    Ich habe den Sensor zwischendurch schon mal gegen einen neuen ausgetauscht. Aber mittlerweile ist die Messung wieder schlecht, manchmal über mehrere Tage durchgehend 100% Luftfeuchte. Im nachfolgenden Diagramm die grüne Linie.



    Hat jemand ähnliche Erfahrungen und ggf. eine Lösung?

    Ich habe ein

    Code
    sudo grep -r br0

    im / (Root) laufen lassen (Danke an llutz für den grep Hinweis).


    Es sind natürlich Unmengen von Ergebnissen gekommen. Vor allem in *.gz, *.png, *.jpg, etc., aber eine ist mir zwischendurch aufgefallen. Es ist eine welcome.sh Datei, welche ich vor langer Zeit mal zum testen der Anzeige der RasPi Informationen ähnlich wie in: https://indibit.de/raspberry-p…-nachricht-anpassen-motd/ versucht hatte. Nachdem ich dort von br0 auf eth0 geändert hatte ist die Meldung nun weg.


    rpi444 hat also richtig gelegen mit seiner Vermutung in #31!

    Danke Dir für Deine unermüdliche Unterstützung.


    Vielen Dank an alle Helfer!!!


    Ich bin so zufrieden und kann das Thema als "gelöst" markieren.

    Quote

    Code


    Code
    systemctl list-units --all | grep -i br0
    find /sys -iname '*br0*'
    sudo sysctl -a | grep -i br0

    Bei allen drei Befehlen erhalte ich keine Ausgabe.


    Ja, aber wpa_supplicant ist doch deaktiviert, oder?

    Wie kann ich feststellen ob wpa_supplicant deaktiviert ist?


    Ich habe mal die drei Dateinamen in /etc/systemd/network/ 02-br0.netdev + 04-br0_add-eth0.network +12-br0_up.network durch google laufen lassen und bin auf die Seite:

    https://raspberrypi.stackexcha…access-point-the-easy-way

    gekommen. Vermutlich bin ich nach der Anleitung nach "♦ Setting up an access point with a bridge" damals vorgegangen. Die kommt mir bekannt vor. Auch dort gibt es einen Abschnitt zu "wpa_supplicant@wlan0.service".

    Ich habe mal eine Suche auf dem RasPi laufen lassen, wo überall noch "br0" als Text in /etc vorkommt:

    in /etc/systemd/system/wpa_suplicant@wlan0.service.d/override.conf mit dem Inhalt:

    Code
    [Service]
    ExecStartPre=/sbin/iw dev %i set type __ap
    ExecStartPre=/bin/ip link set %i master br0
    
    ExecStart=
    ExecStart=/sbin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant-%I.conf -Dnl80211,wext -i%I -bbr0
    
    ExecStopPost=-/bin/ip link set %i nomaster
    ExecStopPost=-/sbin/iw dev %i set type managed
    Code
    sudo netstat -tlpena | grep -i ssh
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          16344      439/sshd            
    tcp        0      0 192.168.0.40:22         192.168.0.5:47036       VERBUNDEN   0          26658      1086/sshd: bracew [p 
    tcp6       0      0 :::22                   :::*                    LISTEN      0          16354      439/sshd   
    Code
    sudo iptables -nvx -L | grep -i br0
    
    keine Ausgabe
    Code
    sudo iptables -nvx -L -t nat | grep -i br0
    
    keine Ausgabe
    Code
    sudo sshd -t
    
    keine Ausgabe
    Code
    cat /etc/default/ssh
    # Default settings for openssh-server. This file is sourced by /bin/sh from
    # /etc/init.d/ssh.
    
    # Options to pass to sshd
    SSHD_OPTS=
    Code
    ps aux | grep -i [s]sh
    root       439  0.0  0.5  10728  5584 ?        Ss   17:32   0:00 /usr/sbin/sshd -D
    root      1086  0.0  0.6  12240  6396 ?        Ss   17:55   0:00 sshd: bracew [priv]
    bracew    1105  0.0  0.3  12240  3432 ?        S    17:55   0:00 sshd: bacew@pts/0
    Code
    apt-cache policy ufw
    ufw:
      Installiert:           (keine)
      Installationskandidat: 0.36-1
      Versionstabelle:
         0.36-1 500
            500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
    Code
    dmesg | grep -i br0
    
    keine Ausgabe


    Ich habe meinen Win10-PC runtergefahren. Er hat Dual-Boot. Ich habe ihn mit Debian-Buster hochgefahren.

    Auch wenn ich aus Gnome-Terminal mich per ssh auf meinem RasPi anmelde kommt:

    Das selbe Verhalten, wenn ich über eine Textkonsole (z.B. ALT-F3) des Debian-PC mich am RasPi einlogge.

    Aufgrund des gleichen Verhaltens bei allen Loggins denke ich, dass es nicht vom ssh-Programm abhängig ist.