Posts by Bracew

    Was ich getan habe:

    Code
    sudo systemctl mask dhcpcd
    sudo nano /etc/systemd/network/mylanif.network
    sudo reboot

    in mylanif.network:

    und jetzt hat er IPv6 auch ohne dhcpcd. Sieht gut aus:


    Was benutzt Du für ssh-login? ... wegen dem br0 ...

    Meist Putty. Die Fehlermeldung ist jedoch unabhängig vom ssh-Programm. Auch wenn ich per ssh der Windows Power Shell auf dem RasPi einlogge bekomme ich die selbe Meldung.

    Ok, ich glaube ich habe eine Lösung hier:

    Raspberry Pi 3 bekommt keine IPV6 zugewiesen

    gefunden.


    Nach

    Code
    sudo systemctl unmask dhcpcd
    sudo systemctl restart dhcpcd

    bekomme ich jetzt:

    Ich habe die /etc/systemd/network/mylanif.network wie folgt geändert:

    Nach dem reboot ist das Netzwerk unverändert:

    kein IPv6.


    Auch kommt noch: Device "br0" does not exist.

    Den ssh-login musst Du evtl. anpassen.

    Die Meldung kommt nach der MOTD:

    Irgendwo in der Netzwerk-Konfiguration muss die Bridge br0 wohl noch raus, oder?


    kannst Du noch wifi und bluetooth in der config.txt deaktivieren

    Kann bleiben


    ipv6 in der cmdline.txt deaktivieren

    So wie ich es sehe ist zur Zeit IPv6 deaktiviert:

    Ich würde aber gerne IPv6 aktiv haben, da wie bereits zu vor zum Glasfaser geschrieben, wir nur noch öffentlichen IPv6 Zugang haben und ich mir gerne die Option offen halten möchte.

    Wie schalte ich IPv6 ein?

    Beim ssh-login kommt: Device "br0" does not exist.


    Code
    ls -la /etc/systemd/network
    insgesamt 24
    drwxr-xr-x 2 root root 4096 Dez 30 14:12 .
    drwxr-xr-x 5 root root 4096 Dez 11 09:17 ..
    -rw-r--r-- 1 root root   30 Nov 26  2019 02-br0.netdev.bak
    -rw-r--r-- 1 root root   39 Nov  4 20:18 04-br0_add-eth0.network.bak
    -rw-r--r-- 1 root root  167 Nov 26  2019 12-br0_up.network.bak
    lrwxrwxrwx 1 root root    9 Sep 26  2019 99-default.link -> /dev/null
    -rw-r--r-- 1 root root  325 Dez 30 14:12 mylanif.network
    Code
    route -n
    Kernel-IP-Routentabelle
    Ziel            Router          Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.250   0.0.0.0         UG    0      0        0 eth0
    192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
    Code
    arp -av
    MyRouter (192.168.0.250) auf 10:06:45:92:57:8c [ether] PERM auf eth0
    ? (192.168.0.252) auf 44:4e:6d:8b:29:2d [ether] auf eth0
    ? (192.168.0.81) auf 24:6f:28:b3:2e:2c [ether] auf eth0
    ? (192.168.0.20) auf dc:a6:32:67:59:1e [ether] auf eth0
    ? (192.168.0.5) auf bc:5f:f4:ea:65:7b [ether] auf eth0
    ? (192.168.0.254) auf 38:10:d5:d7:ef:47 [ether] auf eth0
    Einträge: 6   Ignoriert: 0   Gefunden: 6

    Doch habe ich die umbenannt. Ich habe nach dem Zugriff per ssh zunächst:

    Code
    sudo mv /etc/systemd/network/02-br0.netdev /etc/systemd/network/02-br0.netdev.bak
    sudo mv /etc/systemd/network/04-br0_add-eth0.network /etc/systemd/network/04-br0_add-eth0.network.bak
    sudo mv /etc/systemd/network/12-br0_up.network /etc/systemd/network/12-br0_up.network.bak

    eingegeben, dann:

    Code
    sudo nano /etc/systemd/network/mylanif.network
    sudo systemctl daemon-reload
    sudo systemctl restart systemd-networkd
    ip a
    route -n
    ... usw.
    Code
    route -n
    Kernel-IP-Routentabelle
    Ziel            Router          Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.250   0.0.0.0         UG    0      0        0 eth0
    0.0.0.0         192.168.0.250   0.0.0.0         UG    1024   0        0 br0
    192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 br0
    192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.0.250   0.0.0.0         255.255.255.255 UH    1024   0        0 br0
    Code
    arp -av
    ? (192.168.0.254) auf 38:10:d5:d7:ef:47 [ether] auf br0
    ? (192.168.0.81) auf 24:6f:28:b3:2e:2c [ether] auf br0
    MyRouter (192.168.0.250) auf 10:06:45:92:57:8c [ether] PERM auf eth0
    ? (192.168.0.20) auf dc:a6:32:67:59:1e [ether] auf br0
    MyRouter (192.168.0.250) auf 10:06:45:92:57:8c [ether] auf br0
    ? (192.168.0.5) auf bc:5f:f4:ea:65:7b [ether] auf br0
    ? (192.168.0.252) auf 44:4e:6d:8b:29:2d [ether] auf br0
    Einträge: 7   Ignoriert: 0   Gefunden: 7
    Code
    host heise.de
    heise.de has address 193.99.144.80
    heise.de has IPv6 address 2a02:2e0:3fe:1001:302::
    heise.de mail is handled by 10 relay.heise.de.
    Code
    ping -c 3 1.1.1.1
    PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
    64 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=13.10 ms
    64 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=11.8 ms
    64 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=11.8 ms
    
    --- 1.1.1.1 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 5ms
    rtt min/avg/max/mdev = 11.818/12.543/13.977/1.021 ms
    Code
    ping -c 3 192.168.0.250
    PING 192.168.0.250 (192.168.0.250) 56(84) bytes of data.
    64 bytes from 192.168.0.250: icmp_seq=1 ttl=64 time=0.609 ms
    64 bytes from 192.168.0.250: icmp_seq=2 ttl=64 time=0.472 ms
    64 bytes from 192.168.0.250: icmp_seq=3 ttl=64 time=0.538 ms
    
    --- 192.168.0.250 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 82ms
    rtt min/avg/max/mdev = 0.472/0.539/0.609/0.062 ms
    Code
    date
    Mi 30. Dez 14:20:04 CET 2020
    Code
    rdate -4npu 192.168.0.250
    -bash: rdate: Kommando nicht gefunden.

    Naja, Du hättest ja nur die move's machen müssen ohne reboot, denn dann wäre der Netzzugang erhaltengeblieben.

    Und nach dem reboot hattest Du ja Zugang per Tastatur/Bildschirm zu deinem PI, so dass der ssh-Zugang für diese Änderungen auch nicht mehr erforderlich gewesen wäre. D. h., die move's hättest Du nicht rückgängig machen müssen.

    Stimmt, so kann ich aber Copy&Paste machen.

    Bin kurz zum Einkaufen mit meiner Frau. Bin bald wieder da. Mach dann die Anweisungen aus #15.

    Code
    arp -av
    ? (192.168.0.252) auf 44:4e:6d:8b:29:2d [ether] auf br0
    ? (192.168.0.20) auf dc:a6:32:67:59:1e [ether] auf br0
    ? (192.168.0.254) auf 38:10:d5:d7:ef:47 [ether] auf br0
    ? (192.168.0.5) auf bc:5f:f4:ea:65:7b [ether] auf br0
    ? (192.168.0.81) auf 24:6f:28:b3:2e:2c [ether] auf br0
    MyRouter (192.168.0.250) auf 10:06:45:92:57:8c [ether] auf br0
    Einträge: 6   Ignoriert: 0   Gefunden: 6
    Code
    cat /etc/systemd/network/02-br0.netdev
    [NetDev]
    Name=br0
    Kind=bridge
    Code
    cat /etc/systemd/network/04-br0_add-eth0.network
    [Match]
    Name=eth0
    [Network]
    Bridge=br0
    Code
    cat /etc/systemd/network/12-br0_up.network
    [Match]
    Name=br0
    [Network]
    DHCP=yes
    # to use static IP uncomment these and comment DHCP=yes
    #Address=192.168.0.40/24
    #Gateway=192.168.0.254
    #DNS=192.168.0.254 1.1.1.1

    Die Dateien habe ich umbenannte und den RasPi neu gestartet. Er läuft. Via Tastatur und Monitor kann ich mich anmelden, hat nun aber keinen Netzzugang mehr. Auf ifconfig zeigt er nur die lo-Schnittstelle an. SSH Zugang ist nicht möglich.


    Soll die Zuweisung der IP-Adresse an das eth0-Interface (Kabelverbindung) per DHCP erfolgen oder soll es eine feste/statische IP-Adresse sein? Wenn statisch, wie ist die DHCP-range vom Router?

    Der RasPi soll eine feste IP-Adresse vom Router zugewiesen bekommen. Normalerweise die IPv4: 192.168.0.40.


    Ich hatte bis vor ca. 8 Wochen einen Fritzbox 7490 Router am DSL Anschluß der Telekom. Dieser war auch der DHCP Server im Heimnetz. Seit einigen Wochen habe ich einen DG giga 1000 Anschluß von der Deutschen Glasfaser (DG). Steigerung von 3 Mbit/sec. auf 900 MBit/sec. Deutsche Glasfaser stellt ihren Privatkunden eine öffentliche IPv6-Adresse, ein separates IPv6-Prefix (für das interne Netzwerk) und eine IPv4-Adresse aus dem Carrier Grade NAT Bereich zur Verfügung. Die Bezeichnung für einen Deutsche Glasfaser Privatkunden-Anschluss ist DualStack mit CGNATv4.


    Von der Deutschen Glasfaser habe ich einen Basic Router SagemCom F@st 5366se gestellt bekommen, welcher nun DHCP übernimmt. DHCP ist an der Fritzbox abgeschaltet, sie läuft aber weiterhin im Netz um bis zur Umstellung im Juni 2021 telefonieren zu können. Im Juni 2021 soll die Fritzbox wieder alleiniger Router im Netz werden (Internet und Telefonie wieder auf ein Gerät statt zwei), der Basic Router der Deutschen Glasfaser soll dann zurückgehen. Zur Zeit läuft deshalb mein VPN und mein hausinterner Mail Server (auf einem 2.RasPi) nicht. Ich hoffe, dass ich die ab Juni 2021 auch wieder hin bekomme.


    Zum SagemCom Router gibt es fast keine Dokumentation und er ist meines Erachtens auch nur für Basis Funktionen zu gebrauchen. Manche Einstellungen kann man zwar vornehmen, sie funktionieren jedoch nicht richtig. Der Support der Deutsche Glasfaser ist damit überfordert und kann keine Auskünfte geben. Der Routerhersteller sagt er hätte alle Tätigkeiten für Support und Dokumentation an eine Fremdfirma ausgelagert, welche 2015 pleite gegangen ist. Es gäbe deshalb nichts zum SagemCom Router.

    Die Besonderheit bei mir besteht in der Tatsache, dass 2 Türen gesteuert werden.

    Ich glaube, dass dies für FHEM kein Hindernis wäre, alles eine Frage der zeitlichen Synchronisierung innerhalb FHEM's. Weiterhin ist auch das FHEM-Forum sehr rege und hilfsbereit.

    Aber, wie Du willst, dann ist FHEM halt raus.

    Treffer! Ich denke jetzt wirst Du allein, weiter damit klar kommen, ... oder?

    Eher "oder"!


    Ich habe leider nicht so viel Ahnung mit der RasPi Netzwerkkonfiguration wie Du.

    Was meinst Du, was ich tun müsste um die Netzwerkkonfiguration auf "Werkseinstellung" zurück zu setzen?

    Oder noch besser, gibt es eine erprobte Anleitung? (Entschuldigung, bitte nicht falsch verstehen, ich möchte auf gar keinen Fall Dein Wissen herabwürdigen, ehrlich nicht)

    systemctl status systemd-networkd


    ls -la /etc/systemd/network

    Code
     ls -la /etc/systemd/network
    insgesamt 20
    drwxr-xr-x 2 root root 4096 Nov  4 20:18 .
    drwxr-xr-x 5 root root 4096 Dez 11 09:17 ..
    -rw-r--r-- 1 root root   30 Nov 26  2019 02-br0.netdev
    -rw-r--r-- 1 root root   39 Nov  4 20:18 04-br0_add-eth0.network
    -rw-r--r-- 1 root root  167 Nov 26  2019 12-br0_up.network
    lrwxrwxrwx 1 root root    9 Sep 26  2019 99-default.link -> /dev/null

    systemctl status dhcpc

    Code
    systemctl status dhcpcd
    ● dhcpcd.service
       Loaded: masked (Reason: Unit dhcpcd.service is masked.)
       Active: inactive (dead)



    Quote

    ip a



    cat /etc/network/interfaces

    Code
    "Nichts"


    cat /etc/dhcpcd.conf

    ...ein release-upgrade?

    Ja, vermutlich schon ab Wheezy. So genau weiß ich es nicht mehr. Irgendwann musste ich den RasPi neu installieren, war eine Heidenarbeit. Aber wann?


    ...nicht mehr weißt was Du in Laufe der Zeit auf deinem PI geändert hast.

    Genau, deswegen dachte ich, es gebe die Möglichkeit die aktuellen Buster Grundkonfigurationsdateien (aber welche?) in /etc einzuspielen und alles wäre zurückgesetzt nach einem Reboot und würde funktionieren. Na ja, war wenigstens meine Hoffnung.

    Hallo,


    ich habe einen RasPi 3 unter Raspbian-Buster laufen, welcher über Jahre hinweg auch als AccessPoint (AP) bzw. Bridge funktioniert hat. Soll heißen, er ist auf der einen (Netzwerk-)Seite per LAN-Kabel (eth0) am Router angeschlossen und bekommt von diesem seine IP-Adresse zugeteilt und funktioniert auf der WLAN Seite mit seinem internen WLAN Chip (wlan0) als AP für tragbare Geräte. Dafür musste ich ein br0 Interface konfigurieren.


    Um den RasPi als AP zu konfigurieren habe ich damals (vermutlich 2015) mehrere Anleitungen aus dem Internet ausprobiert und alle möglichen Einstellungen an den Konfigurationsdateien vorgenommen, zum Teil wieder Rückgängig gemacht und wieder andere ausprobiert. Was ich alles ausprobiert und verändert habe, weiß ich heute leider nicht mehr. Irgendwann hat es schließlich funktioniert. Der RasPi hat auch mehrere Distro-Upgrades erhalten.


    Der RasPi als AP hat gut funktioniert. Der AP ist nun aber nicht mehr notwendig.


    Er funktioniert ansonsten tadellos als Kids-PC, CUPS-Drucker-Server, Samba-Server, etc. An diesen Aufgaben möchte ich nicht rütteln. Ich würde gern nur die Netzwerkkonfiguration auf "Werkseinstellung" zurücksetzen ohne das ganze System neu installieren zu müssen.


    Gibt es einen Weg nur die Netzwerkkonfiguration auf die Grundeinstellungen zurückzusetzen?

    Er soll anschließend wieder nur per IPv4 und IPv6 am LAN Kabel (eth0) erreichbar sein. Die interne WLAN Schnittstelle wird nicht mehr benötigt.


    Gruß Bracew

    Hallo,


    wenn Du hier im Forum oder im FHEM Forum suchst zu "Hühnerstall" o.ä. wirst Du bestimmt fündig.


    Ich habe mal den Hühnerstall meiner Frau ein wenig automatisiert: Automatische Hühnerklappe / Hühnerstall (Raspberry Pi und Lego Technik)


    Der Hühnerstall hat auch Strom. Der WLAN Empfang war wegen der Entfernung grenzwertig, deshalb übertrage ich die Daten zum RasPi im Hühnerstall per Powerlan. Funktioniert seit Jahren problemlos und das Stromkabel ist ja eh schon da!


    Mittlerweile habe ich noch einen billigen BME280 Sensor für Temperatur, Feuchtigkeit und Luftdruck an den HühnerPi angehängt.


    Liebe Grüße Bracew


    P.S. Als Bild noch ein Screenshot der FHEM-Steuerung unseres Hühnerstalls