Posts by tooony

    Das dachte ich auch erst, aber als ich das Board dann hatte kam die positive Wendung: Das bei heise beschriebene traf absolut nicht ein. Die geschilderten "Bildaussetzer" sind nix weiter als ein unglücklich eingestellter Timer des Bildschirmschoners / Energiesparers. Eventuell hat sich heise hier noch eine ältere Version von TinkerOS angeschaut.

    Das Asus Tinker Board ist zwar noch nicht ganz ausgereift aber hat sehr viel Potential. Der große Kritikpunkt, wie eigentlich bei jeder neuen Raspi-Alternative, ist die Softwareunterstützung. Natürlich sit der RPi hier weit voraus. Das Gute ist aber das Asus dran bleibt: Neben der entsprechenden Präsenz auf der Herstellerseite, kann man regelmäßige Updates hinsichtlich der Treiber und ähnlichem bei TinkerOS beobachten. Das Board an sich läuft sehr flüssig und ist vorallem im Desktopbetrieb deutlich flotter unterwegs als der Pi. Mehr dazu kann man hier lesen: https://www.einplatinencomputer.com/asus-tinker-board-test/


    Meiner Meinung nach ist das Tinker Board eine nennenswerte Alternative zum Pi.

    Du könntest dir einen Mikrocontroller nehmen und dort die Bewegungsmelder ansteuern. Den Controller dann mit einem Sender deiner Wahl bestücken und am Raspi dementsprechend den passenden Empfänger. Das die Katzen den Bewegungsmelder nicht auslösen ist relativ: Du kannst versuchen den Melder so zu positionieren, dass dieser bei Bewegung unter Kniehöhe nicht auslöst.

    Soweit ich das sehe ist das ein 3 Pin Motor: Also Betriebsspannung, Masse und Tachosignal zurück. Für eine Ansteuerung via PWM hat der Lüfter somit keinen Eingang. Du benötigst nun entweder eine FET-Stufe (z.B. mittels Logic FET) um das Teil via PWM Regeln zu können - oder du benötigst eine dynamische Spannungsquelle (die auch die Leistung) aufbringen kann. Ersteres ist einfacher.


    Da ist wohl der Boardmanager von David Mellis nicht kompatibel mit den aktuellsten Versionen der IDE.
    Wer also lauffähigen Code für einen TINY85 benötigt sollte sich den Eintrag entsprechend abändern.


    Hallo,


    zunächst mal Respekt für diese Geduld und das Tüffteln! Aktuell versuche ich mit einem Attiny85 einen 433 MHz Sender umzusetzen. Der Code wird problemlos mit der IDE Version 1.6.9 kompiliert, die LED blinkt, aber gesendet wird nix (VirtualWire). Ist es möglich das deine Recherche dafür der Grund ist?


    Du hast praktisch die package_damellis_attiny_index.json mit der package_drazzy.com_index.json ersetzt?


    Gruß

    Hallo,


    ich habe aktuell das Gleiche vor wie hier ursprünglich beschrieben, sprich einen Attiny85 als 433 MHz Sender zu nutzen. Die Fehlerbild ist bei mir so wie hier auch beschrieben. Ich verwende die Arduino IDE Version 1.6.9. Von codebender.cc habe ich bisher noch gehört gehabt. Ich habe dort mal meinen Sketch hochgeladen und diesen über die Webseite auf den Attiny85 transferiert, jedoch funktioniert es bei mir nach wie vor nicht. Es blinkt lediglich die LED. Könnt Ihr mir beschreiben wie Ihr vorgegangen seid?


    Dies hier wäre mein aktueller Sketch:


    Hallo in die Runde,


    den bisherigen Antworten zum Thema Netzteil kann ich nur zustimmen. Ich betreibe meinen Pi3 auch wie gewohnt mit einem 5 Volt Steckernetzteil mit 2 A - problemlos. Aber die Frage bezüglich des 5,1 Volt Netzteils ist nicht ganz uninteressant. Ich vermute mal das dies ganz einfach eine reine Empfehlung ist. Hier wurde das Thema ebenfalls mal aufgegriffen: http://www.einplatinencomputer…n-und-bluetooth-on-board/


    Ich bin ebenfalls im Besitz einen offiziellen Raspberry Pi 3 Netzteils. Dort steht als Spezifikation drauf, dass dieses 5,1 Volt liefert. Vermutlich stehen die Händler des Pi3 im Kontakt mit der Raspberry Pi Foundation sodass die Information von dort kommt. Dies ist dann wiederum für die Händler eine Garantie-/Gewährleistungsbedingung, dass ein 5,1 Volt Netzteil verwendet werden muss, um solch einen Service in Anspruch zu nehmen.


    Nichts desto trotz funktioniert ein vernünftiges 5,0 Volt Netzteil.


    Gruß


    PS: Vielleicht erkennst du jetzt schon den Unterschied. Die Datei cpuinfo_cur_freq besitzt nur Leserechte für den Besitzer, also root, wohingegen die Datei scaling_cur_freq Leserechte für Besitzer, Gruppe und Andere besitzt - zudem steht hier die aktuelle Freq. drin, in der anderen nur die Standardtaktung.


    Das ist die Lösung! Danke für die Hilfe!

    Folgende Ausgabe erhalte ich bei dem Befehl:


    total 0
    drwxr-xr-x 2 root root 0 Apr 19 08:14 .
    drwxr-xr-x 5 root root 0 Apr 19 08:14 ..
    -r--r--r-- 1 root root 4096 Apr 19 09:19 affected_cpus
    -r-------- 1 root root 4096 Apr 19 09:19 cpuinfo_cur_freq
    -r--r--r-- 1 root root 4096 Apr 19 09:19 cpuinfo_max_freq
    -r--r--r-- 1 root root 4096 Apr 19 09:19 cpuinfo_min_freq
    -r--r--r-- 1 root root 4096 Apr 19 09:19 cpuinfo_transition_latency
    -rw-r--r-- 1 root root 4096 Apr 19 09:19 debug_mask
    -r--r--r-- 1 root root 4096 Apr 19 09:19 related_cpus
    -r--r--r-- 1 root root 4096 Apr 19 09:19 scaling_available_governors
    -r--r--r-- 1 root root 4096 Apr 19 09:19 scaling_cur_freq
    -r--r--r-- 1 root root 4096 Apr 19 09:19 scaling_driver
    -rw-r--r-- 1 root root 4096 Apr 19 08:14 scaling_governor
    -rw-r--r-- 1 root root 4096 Apr 19 09:19 scaling_max_freq
    -rw-r--r-- 1 root root 4096 Apr 19 09:19 scaling_min_freq
    -rw-r--r-- 1 root root 4096 Apr 19 09:19 scaling_setspeed
    -r--r--r-- 1 root root 4096 Apr 19 09:19 user_event_notify

    Hallo Leute,


    ich bin gerade dabei in einer kleinen Webanwendung ein paar Betriebsdaten vom Pi zu verarbeiten. Dazu möchte ich unteranderem mit PHP die aktuelle CPU Frequenz auslesen:


    [code=php]$cpuSpeed = round(file_get_contents("/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq") / 1000) . "MHz";[/php]


    Jedoch ist die Datei nicht lesbar: Permission Denied.


    Wenn ich mir aber z.B. Raspcontrol herunterlade und installiere werden während der Installation keine Rechte gesetzt. Innerhalb des Tools wird aber die gleiche Zeile verwendet um die aktuelle CPU-Frequenz einzulesen.


    Wie muss die Rechtesetzun erfolgen bzw. wie kann man das Problem lösen?


    Gruß

    Danke für deine Antwort. Sowas ähnliches hatte ich mir auch schon überlegt. Jedoch dachte ich das ich das ganze lösen könnte, ohne per Websprachen eingreifen zu müssen. Aber deine Lösung mit Ajax scheint mir sinnvoll! Danke!

    Hallo,


    ich habe momentan ein Problem, welches mit dem hier genannten einhergeht.


    In einem Eingangsbereich hängt ein Raspi an einem Bildschirm. Der Raspi ist mit einem Webserver (Apache, PHP, SQLite) ausgestattet. Beim Hochfahren des Pis wird Midori automatisch gestartet und ein Webinterface lokal im Fullscreen angezeigt (Frontend).


    Zu dieser Webseite gibt es ein Backend in dem der Content bearbeitet werden kann. Wenn der Content bearbeitet wurde soll dieser natürlich auf dem Frontend (Webseite im Fullscreen auf Bildschirm in Eingangsbereich) aktualisiert werden.


    Natürlich könnte man die Webseite ganz einfach mit einem Bash Script oder Meta Tag zyklisch neuladen. Aber für mich ist eine Lösung interessanter, wo per Button im Backend das Frontend aktualisieren kann.


    Ich habe bereits versucht mit verschiedenen Varianten aus PHP heraus über die exec Funktion das ganze zu realisieren.


    [code=php]exec("midori -e Reload");[/php]


    [code=php]exec('export DISPLAY=:0.0 midori -a 127.0.0.1');[/php]


    Wenn ich mit die Rückmeldung mit PHP ausgeben lassen kommt immer die Meldung Midori - Cannot open display


    Wenn ich die Befehle Lokal ausführe funktionieren diese allerdings.


    Hat jemand eine Idee bzw. einen anderen, besseren Ansatz?


    Gruß


    Tony

    Hallo Leute,


    mein Name ist Tony, ich bin 21 Jahre alt und komme aus Dresden. Zur Zeit studiere ich noch Informationstechnik im 6. Semester. Da ist die Begeisterung für Elektronik, insbesondere dem Raspberry Pi nicht weit entfernt :)


    Nebenbei arbeite ich in der Industrie. Außerdem programmiere ich Webseiten in den gängigen Websprachen und kann C mit schon etwas vorangeschrittenen Kenntnissen.


    Die bisherigen Eigenschaften habe ich verbunden und die Seite http://www.einplatinencomputer.com/ ins Leben gerufen. Dabei beschäftige ich mich vorwiegend mit dem Raspberry Pi, Arduino und weiteren Systemen. Das Projekt soll Einsteigern im Umgang mit den Minicomputern helfen. Das Projekt ist noch im Aufbau :)


    Mein Raspi (Modell B) läuft mit Raspbian und dient in erster Linie als Testplatform für meine C-Programme. Außerdem arbeite ich an zur Zeit an einem kleinen Projekt zur Heimautomation.

    Hey Leute,


    folgendes Problem:


    Im Rahmen einer Industrieanwendung kommt ein Raspi (Model B) zum Einsatz. Dabei soll eine Erweiterungsplatine entstehen die über die GPIO-Pins aufgesteckt wird und die besagte Erweiterungspatine steuert. Soweit alles okay.


    Insgesamt soll aber für Raspi und Zusatzplatine nur eine gemeinsame Stromversorgung verwendet werden. Darüber hinaus ist die Vorgabe das die Stromversorgung nicht über microUSB erfolgen soll, sondern über eine Schreibklemme bzw. im ungünstigsten Fall gelötet.


    Über google konnte ich mich schon etwas informieren. Man könnte an die microUSB Buchse vom Raspi einfach die 5 V dranlöten...dies scheint mir aber keine elegante Lösung zu sein.


    Hat man über P5 die Möglichkeit den Raspi mit 5 V zu versorgen? Wenn ja, könnt die Stromversorgung auf die Zusatzplatine mit drauf kommen und den Raspi somit versorgen.
    Welche Möglichkeiten gibt es noch?


    Gruß


    Tony

    Hallo Leute,


    folgendes Vorhaben:


    Ich habe eine Maschinensteuerung welche ein Netzwerkmodul besitzt. Dieses Modul kann bei bestimmten Ereignissen oder periodisch Statusinfos per Mail senden. Allerdings unterstützt diese nur eine Authentifizierung "POP before SMTP" (keine direkte SMTP Authentifizierung und SSL). Dies ist aber veraltet und wird von den heutigen Providern nicht mehr untersützt.


    Deshalb folgender Gedanke:
    Auf einem Raspberry soll ein Mailserver laufen. Dieser soll eine Mailadresse A als normales E-Mailkonto für die Steuerung unterstützen (lokal). Diese Mailadresse A sendet nun ihre Mails an eine Mailadresse B, weche als E-Mail Weiterleitung eingerichtet ist. Die Ziel-Mailadresse ist bei einem herkömmlichen Provider. Es ist quasi nur der Weg nach draußen notwendig.


    Kann man dies mit Postfix und Dovecot realisieren? Kommt noch ein anderer Ansatz in Frage?