Posts by p3pp0

    Danke für deine Antwort!
    die Distanzhülse selbst hält bestimmt... nur ich habe mich gefragt, wenn ich die Metall-Hülse mit Heißkleber auf eine glatte Plastik-fläche klebe, ob der "Kleber" nicht irgendwann versagt...
    Die Holzdübel-Idee find ich auch gut, wobei die Distanzhülsen halt schon ein fertiges Gewinde hätten und ja auch so gut wie nix kosten...


    Es geht wirklich nur um ein stehendes Gehäuse, das man vielleicht mal von A nach B trägt..

    Hallo liebe Pi-Gemeinde,



    ich habe mich nun schon längere Zeit mit meinem Pi beschäftigt und nutze viele verschiedene Dinge... Temperatursensor, Infrarot-Steuerung, 433 Mhz. Funksteckdosen usw...


    um das alles "ordentlich" und dauerhaft zu machen habe ich mir Lochrasterplatinen gekauft. Daraus habe ich nun eine "Hauptplatine" (Breakout-Kabel des RPI's dockt da an) gebaut, an die ich mittels Pfosten/Wannenstecker dann meine verschiedenen Module (auf Einzelplatinen) andocke.


    [Blocked Image: http://fs2.directupload.net/images/150119/temp/bm7jpz8q.jpg]


    Jetzt stellt sich für mich die Frage, wie ich das alles vernünftig in einem Gehäuse unterbringen kann. Testweise habe ich mir dazu schonmal eine normale große Plastik- Abzweigdose gekauft, bin aber auch für andere Vorschläge offen. Die Frage ist nun für mich, wie ich den Pi und meine "Platinen" nun so in eine Plastikbox bringe, dass das hält aber auch wieder herausnehmbar ist (hatte erst überlegt alles fest mit Heißkleber reinzukleben). Am liebsten wäre mir, wenn man das irgendwie verschrauben könnte. Ich möchte aber nicht durch das Gehäuse schrauben, also die Außenwände intakt lassen.


    Eine Überlegung war, Distanzhülsen wie diese (reichelt-Link) mit Heißkleber auf den Plastikboden zu kleben, und da dann den Pi und die Platinen (lassen sich ja prima durchbohren) draufzuschrauben...aber ob das dauerhaft hält?


    Was haltet ihr davon? Habt ihr vielleicht noch eine bessere Idee?


    Besten Dank!

    aus meiner Sicht ein ganz typischer Fall von nicht-kompatiblen Funksteckdosen...
    vor allem die günstigen Baumarktteile, bei denen der Code nicht über DIpschalter eingestellt werden kann, sondern durch Drücken eines Knopfes erlernt werden muss kannst du vergessen... :)


    Bestell dir mal die Original Elro's
    http://www.amazon.de/gp/product/B00CBSWIZY?psc=1&redirect=true&ref_=oh_aui_detailpage_o08_s00 (Affiliate-Link)


    und probiers aus... ich bin an dem gleichen Punkt wie du fast verzweifelt, mit den Elros gings dann sofort :)

    lasst euch von den vielen unbekannten Begriffen bitte nicht abschrecken... es geht auch nicht darum gerade Personen zu befragen die sich damit gut auskennen, sondern alle :)


    Heißt: auch wenn ihr z.B. keine der beschriebenen Wirkstoffe kennt dann ist das auch ne wichtige Info... einfach mal durchklicken... einiges (wie z.B. die Abstufung zwischen natürlich/künstlich) ist bewusst auch reine Gefühlssache/erster Eindruck :)

    Hallo ihr lieben,


    für eine Uni-Forschungs-Projekt (keine Werbung, gibt nichts zu verkaufen ;) brauche ich Teilnehmer für eine Umfrage zum Thema Cholesterin. Vielleicht ist es nicht schlecht sich neben der ganzen Pi-Bastelei mal mit dem Thema zu beschäftigen, nebenbei bekommt man sicher auch mit welche Wirkstoffe es gibt usw...


    https://www.soscisurvey.de/cholest/


    Ich würde mich sehr freuen wenn sich der eine oder andere die Zeit nehmen würde das kurz durchzuklicken.

    Du bist mein Held des Tages :bravo2::bravo2::bravo2:


    auch wenn das nicht der Fehler war... ich such echt schon seit Stunden nach dem Problem...
    mein Fehler war, dass das sleep auf einer falschen Tab-Ebene, und damit außerhalb der Schleife war... es gab also gar kein Sleep... das erklärt alles...


    und jetzt schau ich mir die Sache mit dem close() nochmal an... das erklärt warum irgendwas das ganze System swapped und mysql abstürzt ;))
    [hr]
    danke Matze das ist auch ein guter Tipp!
    [hr]
    das mit dem nach vorneziehen klappt so leider nicht :-/ aber die CPU-Last ist erstmal weg :)

    Hallo an alle!


    Alle Infos, die auf meinem LCD ausgegeben werden sollen, stehen als Datensatz in meiner Datenbank. Jeweils ein Datensatz ist dabei eine Ausgabe (enthält Zeile1,Zeile2,Zeile3,Zeile4).


    Dadurch ist es mir möglich, aus verschiedenen Modulen heraus LCD Nachrichten zu erzeugen, und dabei sicherzustellen, dass diese schön sauber nacheinander angezeigt werden.


    Eine Python-Schleife schaut dabei alle 3 Sekunden nach, ob ein neuer Datensatz, also etwas neues zum Ausgeben bereit steht. Das funktioniert einwandfrei, aber selbst im Leerlauf brauche ich dafür aber rund 90% CPU-Last (50% Python, 40% Mysql)



    Hat jemand eine Idee für eine bessere Lösung, die weniger CPU frisst?


    Besten Dank und viele Grüße!

    Hallo an alle!


    Ich möchte meinen 433MhZ Sender und Empfänger gerne über Pilight und einen I2C Port-Expander (MCP23017) betreiben.


    Meine erste Idee war, einfach mittels
    gpio -x mcp23017:100:0x20 mode 108 out
    zu setzen und dann in der hardware.json in Pilight Pin 108 anzugeben (sollte über WiringPi ja funktionieren).
    Leider tut sich da nichts, hat jemand eine Idee?


    Das beispielsweise ein DHT22 aufgrund der Bidirektionalen Kommunikation nicht darüber betrieben werden kann leuchtet mir ein. Ein LCD lässt sich aber z.B. über I2C ansteuern... also sollte das eigentlich auch für die Sender/Empfänger gehen, oder?


    Bitte bescheid geben falls Infos fehlen.


    Besten Dank!

    lange Rede kurzer Sinn: ich hab mir jetzt Elro-Steckdosen gekauft. Hat sofort beim ersten mal alles wunderbar funktioniert...


    vll. Senden diese billig-Funksteckdosen nicht sauber auf 433,xx Mhz...


    Danke euch!

    was du sagst klingt logisch - trotzdem gibts irgendwie einen Widerspruch zu deinem Vorredner der wohl ohne Antenne gesendet hat.


    Ich habe nur mit angelernten Komponenten probiert, also:
    1) anlern Knopf steckdose gedrückt
    2) kanal 1 der fernbedienung gedrückt --> angelernt, lässt sich mit Fernbedienung schalten
    3) wieder Kanal 1 der Fernbedienung gedrückt und mit dem Receiver versucht zu empfangen...


    Morgen löte ich ne Antenne dran, glaub aber noch nicht das sich das Problem dadurch löst :-/ achja.. hab auch schon nen zweiten Empfänger probiert - gleiches Ergebnis (hatte direkt nen doppelpack gekauft).


    Wie kann ich denn testen, ob die Kommunikation zwischen den beiden funktioniert? mit pilight send/receive gleichzeitig geht ja aus den weiter oben beschrieben Gründen nicht...

    ja, das habe ich gesehen...
    da ich aber bisher nicht mal ordentlich Codes empfangen konnte, habe ich bis jetzt darauf verzichtet... habe gelesen das man dadurch die Reichweite deutlich erhöht.. im Moment liegt aber alles hier nur wenige cm auseinander...

    Danke für deine Antwort at2001!


    Genau wie in deinem Thread beschrieben habe ich das auch schon gemacht (gerade nochmal nachgebaut). Pilight-Receive zeigt dann auch wie bei dir die entsprechende Meldung an.


    Allerdings glaube ich nicht, dass mit diesem sichergestellt werden kann, dass das Setup funktioniert. In Pilight-REceive steht (auch bei dir) origin: sender. Heißt: pilight schreibt wohl alles auch nochmal rein, was gesendet wurde.


    Der Gegentest: selbst wenn ich die Pins vom Receiver abziehe bringt pilight-receive die Meldung mit origin = sender

    Hallo Bracew,


    danke für deine Antwort. Leider hilft mir das nicht weiter. Meine Erkenntnisse sind schon das Ergebnis der Forensuche - gefühlt kenne ich alle Threads zu dem Thema.


    Besonderheit ist, dass ich eben keine Funksteckdosen mit "Mäuseklavier" habe.

    vielleicht hilft dir mein Ansatz:


    - Soll ein Programm was aufs Display schreiben, erzeugt es lediglich einen Datenbankeintrag
    - ein Daemon liest permanent in der Datenbank, ob es einen Eintrag gibt. Wenn ja löscht es den Eintrag und gibt ihn auf dem Display aus
    - die Datenbankeinträge könntest du von beiden Pi's aus schreiben


    Googlen kannst du nach mysql, php, phpmyadmin usw... ;)