Beiträge von rpi444

Ein neuer Artikel wurde veröffentlicht

    .... auf das Modem selbst habe ich keinen zugriff. ich könnte evtl. mal beim ISP nachfragen.... aber ob das was bringt...

    Das bringt schon etwas bzw. deine Anfrage beim Provider, kann für Klarheit sorgen.


    Sage deinem Provider, dass Du per IPv4 aus dem Internet auf ein Gerät/Dienst in deinem LAN zugreifen willst und ob er (als Provider) destination-NAT machen kann (... denn Du hast ja keinen Zugriff auf das "Modem").

    die Adresse 192.168.254.1 muss entweder die des Routers oder des Modems sein. ...

    Das wird die interne IP-Adresse des Modems sein. Dein Router wird evtl. eine WAN-IP-Adresse aus dem Subnetz 192.168.254.0/24 haben.


    Kannst Du jetzt von deinem PI, per Ping das Modem erreichen?

    Code
    1. ping -c 3 192.168.254.1

    Wenn ja, dann geht das über die default route (mit der IP-Adresse des Routers 192.168.1.1 als gateway) zum Modem.


    EDIT:


    Es würde evtl. funktionieren, wenn die externe IP-Adresse 95.174.246.252, _nur_ (d. h. dein Provider kein NAT macht) die WAN-IP-Adresse deines "Modems" wäre und Du in deinem "Modem", deinen Asus-Router als "Exposed Host" konfigurieren könntest.

    die Ausgabe vom Pi

    Code
    1. pi@raspberrypi:~ $ sudo mtr -4nr -c 2 -i 2 heise.de
    2. Start: Thu Jan 18 13:44:41 2018
    3. HOST: raspberrypi Loss% Snt Last Avg Best Wrst StDev
    4. 1.|-- 192.168.1.1 0.0% 2 0.7 0.7 0.6 0.7 0.0
    5. 2.|-- 192.168.254.1 0.0% 2 0.9 1.0 0.9 1.1 0.0
    6. 3.|-- 213.221.197.190 0.0% 2 4.3 4.4 4.3 4.4 0.0


    von meinem Provider habe ich ein Glasfaser Modem (DRG719)

    Ich gehe davon aus, dass Du CGN (carrier grade NAT) hast. Wegen der IP-Adresse 192.168.254.1.


    https://de.wikipedia.org/wiki/Carrier-grade_NAT


    Oder hast Du ein Gerät in deiner Konstellation, das Du mit dieser IP-Adresse konfiguriert hast?

    Und auf das Modem des Providers habe ich weder Einfluss noch zugriff.

    Schau mal im Web-Interface des Routers nach, ob Du dort die WAN-IP-Adresse des Routers sehen kannst bzw. angezeigt bekommst.

    Was ist das für ein Modem? Ist das evtl. ein Kabel-Internet-Provider?


    Wie ist auf deinem PI, die Ausgabe von:

    Code
    1. mtr -4nr -c 2 -i 2 heise.de

    ?

    beim Pi passiert nix.... ist das richtig ?


    (habe nach 5 min Abgebrochen)

    Schau dir nochmal die Einstellungen in deinem Router an. Ich gehe davon aus, dass Du natives IPv4 mit deinem Internetanschluss hast (d. h. _nur_ dein "border device" allein, hat diese externe/öffentliche IPv4-Adresse und Du hast kein CGN oder DS-lite).


    EDIT:


    Evtl. kann man an einem traceroute etwas bzgl. CGN erkennen. Wie ist die Ausgabe von:

    Code
    1. mtr -4nr -c 2 -i 2 heise.de

    ?

    scheint korrekt zu sein... glaube ich ...

    OK, dann sehe ich z. Zt. das Problem, bei der Portweiterleitung mit deinem Router.


    Testen kannst Du das auch mit z. B. tcpdump auf deinem PI und einem TCP-Port-scan aus dem _Internet_:

    Code
    1. sudo tcpdump -c 40 -vvveni eth0 port 10011

    bzw./oder andere TCP-Ports die Du im Router freigegeben hast.


    EDIT:


    BTW: Ich die TCP-Ports, die Du in deinem Router angeblich freigegeben hast, per TCP-Port-scan aus dem Internet, nicht erreichen.

    Über raspi-config hab ich die ersten Einstellungen wieder an der direkt angeschlossenen Tastatur gemacht. In dem Menü ist ja auch die Option N2 WiFi zum anwählen. Hier kommt schon die Meldung "No wireless interface found". Ein Update aus dem Configmenü hab ich da jetzt auch nochmal laufen lassen. Mehr als nicht gehen kann er nun auch nicht.

    Wie sind die Ausgaben von:

    Code
    1. sudo modprobe -v brcmfmac
    2. modinfo brcmfmac

    ?


    Nach einem:

    Code
    1. sudo modprobe -v configs

    die Ausgaben von:

    Code
    1. zcat /proc/config.gz | grep -iE 'brcm|_bt|mac80211|cfg80211'

    ?


    Hast Du evtl. den device tree deaktiviert?


    Wenn nicht, dann könnte es auch ein Hardware-Fehler sein.


    EDIT:


    ... und die Ausgabe von:

    Code
    1. dmesg | grep -i 'brcmfmac: Firmware version'

    Ich habe meinen Pi3 mit wvdial und nem Huawei E220 erfolgreich mit dem Internetz verbunden.

    Der ddclient läuft auch und hat sich schon über spdns.de verbunden.

    Jedoch kann ich die Kiste nicht erreichen per ssh oder ping.

    Was für einen Internetanschluss hast Du? Natives IPv4 oder DS oder DS-lite/CGN? Was für einen Router hast Du?


    EDIT:


    Evtl. hast Du CGN (abhängig vom Provider) mit dem Huawei E220 haben.


    Siehe: https://de.wikipedia.org/wiki/Carrier-grade_NAT

    Im Browser geht es nur mit der IP-Adresse und zwar deshalb, weil in der /etc/resolv.conf. keine DNS-Server für die Namensauflösung eingetragen sind.


    Wie man die LL-IP-Adressen mit der interfaces-Datei verhindert weiß ich nicht.


    Mit der dhcpcd.conf:

    Code
    1. noipv4ll
    2. Don't attempt to obtain an IPv4LL address if we failed to get one
    3. via DHCP. See RFC 3927.

    mit systemd-network:

    Code
    1. IPv4LL=false

    in der *.network-Datei. BTW: Das hat aber mit deinem aktuellen Problem (keine Namensauflösung) nichts zu tun.

    Also zu 1) ip a erhalte ich

    zu 2)route -n

    zu 3)cat /etc/resolv.conf

    Code
    1. # Generated by resolvconf

    zu 4)ping -c 3 -W 2 9.9.9.9

    Code
    1. PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
    2. 64 bytes from 9.9.9.9: icmp_seq=1 ttl=57 time=32.8 ms
    3. 64 bytes from 9.9.9.9: icmp_seq=2 ttl=57 time=21.3 ms
    4. 64 bytes from 9.9.9.9: icmp_seq=3 ttl=57 time=96.8 ms
    5. --- 9.9.9.9 ping statistics ---
    6. 3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    7. rtt min/avg/max/mdev = 21.355/50.352/96.847/33.210 ms

    zu 5)host -t A heise.de 9.9.9.9

    Code
    1. ping: unknown host heise.de

    PI ohne LL-IP-Adressen konfigurieren bzw. so konfigurieren, dass die DNS-Server in die /etc/resolv.conf eingetragen werden (z. B. mit systemd-network oder mit der dhcpcd.conf).


    Lt. Ping auf 9.9.9.9 ist Internetverbindung vorhanden. D. h. dein PI kommt ins Internet.


    Was hast Du gemacht, weil die Ausgabe von:

    Code
    1. host -t A heise.de 9.9.9.9
    Code
    1. ping: unknown host heise.de

    ist?


    EDIT:


    Wie ist die Ausgabe von:

    Code
    1. nc -zv 9.9.9.9 53

    ?

    Nur komme ich vom Raspberry aus nicht ins Internet.

    Unter Rasbian funktioniert ein Ping auf die Fritzbox problemlos.

    Wie sind auf deinem PI, die Ausgaben von:

    Code
    1. ip a
    2. route -n
    3. cat /etc/resolv.conf
    4. ping -c 3 -W 2 9.9.9.9
    5. host -t A heise.de 9.9.9.9

    BTW: Die interfaces-Datei war mal. Mit dem neuen OS, besser systemd-networkd (oder dhcpcd, auch für statische IPs) verwenden.