Posts by keulemaster

    Ich benutze 8 Sensoren seit mehreren Monaten erfolgreich.


    Allerdings habe ich 2 Stück, einmal TX3, einmal TX4, die mir Probleme bereiten. Die funktionieren nur so zwischen 1-3 Tage lang. Danach liefern sie keine Werte mehr. Einmal Temperatur DS18B20, einmal mit DHT22.


    Nachdem ich die Stromversorgung kappe, laufen Sie wieder für 1-2-3 Tage...


    Standort ist räumlich unterschiedlich.


    Beim DHT22 bestückten habe ich sogar die Spannung erhöht indem ich von 2xAA auf 3xAA gegangen bin...


    Zwei Ideen habe ich:


    - alle Batterien dieser zwei Sensoren auszutasuchen
    - die ATMELs neu flashen


    aber eigentlich sind das keine Lösungen, die die Sensoren ja tagelangen funktionieren.


    Die anderen Sensoren mit den gleichen Sketches funktionieren Seit Monaten tadellos.


    IDEEN warum die zwei Sensoren Spinnen? Danke.


    EDIT: meine Vermutung geht in Richtung zusammenbrechende Batteriespannung. Ich plotte die Spannungskurven über ein Monat aus, und bei den betroffenen Sensoren sind mehr Ausschläge als bei den "guten". Mal weiter beobachten...

    Quote

    Wie stell ich es denn an, den RFM12B zu verwenden? Ich dachte eigentlich, dass die TinyTX das gleiche Modul verwenden...


    TinyTX verwenden RFM12b...


    Quote

    Hat der DHT22 einen Nachteil gegenüber dem DS18B20 abgesehen von den größeren Abmessungen und höherem Preis?


    Meiner Erfahrung nach ist der DHT ungenauer von der Messung her, kann dir jetzt aber keine absolute Zahlen liefern...

    immergut
    also wegen sketches komplieren... wenn man dir helfen soll, wäre besser, wenn man sähe was du wirklich kompilieren willst. Ich vermute du hast beim sketch file anlegen, irgend etwas verhunzt. :lol:


    meigrafd
    nein! :fies: egal ob eingangsspannung niedrig oder hoch, je weniger strom du "entnimmst" umso schlechter der wirkungsgrad. natürlich ist bei niedriger spannung ist der wirkungsgrad noch schlimmer, aber auch bei hoher eingangspannung dürfte der wirkungsgrad bei so kleinen Strömen (<1mA) unter 50% liegen.

    der gewünschte DS18B20 Sketch:



    und der für den DHT22:



    https://github.com/keulemaster…er/ATTINY_Sender_Sketches

    meigrafd


    ich habe nun auch den Stromfluss an den Sendern gemessen, aber auch nur mit billig Mulitmeter. Die Sketches ohne PowerDown ziehen bei mir ca 2mA im Leerlauf und so 7mA beim Senden.


    Mit Watchdog und Powerdown, zieht der Tiny ca 0,07mA. Das ist knapp Faktor 30. Damit kann ich leben.


    Ich habe den DHT22 und DS18B20 mit den PowerDown-Zeug erweitert, diese Sketches funktionieren bei mir. Allerdings habe ich Verschlüsselung und LED-Zeug rausgenommen. Wenn jemand möchte kann ich gerne die Sketches hochladen.


    Arbeite auch gerade an meiner Web-Lösung (mit Python und Flaask).


    Quote

    Allerdings gibts eine Ausnahme beim Anschluss/Beschaltung des ATtiny84A beim Empfänger: Pin#4 wird beim Empfänger mit einem Widerstand vor Vcc versehen, was beim Sender nicht der Fall ist. Inwiefern das relevant ist weiß ich gerade selbst nicht...


    den Widerstand braucht man nicht unbedingt, ich verwende momentan eine TinyTX3 Platine, mit Receiver Sketch, die 2 Leitungen habe ich einfach in den IC-scokel gesteckt, und mit dem Tiny IC geklemmt.


    meigrafd
    bei LINEAR kann man glaube ich nur 100 Stück bestellen, dann wäre aber der Preis ganz ok.

    meigrafd



    und


    Quote

    Ja, nur anders Icon_lol


    Funktioniert trotzdem nicht?


    habs nun ausprobiert...funktioniert nicht.



    dann zu dem LOW_POWER DHT22 ino Script,
    bei mir funzt dieses Script nicht, es wird nichts übertragen oder BAD-CRC das habe ich noch nicht ganz heraus bekommen...
    übertrage ich den standard DHT22 Script aus 2013 von meigrafd ... funzt der DHT22 Sensor wieder.



    dann zu den Step-Up Geschichte...so ein Teil (LTC3525)...kostet ja 4-5 EURO...da kann ich gleich eine günstig LiPo-Akku kaufen und den immer wieder aufladen...ausser es geht einem wirklich extrem um den Platz. Oder?