Posts by dennis_n

    Hi,


    folgendes Problem:
    Ich habe 3 IP Kameras und einen Raspberry. Auf dem Raspberry habe ich kodi laufen.
    Jetzt möchte ich gerne jede Minute ein Snapshot Bild der IP Kameras auf dem Raspberry speichern und dann in Kodi als Screensaver anziegen lassen.


    Also habe ich dazu ein bash Script angelegt und hole mir mit wget das Bild von der Kamara und speichere es auf dem Pi.


    Mein Problem ist nur, dass ich manchmal kein Bild von der Kamera zurück bekomme. Ich habe rausgefunden, dass wohl der Header der Snapshot URL kein Redirect macht, sodass ich manchmal bei content-type:img/jpeg content-lenght:0 habe. Geprüft habe ich das mit folgendem aufruf:

    Code
    curl -i http://meine.kamera | less


    Nach jedem 2.-3. Aufruf hat er das Bild aber wieder geladen.


    Die Frage ist jetzt, wie kann ich es anstellen, dass mir das Bild immer geladen wird?
    Ich dachte vielleicht, dass ich eine Schleife brauche, die nach dem wget prüft, ob das Bild mehr als 0 byte hat und wenn ja, ist alles in Ordnung und wenn nein, muss wget noch einmal ausgeführt werden.


    Kann mir dabei jmand helfen? Ich bin leider kein Programmierer.


    VIelen Dank.

    Ich glaube das liegt eher an der Screenly Software.
    Die Bilder und Seiten, die man da anlegen kann, legt er in Assets ab.


    Wenn ich folgende Adresse angebe: file:///home/pi/screenly/kamera.html
    Dann sagt die Software, dass es keine gültige URL ist.
    Ich habe es auch schon über die ip adresse des Pi's versucht, aber das geht auch nicht.

    Hi Leute,


    ich habe heute auf meinem Pi3 die Signage Software Screenly OSE installiert. mit ein paar Testbildern alles ausprobiert und bin begeistert wie gut das funktioniert.



    Jetzt würde ich auf dem Pi gerne irgendwo eine html Seite anlegen. In dieser html seite will ich die Snapahot URL meiner Überwachungskamera einbinden.
    Wie stelle cih das am besten an? Brauche ich dazu einen laufenden Webserver oder kann ich die html Seite auch so laden?


    Kann mir da jemand helfen?


    Danke


    Gruss
    Dennis

    Hi,


    also die Firmware ist gleich. Wie gesagt, es gibt keinen Unterscheid zum Router im Büro.


    Vielleicht sollte ich dann doch auf das 5GHz wechseln.
    Welchen Mini-WLAN Stick könnt ihr denn für das Band empfehlen?


    Problem ist halt, dass der komplette Pi in einem Dummy-Gehäuse für Überwachungskameras eingebaut ist und da nicht viel Platz ist.
    Netzteil ist ausreichend dimensioniert. 15 Watt / 3A / 5V. Das sollte reichen. Es ist nur die Kamera und der WLAN Stick angeschlossen.


    Gruss
    Dennis

    ok, ich bin selbst ein Schritt weiter gekommen.
    Wenn ich Router im 2,4 Ghz Band die Reichweite von AUTO auf 40MHz stelle, verbindet sich der 7811un mit den 150 Mb/s.


    Was ich jetzt nciht verstehe, in der Firma steht der Wert auf AUTO und zu Hause nomalerweise auch.
    In der Firma habe ich sofort die 150 Mb/s und zu Hause nicht.


    Gruss
    Dennis

    Hi,


    ich habe eine Problem und komme einfach nciht weiter.
    Mein Pi2 hat das fertige image motioneyeos, da ich den als Überwachungskamera betreibe.


    Sowohl zu Hause als auch in der Firma habe ich einen TP-Link Archer C7 Router.


    Wenn ich den Pi in der Firma am wlan anmelde, erhalte ich mit iwconfig bei der Bit Rate einen Wert von 150 Mb/s.


    Wenn ich den Pi dann zu Hause an den Archer C7 hänge, bekomme ich nur noch 72,2 Mb/s mit iwconfig angezeigt.


    Beide Router sind identisch konfiguriert. Es wird am Pi absolut nichts geändert. Lediglich die SSID, die zu Hause eine andere ist.


    Ich weiß nicht mehr weiter woran das liegen könnte und hoffe auf eure Hilfe.


    Danke


    Gruss
    Dennis

    Hallo,


    ich habe einen Raspberry mit Raspbian Image und betreibe darauf einen FHEM Server und das Razberry Modul zur Steuerung meiner ZWAVE Komponenten.


    Jetzt habe ich nach einer Lösung gesucht, neben den ZWAVE Modulen auch noch herkömmliche 433MHz Steckdosen zu betreiben und bin im FHEM Forum auf folgendes Projekt gestoßen:
    http://forum.fhem.de/index.php/topic,17196.0.html


    Soweit so gut. Ich habe den Arduino Nano bestellt mit FTDI Chip und alles geflasht.
    Allerdings wird mit der Arduino absolut nicht am USB des Pi erkannt.
    Wenn ich ihn anstecke und dmesg eingebe, erhalte ich folgenden Fehler:



    Und ls -ltr /dev/tty* zeigt mir nur crw-rw---T 1 root dialout 204, 64 Jan 25 21:15 /dev/ttyAMA0 an. Aber das ist ja mein Razberry Modul auf dem GPIO.


    Kann mir vielleicht irgendjemand sagen, wieso der Arduino am USB nicht erkannt wird?


    Vielen Dank.


    Gruss
    Dennis

    Danke für eure schnelle Antwort, aber ich habe es hinbekommen. Bei der Raspbmc Netinstallation scheinen einige Bibliotheken zu fehlen.
    Nachdem ich g++ nachgeladen hatte ging es dann.


    Erste Steckdosen sind bereits eingerichtet und funktionieren einwandfrei :-)


    Danke, schönes Projekt.
    Wenn jetzt noch irgendwann vielleicht die Elro HE... Anlernschalter dazu kommen, hast Du eine konkurenzlose Software.


    Gruss
    Dennis

    Also ich scheitere irgendwie an der Installation.


    Zunächst hat bei der Raspbmc Installation "make" gefehlt. Also nachinstalliert.
    Jetzt hänge ich an dem Punkt wo rcswitch-pi installiert werden soll.
    Wenn ich in das Verzeichnis wechsele und dann sudo make eingebe kommt:

    Code
    g++ -c -o RCSwitch.o RCSwitch.cpp
    make: g++: Command not found
    make: *** [RCSwitch.o] Error 127


    Ich kenne mich mit Linux leider nicht so gut aus. Wer kann mir helfen, wie es weitergeht?


    Danke


    Gruss
    Dennis

    Aber welchen Empfänger in Verbindung mit welcher Software nehme ich?


    HomeEasy HE889 hat mit allen nicht funktioniert.
    Kennt jemand eine Lösung mit Schalter und Software die funktioniert?


    Gruss
    Dennis

    Wie geagt, ich suche und tüftle schon seit längerem, aber scheitere immer wieder am Zusammenspiel zwischen Software und den Funkschaltern.


    Die HE889 hatte ich mal. Das sind die HomeEasy von Elro zum anlernen.
    Ich hatte damit leider keinen Erfolg. Wenn Du es hinbekommst, wäre klasse.


    Gruss
    Dennis


    P.S. Ich bevorzuge eine Funklösung auf 433 MHz, da ich mir bereits einen Platine für den Pi gemacht habe. Darauf ist eine Antenne und natürlich das Sende und Empfangsmodul für 433 MHz.

    Also die Rolläden haben 230 Volt und haben einen ganz normalen Schalter an der Wand, mit dem ich sie hoch und runter steuere.
    Funk ist nicht vorhanden, die sind direkt mit dem Rolladen verkabelt.


    ich denke einzige Möglichkeit wäre die Schalter durch einen Funkschalter zu ersetzen und für den Pi einen 433MHz Sender zu bauen und dann über GPIO zu steuern, oder?


    Aber gibt es eine Lösung, die speziell Rolladenschalter und eine hier vorhanden Projektsoftware steuern kann?
    Wie gesagt, hier ist immer nur die Rede von Steckdosen.


    Gruss
    Dennis

    Hi,


    ich bin schon seit längerem auf der Suche nach einem Raspi Projekt zur Hausautomatisierung.


    Es sind hier wirklich sehr schöne Projekte zu finden, aber irgendwie scheint sich keiner mit einer Rolladensteuerung zu beschäftigen. Es geht oft immer nur um Steckdosen.
    Hat das einen besonderen Grund?


    Ich habe elektrische Rolläden im Haus, die über einen normalen Schalter geschaltet werden. Diese möchte ich nun mit dem Raspi steuern.
    Hat da jemand einen Tipp für mich, mit welchem Projekt ich das am besten löse?


    Danke


    Gruss
    Dennis

    Ja, auch dann.
    Es kommen immer Meldungen wie:
    433gpio: 639
    433gpio: 2529
    433gpio: 882
    433gpio: 258
    433gpio: 735
    433gpio: 184
    433gpio: 530
    433gpio: 126
    433gpio: 532
    433gpio: 216
    433gpio: 504
    433gpio: 530
    433gpio: 726
    433gpio: 293
    433gpio: 778
    433gpio: 313
    433gpio: 488
    433gpio: 1649
    433gpio: 643
    433gpio: 325
    433gpio: 632
    433gpio: 349
    433gpio: 580
    433gpio: 314
    433gpio: 635
    433gpio: 789
    433gpio: 745
    433gpio: 323
    433gpio: 552
    433gpio: 2862
    433gpio: 687
    433gpio: 311
    433gpio: 99
    433gpio: 552
    433gpio: 319
    433gpio: 511
    433gpio: 215


    Und das hört nicht mehr auf, bis ich es unterbreche.