Posts by Puseidr

    Hallo zusammen,
    ist es möglich ein Backup meiner 16 GB SD Karte zu machen - so, dass ich sie auf einer 32 GB Kart einspielen und die 32 GB voll nutzen kann? bisher hab ich nur gefunden, dass man von einer X GB auf eine andere X GB kopieren kann, jedoch nicht was mit größeren ist.


    keine eine idee?

    die service-Befehle funktionieren als Benutzer: root und pi, www-data hat keine Shell. Die Befehle führ ich mit PHP aus:

    Code
    shell_exec("sudo initctl stop xbmc");
    oder
    shell_exec("sudo service xbmcs stop");
    oder auch
    shell_exec("sudo /sbin/service xbmc stop");


    nichts davon geht


    www-data hat zZ ja nur zum testen alle sudo Rechte, da der eh nur im LAN erreichbar ist und die einzigen Scripte drauf von mir selbst geschrieben sind, kann man sicherheitstechnisch da mal ein Auge zu drücken.
    [hr]
    hab gerade das ganze mit Scripten probiert und auf was merkwürdiges gestoßen


    wenn ich ein script mit dem inhalt:

    Bash
    #!/bin/bash 
    
    
    sudo initctl stop xbmc


    ausführe passiert nichts


    aber wenn ich es so mach

    Bash
    #!/bin/bash 
    
    
    sudo -initctl stop xbmc


    (der Bindestrich war eigentlich ein Versehen, aber es funktioniert so..)
    geht es auf einmal.. kann mir das einer erklären?

    Hallo ich schreibe mir gerade eine Verwaltungsoberfläche für meinen Pi und würde gern XBMC starten/stoppen lassen, jedoch wehrt er sich dagegen.


    Ich nutze Raspbmc und da ist die einzige Möglichkeit XBMC zu starten dieser:


    Code
    service xbmc start/stop



    um service Befehle auszuführen muss man root sein, deshalb hab ich mit visudo bereits die sudoers bearbeitet.. leider ohne Erfolg.


    zum Testen hab ich mal :

    Code
    www-data ALL=NOPASSWD:ALL


    eingetragen, jedoch gehten diese service Befehle immer noch nicht.



    Kann mir jemand weiterhelfen wie das ganze klappen könnte?




    Hier die Lösung, falls es noch jemand braucht:


    Ein kleines Shell-Script erstellen zB unter: [font="Verdana, Arial, sans-serif"]/home/pi/service.xbmc.sh mit dem Inhalt:[/font]

    Bash
    #!/bin/bash
    /sbin/initctl $1 xbmc



    Mit dem Befehl visudo die sudoers bearbeiten und folgendes unten eintragen:

    Code
    www-data ALL=(root) NOPASSWD: /home/pi/service.xbmc.sh


    und nun kann man mit php folgenden Code nutzen:

    Code
    exec('sudo /home/pi/service.xbmc.sh stop');
    exec('sudo /home/pi/service.xbmc.sh start');


    quelle: http://forum.stmlabs.com/showthread.php?tid=12473

    Das mit dem Timestamp hat sich erledigt. ich musste im Windows Explorer nur "letzter Zugriff" anzeigen, das war der Wert den ich brauchte.


    Und zum Thema Samba/Mount muss ich mir nochmal Gedanken machen, Ziel sollte sein ein kleines Script, wenn ich eine USB Festplatte mal abstecken will um sie am PC zu nutzen, weil die Übertragungsgeschwindigkeit vom Pi einfach zu langsam ist.



    Code
    umount -f /dev/sda1



    klappt nicht, da wird oft gemeckert, dass noch Zugriffe drauf sind.
    auf die Platte greift u.a. Samba, pyLoad und ggf. unrar, das ganze soll abgebrochen/beendet werden damit ich die platte aushängen und umstöpseln kann.

    Hallo,
    mir ist aufgefallen, dass der Pi gar nicht das Änderungsdatum von Dateien festlegt wenn diese auf die Festplatte gespeichert werden.


    Ich hab eine NTFS Festplatte am Pi und wenn ich Dateien entpacke (unrar x Datei.rar) haben die kein Änderungsdatum (Zeitpunkt als die Datei auf die Platte geschrieben wurde) sondern als Änderungsdatum steht das Datum der Datei-Erstellung drin, das macht es unmöglich nach Dateien zu suchen die in den letzten x Tagen auf der Platte erzeugt wurden..


    hab keine Idee woran das liegen könnte, bin über jede Hilfe dankbar!




    hat sich erledigt. wonach ich gesucht hab war die Eigenschaft "letzter Zugriff" im Windows Explorer

    Hallo, ich möchte USB Festplatten unmounten jedoch sind die Quellen von Samba-Ressourcen


    wie krieg ich Samba denn komplett aus? um die Festplatten zu entfernen? hab schon

    Quote


    /etc/init.d/samba stop


    und


    Quote


    service samba stop


    probiert, jedoch startet Samba direkt wieder neu und beschlagnahmt die Festplatten.


    bei mir läuft Raspbmc.

    Xbian läuft zwar gut aber allein das anzeigen des XBMC Menüs ohne Hintergrundaktionen oder andere Programme treibt die CPU Auslastung auf über 90%.


    Ich habe Raspbmc noch eine Chance gegeben und es über "NOOBS Lite" installiert, scheinbar hat NOOBS ein anderes Image als der Raspbmc-Installer. Zwar kommt nach der Installation auch ein Fehler, dass das Filesystem nicht gemountet werden konnte, jedoch wird es danach Repariert. Bisher hab ich keine Probleme mehr gehabt, Reboot klappt super. Also einfach mal die Installation über NOOBS Lite probieren!

    Wenn du unter Videos->Dateien deine Quellenangabe für zB. Filme oder Serien wählst und da "C" drückst kannst du die Quellen auch entfernen, allerdings bestehen die Filme noch in der Datenbank, die müsstest du noch bereinigen.
    Ob der ganze Rödel ein einer einzigen Datei hinterlegt ist und wo die ist, kann ich dir auch nicht sagen. Aber über den Weg der XBMC-Oberfläche machst du wenigstens nichts kaputt.

    Du kannst die Datenbank auch unter XBMC löschen und neu erstellen, das ist gar kein Problem:
    System->Einstellungen->Video->Datenbank->Bereinige Bibliothek..
    Aktualisiere Datenbank beim Start ist auch interessant, so schaut XBMC nach jedem Reboot ob neue Filme/etc dazugekommen sind und fügt sie wenn nötig hinzu.
    Alternativ kannst du auchin Videos->Dateien gehen und da deinen Eintrag wählen und auf der Tastatur die "C"-Taste drücken für das XBMC Menü um die Datenbank zu aktualisieren oder den Ordner-Eintrag entfernen.

    ich hab eine andere SD-Karte auch schon probiert, da ist der selbe Fehler. Hab mal openelec getestet, das läuft echt gut! Allerdings is das nur für XBMC zu gebrauchen, da mann keine Programme nachinstallieren kann.. ich probier mal XBian, vielleicht kann man damit arbeiten.

    Ich hab ein wenig an den WLAN-Einstellungen meines Routers (Fritz!Box 7240)rum geschraubt und der läuft jetzt auf Kanal 11 bei 2,4 GHz (802.11n+g+b).


    Wenn ich den Logilink am PC nutz hab ich eine Signalstärke von 100% und ca 115Mbit/s Datenrate, am Pi jedoch nur 80% Signalstärke und ca 80Mbit/s.


    Muss ich beim Pi noch irgendwas einstellen, damit er mit voller Leistung arbeitet?

    hab gerade mal paar Netzteile getestet:

    • Samsung S3 Ladegerät: Problem besteht
    • EasyAcc Micro USB 5V 2A AC: Problem besteht
    • D-Link DUB-H7 USB-Hub: Problem besteht


    ich lehn mich mal aus dem Fenster und behaupte, es liegt nicht am Netzteil.
    entweder es liegt am Pi (warum auf einmal vorher ging es wunderbar) oder es liegt an Raspbmc (werde mal andere OS testen)