Posts by chris78

    Hallo!


    Da dies mein erstes Posting hier im Forum ist, möchte ich mich kurz vorstellen.
    Ich heiße Chris, bin Mitte 30 und stolzer Besitzer von zwei Raspis (Rev. 2, 512MB). Den einen verwende ich als kleinen Webserver um ein bisschen mit gehosteten HTML5-Apps für FirefoxOS zu experimentieren, den anderen verwende ich als low-budget Desktop an dem ich am Wochenende Musik höre und dabei ein bisschen programmiere, wofür er echt ausreicht und mir einiges an Strom gegenüber meinem herkömmlichen Desktop einspart.


    Nun aber zu meinem Problem:
    Ich möchte meinen "Desktop"-Raspi an einem Digitus KVM-Switch betreiben, habe dabei jedoch das Problem, dass ich unter Xorg zwar anfangs kurz ein Bild sehe, aber dann verschwindet es, blitzt evtl. kurz noch das ein oder andere mal auf, und dann bleibt der Monitor irgendwann schwarz.
    Drücke ich dann Ctrl+Alt+F1 und bin wieder in der Konsole, ist das Bild wieder da und bleibt auch stabil.


    Gehe ich mit einem HDMI auf DVI-Kabel direkt an den Monitor (1680x1024, Dell), so gibt es keine Probleme. Und der "echte" Desktoprechner, der als zweites Gerät noch am KVM Switch hängt, funktioniert ja auch über den Switch, also denke ich, dass der Switch in Ordnung ist.


    Zunächst dachte ich, dass die Kabellänge das Problem wäre, denn ich hatte ein 3m langes Kabel (HDMI->DVI) vom Raspi zum KVM Switch, an dem dann nochmals ein 1m lange Kabel als Eingang angebracht ist und von dort aus geht es dann über ein weiteres ca. 2m langes Kabel zum Monitor.
    Also beietwas über 6m Kabellänge hat mich das nicht sonderlich gewundert, also habe ich mir ein 15-20cm langes HDMI->DVI Kabel (vom Raspi zum Eingangskabel des Switchs) gekauft, doch auch das brachte keine Verbesserung.


    Was meint ihr? Sind 3,20m Kabel zwischen Raspi und Monitor zu viel oder liegt evtl. ein anderes Problem (Inkompatibilität mit dem Switch?!) vor?
    Ich könnte jetzt noch versuchen, ein kürzeres DVI Kabel zwischen Switch und Monitor zu verbauen, hab nur gerade keins da.


    Habe ich sonst Alternativen, was ich noch tun könnte? Kann man den Signalpegel des HDMI Ausgangs vom Raspi (per Konfiguration) verstärken?


    Und wieso funktioniert die Konsole so einwandfrei? Läuft die in einem anderen Modus über's Kabel?


    Bin auf eure Antworten gespannt und würde mich sehr über eure Hilfe freuen!


    Grüße,
    Chris