Posts by PHi2Xr

    Hallo Allerseits,


    ich habe folgendes Problem und weiß leider nicht, wie ich es lösen soll.


    Ich habe meinen Pi anhand der hier vorhandenen Tutorials installiert. Apache2, PHP5, MySQL sind installiert und laufen soweit problemlos.


    Zusätzlich habe ich wie folgt mod_rewrite aktiviert:

    Code
    1. ln -s /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled/


    Auf dem Pi habe ich dann per SSH Wordpress 3.5 installiert. Leider war das Update bzw. die Installation von Plugins nicht möglich. Es wurde immer nach FTP Daten gefragt. Es war ein Rechteproblem, welches ich so gelöst habe:


    Code
    1. chown -R www-data:www-data /var/www/


    Zusätzlich noch die Rechte eingeschränkt:

    Code
    1. find /var/www/ -type d -exec chmod 755 {} \;
    2. find /var/www/ -type f -exec chmod 644 {} \;


    Soweit läuft Wordpress ohne Probleme.


    Ich möchte gerne die Permalinks nutzen:

    Code
    1. http://rbpi/2012/12/26/Beispielbeitrag/


    Und hier stecke ich nun fest. Es will nicht funktionieren. Während die Standardeinstellung ohne Probleme läuft, bekomme ich bei der Einstellung der Permalinks leider immer 404er.
    Ich habe gestern und heute das Netz nach einer Lösung durchsucht. Deswegen habe ich ja schon mod_rewrite aktiviert. Trotzdem bekomme ich nur 404er.


    Die .htaccess lautet:


    Hat von Euch jemand noch eine Idee, was bei mir falsch installiert/konfiguriert ist?


    Gruß
    PHi2Xr

    Danke für Deine Tutorials ps915. Sie sind eine große Hilfe.


    Hinweis zu Punkt 3, optionale Pakete:
    Bei der Auswahl der Pakete, die Du angibst, bricht der Vorgang ab. "php5-domxml" kann nicht gefunden werden. Nach kurzer Recherche habe ich erfahren, dass dieses Paket wohl bereits standardmäßig enthalten ist. Du kannst es als rausnehmen.