Posts by PAINKILLER

    Dann stimmt was mit den Verzeichnissen nicht, oder die Bilder sind wirklich nicht da...


    Schau Dir mal die Datei "/var/log/apache2/error.log" an...


    am Besten mit


    Code
    less /var/log/apache2/error.log


    Wenn Du dann "SHIFT"+"S" drückst, springt er ans ende der Datei und zeigt alles neu dazu gekommene automatisch an.


    Dann öffnest Du die Seite, und machst nen Reload, dann müsste er die aktuellen Fehler ausspucken, und Du siehst, was er wo sucht und evtl. nicht findet...


    Das Link zum Admin CP wird ja nur angezeigt, wenn Du Dich mit einem User einloggst, der das "SuperUser" Flag gesetzt hat.


    Gruß
    Harry

    Hallo Muf31,


    Hast Du die Datenbank mit phpmyadmin manuell angelegt?


    Hast Du das Passwort mit SHA1 verschlüsselt in die Datenbank gespeichert, oder "plain-text"?


    auf http://sha1generator.de kannst Du Dir die Sachen verschlüsseln lassen.


    Auch "nichts", also "kein Passwort" ergibt nen Schlüssel, das muß auch bedacht werden.


    Gruß
    Harry

    Ich habe die Relais- und die Treiberplatine mittlerweile auf einer geätzten Platine zusammen gefasst, wenn diese bei mir eintrifft und den Funktionstest besteht, dann gibts einen neuen, kompletten Satz Dokumentation...


    Software war bisher:


    Lochmaster 4.0 für die Lochrasterplatine, eplan P8 für den Schaltplan, das ist aber mit Kanonen nach Spatzen geschossen, so ein kleines Projekt lässt sich auch mit der Platinen Software Eagle bewerkstellen.


    Diese kam auch für die geätzte Platine zum Einsatz.


    Wie gesagt, wenn das alles funktioniert, kommt ein kompletter Doku-Satz mit allem drin.


    Gruß
    Harry

    Da man das Rad ja nicht unbedingt neu erfinden muß, könntest Du das Shutdown Progrämmchen von Helbing benützen, und das umbauen...ist in C geschrieben, mußt dann halt statt dem Shutdown etwas anderes ausführen.


    Müsste man umbauen, und neu kompilieren können.


    Vorteil: Es ist Interruptbasiert, und belegt das System nicht die ganze Zeit mit den kontinuierlichen Abfragen...


    Kannst es Dir ja mal anschauen.


    http://www.helbing.nu/projekte…aspbian-shutdown-key.html

    Hallo allerseits,


    Ich habs auf Anhieb hier noch nicht gefunden, und mir war heute langweilig...


    als "Projekt" würde ich das jetzt nicht bezeichnen, deswegen poste ich es mal hier, und nicht bei "Projekte" oder "fertige Projekte".


    Ich habe eine "Wordclock" gebastelt, (sehr) stark inspiriert von der "QLOCKTWO" Uhr von Biegert & Funk, hier in der in der PHP Version als Webseite.



    Zeigt die Uhrzeit in Wörtern in 5 Minuten Schritten an, die Zwischenminuten zwischen z.B. 5 nach der vollen Stunde und 10 nach der vollen Stunde kann man unten links an den Punkten ablesen, pro Minute ein Punkt.


    Die Seite wird alle 60 Sekunden neu geladen, den Intervall könnte man evtl. noch herunter setzen.



    Besteht aus einer .php Datei und einer .css Stylesheet Datei.



    wordclock.zip


    (Edit 30.01.14 ^^ nochmals Fehler beim umspringen von 23 auf 00 Uhr behoben und in den ersten 5 Minuten der vollen Stunde wird "Uhr" mit eingeblendet)



    Vielleicht kann es mal jemand gebrauchen.


    Gruß
    Harry

    Also wenn Du mit "Splitter" einen USB Hub mit eigener Spannungsversorgung meinst, kann das wohl sehr gut sein...


    Die neueren RasPis können auch über den großen (eigentlich Ausgang) USB Typ A rückwärts mit Spannung versorgt werden.


    Es gab wohl welche mit Sicherungen auf dem Board, welche die dann irgendwann "0 Ohm Widerstände", also Brücken drin hatten, und irgendwann beim Raspi B rev. 2 waren das alles dann wohl komplett verschwunden...


    Ist aber alles "Hören/Sagen", ich habs noch nicht probiert, und auch keine älteren Boards in den Pfoten gehabt, hab das nur irgendwo mal gelesen...



    Gruß
    Harry

    FTP Server in Kanada aufm Rechner installieren und den übers Netz am RasPi einhängen?


    Am besten SFTP mit Cygwin, das dann über SSH tunneln?


    Oder Du hast ein NAS/anderen Windows PC im heimischen Netz laufen?...

    Nicht direkt, in Tablle 1 lässt Du den Widerstand gleich und erhöhst ja die Spannung in 5V Schritten, also drehst das Netzgerät hoch, das zeigt Dir, das der Strom der in der Schaltung fließt proportional zur Spannung ist...also doppelte Spannung, doppelter Strom...3 fache Spannung, 3 facher Strom...


    In Tabelle 2 bleibt die Spannung gleich bei 5V und der Widerstand wird verändert.


    Das soll die Beziehung zwischen Strom und Widerstand zeigen...auch der ist proportional...also halber Widerstand, doppelter Strom und so weiter...

    U = R x I


    Bei der einfachen Widerstandsschaltung ist der Widerstand proportional zum Strom.


    Um nen Vorwiderstand für eine LED zu berechnen, solltest Du folgendes Wissen:


    • IF der LED, also den Strom mit dem sie betrieben werden soll.
    • Die Spannung der LED
    • Spannung der Spannungsquelle


    Wenn Du jetzt in Deinem Beispiel eine LED mit 2,2V/20mA an 3,3V betrieben willst, mußt Du ausrechnen, wieviel Spannung an dem Widerstand abfallen soll...


    In dem Fall also UR = UB - ULED, also 3,3V - 2,2 V, im Beispiel also 1,1V


    Da wir den Widerstand wissen wollen, stellen wir die obere Gleichung nach R um, U=R x I wird zu R= U/I


    Also ist R = 1,1V / 0,02A


    Es ist wichtig die gleichen Einheiten durch zu ziehen, also nicht Volt mit mA rechnen, immer in A umrechnen (oder die Volt in mV)


    Rechnerisch wären das dann also 55 Ohm... Falls es den Wert in der Widerstandsreihe nicht gibt, nimmst den nächst höheren, und fertig... :)


    So sollte es funktionieren.

    Sieht bei mir ähnlich aus, bis auf die SSID halt...


    Code
    pi@shortcrust ~ $ iwconfig wlan0
    wlan0     IEEE 802.11bgn  ESSID:"PAINKILLER"  Nickname:"rtl_wifi"
              Mode:Managed  Frequency:2.447 GHz  Access Point: BC:05:43:A4:59:48
              Bit Rate:150 Mb/s   Sensitivity:0/0
              Retry:off   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=100/100  Signal level=100/100  Noise level=0/100
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0


    Er hat bei Deinem ersten Fall keine Geschwindigkeit ausgehandelt, und ist wohl nicht verbunden, weil er die MAC-Adresse vom AccessPoint nicht anzeigt...


    Und es funktioniert nicht, wenn der output wie bei "iwconfig wlan0: B" aussieht?


    Wie siehts beim Router aus? Hast Du da schon nachgeschaut? Nicht das ein MAC-Adressen Filter aktiv ist? Taucht er da unter den verbundenen Geräten auf?


    Was hast Du für nen Router? Telekom Speedport?

    Es gibt da noch ne Datei


    Code
    /etc/wpa_supplicant/wpa_supplicant.conf


    Dort gibt man normalerweise die WLAN Spezifischen Sachen an?


    Die sieht bei mir so aus:




    Die /etc/network/interfaces fürs WLAN sieht bei mir folgendermassen aus:


    Code
    allow-hotplug wlan0
    iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet static
            address 192.168.69.44
            netmask 255.255.255.0
            network 192.168.69.0
            broadcast 192.168.69.255
            dns-nameservers 192.168.69.1
            gateway 192.168.69.1


    Mußt halt Deine IPs dafür nehmen...


    Hat so ansonsten "out of the box" funktioniert bei mir...


    Edit: Wobei ich gerade sehe, das er Stick nicht erkannt wird?


    Code
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter


    So siehts bei mir dann aus...die letzte Zeile fehlt bei Dir?


    Nochmal Edit: Meine DMESG geht noch weiter, und hört nicht bei dem "SerialNumber" auf...



    Scheint wohl kein Treiber/Modul für Deinen speziellen Realtek Chipsatz dabei zu sein... Hast Du schonmal das Betriebssystem upgedatet? Vielleicht gibts ja mittlerweile was...


    "sudo apt-get update"
    "sudo apt-get upgrade" oder "...dist-upgrade"

    Da kommts jetzt drauf an...


    So ein 5VDC,2.000mA Micro USB Netzteil kostet 11€ bei Amazon...


    Du könntest aber auch eine 12VDC Spannungsquelle mit ordentlich Leistungsreserven nehmen, Dir die 5VDC für den RasPi über einen Traco DC/DC Wandler abzwacken


    z.B. sowas hier:
    http://www.conrad.de/ce/de/pro…0-mA-6-W?ref=searchDetail


    Jetzt kommts drauf an, wie der Strombedarf des Verstärkers ist, was Du für ne 12VDC Stromversorgung Du brauchst, und was der Preisunterschied ist, wenn sie 1-1,5A mehr Ausgangsstrom hat.

    Bei ELV gäbe es einen mit 2x40W (Lieferung ohne Kühlkörper:
    http://www.elv.de/verstaerker-…tz-ohne-kuehlkoerper.html


    und einen mit 2x6W
    http://www.elv.de/stereoversta…-6-w-komplettbausatz.html


    Bei Conrad gäbe es einen Vellemann Bausatz:
    http://www.conrad.de/ce/de/pro…VDC?queryFromSuggest=true
    [hr]
    Regelbar kannst Du es mit nem Stereo Poti machen, das Du in die Leitung vom RasPi zum Verstärker einschleifst, um die 50kOhm logarithmisch sollte funktionieren.


    Sowas hier z.B.


    http://www.conrad.de/ce/de/pro…detview1&rt=detview1&rb=1


    Anschluss dann ähnlich wie hier:
    http://www.hobby-bastelecke.de/projekte/verstaerker_poti.htm